Elektroda.pl
Elektroda.pl
X
IGE-XAOIGE-XAO
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Obsługa wyświetlacza LCD od NOKII E51

BikeRk6 07 Sty 2014 17:59 56594 74
  • #61
    gobo2003
    Poziom 12  
    Nigdy za dużo miernika ustawionego na piszczałkę :)
    Zęby trzeba zjeść mleczne i stałe :) A i to nie wystarcza dla projektów zrobionych w domu w technice SMD z naprawdę małymi elementami (0603, QFN-y, etc...)
  • IGE-XAOIGE-XAO
  • #62
    M. S.
    Poziom 34  
    E51 już opanowałem. Przyszedł czas na N85/86. Niestety, zakupiony AMOLED przekształcił się cudownie w LCD AMDF001 MP1.0.
    Rodzi to podstawowe pytanie. Czy potrzebna mu jest przetwornica napięcia ujemnego, czy może trzeba normalnie diody podświetlające zasilić np z napięcia 10V. Mniej więcej taka różnica występuje między + a - przetwornicy.

    Upss. Odpowiedź znalazła się na 2 str. Czy jednak bez podłączania napięcia dodatniego i ujemnego podświetlanie działa? Po włączeniu go oczywiście.
  • IGE-XAOIGE-XAO
  • #63
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #64
    gobo2003
    Poziom 12  
    zdz_13 niestety nie zgodzę się z Tobą. Nie wszystkie wyświetlacze do n85/86 to podróby. Swego czasu firma z Tychów sprzedawała AMDN001 MP2.0 który ewidentnie nie ma podświetlenia i ma świetną czytelność na dworze... AMOLED.
    AMDF001 MP1.0 napięcie do LEDów podświetlenia tworzy sobie sam z linii VDD - jest tam mała przetwornica (step-up), która robi z 3V3 odpowiednie napięcie dla LEDów. Linie ELVSS i ELVDD chyba są tam niepodłączone...
  • #65
    M. S.
    Poziom 34  
    Dodam tylko że w moim LCD'eku El_on jest we wtyku zwarty z masą. To oznacza że TPS65136 jest wyłączony.
  • #66
    Użytkownik usunął konto
    Użytkownik usunął konto  
  • #67
    gobo2003
    Poziom 12  
    ja kupiłem kilka sztuk i dwie trafiłem z podświetleniem LED a reszta było bez podświetlenia... Te bez podświetlenia miały oznaczenia AMS258D MP2.1 AMDN001 etc...
  • #68
    M. S.
    Poziom 34  
    Mamy już dwie wersje podświetlania LCD'ka:
    1 z wewnętrznej przetwornicy
    2 z zewnętrznej przetwornicy.

    Która jest właściwa? Chyba ta, o zasilaniu ledów z wewnętrznej przetwornicy bo dołączenie zasilania z zewnątrz również daje efekt podświetlenia gdyż zasilanie to powinno być ignorowane przez wyświetlacz. Za tą opcją przemawia unieruchomienie przetwornicy w telefonie poprzez zwarcie do masy El_on we wtyku wyświetlacza.

    Gdyby kolega zdz_13 mógłby odłączyć zasilanie z zewnętrznej przetwornicy i podać efekty to miałbym jasność.

    Pewnie sam to niedługo sprawdzę jak zmajstruję odpowiednie pcb.

    Witam ponownie.
    LCD N85 uruchomiony. Podświetlanie jest realizowane z napięcia zasilania LCD. Nie trzeba podłączać EL_ON, ELVDD, ELVSS.
  • #69
    gimbus
    Poziom 12  
    Hej,
    temat stary i od kilku miesięcy cisza, ale może komuś się przyda:
    wiele ciekawych informacji o tym i innych LCD Nokii i nie tylko jest tu:
    http://andybrown.me.uk/wk/2012/11/03/nokia-n95-8gb-lcd/
    Przede wszystkim:
    typ złącza to 24R-JANK-GSAN-TF, jest też link do strony producenta i ew. sklepy które to sprzedają
    W dziale download soft, można z niego wywnioskować trochę o sposobie sterowania.

    Pozdrawiam
    Gimbus
  • #70
    gobo2003
    Poziom 12  
    Nie wiem jak jest z N95 i czy tam jest rzeczywiście LDS285, ale w E51 i E65 to na pewno nie jest LDS285 - zgodność jest na poziomie tylko kilku najważniejszych komend, nie działają komendy sterowania jasnością, kolorem, etc...
  • #71
    gimbus
    Poziom 12  
    Jeśli tylko czas pozwoli, będę mógł to przetestować. Czekam na złącze, potem lutowanie płytki i testy. Problem z tym lutowaniem - dawno tego nie robiłem...
    Poza tym - nie piłem od kilku lat i ręce mi się trzęsą ;-)
    BTW:
    ma ktos może gotowego breakboarda z tym złączem?

    Postaram się sprawdzić, na ile kontroler jest zgodny ze specyfikacją.

    Gimbus
  • #72
    gobo2003
    Poziom 12  
    Powodzenia ze złączem. Dostaniesz tylko masywnego wkurzenia, a LCDek jak nie działa tak nie będzie działał, bo jeden pin nie będzie stykał... - nie do wykrycia i nie do wydebugowania...
    Ja zarzuciłem pomysł stosowania oryginalnych złącz, niestety, albo jestem taki lewy, że nie umiem go przylutować (ani hot-air'em, ani cieniutką kolbą z cyną 0.25mm i topnikiem, ani niczym innym...)
  • #73
    Pocieszny
    Poziom 38  
    Lutownicą z cienkim grotem i z lekką pomocą taniego mikroskopu można to zrobić bez większego bólu :)
  • #75
    M. S.
    Poziom 34  
    Ja lutuję takie złącze transformatorówką z grotem z drutu 1,37mm.
    Początkowo udawało mi się przylutować jedno na trzy. Teraz lutuję każde. Na płytkę nanoszę warstewkę kalafonii rozpuszczonej w denaturacie. Kładę na to gniazdo, które po ustawieniu lutuję na rogach za pomocą styków mocujących. Później stapiam grotem cynę w odległości ok. 2-3mm od gniazda i przesuwam grot lutownicy aby stopiona cyna musnęła gniazdo (czas ok. 0,5s). Oczywiście robi się spore zwarcie, które następnie usuwam plecionką z odległości ok 1mm od pinów.