Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sterowanie Mosfetami -problem

anjin 19 Cze 2009 13:06 1141 2
  • #1 19 Cze 2009 13:06
    anjin
    Poziom 10  

    Niby wszystko jasne ale....
    mam układ Mosfet typu "p" podłączony do +30V drenem podłączony do drenu Mosfeta typu "n" który jest spięty źródłem do masy. Czyli układ połączonych dwóch mosfetów, typu p i n

    Przez otwarty kolektor układu 7407 jest podane na bramkę G napięcie +30V (przez dzielnik który daje +30V dla zamknięcia tranzystora i +15V dla pełnego otwarcia) górne i +12V (12 dla otwarty i 0V dla zamknięty) dolne. I niestety przy podłączeniu napięcia zasilania, napięcie na bramce "dolnego" Mosfeta spada do około +5V ? dlaczego? przecież Mosfet ma izolowane bramki (rozpinam dreny i wraca +12V). zasilania z różnych źródeł - i jest to samo.

    Poszedłem dalej dolne podpiąłem przez niezależny układ logiczny i dałem dodatkowy zewnetrzny tranzystor sterujący bramką Mosfeta i znowu to samo spada napięcie znów do około 5V (zrobił się jakiś stabilizator czy co?) Czy ktoś może wyjaśnić co się dzieje? Wyraźnie napięcie na tranzystorze (dren) zmienia mi wartość napięcia bramki!

    0 2
  • #2 19 Cze 2009 13:13
    chudybyk
    Poziom 28  

    Czy mógłbyś rzucić kawałkiem schematu? Trudno zrozumieć o co chodzi, ponieważ interpunkcję traktujesz nonszalancko. ;-)

    0
  • #3 19 Cze 2009 13:16
    anjin
    Poziom 10  

    tak to wygląda w całosci:
    Sterowanie Mosfetami -problem

    edit:

    no dobra widzę że nikt nie wie o co chodzi więc zamykam temat, bo odkryłem sprawdzając na oscyloskopie że chodzi o wypełnienie impulsu sterującego bramką. Czyli łopatologocznie uśrednione napięcie jest niższe niż trzeba, albo jeszcze inaczej za szybko przełącza Mosfeta ;-)

    0