Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

przetwormnica AVT2732 pali mosfety i diody prostownicze

tom1eczek 23 Cze 2009 12:46 3945 17
  • #1 23 Cze 2009 12:46
    tom1eczek
    Poziom 20  

    Witam, mam kłopot z przetwornicą Irka avt2732. Zmontowanej na zaprojektowanej przeze mnie płytce z rdzeniem troidalnym TN25 (pierwotne 2x4zw), częstotliwość 40kHz - przy tej pobiera najmniej prądu i oscylacje na tranzystorach są najmniejsze. Radiator ma temperaturę 60*C (może za dużo?), diody nieco mniej, transformator <40*.

    Co może myć przyczyną, że w pali mosfety (oryginalne IR) IRFZ44N i diody prostownicze BY500 (1000V) w przetwornicy przy mocy ~70W? chciałbym aby przetwornica "znosiła" moc chwilową o wartości przesterowania głośnika P=25^2/4=625/4=~160W, przy czym moc średnia nie przekracza ~70W (TDA7294).

    Raz w czasie pracy przetwornicy do jednej gałęzi zasilania dołączam rezystor 12ohm (I=30V/12R=2,5A P=30*2.5=75W itak policzone z nadwyżką, bo napięcie przysiada z 29V na 25V) i pęka dioda w mostku greca.

    Dodałem dławik wyjściowy na rdzeniu proszkowym (?) z zasilacza AT nawinięte 2x8albo9zw - brak jakichkolwiek obliczeń. Na oscyloskopie widać, że w chwili przełączania wydziela się na nim (prawie) całe napięcie wyjściowe przetwornicy łagodząc zbocze narastające (o to chodzi?), później napięcie na nim jest bliskie zeru.

    Czy tak wykonany dławik może powodować jakieś przepięcia uszkadzające diody?

  • #2 23 Cze 2009 13:02
    Qwet
    Poziom 33  

    Po pierwsze, przy 4 zwojach i napięciu 14,5V rdzeń TN25 będzie się nasycał przy 60kHz, a 40kHz to jest już tragedia :(

    Mosfety zwykle padają od przebić wywołanych oscylacjami przy przełączaniu. Obejrzyj wykresy napięcia na drenach pod pełnym obciążeniem.

    Temperatura radiatora 60*C pod pełnym obciążeniem może być. Ale jeśli taka temperatura występuje bez obciążenia, to znaczy że coś jest baaardzo źle :( Bez obciążenia mosfety powinny pracować bez radiatora i być zimne jak lód. Prawdopodobnie wina nasycania rdzenia transformatora.

    W ogóle to jaki prąd pobiera przetwornica bez obciążenia?

    Co do diód - jesteś absolutnie pewien, że się nie pomyliłeś i nie kupiłeś BY550 ?

    Jak jest nawinięty dławik? W jaki sposób połączone są uzwojenia?

  • #3 23 Cze 2009 14:47
    tom1eczek
    Poziom 20  

    temperatura 60* pod pełnym obciążeniem, bez obciążenia nie grzeją się bez radiatora. Przetwornica pobiera 350mA w spoczynku przy 13V

    Przetwornica nie będzie pracowała w samochodzie, tylko z akumulatorem (ładowane będzie następowało po wyłączaniu przetwornicy) o maksymalnym napięciu 13,5V bez obciążenia - z pełnym obciążeniem napięcie wejściowe spadnie na 12...12,5V. Czy dla tego napięcia ilość zwojów jest prawidłowa? można prosić o wzory?

    BY500 na 100%. Do temperatury 50...60* dochodzą w minutę, nie za ciepło?

    Uzwojenia dławika nawinięte bifilarnie - przy czym jedno podłączone odwrotnie - tak aby pole magnetyczne się sumowało. bo to zasilacz symetryczny. Napięcie na dławiku wynosi w szczycie 12V, a nie jak napisałem całe napięcie przetwornicy. Ten dławik coś mi się nie podoba. Policzysz mi nowy na rdzeniu proszkowym z zasilacza AT/ATX? Mam druty fi 0,6 i 10,mm

    Mój oscyloskop ma dziś gorszy dzień i musiałbym tłumaczyć bo nie bardzo widać więc narysuję.
    Przebieg na wyjściu TL jest pozbawiony tych oscylacji

  • Pomocny post
    #4 23 Cze 2009 15:22
    trol.six
    Poziom 30  

    tom1eczek napisał:
    Co może myć przyczyną, że w pali mosfety (oryginalne IR) IRFZ44N i diody prostownicze BY500 (1000V) w przetwornicy przy mocy ~70W?

    Patrząc na przebieg to może masz problem z wysterowaniem tranzystorów, nie ma gdzieś tam błędu przy montażu ?

    Swoją drogą to diody, może jednak nie są najlepsze, diody raczej nie padają od samych przebiegów i prądu raptem 2A.

    Słabe gasiki na drenach, jeśli chodzi o tranzystory, ale to już zostało napisane.

    Spróbuj może obciążyć bez mostka tym rezystorem ? Czy też upali tranzystory? Jaki wtedy jest przebieg. Jaki masz prąd spoczynkowy bez diod ?

    Od biedy te 4 zwoje powinny wystarczyć. Ale rzeczywiście mało na tę częstotliwość.

  • #5 23 Cze 2009 15:32
    Qwet
    Poziom 33  

    Częstotliwość 40kHz i 13V i tak będzie za mało. Rdzeń będzie pracował w ekstremalnych warunkach. Może nie będzie się mocno grzał, ale tranzystory będą już atakować szpilki prądu związane z jego nasycaniem.

  • #6 23 Cze 2009 19:00
    -RoMan-
    Poziom 42  

    Na rdzeniu TN25 powinno być 2*5 zwojów. 2*4 zwoje można dać na rdzeniu TN32.

    Dodano po 1 [godziny] 3 [minuty]:

    Acha - przypominam, że częstotliwość pracy przetwornicy jest dwukrotnie niższa od częstotliwości oscylatora w kontrolerze!

  • #7 24 Cze 2009 10:29
    Qwet
    Poziom 33  

    To jest kit AVT2732, więc autor tematu przy dobieraniu częstotliwości prawdopodobnie sugerował się wartościami Ct podanymi na schemacie ;)

  • #8 24 Cze 2009 14:25
    tom1eczek
    Poziom 20  

    Częstotliwość wynikła stąd że za rezystor oscylatora wstawiłem potencjometr i wybrałem taką częstotliwość, żeby prąd spoczynkowy był najmniejszy i wyszło 40kHz. Częstotliwość mierzyłem na tranzystorze kluczującym.

    Sprawdziłem przebiegi, i rzeczywiście jest problem ze sterowaniem tranzystorów. Z samej TL494 przebieg wychodzi zniekształcony i to jest na rysunku. Na bramce ten przebieg zniekształca sie jeszcze bardziej (rysunek) powodując ten "haczyk przy przełączaniu".

    wzór płytki też dołączam, błędów nie znalazłem ale proszę spojrzeć.

    Taki sam przebieg występuje na trzech scalakach więc to też nie one raczej. Może jakieś przeciążenie ich wyjść?

  • #9 24 Cze 2009 16:44
    trol.six
    Poziom 30  

    Jeśli chodzi o płytke, to IMHO masz w nienajlepszym miejscu pojemność 4700u, ścieżki prądowe załączające, nie powinny kolidować z ścieżkami mocy tranzystor trafo. Ta pojemność ma dość kluczowe znaczenie.

    Wprawdzie na oscyloskopie wygląda to niby lepiej , choć dziwnie to wygląda, bo skąd się bierze mały plus? Na pewno masz teraz dobre tranzystory ? Jak wygląda przebieg bez podłączonych bramek? Może przy okazji tranzystory BC327 wyjściowe też poszły? Gdzie podłączałeś mase oscyloskopu podczas pomiaru ? Powinieneś zaraz przy kości.

    Ja na twoim miejscu podniósłbym f do 60-70kHz, a potem jak pisałem przetestował stan jałowy bez diod, i po podłączeniu diod.

  • #10 24 Cze 2009 17:33
    Qwet
    Poziom 33  

    Kurcze no, na tej płytce jest trochę błędów. O najpoważniejszych wspomniał trol.six. Ja proponuję złożenie przetwornicy na oryginalnej płytce AVT - z właściwymi elementami na pewno ruszy i będzie pięknie działać ;) Poza tym jeszcze wypadałoby zwiększyć liczbę zwojów na transformatorze do 2x5zw, albo tak jak mówi trol.six - zwiększyć częstotliwość.

  • #11 24 Cze 2009 18:30
    tom1eczek
    Poziom 20  

    przebiegi stają sie prawidłowe po odłączeniu rezystorów od bramek ale ten sam efekt daje odłączenie transformatora po stronie pierwotnej - czyli pewnie w nim tkwi problem.

    Na próbę pod wyjście mosfetów podłączyłem rezystory 120R i przebiegi na bramkach były dalej oki. Po odpięciu gasika rezystorze był idealny prostokąt. Z gasikiem wiadomo ładowała sie pojemność.

    EDIT:

    nawinąłem trafo na próbę dwużyłowym kablem. początek jednego połączyłem z końcem drugiego i to do plusa zasilania, dwa pozostałe do tranzystorów.

    oscylacje w formie haczyków zniknęły bezpowrotnie, problem jest tylko taki, że przy 2x5zw mam pobór 250mA - czyli wg Irka nieco za dużo, na 2x6zw mam 150mA.

    Zauważyłem, że prąd pobierany przez przetwornicę znacząco spada (a także rośnie sprawność pod obciążeniem) aż do pewnej granicy przy której zaczyna rosnąć. W tym momencie też oscylacje są najmniejsze. Problem w tym, że ta częstotliwość leży gdzieś koło 285kHz dla 5zw ok76kHz dla 6zw i przy 27-33 dla 7zw ale przecież tyle nie będę nawijał bo w rdzeń sie nie zmieszczę.

    Jak zrobić, żeby przetwornica tak ładnie pracowała przy 30kHz?

  • #12 24 Cze 2009 21:23
    trol.six
    Poziom 30  

    Tu już nic nie zrobisz, przy takich rzeczach jedynie stosowanie specjalnych materiałów z bardzo wysoką przenikalnością może coś pomóc. Ale one znowu zwykle mają mniejszą indukcje nasycenia. Tak więc coś za coś

    Pozostaje ci albo większy rdzeń, albo dokonać jakiegoś konsensusu projektowego. Nie wiem czemu boisz się dać odrobine większej częstotliwości, jeśli tylko elementy to znoszą bez większych strat, to czemu nie. Tylko uważaj na diody :) Przy większej częstotliwości lepsze byłyby schottky.

  • #13 25 Cze 2009 11:46
    tom1eczek
    Poziom 20  

    to może nawinę 2x6zw i dam 76kHz, ale czy wtedy mogę dać dławik proszkowy z zasilacza AT? Co sie jemu może stać?

    Na wyjściu mam 10000uF nie LOW ESR (bo są wspólne z zasilaczem sieciowym 50Hz). Czy ma to jakieś znaczenie na grzanie się tych diod?

  • #14 25 Cze 2009 11:57
    Qwet
    Poziom 33  

    Jeśli nie ma stabilizacji napięcia wyjściowego, a dławiki proszkowe są tylko po to aby załagodzić szpilki ładowania kondensatorów wyjściowych, to częstotliwość pracy przetwornicy może przekraczać nawet 50kHz. Z tym że oczywiście im wyżej tym większe straty na ciepło w rdzeniu proszkowym :)

    Mówisz że sprawność przetwornicy rośnie, co oznacza że któryś z elementów coraz mniej się grzeje - który to?
    Proponuję ci zostawić 2x6zw i ustalić częstotliwość na 50kHz.

  • #15 25 Cze 2009 23:19
    tom1eczek
    Poziom 20  

    witam, nawinąłem nowe trafo 2x7zw, przetwornica chodzi na 36kHz, pobiera chyba z 170mA bez mostka i kondensatorów, przebieg na tranzystorze bez obciążenia jest prawie idealny trapez - lekko pochylone zbocza. Niema żadnych oscylacji. Tranzystory zimne nawet pod obciążeniem - ale dałem większy radiator.

    Temperatura diod prostownika dochodzi do 70* i wg załączonego wykresu z noty BY500 -1000 maksymalny średni(!) prąd wynosi wtedy 2A.

    Wydaje mi się jednak, że po dwie diody przewodzą prąd na dodatnie wyjście zasilacza i po dwie na ujemne. Związku z tym chyba prąd tych diod powinien się sumować? 2+2=4A na wyjściu... Mam racje?

    Czy ktoś by mi policzył (ile zwojów) dławik wyjściowy na rdzeniu z zasilacza AT dla napięcia +-30V, i mocy ciągłej 80W?

    Czym sugerować się przy nawijaniu dławika "na oko"?

  • Pomocny post
    #16 26 Cze 2009 14:01
    Qwet
    Poziom 33  

    tom1eczek napisał:
    Wydaje mi się jednak, że po dwie diody przewodzą prąd na dodatnie wyjście zasilacza i po dwie na ujemne. Związku z tym chyba prąd tych diod powinien się sumować? 2+2=4A na wyjściu... Mam racje?

    Tak jest proszę pana ;)

    tom1eczek napisał:
    Czy ktoś by mi policzył (ile zwojów) dławik wyjściowy na rdzeniu z zasilacza AT dla napięcia +-30V, i mocy ciągłej 80W?

    Znamy napięcie, ale żeby obliczyć optymalną wartość indukcyjności i prąd nasycenia dławika, musimy wiedzieć jaki będzie wzmacniacz.
    Trzeba znać:
    - liczbę kanałów wzmacniacza
    - mostek czy półmostek
    - impedancję obciążenia dla każdego z kanałów.

  • #17 26 Cze 2009 17:42
    tom1eczek
    Poziom 20  

    jeden kanał, 1sztuka (nie mostek) TDA7293 (tj 7294) 4omy, chcę z niej wycisnąć te 70W, pod obciążeniem planuje napięcie 25,6V. Powinno chyba z 30V tyle przysiąść.

  • #18 28 Cze 2009 13:05
    Qwet
    Poziom 33  

    No to super, bo TDA7293/7294 mogą pracować z wyższymi napięciami niż zalecane do danej impedancji, więc nic im nie będzie ;) Napięcie w instalacji samochodu waha się od 10 do 14,5V, więc jeśli robisz przetwornicę bez stabilizacji, takie wahania napięcia będziesz miał na wyjściu przetwornicy.
    Proponuję ci zrobić tak:
    Policz taką przekładnię, żeby przy napięciu zasilającym 10V na wyjściu było 2x25V. Przy napięciu zasilania 14,5V (włączony silnik) bez podawana sygnału na końcówkę będziesz miał 2x36V, czyli TDA bez probelmu to wytrzyma ;) A wzamcniacz będzie osiągał założone 70W zarówno na włączonym i na wyłączonym silniku ;)

    Dodano po 6 [minuty]:

    Co do dławika - prąd nasycenia powinien wynosić 6,5A, bo taki jest próg zabezpieczenia nadprądowego w TDA7294. Nie sugeruj się "Absolute Maximum Ratings" gdzie podawane jest 10A - on odcina przy 6,5A ;)
    W związku z tym, ponieważ proszkowe krążki z ATX nasycają się powyżej 300A*zw, możesz nawinąć najwyżej 2x46 zwojów. Dla pewności jednak polecam 2x40 zwojów. Spadnie indukcyjność, ale to nie przeszkadza bo i tak będzie bardzo duża - te 40 zwojów daje aż 100-160µH, zależnie od rodzaju materiału. Nawet 100µH to znacznie więcej niż potrzeba ;)
    Jeszcze raz przypominam o sposobie podłączenia uzwojeń - strumienie indukcji magnetycznej obu uzwojeń MUSZĄ SIĘ SUMOWAĆ, NIE KOMPENSOWAĆ! Krzyczę, bo to bardzo ważne :)

 
Black Friday do -15%
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
Ferguson