Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Sinumerik 840C- błąd przy zjeździe na bazy

arci36 06 Jul 2009 13:02 2274 3
  • #1
    arci36
    Level 12  
    Witam
    Mam problem z tokarką CNC ze sterowaniem Sinumerik 840C. Przy maszynie uszkodził się enkoder w osi Z. Okazało się, że przepaliła się żarówka. Wymieniłem ją na żarówkę z innego typu enkodera. Teraz mam odczyt drogi w osi Z, ale maszyna nie chce "wybazować się" w osi Z. Po naciśnięciu przycisku zjazd na bazę w osi Z maszyna jedzie do krańcówki po czym zmienia kierunek jazdy i jedzie do samego uchwytu aż wystąpi błąd przeciążenia. Powinna jechać około 20mm i wrócić na krańcówkę. Czy jeszcze jest coś nie tak z enkoderem czy pomieszało się coś w sterowaniu jak nie było odczytu z enkodera?
    Ethernet jednoparowy (SPE) - rozwiązania w przemyśle. Szkolenie 29.09.2021r. g. 11.00 Zarejestruj się za darmo
  • #2
    12robert12
    Level 28  
    a co to jest żarówka w enkoderze ? :D chyba czegoś nie wiem. a co to za silniki ? Serwa? rozpinałeś enkodery w serwach ?

    ja nie zajmuję się tokarkami, ale u mnie w maszynach jest podobny sposób ustawiania podejrzewam że masz enkoder inkrementalny z punktem zerowym i czujnik pozycji zerowej.

    nie zajmuję się Sinumerikiem, znam simodrive:

    jeżeli z enkoderem jest wszytko ok to:

    rozepnij oś Z mechanicznie i przytrzymaj krańcówkę, włącz bazowanie, jak silnik będzie kręcił do odjazdu to puść krańcówkę po pewnym czasie się zatrzyma i zmieni obroty to po zmianie obrotów naciśnij znów krańcówkę i trzymaj aż się zatrzyma silnik, po tym wyłącz maszynę, najedź fizycznie osią na krańcówkę i połącz mechanicznie z osią silnika. wyłącz zasilanie i załącz ponownie maszynę i sprawdź czy zadziałało.

    u mnie w pracy tak mnie uczyli ustawiać inżynierowie włoscy przędzarki wózkowe o długości osi 40metrów, kiedy jak są za duże prędkości, przyśpieszenia na osiach przeskoczą pasy zębate lub łańcuchy, lub po wymianie serw. Zawsze skutkuje poprawną pracą :D .

    Pewnie są inne sposoby wykonania zreferowania tej osi ale ja nie znam się na Sinumeriku (zapewne instrukcja G74 lub zaznaczenie programowo punktu zero)
    ale myślę że coś źle zrobiłeś przy naprawie enkodera

    Pozdrawiam :)
  • #3
    Jarosław Pawlik
    Level 11  
    Trzeba sprawdzic czy z enkodera wychodzi sygnał identyfikacji. Impuls ten pojawia się tylko raz na obrót, czyli co 360 stopni. Jeśli go nie ma nigdy maszyny nie wybazujesz.
  • #4
    wjmarcia
    Level 13  
    Masz uszkodzony przetwornik lub kabel, ewentualnie karte, ale na sam początek zamień przetworniki z X.