Elektroda.pl
Elektroda.pl
X
Sklep HeluKabel
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Jak wzmocnić sygnał karty dźwiękowej i pozbyć się szumów?

RhumZeiss 07 Lip 2009 09:44 7457 8
  • #1 07 Lip 2009 09:44
    RhumZeiss
    Poziom 8  

    Jestem tu po raz pierwszy zatem kłaniam się Państwu nisko. ;)

    Problem
    Postanowiłem podłączyć komputer do wzmacniacza. Niby nic wielkiego. Niestety — poległem. Sygnał z karty dźwiękowej jest tak słaby, że brakuje mi wzmocnienia na skali. „Na ucho” oceniam, że jest co najmniej 2/3 słabszy niż sygnał radiowy. Dodatkowo, słyszę szumy oraz coś w rodzaju… bulgotania w lewej kolumnie.

    Sprzęt
    Posiadam wewnętrzną kartę dźwiękową SoundBlaster Audigy 2 ZS podłączoną kablem mini jack/DIN do radiowzmacniacza Tosca 303. Tosca jest stareńka ale dzielna. Jest pierwszego typu i ma z tyłu jedynie wejście magnetofonowe i gramofonowe.

    Niestety nie znam tych danych:
    Parametry sygnału gniazda line-out karty SB Audigy 2 ZS: ???
    Paramatry dla gniazda magnetofonowego w Tosce: ???
    Paramatry dla gniazda gramofonowego w Tosce: ???

    Objawy — dokładniej
    Po pierwsze — CICHO:
    Dla wejścia magnetofonowego wręcz ekstremalnie cicho. Dla gramofonowego — ciut lepiej, może Tosca sobie sygnał z tego gniazda nieco wzmacnia?
    Po drugie — ZAKŁÓCENIA:
    Szumi. Dla wejścia magnetofonowego ledwie słyszalnie, bo ledwie słyszalna jest sama muzyka. Dla wejścia gramofonowego — mocniej, bo muzyka jest też nieco głośniejsza. Zapewne odległość między szumem a poziomem muzyki i tu i tu jest podobna.
    Szumu nie słychać przy sygnale puszczonym z radia, więc to nie wzmacniacz w Tosce szumi. Ale chyba i nie karta Audigy, bo na słuchawki daje sygnał przyzwoity. Poza tym, w komputerze mam też kolejny układ dźwiękowy — wbudowanego Realtec'a AC97. Puściłem dźwięk z niego na wzmacniacz i szumiało i bulgotało i było cicho, zaś na słuchawki — było dobrze.
    W końcu, tym samym kablem podłączyłem odtwarzacz iRiver T10, czyli coś, co jak na zabawkę brzmi na prawdę ładnie. Efekt — identyczny, czyli cicho, szumi i bulgocze.
    Potem wyjąłem kabel z karty, tak, że zwisał swobodnie z gniazda Tosci i szumiało nadal. Wyjąłem więc kabel także z Tosci i wciąż szumiało, wciąż bulgotało.
    Zacząłem już myśleć, że to komputer stojący blisko radiowzmacniacza negatywnie wpływa na jego pracę. Wyłączyłem go. Szumiało nadal.
    Po trzecie — ZNIEKSZTAŁCENIA:
    Dla wejścia magnetofonowego basy i część środka są nie przenoszone, ewentualnie wysokie tony nadmiernie podbite. Raczej — to pierwsze.
    Dla wejścia gramofonowego sygnał jest równomierny.
    Identycznie zachowywały się oba komputerowe układy dźwiękowe oraz odtwarzacz iRiver T10.
    Być może taka jest charakterystyka wejść magnetofonowych, że im się obcina "dół" — nie wiem — gdybam.

    Uwagi




    Przed laty, do dokładnie tego samego amplitunera miałem podłączoną kartę SoundBlaster AWE 64 Gold z wyjściami chinch’owymi i sygnał był nieco mocniejszy i nie szumiał tak szpetnie. Wiem, że ta karta (AWE 64) nie miała wbudowanego wzmocnienia sygnału wyjściowego, tym bardziej dziwię się, że była jednak głośniejsza i czystsza.
    Sam radiowzmacniacz był rok temu na przeglądzie w serwisie, dlatego zakładam, że działa dobrze.

    Próbki
    Na wszelki wypadek pozwoliłem sobie zamieścić próbki, tego, co wydobywa się z moich głośników. A zatem: brak sygnału zewnętrznego, Tosca ustawiona na odbiór z gramofonu, wzmocnienie do końca skali i
    Szumiący i bulgoczący kanał lewy (mikrofon 30cm od głośnika): ściągnij: kanał lewy — MP3
    i szumiący kanał prawy (mikrofon 20 cm od głośnika): ściągnij: kanał prawy — MP3

    Gubię się w rozwiązaniach
    Jak tu wzmocnić sygnał? Kupić przedwzmacniacz? Ale jaki? Na drogi i nowy mnie nie stać. A może będzie pasowała któraś z tych miniaturek słuchawkowych za 35-80 zł, choćby:
    zobacz: drobny kawałek plastiku na bateryjkę
    Albo gramofonowy:
    zobacz: przedwzmacniacz gramofonowy na zasilacz
    A może przedwzmacniacz mikrofonowy lecz stereo też będzie się nadawał?
    zobacz: to samo, ale na mikrofon stereo
    Inna droga? Coś takiego:
    zobacz: płytkę
    zobacz: inną płytkę
    A szum? Skąd się bierze? Jak go zlikwidować. Może powinienem coś uziemić? Jeśli nawet, to co?
    I jeszcze "bulgotanie"? Jak się go pozbyć? To sprawa uziemienia, a może coś w Tosce padło?

    Pytający
    Wybaczcie mi państwo jeśli cokolwiek pokręciłem lub podałem jakąś niezwiązaną ze sprawą informację — nie znam się na elektronice.


    A może jest coś zasilanego z USB, albo Molexa lub PCI?

    0 8
  • Sklep HeluKabel
  • #2 07 Lip 2009 10:14
    780810
    Poziom 17  

    Wzmocnienie sygnału nic ci moim zdaniem nie da. Jeśli radio dobrze chodzi to najprostrzą przyczyną jaka mi przychodzi do głowy to źle zrobiony bądź uszkodzony kabelek, żle podpięte piny we wtyczce DIN, dlatego cicho chodzi bo sygnał dostaje się tylko przez przesłuch między przewodami a nie jest elektrycznie podłączony. Wyciąg kabel z gniazda i sprawdź np igłą w których "dziurkach" wzmacniacz "buczy" i tam prowizorycznie podepnij kabelek z kompa (wymagać to będzie rozcięcia kabelka)a masę tegoż kabla na środkowy pin DINa

    0
  • Sklep HeluKabel
  • #3 07 Lip 2009 10:17
    tronic1
    Spec od komputerów

    Kupić ? Żaden z powyższych. Problem jest w niedopasowaniu wyjścia z Line Out z wejściem wzmacniacza. Poziom sygnału z wyjścia karty jest na tyle wysoki że potrafi wysterować wzmacniacz mocy. Przykład: https://www.elektroda.pl/rtvforum/topic569702.html .Problem w tym że jak piszesz nie znasz się na elektronice. Należało by pominąć istniejące wejścia wzmacniacza i dobudować nowe, dedykowane dla karty dźwiękowej, z pominięciem przedwzmacniaczy, podając sygnał na wejście wzmacniacza mocy, przed regulacją siły głosu. Może w dziale Audio znajdziesz gotowe rozwiązanie.

    0
  • #4 07 Lip 2009 10:23
    780810
    Poziom 17  

    Z całym szacunkiem ale przy za mocnym sygnale miałby po prostu przester a u niego nie odzywa się prawie nic, a te szumy to przez to że pewnie gała odkręcona do oporu a to w końcu leciwa Tosca.

    0
  • #5 07 Lip 2009 11:09
    tronic1
    Spec od komputerów

    Kolego 780810 - przeczytaj uważnie co napisałem i wskaż w którym miejscu jest błąd. Jeżeli pytający zastosuje któreś z istniejących wejść to i tak będzie źle. Wejście będzie niedopasowane. Należy wykonać nowe połączenie. Oczywiści można wykorzystać któreś z istniejących gniazd ale chyba nie sprawi większego problemu mechaniczne zamocowanie dodatkowego gniazda Jack i wykonanie poprawnego połączenia oczywiście kabelkami ekranowanymi. W końcu charakterystyka pasma przenoszenia wejścia też ma znaczenie. Istniejące wejścia nie nadają się do tego celu.

    0
  • #6 07 Lip 2009 11:15
    780810
    Poziom 17  

    Zgadzam się że to by było najlepsze rozwiązanie. Chodzi mi o to że kolega jak sam zaznaczył nie zna się na elektronice i nie wiem czy sobie poradzi z takim rozwiązaniem, a z drugiej strony sam używałem Toski jako wzmacniacza do komputera i wiem że wyrabia jeśli się nie jest audiofilem oczywiście. I po pierwsze powinien sprawdzić nawet palcem czy na minijacku ma sygnał wejściowy bo podejrzewam że nie a dopiero po rozwiązaniu tego problemu martwić się o parametry sygnału.

    0
  • #7 08 Lip 2009 15:10
    RhumZeiss
    Poziom 8  

    Pochłonęły mnie poszukiwania internetowe. W sprawie Audigy 2 ZS niczego sensownego nie znalazłem. Google jest pełne chwalebnych wieści na temat tego SoundBlastera, ale danych o wyjściach liniowych — nie uświadczysz choćbyś pękł. Natomiast z Toscą sprawa przybrała kształt liczb.
    Znamionowe napięcie wejściowe wzmacniacza m.cz.:
    - magnetofon ≤200 mV
    - gramofon z przetwornikiem magnetoelektrycznym ≤2 mV
    Cokolwiek to znaczy, mam już jakieś dane na temat. :)
    Znalazłem je w tym uroczym miejscu.
    Zakładam, że napięcie wejściowe wzmacniacza małych częstotliwości i napięcie na DINowskich gniazdach wejściowych to być może to samo. Jeśli nie proszę mnie poprawić.

    Na wszelki wypadek znalazłem też schemat Tosci 303:
    1. Schemat Tosca 303 w PDF-ie
    2. Schemat Tosca 303 w TIFF-ie (ciut wyraźniejszy)
    A nawet porządną instrukcję serwisową wraz z wyraźnym schematem i podziałem na bloki. Uwaga: 27,6 MB ale warto!
    Może się przyda?

    Zatem, po kolei…

    Sprawdzanie kabla i gniazd
    W obu gniazdach to samo — po włożeniu „czegoś metalowego” w skrajny lewy otwór buczy kanał lewy, z kolei sąsiedni otwór reaguje adekwatnie, ale dla kanału prawego.
    Kable (bo sprawdzałem dwa) raczej są dobre. Nie robiłem ich sam, lecz kupiłem gotowe. Po podłączeniu kabla i dotknięciu końcówki mini Jacka — buczy lewa kolumna, zaś po dotknięciu środka wtyku — odzywa się prawa.
    W tym miejscu znalazłem opisy gniazda i wtyku DIN5 oraz Jacka stereo. Tak samo jest u mnie.
    Rozebrałem wtyki DINowe i masę tez mają tam gdzie trzeba.

    Jeśli biorę kable w dłoń, to buczenie wzmaga się tym mocniej im bardziej zwinę kabel w równomierną wiązkę. Dlatego napisałem, że kable są tylko „raczej dobre”. Jeden z kabli ma pięć metrów. Jeśli rozwinę go na długość, wówczas potęguje buczenie sam z siebie, nawet nie muszę go trzymać. Jeśli jednak zwinę go w kłębek i położę przy Tosce, przestaje buczeć. Krótki kabel, metrowy — nie buczy. Wygląda na to, że przy okazji powinienem wymienić kable na ekranowane?

    Nowe gniazdo czy przeróbka starego?
    Zmartwiłem się, że żadne ze znalezionych przeze mnie „ustrojstw” nie da odpowiedniego sygnału. Zatem stanęło na dorobieniu nowego wejścia w Tosce (miejsce jest) lub… dolutowaniu jakiegoś układu za wejściem magnetofononowym tak, by na stałe przystosować je do odbioru sygnału z karty dźwiękowej komputera.
    Wolałbym zmienić przeznaczenie wejścia magnetofonowego, bo:
    - gramofonowe będzie mi potrzebne,
    - uniknę konieczności defasonowania panelu Tosci niezręcznym wycinaniem otworu pod przycisk „komputer” jeśłibym dorabiał trzecie gniazdo.
    Jeśli jednak macie dobry pomysł na trzecie wejście — to czekam niecierpliwie i z zaciekawieniem.

    Przeszukałem forum…
    dokładniej i znalazłem pewne tropy… jak dla mnie — niedokończone:
    Tutaj są przypuszczenia o tym, jaki powinien być sygnał na wyjściu karty a jaki po wyjściu z przedwzmacniacza i przypuszczenia z czego być może trzeba sklecić rozwiązanie.
    Zaś w tym miejscu są sprzeczne dywagacje o buczeniu: raz, że kabel za długi, innym razem, że marnej jakości, jeszcze innym, że źle uziemiony (i trzeba wlutować mocny opornik), albo z kolei komputer nie uziemiony. Ech.

    Bardzo ciekawe jest wątek przytoczony przez tronic1. Chodzi mi o rozwiązanie oparte na czymś co się nazywa TDA7053. Rozumiem, że jest to zestaw do zlutowania razem z płytką? Można go dostać w sklepach elektronicznych? Pytam, bo na alleDrogo.pl — nie ma. Poza tym są dwie kwestie: pierwsza, żeby to wsadzić bezpośrednio do USB musiałbym mieć zrobioną specjalną płytkę, a to chyba nie Philipsa, lecz rosyjski pomysł, więc u nas nie ma.
    Kwesta druga — a basy to mi przywróci do normy?

    Moja elektronikoodporność…
    polega na tym, że nie znam się na teorii elektryczności, toteż nie bardzo umiem czytać schematy. Gdy mi ktoś powie: „…no wiesz, cewka indukcyjna(…). Tylko pilnuj napięć. (…) I pamiętaj o polaryzacji…” — wtedy uciekam. Płytki też nigdy nie trawiłem. Ale jeśli powiedzą mi: „Kup płytkę o tej nazwie, wiaderko oporników, potencjometr i włącznik. Weź to i przylutuj tu, ale najpierw połącz z tym, w ten sposób żeby pomiędzy był ten rezystor i w tę stronę, a od tego miejsca poprowadź kabelek do obudowy albo radiatora…” — to sobie poradzę.
    Niewiele to, ale zawsze.

    Szczególnie, że jestem zdeterminowany, by rozwiązać tę sprawę.


    ___________
    Jeśli coś pomieszałem, to zacznijcie od „prostowania” mnie, żebym zrozumiał.

    Jeszcze o szumach i różnicy wzmocnienia w mojej Tosce, tym razem dokładnie
    Zwykle podczas słuchania radia ustawienie pokrętła głośności nie przekracza drugiej kropki z dziesięciu, które je otaczają. Szumu nie słychać, bo słuchać radio. Jeśli wyłącze radio (gramofon i magnetofon tez są wyłączone), to wzmacniacz nie otrzymuje znikąd sygnału. Wtedy przesuwam wzmocnienie do końca, czyli na 10 (podbicie niskich i wysokich wyzerowane) i w głośnikach pojawia się ledwie słyszalny szum. Przy podbiciu niskich i wysokich do końca — szum ten słychać zarówno przy ustawieniu wzmocniena na 10 jak i na 9. Zakładam, że jest to naturalny poziom szumu w mojej Tosce i do niego będę się odnosił. Myślę, że wymiana paru drobnych fantów ze środka na wspólczesne odpowiedniki zlikwidowała by sprawę, ale my dziś nie nie o tym.
    Gdy przełączę Toscę na magnetofon — poziom szumu jest identyczny.
    Przy przełączeniu na gramofon szum jest bardzo silny. Słuchać go jeszcze przy trójce na skali głównego wzmocnienia o ile podbicie wysokich i niskich jest na maksa. Przy wyzerowanym podbiciu wysokich i niskich szum pojawia się przy czwórce.

    Przy sygnale z komputera na wejście gramofonowe minimalną głośność do słuchania uzyskuję dopiero przy nastawieniu wzmocnienia na 8, przy czym szumy są okropne, szczególnie w lewym kanale (podbicie niskich i wysokich oczywiście na zero). Wygląda na to, że panowie w serwisie jednak nie przyłożyli się do toru związanego z gramofonem.
    Na wszelki wypadek załączam próbki "gramofonowe" z kanału lewego oraz kanału prawego.

    Przy sygnale z komputera na wejście magnetofonowe minimalną głośność do słuchania uzyskuję dopiero przy nastawieniu wzmocnienia na 9, przy czym szumy są prawie niesłyszalne, za to dźwięk jest płaski i niemal całkowicie pozbawiony basu (o czym pisałem za pierwszym razem).

    Zupełnie na marginesie — okazuje się, że podbicie niskich i wysokich w Tosce daje 10% wiecej. Tak na słuch.

    0
  • #8 08 Lip 2009 15:21
    tzok
    Moderator Samochody

    Wejście gramofonowe ma większe wzmocnienie i nieliniową charakterystykę, nie nadaje się do wykorzystania wprost. Wejście magnetofonowe powinno działać bez przeszkód.
    Poziom sygnału na wyjściu line-out wynosi 1Vp-p dla impedancji obciążenia 75 Ohm (typowe parametry wyjścia liniowego w niemal każdym sprzęcie audio).

    Wszelkie objawy pasują do braku połączenia masy. Spróbuj w miejsce karty dźwiękowej (na tym samym kablu) podłączyć np. discman'a (jeśli ma tylko wyjście słuchawkowe, to ustawiony na ok 1/4 głośności). W PRLowskich sprzętach masa z DINów często nie była podłączona na pinach, a jedynie na ekranie wtyczki, sprawdź więc czy w Twoim kablu masa jest na "kołnierzu" wtyku DIN.

    O ile widzę z tego schematu (choć tam chyba kawałka brakuje...), to kanały L i P powinieneś mieć podłączone do 2 kolejnych pinów we wtyku DIN i to w ten sposób, by po podłączeniu do wejścia gramofonowego w ogóle nie było żadnego sygnału w głośnikach (czyli piny* 1 i 4, a nie 5 i 2). Uważaj też na przełącznik wejść - bo aktualnie odłączone wejścia są zwierane do masy, karcie może się to "nie spodobać".

    ---
    * - numeracja pinów idzie tak:

    Code:
       _____
    
      /     \
     | 1   3 |
     | 4   5 |
      \__2__/

    0
  • #9 09 Lip 2009 10:28
    780810
    Poziom 17  

    Tą masę sprawdź w ten sposób. Weź tego minijacka i dotknij np środkowy segment aby buczał np płaskim śrubokrętem a następnie zewrzyj go z segmentem masy (ostatnim, nie końcówką:-) buczenie ma ucichnąć, jeśli nie ucichnie to jednak ta masa gdzieś znika

    0