Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

open office/excel - makro - kopiowanie danych dwóch kolumn

cleanharry 09 Lip 2009 14:51 3639 3
  • #1 09 Lip 2009 14:51
    cleanharry
    Poziom 2  

    Witam,

    używam Open Office.

    W arkusz1 mam kolumnę 'substancja' oraz 'cena'. W każdej komórce kolumny 'substancja' można wybrać substancję z rozwijanej listy. Lista substancji znajduje się w arkuszu2 (również w kolumnie). I teraz chciałbym, aby wybierając jakąś substancję, kopiowała się również jej cena do kolumny obok (ceny podane są również w arkuszu2 w kolumnie sąsiedniej do tej z listą substancji.

    Jak to zrobić w open office?

    Być może nie trzeba robić makra?

    chciałbym załączyć plik, ale rozszerzenie .odt nie przechodzi.

    Z góry dziękuję za wszelką pomoc.

    Pozdrawiam

    0 3
  • #2 09 Lip 2009 15:14
    adamas_nt
    Moderator Programowanie

    Zakładając, że dane w Arkusz2 zajmują dwie pierwsze kolumny (w Excelu) w komórkę B1 należy wpisać:
    =WYSZUKAJ.PIONOWO(A1;Arkusz2!A:B;2;0)
    i skopiować w dół.

    0
  • #3 09 Lip 2009 22:02
    cleanharry
    Poziom 2  

    Dzięki Tobie doszedłem jak to jest w OpenOffice.

    dzięki!

    A przy okazji, jak zsumować kolumnę w której np. jedna wartość jest '#N/A'? Albo jak zrobić, żeby to #N/A się nie pojawiało (choć teoretycznie będzie w tle) i można było zsumować?

    0
  • #4 09 Lip 2009 22:25
    adamas_nt
    Moderator Programowanie

    Jeśli sumujesz zakres, który zawiera błąd to wynikiem będzie błąd. Należałoby postawić warunek dla formuły, która błąd generuje. W Excelu wystarczy użyć CZY.BŁĄD Np
    =JEŻELI(CZY.BŁĄD(Twoja Formuła);0;Twoja Formuła)
    W wyniku czego wartość komórki przy błędzie będzie zerowa (akceptowalna jako składnik sumy).

    0