Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Przetwornica push pull spadek napięcia wyjściowego- problem

16 Jul 2009 14:59 4752 7
  • Level 13  
    Witam,
    Zrobiłem ostatnio przetwornicę, która miała mieć moc min 250 W. Sterownik Tl494, tranzystory 337/327 i irfz44N transformator na rdzeniu E55 f-867 (proszę nie pisać, że jest on o wiele za duży :D ) uzw. pierwotne 2x5zw 25szt drucików 0,5mm wtórne 2x11zw 10szt 0,5mm (Ta przetwornica miala mieć opcję rozbudowy, dlatego są takie ilości miedzi na transformatorze, a poza tym jest tam dużo miejsca :) ) Diody prostownicze schottkiego (3 szt bo 4 poszła z dymem :) ale dziś ją jeszcze wymienię). I to by bylo chyba tyle. Więc moim problemem jest to, że gdy podłączę jakiekolwiek obciążenie napięcie na wyjściu strasznie spada :( pod obciążeniem 0,52A napięcie wynosi 26,1V z 31V luzem Sprawność ok 85% ( wyjście 13,57W wejście 15,9W). Przetwornice zasilam z akumulatora, więc prądy jej nie brakuje, napięcie jest w miarę stabilne. Prąd spoczynkowy to ~100mA, A częstotliwość to ok 30kHz (tylko tego nie jestem pewien z powodu mojego miernika, który jest powiedzmy delikatnie uszkodzony) A napięcia i prądy mierzyłem dobrze działającym innym, więc nie powinno być błędu.

    W przetwornicy jedyne co się grzeje, to rezystor od gasika (bardzo słabo) irfz'y na luzie, praktycznie wogóle, i diody prostownicze (pod obciążeniem)

    Dlaczego mam takie spadki napięcia ?

    zdjęcia:
    Przetwornica push pull spadek napięcia wyjściowego- problem

    Przetwornica push pull spadek napięcia wyjściowego- problem

    A na końcu schemat (innej wersji nie mam, ale to jest najprostsza aplikacja tl'ka ):
    Przetwornica push pull spadek napięcia wyjściowego- problem
    [Szkolenie 22.06.2021, g.9.00] Zabezpieczenia Internetu Rzeczy (IoT) programowe i sprzętowe. Zarejestruj się za darmo
  • Level 33  
    Overclocker wrote:
    transformator na rdzeniu E55 f-867 (proszę nie pisać, że jest on o wiele za duży :D )

    Dlaczego nie? :) Trzeba wyraźnie zaznaczyć, że jest o wiele za duży. Transformator 250W na tak dużym rdzeniu trudno jest poprawnie nawinąć. Pewnie zostało ci sporo pustego miejsca w oknie rdzenia i właśnie to może być przyczyną spadków napięcia. Swoją drogą, jak duża jest szczelina na kolumnie głównej rdzenia? :)

    Nie widzimy na schemacie uzwojeń transformatora ani sposobu nawinięcia dławika wyjściowego.

    Pokaż oscylogramy napięć na drenach i prądów drenów pod obciążeniem i bez obciążenia.

    Podaj wartości Rt i Ct. Określimy częstotliwość pracy przetwornicy ;)
  • Level 13  
    transformator nawinięty jest bifilarnie, starałem się najlepiej jak mogłem :) uzwojenie pierwotne i wtórne jest na całej szerokości karkasu. rdzeń ten nie ma szczeliny, a jeżeli ją ma, to pewnie um :D Rt 10k Ct 3,3 F. Niestety nie mam oscyloskopu :/
    Sposób nawinięcia naszkicowany w paincie :D

    Przetwornica push pull spadek napięcia wyjściowego- problem

    Oczywiście jest 2x5zw i wszystkie wyprowadzenia uzw. pierwotnego są po jednej stronie a wtórnego po drugiej, długość uzwojeń pierwotnych praktycznie się nie różnią podobnie jak wtórnych

    Zapomniałem napisać o dławiku, rdzeń z ATX'a 2x16 zw nawinięte tak, pola się sumują, drut nawet nie wiem jakiej grubości jest ale coś kolo 1mm
  • Level 33  
    Ta przetwornica nie ma prawa działać - częstotliwość jest absurdalnie mała, ledwo 16,6µHz :( Pokaż nam ten kondensator Ct.

    Uzwojenia transformatora połączone prawidłowo, ale nie o to mi chodziło. Czy udało ci się zapełnić okno uzwojeniami tak że miałeś kłopoty z założeniem rdzenia?
  • Level 13  
    Sory mój błąd ^^ 3,3 nF a z uzwojeniem problemu nie miałem, mam tam jeszcze miejsce, rdzeń wchodzil lekko, nawet bardzo, dlatego nawinąłem na jego środkową kolumnę kilka zw taśmy, żeby nie tłukł się w karkasie, oczywiście taśma nie przeszkadza, żeby złączyć rdzeń ( nie robi żadnej szczeliny) w wersji na pająka przez przypadek wysunął mi się rdzeń, i IRFZ poszedł z dymem, więc wolałem się zabezpieczyć :D
  • Level 33  
    Czyli przyczyną spadków napięcia jest nieprawidłowe nawinięcie transformatora. Puste miejsce w oknie znacznie pogarsza sprzężenie między uzwojeniami. W ogóle rdzenie kształtkowe słabo nadają się do przetwornic CarAudio. Lepiej zastosuj jakiś TN32, spadki napięcia będą dużo mniejsze ;)

    Układ był palony, więc sprawdź jeszcze bufory i tranzystory w TL494, bo one też mogły ulec zniszczeniu. Bez aktywnego jednego klucza przetwornica CarAudio pracuje jak jednotranzystorowy forward i spadki napięcia na pewno będą duże.

    Częstotliwość pracy masz tylko 16,6kHz. Czy transformator ci nie piszczy? Zapytaj osobę z dobrym słuchem :) A jeśli nie piszczy, posprawdzaj Rt i Ct miernikiem.
  • Level 13  
    Nie, nie piszczy :) oba klucze są ok, przynajmniej tak mi się wydaje, obciążałem je rezystorkiem zamiast rdzenia, i sprawdzałem czy jest ciepły, wiem, że metoda słaba jest :D ale sprawdzałem też tym moim super miernikiem, i pokazywało że coś jest, więc nie wiem myślałem o zrobienieniu stabilizacji napięcia,a ale nie wiem, jak się za to zabrać... i jeszcze jedno, jako wskaźnik napięcia wżyłem diody LED i 1 zw na transformatorze (diod mam w zapasie, wiec nawet nie sprawdzałem napięcia :) ) i przy obciążeniu 1 A dioda prawie całkiem gaśnie :/ no ale to nie jest problem. Możliwe, że kondensator na wejściu jest jakiś dziwny, dałem 10000uF/16V 105 *C

    Czy możliwe jest, że dzieje się to, dlatego, że nie wypełniłem całego wolnego miejsca na karkasie ? bo mi się to nie wydaje za bardzo prawdopodobne...
  • Level 35  
    To JEST mozliwe i właśnie o tym pisze kolega Qwet. Ja sie trzymam zasady zeby "za*rać" całe okno do bólu. Jak masz duzy rdzen, uzyj wiekszej ilosci drutu do nawijania (Większej ilości, nie więcej zwojów!), to ma szanse troche poprawić prace.

    Do Twoich zastosowan i tak najlepszy byłby toroid, tam tego problemu raczej nie bedziesz mieć.

    A napięcie wyj pod obciążeniem tak czy siak będzie ci pływać, bo nie masz stabilizacji...