Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Ciągłe pobieranie adresu sieciowego. LAN Eathernet RJ45

mrozwisz 22 Lip 2009 11:59 9121 11
  • #1 22 Lip 2009 11:59
    mrozwisz
    Poziom 9  

    Witam.
    Mam problem z Połączeniem lokalnym. Połączyłem dwa komputery kablem "scrossowanym" RJ45. Chciałbym udostępnić internet z komputera A na komputer B. Na komputerze A internet działa. Połączenie lokalne konfigurowałem na wiele sposobów. Kreatorem konfiguracji sieci (z panelu sterowania) oraz wpisywałem IP "na sztywno" czyli
    Komputer A:

    IP: 192.168.0.1
    Maska: 255.255.255.0
    Brama: BRAK
    Komputer B:
    IP: 192.168.0.2
    Maska: 255.255.255.0
    Brama: 192.168.0.1

    Po wpisaniu tych danych pisze na komputerze A i B iż są połączone lecz na komputerze B wciąż nie ma internetu. Na komputerze udostępniającym łącze jest włączona opcja. Moja konfiguracja wydaje się być poprawna lecz tak nie jest. Lecz gdy włączę automatyczne wykrywanie IP wciąż widnieje błąd "Pobieranie adresu sieciowego..." Po pewnym czasie ten komunikat zmienia się na "To połączenie ma ograniczoną łączność. Ten problem cały czas mnie prześladuje. Formatowanie komputera nic nie pomaga. Proszę o pomoc.

    Modem: ZTE ZXDSL852 v1 (2diody)
    Model karty sieciowej komputera A:
    Realtek RTL8168C(P)/8111C(P) PCI-E Gigabit Ethernet NIC
    Model karty sieciowej komputera B:
    SiS 900-Based PCI Fast Eathernet Adapter

    Załączam screen z konfiguracją komputera A
    Ciągłe pobieranie adresu sieciowego. LAN Eathernet RJ45

    @EDIT:
    Problem z pobieraniem adresu sieciowego występuje tylko na komputerze B na komputerze A jest komunikat "Połączono".
    Probowałem też się łączyć bez zapory oraz bez antywira a nawet firewalla .

    0 11
  • #2 22 Lip 2009 12:47
    moskit307
    Poziom 11  

    Po pierwsze nie włączaj automatycznego pobierania IP-a tylko wstukaj go z palca.

    Domyślam sie po screenach, że ma Xp-ka.
    1. Sprawdź czy kabel przepuszcza sygnał: np. udostepnij jakiś folder na kompie A. Z kompa B spróbuj się do niego dostać. Lub pingnij go z B na A albo odwrotnie, to będziesz wiedzał czy się komunikują.
    2. Na kompie B trzeba wpisać DNS-y, bo nie będzie rozpoznawał domen. Najlepiej przepisz mu dnsy z karty, która wychodzi na zewnątrz.
    3. Wrzuć polecenie ipconfig /all na kompie A. będziesz wiedzial, czy udostępnienie połączenia nie skopało ci ustawień dostępu do netu.
    4. Spróbuj ping-ąć z kompa B np. www.wp.pl

    Na koniec -
    KOMP A - Karta do netu - ustawienia automat.
    Karta do udostępnienia - 192.168.0.1, maska 255.255.255.0 i tyle.
    KOMB B - IP 192.168.0.xxx np.2, maska 255.255.255.0, brama 182.168.0.1, Dns spisany z karty do netu.

    Tu masz przykładowy dns tpsa - 212.85.112.32.

    Ma być. Sprawdź, jeszcze czy nie masz jakiegoś firewalla włączonego.
    Pozdrawiam

    0
  • #3 22 Lip 2009 13:20
    kwansterp
    Poziom 22  

    Cytat:
    IP: 192.168.0.1
    Maska: 255.255.255.0
    Brama: BRAK
    Komputer B:
    IP: 192.168.0.2
    Maska: 255.255.255.0
    Brama: 192.168.0.1


    Zapomniałeś wpisać DNS-a w komputerze B. Ma być
    192.168.0.1

    I wszystko ba działać.

    0
  • #4 22 Lip 2009 14:58
    mrozwisz
    Poziom 9  

    moskit307 napisał:

    1. Sprawdź czy kabel przepuszcza sygnał: np. udostepnij jakiś folder na kompie A. Z kompa B spróbuj się do niego dostać. Lub pingnij go z B na A albo odwrotnie, to będziesz wiedzał czy się komunikują.


    Kabel jest ok, ponieważ na początku działał ok ale po restarcie ginęły wszystkie ustawienia sieci i wracał problem z pobieraniem adresu sieciowego. Jedynym rozwiązaniem był format i to dwóch komputerów. Format jednego nic nie dawał

    moskit307 napisał:

    2. Na kompie B trzeba wpisać DNS-y, bo nie będzie rozpoznawał domen. Najlepiej przepisz mu dnsy z karty, która wychodzi na zewnątrz.


    Ja zewnętrznej karty sieciowej nie posiadam ale wirtualną, gdyż posiadam modem na USB więc go nie podpinam pod kartę sieciową. System widzi go jako kartę.

    moskit307 napisał:

    3. Wrzuć polecenie ipconfig /all na kompie A. będziesz wiedzial, czy udostępnienie połączenia nie skopało ci ustawień dostępu do netu.


    Podczas wpisania tego polecenia na kompie A okienko z procesem włącza się lecz po 0,5 sekundy się wyłącza nie pokazując mi wyników

    4. Spróbuj ping-ąć z kompa B np. www.wp.pl[/quote]

    Podczas wpisania tego polecenia na kompie A okienko z procesem włącza się lecz po 0,5 sekundy się wyłącza nie pokazując mi wyników. To samo co z ipconfig /all

    moskit307 napisał:

    Na koniec -
    KOMP A - Karta do netu - ustawienia automat.
    Karta do udostępnienia - 192.168.0.1, maska 255.255.255.0 i tyle.
    KOMB B - IP 192.168.0.xxx np.2, maska 255.255.255.0, brama 182.168.0.1, Dns spisany z karty do netu.

    Tu masz przykładowy dns tpsa - 212.85.112.32.


    Skonfigurowałem w ten sposób ale brame wpisałem jako 192.168.0.1 bo Ty raczej się pomyliłeś. Adresy DNS wpisywałem rózne. Jako że ja mam Netię to użyłem dns z ich strony.
    213.241.79.38
    213.241.79.37
    83.238.255.76

    Ale wpisywałem też TP 212.85.112.32. a także IP komputera A 192.168.0.1.

    Tak więć wciąż to samo. Piszę iż połączono ale internetu nie ma (gdyby był pojawił by się globusik nad połączeniem lan i by pisało "ZTE ZXDSL852 na KOMP A")

    Tak więc proszę o dalsze rady. Jeżeli nie ma już możliwości naprawy tego problemu. Proszę chociaż o instrukcję aby Połączenie lokalne dobrze działało (dostęp do folderów innego komputera, oraz gra w sieci lan)
    Dodam jeszcze iż gdy wejdę do Mój komputer -> Moje miejsca sieciowe -> Wyświetl komputery z grupy roboczej.
    Na komputerze A widzę że jest dostępny komputer A i komputer B.
    Ale na komputerze B widze tylko komputer B komputera A nie widze.
    Więcej na screen.
    Ciągłe pobieranie adresu sieciowego. LAN Eathernet RJ45
    Jeżeli internetu nie da się podłączyć na komputerze B poprzez udostępnienie z komputera A proszę o poradę aby dostępne było chociaż połączenie LAN (chodzi mi o przenoszenie przez połączenie lokalne plików pomiedzy komputerami oraz granie w sieci LAN).

    0
  • #5 22 Lip 2009 15:37
    dziadzia
    Poziom 15  

    Wklej wynik działania komendy:
    route print

    0
  • #6 22 Lip 2009 16:27
    mrozwisz
    Poziom 9  

    Dzięki hicat. Zapamiętam to.

    Mój route print

    Code:
    0x1 ........................... MS TCP Loopback interface
    
    0x20003 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
    0x20004 ...00 1f d0 94 35 c4 ...... Realtek RTL8168C(P)/8111C(P) PCI-E Gigabit E
    thernet NIC - Sterownik miniport Harmonogramu pakietˇw
    ===========================================================================
    ===========================================================================
    Aktywne trasy:
    Miejsce docelowe w sieci      Maska sieci      Brama      Interfejs      Metryka

              0.0.0.0          0.0.0.0    77.253.121.11   77.253.121.11       1
        77.253.121.11  255.255.255.255        127.0.0.1       127.0.0.1       50
       77.255.255.255  255.255.255.255    77.253.121.11   77.253.121.11       50
            127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
          192.168.0.0    255.255.255.0      192.168.0.1     192.168.0.1       20
          192.168.0.1  255.255.255.255        127.0.0.1       127.0.0.1       20
        192.168.0.255  255.255.255.255      192.168.0.1     192.168.0.1       20
      195.114.190.150  255.255.255.255    77.253.121.11   77.253.121.11       1
            224.0.0.0        240.0.0.0      192.168.0.1     192.168.0.1       20
            224.0.0.0        240.0.0.0    77.253.121.11   77.253.121.11       1
      255.255.255.255  255.255.255.255    77.253.121.11   77.253.121.11       1
      255.255.255.255  255.255.255.255      192.168.0.1     192.168.0.1       1
    Domyślna brama:    77.253.121.11.
    ===========================================================================
    Trasy trwałe:
      Brak


    moskit307 napisał:

    3. Wrzuć polecenie ipconfig /all na kompie A. będziesz wiedzial, czy udostępnienie połączenia nie skopało ci ustawień dostępu do netu.


    Zamieszczam więc mój raport z ipconfig
    Ciągłe pobieranie adresu sieciowego. LAN Eathernet RJ45

    Proszę o dalsze wskazówki odnośnie mego problemu

    @EDIT.
    Oto screen z ipconfig z komputera B.
    Zaniepokoiły mnie pewne połączenia. Patrz screen
    Ciągłe pobieranie adresu sieciowego. LAN Eathernet RJ45

    0
  • Pomocny post
    #7 22 Lip 2009 16:42
    hicat
    Poziom 30  

    To ja zrobię troche off topic ale podam Ci jeszcze łatwiejszą metodę.
    Start > Uruchom > cmd [Enter]
    route print [enter]
    ppm odznacz > zaznaczasz tekst myszka [enter]
    i wszystko co zaznaczyłeś masz w schowku.

    0
  • #8 22 Lip 2009 19:43
    mrozwisz
    Poziom 9  

    Czy jest jeszcze jakiś sposób na naprawę tej usterki ?

    0
  • #9 22 Lip 2009 20:01
    KondyMP3
    Poziom 12  

    hmmm wygląda też jakbyś na drugim komputerze miał włączoną obsługę ipv6, może wyłącz ją... obstawiam że drugi komputer posiada vistę...
    W sumie udostępnianie jest tak proste jak i budowa cepa, ale może tkwi problem w kablu sprawdź inny kabel... może poluzował Ci się któryś z zacisków i masz luźny drucik lub połamany... wszystko jest możliwe.

    Bo nie musisz robić nic więcej niż...
    http://support.microsoft.com/kb/314066/pl
    żeby poprawnie działało udostępnianie

    0
  • #10 23 Lip 2009 00:30
    Manio95
    Poziom 21  

    Jeżeli drugi komp ma viste to na xp należy zainstalować poprawki:WindowsXP-KB914440-v12-x86-PLK.exe i WindowsXP-KB922120-v5-x86-PLK.exe.
    Na kompie z xp:
    Prawym myszy na nasze połączenie z internetem
    >właściwości>zaawansowane zaznaczone trzy opcje.
    Na drugiej karcie ip ustawi się automatycznie na 192.168.0.1 maska 255.255.255.0
    na kompie z vistą ip 192.168.0.5 maska 255.255.255.0 brama 192.168.0.1
    a dns-y takie jak w karcie na xp co net przychodzi.
    Uważaj:
    Na obu kompach te same grupy robocze i inne adresy mac kart(najlepiej inne o jedna liczbę).
    Kabel cross.
    Pozdrawiam.

    0
  • #11 23 Lip 2009 13:12
    mrozwisz
    Poziom 9  

    Ale na 2 komputerach mam zainstalowany Windows XP z zainstalowanymi najnowszymi uaktualnieniami oraz SP3. Wszystko co najnowsze zainstalowane. Sprawdzałem przez Live Upadate

    0
  • #12 23 Lip 2009 14:57
    hicat
    Poziom 30  

    Wyszukaj na forum tematy: "Udostępnianie połączenia"
    Było ich mnóstwo i są opisane praktycznie krok po kroku.

    Jak sie naczytasz, to pewnie sam wpadniesz na rozwiązanie problemu. Albo znajdziesz ten "problem" który powoduje że internet Ci nie działa.
    Na początek wywal te tunelowe połączenia z komputera B.

    0
  Szukaj w 5mln produktów