Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

AtMega + przekaznik zasilany 12V bc337-12

levy^ 22 Lip 2009 22:50 5603 6
  • #1 22 Lip 2009 22:50
    levy^
    Poziom 16  

    Witam

    Otoz przeszukuje forum google itp od 3 dni i rece mi juz opadaja. Znalazlem taki oto schemacik /zreszta tutaj na forum/
    AtMega + przekaznik zasilany 12V bc337-12
    i jest problem. Przekaznik zaraz po zalaczeniu zasilania zamyka obwod czy jest podlaczony do atmegi czy tez nie. Oczywiscie rezystor na nozce pin 4k7. Ma ktos z was pomysl co moze byc nie tak ? Sprawdzalem juz na 3 tranzystorach, na dwoch atmegach na innym przekazniku oczywiscie z dioda i za kazdym razem zalancza obwod cewki. Cewka ma okolo 400Ω Ma ktos z Was jakis pomysl co moze byc nie tak ?

    0 6
  • #2 22 Lip 2009 23:59
    elektronikawm
    Poziom 11  

    Witam
    Do Bazy trazystora dołącz rezystor łączący baze z minusem
    musisz dobrać wartość rezystora tak by impuls z AT był wstanie wysterować trazystor -włączyć przekaźnik
    Powodzenia

    0
  • #3 23 Lip 2009 00:31
    levy^
    Poziom 16  

    a czy jesli nie podajemy zadnego sygnalu na baze to on bedzie zalaczal cewke przekaznika ? czy bedzie "zwarty" ?

    0
  • #4 23 Lip 2009 00:40
    rdt
    Poziom 24  

    nie - nie będzie załączał ale ATmega ma wewnętrzne rezystory podciągające
    dlatego trzeba ściągnąć rezystorem do masy

    0
  • #5 23 Lip 2009 00:52
    levy^
    Poziom 16  

    no i wlasnie w tym problem bo nawet jak wyciagne atmege z plytki i baza wisi w powietrzu to przekaznik sie zalacza, 3 tranzystory padniete ? dziwne no nic pojade do sklepu i sprawdze kolejny

    0
  • #6 23 Lip 2009 00:56
    rdt
    Poziom 24  

    osobiście po kilku próbach zrezygnowałem z takiego rozwiązania (sterowanie bezpośrednie) i zastosowałem CNY17
    a spróbuj jednak ściągnąć do masy tą bazę

    0
  • #7 23 Lip 2009 07:38
    levy^
    Poziom 16  

    ok problem sam sie rozwiazal o 3 w nocy bo mi to spokoju nie dawalo. Na odwrot wlutowany tranzystor ehhhh, a dodatkowo trzeba bylo dac rezystor miedzy kolektor i baze

    dzieki za pomoc

    0