Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sieć wewnętrzna - Windows XP SP3 i Windows 2000 SP4

Kubbaz 08 Sie 2009 22:01 4421 16
  • #1 08 Sie 2009 22:01
    Kubbaz
    Poziom 26  

    Witam wszystkich Elektrodowiczów,

    od kilku godzin próbuję połączyć siecią wewnętrzną dwa komputery, żeby można było wymieniać pomiędzy nimi pliki (a później udostępnić połączenie Internetowe przy użyciu programu WinRoute Lite 4.25) i pomimo dociekania w Internecie jak to zrobić, niestety nie udało mi się tego dokonać.

    Tak jak napisałem w temacie tego postu, chcę połączyć dwa systemy operacyjne: Windows XP SP3 i Windows 2000 SP4.

    Jakieś Kilka dni temu połączyłem siecią wewnętrzną systemy Windows XP (bez SP) i Windows 2000 SP4 - ustawiłem te same nazwy grupy roboczej na obu komputerach i pełne nazwy komputerów (oczywiście różne na obu komputerach), a w Windows XP tylko wyłączyłem Zaporę systemową. Tym oto systemem sieć działała. Teraz (w tym przypadku) niestety nie działa. Używałem pod Windows XP SP3 Kreatora konfiguracji sieci, ale niestety coś nie za bardzo pomógł (a może i ja nie wiem jak tego narzędzia poprawnie użyć...).

    Prosiłbym o jakąś pomoc w sprawie uruchomienia sieci wewnętrznej pomiędzy tymi dwoma systemami operacyjnymi. Dodam, że w sieci tej będę chciał udostępniać połączenie Internetowe.

    Z góry serdecznie dziękuję za pomoc i pozdrawiam!
    Kuba.

  • #2 08 Sie 2009 22:14
    alvaro99
    Poziom 22  

    Sprawdź w firewallu czy masz odfajkowane udostępnianie plików i drukarek. Ewentualnie w jakimś dodatkowym, którego używasz na którymś z komputerów.

  • #3 08 Sie 2009 22:21
    Kubbaz
    Poziom 26  

    W obu systemach mam zaznaczoną opcję Udostępnianie plików i drukarek w sieciach Microsoft Network. Oprócz wbudowanej Zapory systemowej w Windows XP SP3 nie mam żadnego innego firewall'a.

    System Windows XP SP3 wyświetla w ikonkę połączenia sieciowego Tray'u w stanie: Ograniczenie lub brak łączności.

    W obu systemach we włąściwościach połączeń -> Protokół internetowy (TCP/IP) jest ustawione Uzyskaj adres IP automatycznie

  • Pomocny post
    #4 08 Sie 2009 22:43
    978074
    Usunięty  
  • #6 08 Sie 2009 23:23
    tzok
    Moderator Samochody

    W momencie włączenia udostępniania, komputer udostępniający uruchomi serwer DHCP, a kreator zmieni adres karty sieciowej przez którą połączenia z Internetem będzie udostępnianie.

    Na razie sprawdź czy komputery się bez przeszkód wzajemnie pingują.

  • Pomocny post
    #7 09 Sie 2009 09:34
    Darrieus
    Poziom 38  

    Na win2000 trzeba utworzyć konto (albo włączyć konto gościa) żeby udostępnianie plików chciało zadziałać.
    Panel sterowania > narzędzia administracyjne > Zarządzanie komputerem > Użytkownicy i grupy lokalne.

  • #8 09 Sie 2009 22:06
    Kubbaz
    Poziom 26  

    tzok napisał:
    Na razie sprawdź czy komputery się bez przeszkód wzajemnie pingują.

    Ping z komputera hosta.
    Code:

    Microsoft Windows 2000 [Wersja 5.00.2195]
    (C) Copyright 1985-2000 Microsoft Corp.

    C:\>ping 192.168.100.101

    Badanie 192.168.100.101 z użyciem 32 bajtów danych:

    Odpowiedź z 192.168.100.101: bajtów=32 czas<10ms TTL=128
    Odpowiedź z 192.168.100.101: bajtów=32 czas<10ms TTL=128
    Odpowiedź z 192.168.100.101: bajtów=32 czas<10ms TTL=128
    Odpowiedź z 192.168.100.101: bajtów=32 czas<10ms TTL=128

    Statystyka badania dla 192.168.100.101:
        Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0 (0% utraconych),
    Szacunkowy czas błądzenia pakietów w millisekundach:
        Minimum = 0ms, Maksimum =  0ms, Średnia =  0ms

    C:\>

    Ping z komputera klienta.
    Code:
    Microsoft Windows XP [Wersja 5.1.2600]
    
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Admin>ping 192.168.100.100

    Badanie 192.168.100.100 z użyciem 32 bajtów danych:

    Odpowiedź z 192.168.100.100: bajtów=32 czas<1ms TTL=128
    Odpowiedź z 192.168.100.100: bajtów=32 czas<1ms TTL=128
    Odpowiedź z 192.168.100.100: bajtów=32 czas<1ms TTL=128
    Odpowiedź z 192.168.100.100: bajtów=32 czas<1ms TTL=128

    Statystyka badania dla 192.168.100.100:
        Pakiety: Wysłane = 4, Odebrane = 4, Utracone = 0 (0% utraconych),
    Szacunkowy czas błądzenia pakietów w millisekundach:
        Minimum = 0ms, Maksimum =  0ms, Czas średni =  0ms

    C:\Documents and Settings\Admin>


    Zatem komputery się pingują.

    lubamet napisał:

    Na win2000 trzeba utworzyć konto (albo włączyć konto gościa) żeby udostępnianie plików chciało zadziałać.
    Panel sterowania > narzędzia administracyjne > Zarządzanie komputerem > Użytkownicy i grupy lokalne.


    Faktycznie, że na Windows 2000 SP4 konto Gościa istniało, ale nie było włączone. Teraz oba konta - na Windows XP SP3 i na Windows 2000 SP4 - są włączone. W Windows XP SP 3 Zapora systemowa jest cały czas wyłączona.

    Co nie zmienia faktu, że po restarcie obu komputerów udostępnianie plików dalej nie działa.

    Komputer hosta wysłał rzekomo 5 pakietów, nie odebrał żadnego.
    Komputer klienta wysłała 51 pakietów i również nie odebrał żadnego.

  • #9 09 Sie 2009 22:34
    tzok
    Moderator Samochody

    Na komputerze o adresie 192.168.100.101 spróbuj zrobić Start -> Uruchom: \\192.168.100.100

    Jeśli na obydwu komputerach istnieją konta które się tak samo nazywają i na nich pracujesz to powinny mieć też takie same hasła (i muszą mieć hasła), ew. na obydwu komputerach musi być aktywne konto Gość.

  • Pomocny post
    #11 09 Sie 2009 22:47
    tzok
    Moderator Samochody

    ...a w drugą stronę?

  • #13 09 Sie 2009 22:56
    tzok
    Moderator Samochody

    Czy na komputerze z Windows XP uruchomiłeś i przeszedłeś wszystkie kroki Kreatora konfiguracji sieci (w ostatnim kroku odpowiadasz, że chcesz go zakończyć)?
    Na pewno nie masz na tym komputerze innego niż systemowy firewalla lub pakietu Internet Security?

  • #14 09 Sie 2009 23:12
    Kubbaz
    Poziom 26  

    tzok napisał:
    Czy na komputerze z Windows XP uruchomiłeś i przeszedłeś wszystkie kroki Kreatora konfiguracji sieci (w ostatnim kroku odpowiadasz, że chcesz go zakończyć)?

    Tak, ale dla pewności zrobiłem to jeszcze raz.
    I zaznaczałem:
    > Ten komputer łączy się z Internetem przez lokalną bramę lub za pośrednictwem innego komputera z mojej sieci.
    > Opis komputera: NOTEBOOK
    > Nazwa komputera: NOTEBOOK
    > Nazwa grupy roboczej: HOME
    > Włącz udostępnianie plików i drukarek.
    > Po prostu zakończ kreatora; nie potrzebuję uruchamiać go na innych komputerach.

    Komputer został zrestartowany. Sieć nie działa.
    W dodatku za każdym razem - za każdym uruchomieniem komputera na siłę włącza się Zapora systemowa i jest zafajkowana opcja w Panel sterowania > Zapora systemu Windows > Zaawansowane > Ustawienia połączeń lokalnych > Połączenie lokalne 2, a z tego wynika że właśnie jest blokowane. Można jakoś wyłączyć Zaporę systemową raz na zawsze?
    Na tym komputerze zainstalowany jest tylko system operacyjny MS Windows XP SP3 pakiet MS Office oraz sterowniki do tego komputera. Nie ma żadnego innego firewall'a.

  • #15 09 Sie 2009 23:36
    tzok
    Moderator Samochody

    Ciekawa sprawa, bo zapora systemowa nie powinna przeszkadzać ani tym bardziej sama się włączać.

    Z tego co piszesz - wszystko robisz dobrze i udostępnianie powinno działać. Uruchom najpierw komputer z systemem Windows 2000 a po kilku minutach z systemem Windows XP - wtedy powinno zadziałać otoczenie sieciowe, ale oczywiście nie rozwiąże to problemu z udostępnianiem w Windows XP. Przydałby się może jakiś skan antywirusowy dla tego systemu... bo to już wykracza poza kwestie konfiguracji sieci.

  • #16 10 Sie 2009 09:43
    Kubbaz
    Poziom 26  

    tzok napisał:
    Uruchom najpierw komputer z systemem Windows 2000 a po kilku minutach z systemem Windows XP


    Uruchomiłem komputer klienta (Windows XP SP3) z opóźnieniem 10 min w stosunku do komputera hosta i nic to nie pomogło.

    tzok napisał:
    Przydałby się może jakiś skan antywirusowy dla tego systemu...

    Zainstaluje Avasta Home 4.0 Pro wraz z najnowszą bazą danych wirusów i przeskanuje cały komputer.

    Dodam, że możliwość wkradzenia się wirusa już podczas instalacji systemu operacyjnego w postaci ściągniętej z internetu "spreparowanej" pirackiej instalki systemu odpada, gdyż system ten (Windows XP SP3) jest legalnie pobranym systemem pobranym z MSDNAA i wraz z licencją akademicką.

    -----------------------------------------------------------------------------------------------
    -----------------------------------------------------------------------------------------------


    Skanowane Avast nic nie wykazało.
    Znalazłem w sieci jedną z wielu instrukcji (niestety nie pełnych) konfiguracji sieci LAN na systemach Windows XP i Windows 2000.
    Ustawiłem takie parametry:

    komputer hosta (Windows 2000 SP4)
    Adres IP: 192.168.1.1
    Maska podsieci: 255.255.255.0
    Brama domyślna: (puste pola)
    Preferowany serwer DNS: 192.168.1.1
    Alternatywny serwer DNS: 194.204.159.1

    komputer klienta (Windows XP SP3)
    Adres IP: 192.168.1.2
    Maska podsieci: 255.255.255.0
    Brama domyślna: 192.168.1.2
    Preferowany serwer DNS: 192.168.1.1
    Alternatywny serwer DNS: 194.204.159.1

    Komputery pingują się na wzajem. Na komputerze klienta w oknie Połączenie lokalne 2 > Ogólne > Aktywność nawet pojawiła się wymiana pakietów (Wysłano 4098 / Odebrano 2176). Natomiast na komputerze hosta Wysłano 37 / Odebrano 50 pakietów.

    Z obu komputerów Start > Uruchom > \\:192.168.1.x (gdzie x to odpowiednio z danego komputera 1 lub 2) nie działa.
    "Nie można odnaleźć pliku "//:192.168.1.x" (lub jednego z jego składników). Upewnij się, że podana ścieżka i nazwa pliku są poprawne i że wszystkie wymagane biblioteki są dostępne."
    Sieć dalej nie działa.
    Czy lepiej wrócić do poprzednich adresów IP (192.168.100.x, gdzie x to 100 i 101)?

TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo