Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zasilacz 0-30 10A, początek prac.

VaM VampirE 15 Aug 2009 00:44 11328 36
Altium Designer Computer Controls
  • #1
    VaM VampirE
    Level 21  
    Witam.
    Nie jest to post o schemat, czy tym podobny. Mam dwa problemy na które nie bardzo potrafię znaleźć odpowiedź.

    Ogółem:
    Mając na stanie toroida 300W 2*24V 6,25A, postanowiłem poskładać zasilacz labolatoryjny dający napięcia 0-30V i prąd 0-10A (chcę zachować jakiś margines bezpieczeństwa dla trafa). Jako stabilizator końcowy chcę wykonać stabilizator liniowy na dwóch KD502 (mam ich kilkadziesiąt z jednej serii, więc te o identycznym wzmocnieniu łatwo znajdę), radiator mam wykonany z radiatora tyrystora spawarki argonowej (2kg wagi), przez fabryczne otwory jedynie 2 tranzystory mogą się tam zmieścić mając pełny kontakt termiczny. W celu zminimalizowania strat mocy na końcowym stabilizatorze planuje w stopniu wejściowym zastosować stabilizatow wstępny z praktycznego elektronika 6/2000. Zresztą tylko takie układy wchodzą w rachubę bo trafo nie ma odczepów i mieć nie będzie. Uzwojenia na toroidzie łączą się równolegle i dział to ok.

    Teraz moje pytania, czy ta koncepcja ma jakieś słabe strony, i czy dwa KD502 wytrzymają prądy zwarcia w takim układzie?
    Sam zasilacz będzie wykonany w oparciu o schemat velleman k7200, zresztą nie ma to większego znaczenia bo problem jest taki sam w przypadku każdego innego stabilizatora liniwego.

    Będe wdzięczny za wszelkie informacje.
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • Altium Designer Computer Controls
  • #2
    User removed account
    User removed account  
  • Altium Designer Computer Controls
  • #3
    VaM VampirE
    Level 21  
    Zgodnie z opisem z PE, układ stabilizatora wstępnego ciągle utrzymuje w układzie zasilacza napięcia o 2V większe (możliwość regulacji), od napięcia wyjściowego. więc w najgorszym wypadku przy niskim napięciu i wysokim prądzie staraty na tranzystorach powinny być niewielkie. W sumie to duże nadzieje pokładam w tym układzie bo nie chce budowac grzejnika. Stabilizatory liniowe ogółem grzeją cię mocniej im większą moc trzeba na nich wytracić. W tym przypadku różnica napięć między wyjściem a wejściem będzie zawsze stała.

    KD502:
    Uce = 60V
    Ic = 20A
    Ib = 7A
    P = 150W
    h21E > 40

    W sumie to dołorzenie dodatkowych tranzystorów jest jeszcze możliwe, ale tylko 2 i nie będą miały pełnego styku termicznego, tylko jakieś 70% powierzchni będzie miało dobry kontakt.

    Co do schematu wspomnianego regulatora wstępnego, użytkownik SIEKIERA_666 zamieścił skany, oto link:
    https://www.elektroda.pl/rtvforum/topic102059-0.html
  • #4
    gothye
    Level 33  
    w EP był projekt impulsowego regulatora nba LM2575 + Mosfet P , docelowo układ wytrzymywał 10A przy 25V
  • #5
    jatzek j
    Level 21  
    Siemanko .Skupmy się na razie na tym co kolega posiada .Jeżeli ma to cudo pracować ciągle to jakiś ,,wiatraczek '' by się też przydał .
  • #6
    marekzi
    Level 38  
    Daj linka do tego wstępnego stabilizatora.
    Dwa tranzystory w końcówce to za mało - chyba że nie rozumiem idei z tym stabilizatorem wstępnym - stąd prośba o ten link.
    Trafo ma 24V? - po elektrolitach będziesz miał ok. 34V - ale już pod obciążeniem 10A? - bo jeśli na biegu jałowym to za mało, poza tym powinieneś uwzględnić możliwe spadki napięcia w sieci (-10%).
    Ja bym obadał trafo tak: zmontować prostownik z elektrolitami, dać obciążenie 10A i mierzyć napięcie, to będzie nominalne Uwy pod obciążeniem i od tego odjąć tętnienia (obadać oscyloskopem) oraz 10% jako zapas na możliwy spadek napięcia w sieci.
  • Helpful post
    #7
    cyruss
    Level 30  
    Trafo za małe:
    1. żeby po prostowniku z filtrem pojemnościowym uzyskać 10A DC trafo musi dostarczyć 12...14A AC RMS. Wynika to z impulsowego ładowania kondensatora filtru.
    2. żeby po stabilizacji uzyskać 30V przy 10A musisz mieć na wejściu ostatniego stabilizatora jakieś 32...35V DC, na wejściu pierwszego stabilizatora 35...40V DC, przed mostkiem 37...42V AC. Oczywiście bez obciążenia na kondensatorze będzie max 42√2 = prawie 60V, zakładając zmiany napięcia w sieci +-10% -> kondensatory filtra muszą być na 80V, mostek 200V - 25A.
    3. 42V x 14A = prawie 600W....
  • #8
    marekzi
    Level 38  
    Że trafo ma za małą moc to fakt, ale chyba trochę przesadziłeś.
    Prąd wyjściowy ma wystarczający - bo 6,25Ax2=12,5A.
    Ale napięcie za niskie, to fakt.
    Tylko skąd wziąłeś te 42V zmiennego ?
    Pisałem o próbach z trafem aby sobie autor watka doświadczalnie to uzmysłowił. Wg mnie wystarczyłoby trafo ok.30-32VAC/12A= ok. 400VA.
  • #9
    User removed account
    User removed account  
  • #10
    VaM VampirE
    Level 21  
    Co do schematu to w drugim swoim poście w tym temacie dałem link do tematu gdzie owe materiały są udostępniane. Urzytkownik SIEKIERA_666 w jednym ze swoich postów zamieścił 5 rarów ze skanami z Praktycznego elektronika. Po prostu nie chcę śmiecić i zamieszczać raz jeszcze to samo.

    Idea owego stabilizatora polega na kontroli napięcia na kondenstaorach filtrujących zasilacza głównego, mierzy on napięcia na wyjściu i na kondenstorze filtrującym. A następnie sterując mosfetem doładowywuje kondensator filtrujący do napięcja wyższego o ustaloną wrtość od wyjściowego napięcia głównego stabiliztora. Robi to z częstotliwością 100Hz czyli z taką jak mostek prostowniczy przy 50Hz. Więc napięcie przed stabilizatorem liniowym jest zawsze np. o 2V większe od wyjściowego napięcia zasilacza głównego. Co powoduje że moc do rozproszenia na tranzystorach zasilacza liniowego jest mniejsza. A sam Mosfet pracuje impulsowo więc jego moce starat do tragicznych nie należą. Cały układ był ulepszeniem zasilacza czterozaciskowego z wczesniejszych numerów PE.

    Druga sprawa to to że jestem świadom że trafo 2*24 do 30V może nie wyrabiać, nie ma problemu. Dostosuje się projekt do posiadanych części.

    Pełną moc zasilacza będe wykorzystywał nie za często, głównie do testów silników krokowych, replik ASG, etc. Normalnie będzie pracował przy ułamkach jego mocy.
  • #11
    User removed account
    User removed account  
  • #12
    marekzi
    Level 38  
    Myślę, że autor zna te niebezpieczeństwa - bez kontroli prądu wyjściowego się tu nie obejdzie.
  • #13
    User removed account
    User removed account  
  • #14
    VaM VampirE
    Level 21  
    Mam już kondenstatory o łącznej pojemności poda 15000uF, grubość przewodów też dobiorę odpowiednią, nie jest to pierwszy zasilacz dużej mocy jaki składam. Tyle że wcześniejsze miały max 8A i do tego napięcia 13,8V typowe do CB. Pisząc że nie będe katował zasilacza non stop, nie maiłem na myśli że odpuszczę z solidnością. W ostateczności będze nowy radiator. Ale narazie wierzę w stabilizację wstępną, bo władowanie 10szt KD502 jest wykonalne, jedynie radiator mi trzeba bardziej odpowiedni. Jednak narazie chcę zostać przy opcji stabilizacji wstępnej, nie tylko po to by było taniej ale i przynajmniej trochę bardziej ekonomicznie.

    Oto zdjęcia radiatora i toroida.
    Zasilacz 0-30 10A, początek prac.

    Zasilacz 0-30 10A, początek prac.

    Zasilacz 0-30 10A, początek prac.

    Jak widać kawał alumininium jest, jednak fabryczne otwory utrudniają zamontowanie kilku KD.
  • #15
    User removed account
    User removed account  
  • #16
    marekzi
    Level 38  
    Zmieścisz jeszcze 2 szt - tym, że z nieco mniejszą powierzchnią kontaktu - trudno (można im dać nieco większe rezystory emiterowe - wyrównawcze).
    I rozważ czy te dwie szt nie zamontować od drugiej strony - to nieco polepszy odprowadzanie ciepła, chociaż skomplikuje prowadzenie przewodów.
    Na takich 4 szt KD na tym radiatorze można by już myśleć o rozproszeniu mocy rzędu 300W, ale z nadmuchem.
    Można rozważyć celowość zatkania otworów w radiatorze - rozwiercenie otworów rozwiertakiem na dokładne i gładkie fi, szlifowane korki z nadmiarową średnicą rzędu 0,02mm, montaż zmrożonego korka do nagrzanego radiatora, frezowanie całej powierzchni-przylgi pod tranzystory
  • #17
    VaM VampirE
    Level 21  
    Od dołu są wyfrezowane wgłębienia, widać na fotografii z boku. Mam jeszcze jeden radiator kiedyś były na nim trzy KD503 i jeden KD367A był to chyba jakiś zasilacz, ale tylko radiator i kilka elementów wpadło mi w łapy. Byłem kilka lat młodszy i nie zastanawiałem się nad tym :]
    Został radiator bo tranzystory poszły gdzie indziej. Teraz mam na nim cztery KD502 bo testowałem je we wzmacniaczu audio. Docelowo inny radiator zarobił na miejsce we wzmacniaczu. Oto foto.

    Zasilacz 0-30 10A, początek prac.

    Ale inna sprawa to to że znaczna część wypowiadających się tutaj osób zakłada że ja chcę wytracać moc na tranzystorach stabilizatora liniowego. A mnie intersuje tylko jak sobie jedna, albo dwie pary tranzystorów KD502 poradzi w układzie ze stabilizacją wstępną. Gdzie nawet w najgorszym wypadku, kiedy duży prąd będzie pobierany przy małym napięciu. Na stabilizator zgodznie z projektem z PE nie będzie podawane całe napięcie z trafa. To rozwiązanie w prostszej wersji to poprostu mostek z dwoma diodami i dwoma tyrystorami, a w najprostszej to trafo w masą odczepów. Namiary na materiały zamieściłem. Co do wentylatorów, to ostatnia rzecz jakiej mi braknie, a docelowo i tak mają być w okolicy wszystkiego co się grzać będzie.
  • Helpful post
    #18
    marekzi
    Level 38  
    Napisałem ci, abyś przewidział 4 szt KD - bez problemu sobie poradzą, nawet na tym mniejszym radiatorze, bez nadmuchu. Nadmiar napięcia dla stabilizatora liniowego 2 V to za mało - ja założyłbym ok.4V co dla 10A da moc strat ok.40W. Dla każdego z 4 KD to będzie ok. 3A i 12W (zakładam nierówny podział prądów i mocy, mimo dobierania tranzystorów i rezystorów wyrównawczych).
  • #19
    User removed account
    User removed account  
  • #20
    VaM VampirE
    Level 21  
    @marekzi - dzięki sprawdzę jak i co. Początkowo projekt ruszy na desce, tam wyjdzie co i jak będzie trzeba zmienić. Nie śpieszy mi się, mam czas żeby to potewstować.

    @ Monotronic - Idea stabilizacji wstępnej polega na niedpouszczeniu do tego by rozpraszać całą moc na tranzystorach stab. liniowego. Właśnie dla tego cały czas szukałem odpowiedzi na to ile tranzystorów wytrzyma takie warunki pracy, prąd i zwarcia. Zresztą w materiałach z PE opisano co i jak w tym temacie.

    Tematu, na razie nie zamykam. Może wyniknąć coś jeszcze z tego projektu.
  • #21
    VaM VampirE
    Level 21  
    Witam ponownie, chwilowo prace utknęły nad regulatorem wstępnym. Mianowicie nie reguluje napięcia na kondensatorach filtrujących, jest tam zawsze 36V, w samym układnie znalazłem tyle dziwnych zachowań że sam nie wiem czy tak naprawdę to w ogóle działa. Największy problem jest z napięciem ujemnym, scalona przetwornica nie daje napięcia ujemnego tylko dodatnie na poziomie 200mV, w schemacie są dwa błędy w jej sekcji. Wystarczy przeczytać notę katalogową. Pierwszy to to że nóżki 6 nie podłącza się do masy przy napięciu wyższym niz 3V, drugi to to że kondensator w projekcie jest podłączony odwrotnie niż podaje nota. W czasie testów zasilałem przetwornicę z oddzielnego zasilacza stabilizowanego ( z płytki testowej do AVR-ów). I podczas pracy całego układu nnapięcie było ok i wynosiło -4.99V, po dolutowaniu na szybko dodatkowego stabilizatora na diodzie zenera 6V napięcie w czasie pracy całości dalej wynosiło ~200mV. Zasilanie dodatnie wzmacniacza operacyjnego działa ok. Ale całość nadal nie działała nawet z dodatkowym zasilaczem z którym w czasie pracy wszystkie napięcia na diodach zenera się zgadzały, łącznie zujemnym. Układ nie wybucha i nie dymi, ale tutaj sie kończą zalety. Wszystkie części mierzyłem miernikiem przed montowaniem. Miernik to UT60E więc z dokładnością nie ma problemów.
    Ogółem do głowy przychodzi mi jeszcze pomysł zasilenia całości z symetrycznego zasilacza. Ale muszę w tym celu dowinąć kilka zwojów na trafo i na razie sie z tym wstrzymam. Narazie do testów kondensatory mają pojemność 4700uF, bo boję się ryzykować z baterią o pojemności 32000uF.

    Jeśli ktoś miał by jakieś sugestie na temat tego układu to proszę o pomoc. Bo mi się pomysły kończą.

    Oto schemat:
    Zasilacz 0-30 10A, początek prac.

    PS: Z zamontowanymi elementami przetwornicy napięcie na jej lini zasilającej wynosi kilka mV dioda D3, a na diodzie D2 jest wynosi tyle ile jej wartość, czyli 22V lub 12 (sprawdzałem obydwie wersje), po usunieciu przetwornicy jest ok. zasilam ją oddzielnie do testów, przez kabelek dolutowany do nóżki tak wygiętej by nie wchodziła w podstwakę.
  • #22
    marekzi
    Level 38  
    Sugestie są oczywiste:
    1. -przetwornicę podłącz zgodnie z datasheet (pin6 odłącz od masy, C5 odwrotnie) - ma działać, możliwy jest spadek napięcia na wyjściu o 0,5V.
    2. -takie błędy w schemacie przetwornicy (który należało po prostu przerysować z datasheet) źle wróżą całości. Niestety, ale chyba ktoś to projektował w stanie wskazującym....
  • #23
    VaM VampirE
    Level 21  
    Napisałem, że przetwornica na zewnętrznym napięciu zasilającym +5V zadziałała, zrobiłem te porawki. sprawdzałem tak że zasilając przetwornicę z wyższych napięć np. 8V Ale działa OK tylko kiedy zasilam ją oddzielnym zasilaczem. Kiedy biorę napięcie z diod zenera siada i na szynie (-) jest kilkaset mV na plusie. W sumie to muszę powiedziec że ten scalak to jedna z fajniejszych cech tego układu na pewno sobie zachowam go do przyszłych projektów, gdzie będzie potrzebne napięcie ujemne w bardzo limitowanej ilości.

    Testowałem obydwie opcje napięciowe tego układu, z diodami zenera 22 i 12, rezystor zgodnie z opisem tez zmieniałem.

    Tranzystor mocy ma na bramce ~100Hz sprawdzałem miernikiem, napięcie na diodzie zabezpiecającej ten tranzystor to około 4V.

    Te błędy w układzie mnie też zmartwiły, bo układ typu ma działać nie robi nic. Cały sens budowy tego zasilacza to dla mnie zbudowanie właśnie czegoś ze stabilizacją wstępną.
  • #24
    marekzi
    Level 38  
    Gdy zasilasz tą przetwornicę z układu - mierzyłeś napięcia? - na anodzie D1, na katodzie D2 (27V albo 17V)? Sprawdź R2 ( czy ma 1k).
    Może wartość R2=1k jest za duża? - bo aby przetwornica mogła pobrać 10 mA (bez obniżenia się napięcia +5V) to nawet przy diodzie D2=12V musisz na katodzie D1 mieć co najmniej 28V, a przy D2=22V - na kat. D1 musisz mieć min. 38V.
  • #25
    VaM VampirE
    Level 21  
    Z diodą D2 12V, oraz zewnętrznym zasilaniu przetwornicy wszystkie napięcia się zgadzały. sprawdziłem po kolei wszystkie zenerki. Po podłączeniu przetwornicy pod D3 napięcie ujemne znikało. w akcie desperacji zrobiłem oddzielny stabilizator na diodzie zenera i podłączyłem go równolegle do D2 tak, aby oddzielnie stabilizowało napięcie dla przetwornicy pomijając D2 i D3 - i dalej nic.
    Trafo daje 27V AC, bez obciążenia, napięcie 17V na pierwszej diodzie daje się uzyskać ale bez podłączonej przetwornicy, gdy ją podłaczam to spada do 12, tak jak by D3 nie było. Właśnie dlatego dokładnie zająłem się przetwornicą i dalej samo się posypało problemami.
  • #26
    marekzi
    Level 38  
    Wyjdź z siebie, stań obok i przeczytaj co napisałeś:
    "Z diodą D2 12V, oraz zewnętrznym zasilaniu przetwornicy wszystkie napięcia się zgadzały. sprawdziłem po kolei wszystkie zenerki. Po podłączeniu przetwornicy pod D3 napięcie ujemne znikało. w akcie desperacji zrobiłem oddzielny stabilizator na diodzie zenera i podłączyłem go równolegle do D2 tak, aby oddzielnie stabilizowało napięcie dla przetwornicy pomijając D2 i D3 - i dalej nic. "
    Co ja mam z tego zrozumieć?
    Ty zapewne rozumiesz bo to pisałeś.
    Ale powinieneś pisać tak aby inni też mogli.
    Rozumiem tylko tyle, że nie zrobiłeś nic albo prawie nic z tego co ci sugerowałem w ostatnim moim poście.
  • #27
    VaM VampirE
    Level 21  
    Sorki jest puźno i mogę trochę cheretycznie nawijać, sorki też za błędy. W chwili obecnej nie bawiłem się tym, bo to co mi polecałeś robiłem wcześniej. Z diodą D2 12V napięcie po podłączeniu przetwornicy do układu na jej katodzie wynosi 12V. Jak odłącze przetwornice to napięcie rośnie do 17V, w żadnym wypadku kiedy starałem się zasilać przetwornice z układu, nie działała ona prawidłowo. Jedyna udana próba kiedy uzyskałem wyszytkie potrzebne napięcia, to ta kiedy przetwornica była zasilana z dodatkowego zasilacza bezpośrednio na odgiętą nóżkę 8. Rezystor R2 ma wartość 1k, bo sprawdzam każdą część przed wlutowaniem za pomocą miernika. Trafo ma 27V AC bez obiążenia, więc może być problem z zasilaniem. Sprawdzę to na dniach.

    Dzięki za sugestję, napiszę co uda mi się działać.
  • #28
    marekzi
    Level 38  
    Na zasilaniu zewnętrznym pomierz pobór prądu przez przetwornicę.
  • #29
    VaM VampirE
    Level 21  
    Na podłączonym do zasilania układzie i przetwornicy działającej +5V z dodatkowego zasilacza pobór prądu przez przetwornicę to 6.34mA, z wyłączonym trafo (samo zasilanie +5V) pobór to 1.75mA.

    Napięcie na złaczu "Z" (wejście napięcia z mostka prostowniczego) to 23,4V (pomyłka z tym 27V co pisałem wcześniej to dotyczyło innego trafa), napięcia na diodzie D2 to 17V. Bez kondensatora filtrującego przed zasilaczem na lm317 który złuży zamiast domyślnego stabilizatora (bez niczego, odłaczone wszystko od wyjścia, oraz wejść pomiarowych) pobór prądu przez układ to 3.53mA na UT60E (tyle że miernik mi dziczeje, na zmianę wyświetla 3.53 i 0), analogowa Sunwa pokazuje około 40mA (około bo dokładność tego miernika to rzecz względna).

    Kierując sie twoimi poradami marekzi ,jutro idę po dodatkowe rezystory, jakie miejwięcej miały by to być wartości? Zakładając pobór 50mA wyszło by około 110-120ohm, kierując sie wzorem zamieszczonym przy schemacie.
  • #30
    marekzi
    Level 38  
    Do czego służy wyprowadzone napięcie +27V (+17V) / - czy do zasilania R15?
    Z czego zasilacz wzm. operacyjne ( napięcie dodatnie)?
    Te pomiary (3,5mA - 40mA) mnie martwią. Tu musimy być pewni. Być może masz wzbudzanie w układzie?
    Teraz widzę, że pomiary przetwornicy robiłeś przy obciążonej przetwornicy (zasilanie wzm. oper.) - spróbuj odpalić przetwornicę z zasilania gł. ale nieobciążoną - odłącz linię -5V z przetwornicy od reszty (wzm. op.). Jeśli ruszy - t.zn. że przetwornica jest przeciażona - szukaj zwarć, błędów montażu, albo wzbudzanie.
    Uważaj z tymi opornikami, bo jak dasz za małą wartość R2 to spalisz D2, D3 i w konsekwencji ICL. Dlatego tak ważny jest wiarygodny pomiar poboru prądu przez przetwornicę (maksymalny)- oznaczmy go Ip.
    Na C2 masz napięcie 23,4VACx1,4=32,7VDC-UD1=ok.32V - pomierz i sprawdź.
    Tak więc ID2=ID3+Ip=(32-17)/R2.
    Z tego licz. Pamiętaj, żeby nie przekroczyć mocy strat D2=12V x ID2.
    Dla D3 przyjmij jakiś prąd minimalny - np. 5mA przy Ip=max, gdy Ip się zmniejszy - przejmie go D3 - bez obaw, ta dioda ma tylko 5V a wiec wytrzyma spory prąd (jeśli ma np. 250mW to Imx=50mA).