Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Schemat generatora wn na trafopowielaczu

Dragas 29 Aug 2009 20:12 32093 93
IGE-XAO
  • #1
    Dragas
    Level 26  
    Witam
    Posiadam trafopowielacz, którego użyłem do zvs'a, ale podobno zvs nie radzi sobie poprawnie z trafopowielacze. Nie chce, aby zmarnował się trafopowielacz i chciałem zrobić z niego użytek. I jeśli ma ktoś, to prosiłbym o jakiś w miarę prosty i tani schemat zasilacza do trafopowielacza. Szukałem w internecie, ale nic nie znalazłem ciekawego.

    Dzięki z góry

    Pozdrawiam Krzysztof
  • IGE-XAO
  • #2
    Dragas
    Level 26  
    Tylko chodzi mi o to, że już mam prawie całego zvs'a (dzisiaj rozwaliłem w nim mosfety, ale kupie i będzie działało) z użyciem trafa tv, a Generator WN oparty jest na trafir tv, a nie na trafopowielaczu, a jak włąśnie chce go wykorzystać.
  • IGE-XAO
  • #3
    fuutro
    Level 43  
    Nie wydaje ci się, że transformator wysokiego napięcia i trafopowielacz to to samo w telewizorze ?
  • #4
    Dragas
    Level 26  
    Może i to samo,tylko żę trafopowielacz składa się z kaskadowego powielacza napięcia i z trafa wn. Dzisiaj rano uruchomiłem mojego zvs'a na trafie tv i działał poprawnie, a kiedy trafo tv zamieniłem na trafopowielacz od razu przepaliło wszystkie mosfety.
  • #5
    Otaku9
    Level 23  
    Już dawno nie stosuje się jako takiego trafopowielacza jak w opisie powyżej, Te nowe, generujące 15-30KV różnią się tym od starych że mają znacznie więcej zwojów wtórnego, diodę prostującą i kondensator WN 200-500pF.
    Od dawna wiadomo że ZVS jest problematyczną konstrukcją (o dużej sprawności), Jednak dużo większe napięcie uzyskasz kluczując tranzystorem napięcie z akumulatora/transformatora (5-80V) uzyskując 10-100KV.
  • #6
    Dragas
    Level 26  
    To nie wiem dlaczego po podłączeniu trafopowielacza zamiast trafa tv do zvs'a od razu przepaliło wszystkie mosfety. Wg mnie musi być gdzieś problem z tym trafopowielaczem:(

    Co do mojego zvs'a stosuję trafa 30V AC (około 38.8 V DC) / 8-10A
  • #7
    Mirek Z.
    Moderator
    Trafopowielacz w typowej aplikacji w TV, przy zasilaniu ok. 100-150V powoduje powstawanie na złączu CE tranzystora kluczującego przepięć (impulsów) rzędu 1000V.
    Nie piszesz, z jakiego TV masz ten trafopowielacz. Można przyjąć, że na tranzystorze (przy tych 30-kilku woltach zasilania) mogą powstać impulsy 200-300V. Ta wartość zależy też oczywiście od częstotliwości impulsów sterujących i od indukcyjności uzwojenia trafopowielacza/transformatora. Dlatego na wcześniej podłączonym transformatorze przepięcia mogły być mniejsze.
    Nie piszesz również, jakie MOSFET-y zastosowałeś. IRF510 ma (tylko) 100Vdss.
  • #8
    User removed account
    Level 1  
  • #9
    Dragas
    Level 26  
    Dobra, naprawiłem ZVS'a - zmieniłem stare (przepalone) IRF540 na nowe sprawne, ale nie wiem dlaczego jeden z nich się przepalił, mimo że układ nie był przerabiany.
    Mianowicie gdzieś w nim jest spięcie, trafo działa na maksymalnych "obrotach", przepalony tranzystor grzeje się bardzo, mimo że ma duży radiator.
    Pamiętam o tym, aby obrócić 2 tranzystor, każdy ma swój własny radiator. Ale to wszystko i tak nie da się odpalić, poza tym, że co chwila pali nowe tranzystory.

    Nie wiem gdzie jest problem.

    ZVS, który działał, ale przepalił się z powodu zmiany trafa tv na trafopowielacz wyglądał tak:
    Schemat generatora wn na trafopowielaczu


    Załączam również aktualne zdjęcie mojego ZVS'a.

    Schemat generatora wn na trafopowielaczu

    Naprawdę bardzo zależy mi na tym, aby zmontować tego ZVS'a aby działał poprawnie.
  • #10
    Otaku9
    Level 23  
    Na pewno dużo czytelniej wyglądał by na płytce drukowanej niż w pająku.
    Kłopotem mogą być za długie złącza do tranzystorów. Przy takiej częstotliwości jest to problem.
    Zdjęcia nie pokazują dokładnie, możliwe że masz gdzieś zimne luty, co wbrew pozorom jest NAPRAWDE sporym problemem, szczególnie przy dużych częstotliwościach.
    Czy na pierwszym zdjęciu na śrubach mocujących tranzystory są kołnierze?
    Masz mało zwoi na dławiku, naliczyłem 10, mam taki sam rdzeń, ale 28 zwoi nawiniętych drutem 1,5mm.
    Sprawdź lub wymień zenerki, mi często paliły gdy padał któryś tranzystor.
    Ale najbardziej prawdopodobne są tu zimne luty. najlepiej daj to na jakąś płytke uniwersalną lub zrób własną (polecam drugie).
    Mój pierwszy ZVS : https://obrazki.elektroda.pl/3_1205843685.jpg
    oraz ostatni, ostatnio przystosowywany do zasilania ~60V:
    https://obrazki.elektroda.pl/17_1223749895.jpg
  • #11
    Dragas
    Level 26  
    Najbardziej zaniepokoiło mnie to co pisałeś o tych długich przewodach do tranzystorów.
    Jak będę miał czas, to popracuje nad tym. A co do nich, to mają one około 10cm każdy.

    A co do płytki, to nie wiem czy zwykła płytka uniwersalna wytrzyma aż 30V i 8-10A. Wg mnie te nadrukowane ścieżki są za cienki i nie wytrzymają aż takiego prądu, ale nie jestem tego pewien. A sam nie za bardzo umiem i mam czas na zrobienie własnoręcznie płytki uniwersalnej.
    Co do dławika, to był on już używany na ZVS'ie zrobionym przez kolegę. Jemu chodził bez problemu. Zanim podłączyłem do układu trafopowielacz, wszystko działało sprawnie na tym dławiku i na tych przewodach od tranzystorów.

    Od tego momętu kiedy ZVS działał poprawnie, nic w nim nie modyfikowałem z elektroniki, tylko parę spraw kosmetycznych.

    PS. Otaku9, mam do Ciebie wielką prośbę, czy mógłbyś umieścić schemat swojego ZVS'a przystosowanego do 60V, ponieważ bardzo spodobała mi się jego konstrukcja.
  • #12
    Mirek Z.
    Moderator
    Dragas wrote:
    Dobra, naprawiłem ZVS'a - zmieniłem stare (przepalone) IRF540 na nowe sprawne, ale nie wiem dlaczego jeden z nich się przepalił, mimo że układ nie był przerabiany.


    A przecież:
    Mirek Z. wrote:
    Można przyjąć, że na tranzystorze (przy tych 30-kilku woltach zasilania) mogą powstać impulsy 200-300V. Ta wartość zależy też oczywiście od częstotliwości impulsów sterujących i od indukcyjności uzwojenia trafopowielacza/transformatora. Dlatego na wcześniej podłączonym transformatorze przepięcia mogły być mniejsze.
    Nie piszesz również, jakie MOSFET-y zastosowałeś. IRF510 ma (tylko) 100Vdss.

    nemo07 wrote:
    ZVS osiaga piki napiec Uds_pp ≈ 4*Uzas. MOSFETy od solidnych producentow projektowane na 100V zwyczajowo wytrzymuja napiecia Uds do ok. 2*Udsmax; wskazane jednak bylyby tu typy z Udsmax ≥ 160V.

    Zapominasz, że masz zasilanie o napięciu przekraczającym o 50% "schematowe" 24V.

    Ponadto:
    Dragas wrote:
    przepalony tranzystor grzeje się bardzo, mimo że ma duży radiator.
    -----------
    Ale to wszystko i tak nie da się odpalić, poza tym, że co chwila pali nowe tranzystory.

    Za chwilę temat będzie w Koszu...
  • #13
    fuutro
    Level 43  
    Rozmiar radiatora (zwłaszcza dawanie dowolnie wielkiego) akurat tu nie ma za bardzo znaczenia, bo i tak nawet to ciepło nie pójdzie poza tranzystor a energia impulsu zniszczy złącze.
  • #14
    Dragas
    Level 26  
    A czy mogę użyć IRF640 zamiast IRF540. IRF640 jest na 200V i 18A.

    I dlaczego IRF540 wcześniej działał poprawnie :?: , ponieważ przed podłączeniem trafopowielacza działał poprawnie?

    fuutro wrote:
    i tak nawet to ciepło nie pójdzie poza tranzystor a energia impulsu zniszczy złącze.

    To jak mogę zabezpieczyć się przed tym?

    Może jakieś kondy odcinające skoki napięcia? Tylko nie wiem jakie.
  • #15
    Otaku9
    Level 23  
    Jeżeli chcesz zmniejszyć prąd w impulsie zastosuj jako kondensator rezonansowy 100nF, lub nie więcej jak 300nF. Gdy zwiększałem napięcie zasilania musiałem zmniejszyć pojemność kondensora rezonansowego z 660 do 100nF ze względu na zbyt duży prąd dla IRF840.
    Jeżeli nie masz zamiaru zasilać ZVS większym napięciem to zastosuj IRF640 i impulsowe diody zenera 200V między dren i źródło. Dla pewności kup 1W zenerki 12V i sprawdź diody idące z bramek tranzystorów do kondensatora rezonansowego.
    Teoretycznie jest możliwe żeby przewód prowadzący do bramek IRF-ów nie był właściwie zlutowany, po wymianie jakiegoś elementu, napięcie na bazie jest za małe i nieotwarty tranzystor sie pali.

    Dodano po 7 [minuty]:

    fuutro wrote:
    Rozmiar radiatora (zwłaszcza dawanie dowolnie wielkiego) akurat tu nie ma za bardzo znaczenia, bo i tak nawet to ciepło nie pójdzie poza tranzystor a energia impulsu zniszczy złącze.

    Przy dobrze pracującym ZVS wystarczają naprawde małe radiatory.Jeśli urządzenie nie będzie wychodzić z rezonansu to tranzystory powinny zostać zimne nawet po 10min pracy (pewne dla 120W).
    Mój ZVS z kondensatorem rezonansowym 680nF zasilany napięciem 30V z 200W transformatora pracujący zarówno jako piec indukcyjny, zasilanie drabiny jakoba oraz jonolotu (30kV) nie grzeje sie wcale, przez co wentylator na wierzchu jest tylko ozdobą.
  • #16
    Dragas
    Level 26  
    Moje trafo ma 30V, ale przy 8A-240W, przy 10A-300W.

    Diody do bramek tranzystorów są sprawne prawdopodobnie, spaliłem już 10-12 mosfetów na tym ZVS'ie, ale nic poza nimi się nie spaliło.

    Tylko czy przepalony mosfet może robić spięcie w całym układzie, ponieważ właśnie to, najbardziej zaniepokaja mnie.
  • #17
    User removed account
    Level 1  
  • #18
    Otaku9
    Level 23  
    Jeżeli problemy aż tak uniemożliwiają start ZVS to radził bym zamiast palić kolejne tranzystory -rozlutować całość, sprawdzić miernikiem które elementy są jeszcze sprawne,dokupić potrzebne, następnie skonstruować możliwie małą lecz przejżystą konstrukcje choćby i w pająku (aczkolwiek odradzam).
    Do lutowania używać możliwie jak najmniej cyny lekko zanurzonej w kalafonii. Zbędne nóżki odcinać.
    Pamiętaj że układ nie ruszy prawidłowo jeżeli któryś element nie jest zamocowany, Tu one wszystkie są niezbędne.
    Kolejną możliwą rzeczą było by zmiana zasilania z transformatora 240W na mniejszy, 40-100W (działa i na 40W zasilania, aczkolwiek łuk rozciąga się tylko do 2 cm).Ewentualnością byłby akumulator, i to jego najbardziej bym polecał na początek.
    Przy 240W kondensator w filtrze powinien być naprawde porządny, ja używam kondensatora o pojemności 6000uF, ale zdecydowanie lepszy byłby trzykrotnie taki, oczywiście na całkowicie sprawnym układzie, gdyż to znacznie zwiększa moc pobieraną i wzmacnia efekt.

    Polecam lekturę :
    http://www.lucaslab.grandhost.pl/zvs.htm
    Przetwornica może wyglądać dowolnie:
    https://obrazki.elektroda.pl/13_1233070675.jpg
  • #19
    Dragas
    Level 26  
    Nie zbytnio mam aku i inne trafo.
    Myślałem już na dodaniem do układu równolegle konda 4700uF/63V, na razie są połączone 2 kondy szeregowo, każdy 4700uF/25V, ponieważ tylko takie mieli w sklepie.

    Na razie spróbuję użyć IRF640, ponieważ one są na 200V, a nie jak IRF504 na 100V, może to coś pomoże. Niestety, ale do elektronika jadę dopiero w piątek lub sobotę, bo wcześniej nie dam radu. Jak kupie IRF640 , zamontuje je, to napisze jak działa ZVS. Zanim podłącze zasilanie sprawdzę cały układ jeszcze parę razy dla pewności.

    Czy przepalony mosfet może tworzyć spięcie w układzie?
  • #20
    User removed account
    Level 1  
  • #21
    Dragas
    Level 26  
    nemo07 wrote:
    Popraw ten "zasilacz". Pozniej doloz jeden ekstra "wylacznik ZVSa": dwie diody 1N4448 lub tp. od obydwu bramek mosfetow poprzez kontakt "on/off" wylacznika na mase (-) ukladu.
    Procedura nastepujaca: najpierw wlaczasz zasilacz, potem ZVS - nigdy na odwrot.


    Czy ma znaczenie który mosfet włączam jako pierwsze, czy może dla bezpieczeństwa zastosować równoległy włącznik?

    Co do pomiaru ZVS'a, za pomocą jakiegoś urządzenia, to na chwilę obecną nie posiadam nic. Posiadam jedynie zepsuty miernik, który piszczy wtedy, kiedy coś przewodzi prąd.
  • #22
    Otaku9
    Level 23  
    Dragas wrote:
    Czy ma znaczenie który mosfet włączam jako pierwsze, czy może dla bezpieczeństwa zastosować równoległy włącznik?

    Co do pomiaru ZVS'a, za pomocą jakiegoś urządzenia, to na chwilę obecną nie posiadam nic. Posiadam jedynie zepsuty miernik, który piszczy wtedy, kiedy coś przewodzi prąd.


    I lol'd :D Czy może włączasz tranzystory oddzielnie?

    Brak odpowiedniego miernika może być tu sporym problemem, często jak jakiś element sie spali to nie widać czy jest uszkodzony, ma przerwe czy jest zwarty. Najgorzej jest z diodami. Być może któraś zenerka robi zwarcie dla bramki, otwiera sie jeden tranzystor i po chwili pada. Na pewno też twoje IRF540 były za małe, jak na 30V zasilania.
    Dlatego sądze, że jeżeli to nie niedopasowanie otwierania tranzystorów zabiło ZVS, to robiły to piki napięciowe, osiągając ~120V .
  • #23
    Dragas
    Level 26  
    Czy użyje równoległego włącznika.

    jeśli piki sięgają ~120V, to użyję IRF640, on jest na 200V i 18A, czyli wystarczy w zupełności na moje zasilanie.
  • #24
    Otaku9
    Level 23  
    IRF640 naprawią sytuacje jeżeli winą uszkodzeń są piki napięciowe.
    Żeby włączać lub wyłączać ZVS należy całość na raz uruchamiać, nie wolno tu nic segmentować podczas pracy ZVS.
    Jeżeli jesteś sprytny to możesz tranzystory zastąpić włącznikami monostabilnymi i naciskać je z częstotliwością rezonansową ukladu LC tegoż ZVS, czyli około 30 tysięcy razy na sekunde.
    Nie rozumiem co chcesz osiągnąć tym wyłącznikiem.
  • #25
    Dragas
    Level 26  
    nemo07 wrote:
    Popraw ten "zasilacz". Pozniej doloz jeden ekstra "wylacznik ZVSa": dwie diody 1N4448 lub tp. od obydwu bramek mosfetow poprzez kontakt "on/off" wylacznika na mase (-) ukladu.
    Procedura nastepujaca: najpierw wlaczasz zasilacz, potem ZVS - nigdy na odwrot.


    Chodzi mi o to, że przy starcie ZVS'a, tranzystory zatrzaskują się, i nie mogą się już odtrzasnąć. I chodzi mi o to, aby uniknąć na starcie ZVS'a skoku wysokiego napięcia.
  • #26
    Otaku9
    Level 23  
    Schemat generatora wn na trafopowielaczu
    Jeżeli na bramce tranzystora pojawi sie napięcie, a przy wibrującym ZVS musi się ono tam pojawić to tranzystor sie otworzy. Następnie polaryzacja kondensatora rezonansowego sie odwruci, napięcie spadnie do 0 zablokuje sie dida prowadząca z drugiej bazy do drugiej nóżki kondensatora rezonansowego i otwoży sie drugi tranzystor.
    Tak działa ZVS, teraz wybadaj co nie pasuje w tym schemacie do Twojego projektu.
  • #27
    User removed account
    Level 1  
  • #28
    Otaku9
    Level 23  
    Ale Nemo07, czy te zabezpieczenia sprawią że ZVS będzie sprawnie działał? Nie stosowałem tego wcześniej, jestem bardziej praktykiem niż teoretykiem. Jeżeli jest tu gdzieś problem którego się nie naprawi to lepiej chyba dać tu po prostu zabezpieczenia przeciwzwarciowe, bo ten układ domyślnie powinien pracować bez nich. Choć w sumie nie wiem, nie wszystko jest takie proste jakim sie zdaje, więc moge sie mylić. Ale skoro nie widze żeby coś tu drgnęło, to na siłe ZVS raczej nie ruszy. Skoro ZVS pali tranzystory, które sie "blokują" to znaczy że coś jest nie tak z budową.
  • #29
    User removed account
    Level 1  
  • #30
    Dragas
    Level 26  
    Dzisiaj rano zmieniłem IRF540 na IRF640. Dodałem również dodatkowy przełącznik na masę IRF'ów. Włączam zasilanie. Załączam po kolei wszystkie przełączniki. Zbliżam do siebie końce trafa TV. Słyszę, że układ zaczyna działać na najwyższych "obrotach". Coś zaczęło strzelać. Nie zdążyłem nawet wyłączyć zasilania. Jeden z IRF'ów staje w płomieniach. Szybko wyłączyłem wszystkie możliwe przełączniki i wyjąłem wtyczkę z gniazdka.

    I ty moje pytanie, co mogło spowodować zapalenia się tego IRF'a. Układ jest złożony dobrze.
    Czy możliwe, że to wina dławika?