Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Sygnał PWM 250kHz - izolacja galwaniczna - jak?

ddokupil 17 Sep 2009 18:23 3449 3
  • #1
    ddokupil
    Level 15  
    Chcę sterować mosfetem za pomocą pary komplementarnej, mniej więcej coś takiego:
    Sygnał PWM 250kHz - izolacja galwaniczna - jak?

    generalnie steruje się ładnie tylko podczas pracy na atmedze mam straszne przydźwieki. Na oscyloskopie szpile mają do 1 wolta nawet. Zauważyłem, że jak podam PWM z generatora to nic takiego się nie dzieje i pomiary są miodzio. No i teraz pytanie. Czym najlepiej odseparować atmege od tego drivera? Pierwsze co mi przyszło do głowy to transoptor. Akurat pod ręką mam 4N35. Zamieniłem Q1 z układu właśnie na tranzystor transoptora. Tylko sygnał wyszedł piłokształtny (250kHz). Okazuje się, ze transoptor (przynajmniej ten) ma czas narastania i opadania sygnału w okolicach 2µs. Czyli za dużo.
    Czy jest coś szybszego? Jak mądre głowy by ten problem rozwiązały?
  • #2
    Dar.El
    Level 40  
    Witam
    6N137 cyfrowy transoptor do 10MHz, lub 6N136 analogowy.
  • #3
    lechoo
    Level 39  
    Poeksperymentuj z transoptorem HCPL3120 albo tańszym TLP250, przy okazji zmień tranzystor na N-ch. A tak wogóle co to będzie za wynalazek?
  • #4
    ddokupil
    Level 15  
    To ma być przetwornica impulsowa. Ten układ ze schematu to sterowanie kluczem jest. Myślałem o zmianie tranzystora na N ale przewaga obecnych P jest taka, że mam ich kilka a N bym musiał kupić. Zastanawia mnie mechanizm powstawania tych przydźwięków. Tak jakby jakiś odbity sygnał z Q1 wracał do mikrokontrolera.

    Hmmm... W sumie to nie wiem...
    Nagle wszystko zaczęło działać nawet zbyt idealnie. Nie wiem skąd i dlaczego dzisiaj rano przebiegi zaczęły być takie jakbym je sam rysował i wszystko chodzi bosko. Żadnych przydźwięków. Skąd to się wzięło? Nie mam pojęcia co zrobiłem najgorzej. No poza dodaniem do układu podstawki pod 4N35 która itak jest pusta. Tylko cewka zaczęła piszczeć.