Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Subiekt4 + WinXP + Kasa ELZAB

Gorgoroth 15 Jun 2004 14:02 19709 26
  • #1
    Gorgoroth
    VIP Meritorious for electroda.pl
    Witam!
    Jak to uruchomic ??? Nie wykrywa mi kasy fiskalnej ELZAB ALFA SUPER pod subiektem, który pracuje pod windowsem XP - czasem niby odczytuje bity konfiguracji z wynikiem pozytywnym, ale ściągnąć "sprzedaży" z kasy to już nie ma szans ! - "błąd numer 21 - TIMEOUT ODBIERANIA" i tyle. Czy ktoś spotkał się z takim problemem ? Kasa, przewód, i port w komputerze są sprawne na 100%, test portu szeregowego w subiekcie wychodzi pozytywnie.
  • #2
    Gorgoroth
    VIP Meritorious for electroda.pl
    Jestem jedyny w Polsce ktory korzysta z tej kasy pod XP :?: :cry: Programy do odblokowywania portu nic nie daja.... Casami Subiekt ja widzi a czasami wywala błędy przy komunikacji
  • #3
    djanek
    Level 13  
    Witam
    proszę o sprawdzenie zgodności uruchamiania programu z np W98, NT itp.
    Ewentualnie sprawdzic ustawienia portow w biosie

    aaa czasami XP ja NT potrafi zamienić porty , COM1 na COM2 i odwrotnie
  • #4
    silver111
    Level 12  
    Jestem dystrybutorem prodoktow zarowno elzab jak i insert.

    Wiele razy wdrazalem na win xp subiekta 4 jak i gt wraz z drukarkami fp600 oraz omega jak i kasami elzaba alfa, jota. nie bylo zadnego problemu.

    tu ftp://ftp.elzab.com.pl/pub/serwis/rstest.zip masz program do testowania rs232.

    ustaw transmisje na 9600- zawsze pewniej i stabilniej dziala.
    sprobuj tez na drugim comie - moze port sie wypalil ??
  • #5
    Gorgoroth
    VIP Meritorious for electroda.pl
    Port jest ok to wina systemu (na tym samym kompie jak wsadze dysk z dosem to wszystko jest ok). Kase mam ustawiona na 9600 port rowniez. Czasami uda sie zapisac bity konfiguracji do kasy ale w 90% przypadkow nie :/
    Sam subiekt dziala bez zarzutu pod XP tylko z kasa sie komunikowac nie chce a zmiana systemu nie wchodzi w gre bo tylko na XP jest faktura...
    W subiekcie jest opcja testowania portu za pomoca odpowiednio zmostkowanej wtyczki i ten test wychodzi OK :cry:
  • #6
    md
    Level 40  
    Podobny problem współpracy z drukarką Posnet Thermal w programie DOS-owskim rozwiązałem tak, że po włączeniu programu magazynowego, z poziomu programu wysyłam 2 krotnie polecenie wyświetlenie aktualnej daty. Program "trzyma" kontakt z portem COM aż do zamknięcia programu.
  • #7
    LEM
    R.I.P. Meritorious for the elektroda.pl
    Nie wiem jak insert ale ja takie problemy załatwiam w produktach CDN plikiem wsadowym, którego składnia wygląda tak:
    Code:
    mode com[nr portu com]: 9600,n,8,1
    
    [wywołanie właściwego programu]


    Np.:
    Code:
    mode com1: 9600,n,8,1
    
    c:\FPP\fpp.exe



    Tak zrobiony plik wsadowy uruchamia program, jednak przed uruchomieniem robi tzw. "otwarcie portu" (ustawia tryb pracy). W 99% przypadków pomagało, więc moze warto spróbować.
  • #8
    Gorgoroth
    VIP Meritorious for electroda.pl
    LEM wrote:
    Nie wiem jak insert ale ja takie problemy załatwiam w produktach CDN plikiem wsadowym, którego składnia wygląda tak:
    Code:
    mode com[nr portu com]: 9600,n,8,1
    
    [wywołanie właściwego programu]


    Np.:
    Code:
    mode com1: 9600,n,8,1
    
    c:\FPP\fpp.exe



    Tak zrobiony plik wsadowy uruchamia program, jednak przed uruchomieniem robi tzw. "otwarcie portu" (ustawia tryb pracy). W 99% przypadków pomagało, więc moze warto spróbować.


    Dzieki !
    Sprawdze to w poniedzialek bo narazie nic z powyzszych nie pomoglo :(
  • #9
    md
    Level 40  
    LEM wrote:
    Nie wiem jak insert ale ja takie problemy załatwiam w produktach CDN plikiem wsadowym, którego składnia wygląda tak:
    Code:
    mode com[nr portu com]: 9600,n,8,1
    
    [wywołanie właściwego programu]



    Tak zrobiony plik wsadowy uruchamia program, jednak przed uruchomieniem robi tzw. "otwarcie portu" (ustawia tryb pracy). W 99% przypadków pomagało, więc moze warto spróbować.

    Właśnie miałem do czynienia z pozostałym 1%, bo nie działało. Dopiero przypadkiem zauważyłem, że dwukrotne przełsanie daty do drukarki otwiera port i utrzymuje ten stan do zamknięcia programu. Nastepne uruchomienie (nawet za 10 sekund) i trzeba wszystko od nowa
  • #10
    Bicker1
    Level 19  
    Po pierwsze ściagnij sobie drivery do kasy ze strony ftp://ftp.elzab.com.pl/pub/kody/winexe.zip - trzeba to rozpakować do podkatalogu subiekta w którym bedą pliki o takich samych nazwach jak te zawarte w archiwum.
    Po drugie czasem pomaga wyłaczenie w biosie funkcji ACPM
  • #11
    Gorgoroth
    VIP Meritorious for electroda.pl
    Jeszcze nie mialem okazji sprawdzic nic, narazie remont.... Zapewniam ze powiadomie czy sobie poradzielm :)
  • #12
    grzegorz__72
    Level 11  
    przy programie wf-mag, też nie miałem komunikacji. Problem usunąłem stosując urządzenie "WinCom" produkowane przez elzaba. Niestety kosztuje koło 300- 400 zł. POWODZENIA
  • #13
    tomus2k
    Level 26  
    Jesli chcesz stosować drivery oryginalne to musisz mieć WINCOM ale wystarczy do katalogu c:\subiekt4\SYS600 nowe drivery ściągnięte ze strony www.elzab.pl no i odblokuj RS /patrz wcześniej/ i będzie ok.
  • #14
    franeczek
    Level 13  
    Wg. mnie nie jest to wina systemu XP a sterowników do Via. Miałem podobny problem i nic nie pomogło tylko po uruchomieniu programu robie raport i on oczywiscie nie wychodzi a potem juz wszystko działa.
  • #15
    piero
    Level 13  
    Ja podobny problem pod XP obszedłem za pomocą programu UserPort. Wydaje mi się, że w Twoim przypadku XP "zamyka" dostęp do portu. Ten sam programik przydał mi się aby przywrócić działanie programatorów, które pod 95/98 działały a pod XP przestały działać.
  • #16
    Gorgoroth
    VIP Meritorious for electroda.pl
    A ja szczerze mowiac sie poddalem, zadne z Waszych rad nie sprawdzily sie u mnie i w koncu wrocilem do dosa :cry:
  • #17
    makiff
    Level 2  
    Czy ktoś siedzi jeszcze w tym temacie mam FPP pod xp i nie chodzi mi kasa fiskalna FP-600 elzab, ten plik wsadowy jak sie nazywa i jakie ma rozszerzenie do którego trzeba mu dopisać ten port?:|
  • #18
    Bushmen_DZ
    Level 14  
    Witam
    Przetestowałem wszystkie wskazówki i nie działa.
    Konfiguracja u mnie wygląda tak: program F++ oraz FP600windows XP PRO sp3, port komunikacji com1.
    Dodam że mam takie dwa stanowiska i na jednym działa bez zarzutu a na drugim,
    brak komunikacji z drukarką.
    Ale doszedłem co jest przyczyną, pętla diagnostyczna dla portu com1.
    Sytuacja wygląda tak włączam drukarkę i komputer i uruchamiam f++,
    próbuję wystawić paragon i mam brak komunikacji z drukarką, teraz uruchamiam program serwisowy do drukarki fp600 i podaje komunikat o pętli diagnostycznej oraz że ją wyłączy, wszystko potwierdzam i zostawiam program włączony.
    następnie przechodzę do F++ i paragony śmigają jak nigdy dotąd.
    Pytanie brzmi kto wie jak włączyć tą pętlę plikiem wsadowym??

    Dodano po 1 [godziny] 56 [minuty]:

    Znalazłem jeszcze instrukcję do F++

    4. Po reinstalacji z wersji wcześniejszej do 3.0 występuje komunikat o błędzie połączenia z drukarką
    fiskalną, choć w wersji poprzedniej drukarka działała poprawnie.
    Od wersji 3.0, aby drukarki fiskalne poprawnie współpracowały z programem FPP, przy zaznaczonym parametrze NT,
    naleŜy zastosować następujące ustawienia portów COM w systemie operacyjnym:
    Elzab:
     szybkość: 9600 / 19200
     parzystość: parzysta (even)
     liczba bitów: 8
     bit stopu: 1
     sterowanie przepływem: brak, xon/xoff
    Uwaga: w przypadku drukarek Elzab starszego typu należy sterowanie przepływem ustawić na sprzętowe.


    Niestety po tych zmianach też nie działa.
    Attachments:
  • #19
    Bushmen_DZ
    Level 14  
    Witam na F++ rozwiązanie jest zresztą opsane w powyższym kliku pdf
    mianowicie należy do katalogu F++
    stary sterownik elzab FP600.dll
    a nowy to elzabdr.dll oraz RECEIPT.exe
    przestawiłem w kofiguraji na obsługę systemu nt(win200/xp)
    i działa coprawda wolniej ale działa bez zrzutu
    nad tą pętlą diagnostyczną jeszcze pomyślę.
    Oczywiście zamieszczam pliki :)
    Attachments:
  • #20
    jstepien
    Level 10  
    Miałem podobny problem z tą kasą i OPTIMĄ.
    Pomogło:
    1. ustawienie parametrów portu: parzyste, sterowanie sprzętowe a przede wszystkim zmiana nr portu z 1x na mniejszy (1-4) (zakładka "zaawansowane")
    2. sprawdziłem też zapis w rejestrze Windows (CDN -> Fiskalne)

    pozdrawiam
  • #21
    rayan7979
    Level 1  
    Witam, niestety mam podobny problem, a mianowicie : zainstalowałem program fpp (wersja 2,5) na windowsie xp sp2 professional , odblokowałem porty programem userport (klucz HASP widoczny bez problemu), wszystko działa poprawnie niestety drukarka fiskalna posnet thermal df300 za nic nie chce drukowac paragonów.
    W samym windowsie program diagnostyczny komunikuje sie bez problemu z tą drukarką, parametry portu com1 usatwione mam na: 9600, 8 ,parzystość: brak, bity stopu 1, str. przepływem Xon/Xof,
    W BIOSie Com1 ustawiony na 2E8/IRQ3. Program UserPort ma parametry następujące: 200 - 37F ; 3BC - 3BF; 3E8 - 3FF. Niemam juz pojecia w czym tkwi problem, czy może jakieś ustawienia w samym Fpp czy chodzi raczej o problem z jakimiś ustawieniami portu, bardzo proszę o pomoc lub wskazówkę , pozdrawiam
  • #22
    papa81
    Level 10  
    Witam Prosze o pomoc
    Posiadam drukarke elzab omega była podłączona w sklepie przez rok i bylo ok zlikwidowałem sklep i zabrałem sprzęt do domu po ponownym podłączeniu było przez 2 dni ok teraz przy próbie drukowania paragonu z subiekta gt wyskakuje mi brak komunikacji tak jakby mi porty com przestały działac sprawdzałem inne kable i dalej to samo jak je uruchomic gdyz potrzebuje zamknąć działalność a nie moge wystukać paragonów
  • #23
    Bicker1
    Level 19  
    Na wyświetlaczu drukarki nie ma jakiegoś komunikatu np nota1 albo err2?
  • #24
    pabik
    Level 11  
    Gorgoroth wrote:
    A ja szczerze mowiac sie poddalem, zadne z Waszych rad nie sprawdzily sie u mnie i w koncu wrocilem do dosa :cry:


    A jaki masz komputer?Pocesor ?
  • #25
    Bicker1
    Level 19  
    Pabik od postu który cytujesz minęło 8 lat.
  • #26
    pabik
    Level 11  
    to skoro tak ,to temat powinien być zamknięty.Tym bardziej ,że z Subiekta przerodził się w FPP.
  • #27
    al11
    Level 14  
    W jaki sposób masz podłączoną drukarkę? Jeśli przez USB, to mógł zmienić się nr wirtualnego COM.