Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[ATMEGA8] Siprog, PonyProg, niepewne działanie

12 Paź 2009 22:08 2470 4
  • Poziom 13  
    Witam

    Zrobiłem programator Siprog na rs232, ale w PonyProg na Viście (laptop rs sprzętowy) programowanie Atmegi 8 przebiega niepewnie, raz się udaje a raz nie:

    W PonyProg ustawiłem Siprog Api, na Com1, Probe jest ok, następnie Calibration ->ok
    Read All->Ok, ale wybierajac gotowego hexa na koniec wywala komunikat Write failed. Ładowanie trwa ok. 3 min.

    Ten sam programator podpiąłem w Linuxie i procek programuje się w 2 sek. bez problemu za każdym razem, zarówno w AVR8 Burn8 o Mat i KotrollerLab.

    Co to może być?

    Pozdrawiam
  • Poziom 32  
    IMHO znowu vista nie lubi uc. Spróbuj w trybie zgodności z innym systemem.
  • Specjalista PLD
    Mialem duzo klopotow z roznymi programatorami szeregowymi.
    Kilkanascie prockow zostalo zablokowanych.
    Zrobilem sobie rownolegly programator na LPT i problemy ustapily.
    Zablokowane procki ozywilem i dzialaja jak nalezy.
    Warto poswiecic dzien na wykonanie sobie takiego programaora i juz nigdy nie martwic sie czy zadziala czy nie.
    Co innego gdy robisz ISP, wtedy wyboru raczej nie ma - pozostaje Leniux.
  • Poziom 13  
    Witam


    Mam już programator na LPT, używałem go ze starym laptopem, ale niestety padła mu płyta i musiałem kupić nowy, ten zaś nie ma LPT, ale ma RS stąd moje próby odpalenia na RS232.

    Ściągnę nową wersję PonyProga i zobaczę, wypróbuję też tryb zgodności.

    Schemat jest z któregoś postu na elektrodzie.

    [ATMEGA8] Siprog, PonyProg, niepewne działanie

    Pozdrawiam
  • Poziom 13  
    Witam
    Już wszystko działa, niestety nie napisałem, że testowałem to na maszynie wirtualnej w Virtual PC. Standardowo nie w maszynie wirtualnej, PonyProg, Winavr działa bez problemów.

    Pozdrawiam