Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

at89s8252 - sterowanie wyświetlaczem NOKIA - dziwny problem

sancio 20 Jun 2004 23:59 1458 8
  • #1
    sancio
    Level 14  
    Witam
    Mam przed sobą zmontowany układzik na AT89s8252 do sterowania wyswietlaczem NOKIA (od 3310). Napisalem programik (w ASM) do sterowania, jendak mam problem :( Sterowanie działa połowicznie..
    Kiedy wysyłam do wyświetlacza instrukcje (SD_C=0) to wszystko pięknie działa i mogę zmieniać wszystkie parametry. Widzę to po funkcjach: normal mode, invert mode, clear, all on. Jednak kiedy chcę wysłać dane do wyświetlenia nic się nie dzieje :(. Nie jest ro raczej (tego nie jestem w 100% pewien) wina pinu SD_C, bo gdy ustawie go w stan 1, to nie działają już funkcje.
    Mikrokontroler jest połączony z wyświetlaczem poprzez rezystory 1k2 i diodę zenera 3.3V (najprostszy układ ograniczenia napięcia).
    Nie mam możliwości podłączenia wyświetlacza do telefonu by go sprawdzić. Do portu LPT też nie podłączałem.
    Mam więc pytanie czy spotkał się ktoś z czymś takim??

    Pozdrawiam
    Piotrek
  • #2
    wisiena
    Level 18  
    Witam !!!
    Odpowiedzi może być bardzo wiele. Najlepiej będzie jak załączysz jakiś schemat. Narazie wydaje się, że nie dostosowałeś jakiegoś czasu albo coś źle podłączyłeś.


    Pozdrawiam (M.)
  • #3
    piotruss
    Level 12  
    zapytam dla pewnosci czy wyswitlacz jest poprawnie resetowany przy wlaczeniu i czy kontrast jest odpowiednio dobrany
  • #4
    sancio
    Level 14  
    Właśnie znalazłem rozwiązanie mojego problemu... Zgadza się coś zle podłączyłem Nigdy bym nie przypuszczał, że słabe styki mogą być przyczyną takiego dziwactwa (transmisja działa ale tylko częściowo)
    Musiałem (nie wiem jak) minimalnie uszkodzic połączenie między szybka wyświetlacza a przyklejonym do niego złączem (pewnie przy lutowaniu). Odkleiłem to złącze (jakis słabiutki klej dali - oszczedzają pewnie :P, a wyswietlacz byl oryginalny NOKII) wyczyściłem styki i przykleiłem jeszcze raz i od razu smiga jak trzeba :). Jednak aż tak dobry w drobnych pracach manualnych nie jestem i długo nie wytrzymało to co "naprawiłem". Teraz znów nie działa :( Ale przynajmniej jestem pewien co jest nie tak. Popracuje nad tym połączeniem jeszcze troche. Nigdy nie lubiłem tych szybek z napylonymi stykami, bo nic się tego nie chce trzymać porządnie i trzeba być bardzo ostrożnym.
    Co do programu to używałem wielu znalezionych implementacji i wszystkie zachowywały się tak samo, więc bałem się, że na samym początku uszkodziłem wyświetlacz źle go inicjując (tak jak to w dokumentacji do sterownika napisali), jednak jest OK.

    Potrzebuje teraz jakis sprawdzony sposób połączenia tego kawałka szybki z grucikami :)

    Pozdrawiam
    Piotrek
  • #5
    McRancor
    VIP Meritorious for electroda.pl
    Uśmieszek na końcu Twojej wypowiedzi jest za bardzo dwuznaczny!

    Przyklejenie tych cholernych styków do tej szybki jest trudne! Sam też bawiłem się orginalnym telewizorem noki i muszę przyznać że był to problem numer jeden!

    Ma ktoś jakiś dobry sposób na to?
    PS. tylko nie piszcie "nie odrywać" bo to już wiemy
  • #6
    sancio
    Level 14  
    Oj jest dwuznaczny i to bardzo....

    No ja przy tym szkiełku troche już przesiedziałem starając się go poskładać do kupy. Kropelka jest dobra (nawet jakos trzyma) ale straszna ma konsystencje i sie rozlewa i nie ma styku. Nie raz, to o mały włos nie złącze a ja bym był przytwierdzony do ekraniku :D.
    Badziewne jest to oryginalne złącze, bo te blaszki wcale nie są sprężynujące i jak sie mocniej przydusi, to juz się nie odegną i nici z połączenia. Czytałem gdzieś na forum, że można zastosować te blaszki od podstawek np DIL-8, jednak są o połowe za szerokie i nie mieszczą się.
    No cóż.. trzeba szukać i próbować dalej...

    PS
    nie piszcie też, by kupic nową sztuke wyświetlacza :P
  • #7
    PJS
    Level 15  
    Można spróbować klejem przewodzacym (np. takim do "montowania" układów smd). Nie wiem tylko czy jest coś takiego dostepne w niewielkich ilościach :-(
  • #8
    sancio
    Level 14  
    Najmniejsze co zalazlem kosztuje okolo 14 zl netto...
    To juz lepiej wyświetlacz...
  • #9
    alex1205
    Level 18  
    mozna kupic wysiwtlacz od noki 5510 - to to samo co 3310 tyko ze w 5510 sa blaszki przytwierdzone na stale do szybki i do tych blaszek mozna bardzo latwo wlutowac kabelki :) a klej przewodzacy ze srebrem na bazie kropelki mozna dostac za kolo 10-8 zl w sklepach motoryzacyjnych - takim klejem reperuje sie zerwane polaczenie w ogrzewaniu szyby w samochodzie sam stosuje taki do klejenia smd trzyma jak kropelka i zawsze mozna zmyc go spirytusem lub rozpuszczalnikiem jak cos nie tak bedzie i kleic od nowa :)