Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Logo 12/24 RC Problem przy mierzeniu temp.

29 Paź 2009 22:04 1559 12
  • Poziom 9  
    Witam! zwracam sie do was z nietypową jak dla mnie sprawą. na wstepie zaznacze iz słabo sie orjętuje co do tych spraw.
    Ale problem dotyczy palących sie styczników, na skutek zbyt czestego załączania i wyłaczania. Otóz sterownik o którym mówie to logo 12/24 RC, który pełni szereg funkcji w maszynie ,jedna z nich to załaczanie i wyłączanie grzałek za pośrednictwem palących się styczników.
    A wyglada to tak:
    sterownik mierzy temperature za pomoca czujnika Pt 100,
    podczas podgrzewania do temp właściwej( nastawionej), wszystko jest w porzadku, problem pojawia sie wówczas gdy temperatura dochodzi do max , przy której sterownik ma za zadanie wyłączyć podgrzewanie. Wówczas styczniki załączajace grzałke zaczynaja warjować( wpadaja w jakiś dziwny stan gdzie poprostu drża) na skutek tego w stycznikach wypalają sie styki.
    Wymieniłem czujnik temp PT100 z myslą iz to on jest przyczyną takiego stanu.( nie pomogło)
    W sterowniku słychać jest tez przekażnik który zamyka obwód zasilania cewki styczników , i zachowuje sie on podobnie jak te styczniki czyli załąacza sie i wyłacza w bardzo krutkich odstepach.( jednoczesmie podaje zasilanie na cewke owych styczników)
    Program który, jest w sterowniku, został ponownie wgrany z karty pamięci , ( to oczywiscie tez nie pomogło.
    Proszę o pomoc , co może być przyczyna takiego zachowania sie LOGO?
  • Poziom 13  
    Jaką ustawiłeś histerezę zmian temperatury? Prawdopodobnie nie ma jej wcale i taki efekt. Ustaw temperaturę załączenia stycznika o kilka, kilkanaście stopni niższą od temp. wyłączenia grzałek i problem zniknie.
    Pozdrawiam
    Marek
  • Poziom 9  
    Witam . Temp załaczania jest nizsza od temp wyłąączania jakies 20 stopni , a mianowićie zauwazyłem iz ten sterownik działa jak gdyby odwrotnie, czyli on wyłącza , of załącza. ale to jest chyba mało istotne, bo ruznica temp jest jakieś 20 stponi.

    Dodano po 2 [minuty]:

    Mam jeszcze jedno pytanie , a mianowicie , czy ta histereze ustawia sie w programie czy w samym sterowniku. Bo program który wgrałem wziołem z innego urzadzenia , które działa bez zastrzezeń , mimo iż jest identyczne.
  • Poziom 13  
    Oczywiście że w programie. Nie rozumiem twojego stwierdzenia:ON wyłącza, OFF włącza. Trzeba przeanalizować program i podłączenia. Może problem leży w wersji sterownika (jeden BA5- drugi BA6) lub w kablach do czujnika temp?
    Powiedz coś więcej o tym urządzeniu, zakresie temp pracy, itp.
    Pozdrawiam
    Marek
  • Poziom 9  
    Witam, dzieki za zainteresowanie.
    Urządzenie to myjka przemysłowa. Układ nie jest bardzo skomplikowany, w skład układu wchodzą
    2 styczniki ( od grzałek)
    Stycznik pompy myjącej
    Sterownik logo 12/24 Rc wersja 4( program kompatybilny do tej wersji , przynajjmniej tak mi sie wydaje, bo chciałem wrzucić program do wersji 5 to niechciał sie załadować)
    Czujnik temperatury pt 100
    Termostat bezpieczeństwa
    2 grzałki , jedna 2 i druga 4 kW
    Myjka dziłała następujaco
    Przy załaczeniu zasilania załączają sie dwie grzałki 2 i 4 kW, w tym czasie pompy nie mozna uruchomić , az do osiagnięcia minim temp jaka jest 45stopni, po osiagnieciu tej temp mozliwe jest załaczenie pompy. Ale grzałki pracują dalej, podgrzewaja roztwór do temperatury właściwej jaką jest 60 stopni( temp ta wynika z specyfikacji smego płynu , bo po osiągnięciu tej temp, dopiero jego skuteczność jest własciwa)
    Obydwie grzałki wyłaczaja sie po osiagnięciu 60 stopni.
    Jedna znich 2kW jest grzałka podtrzymujaca temp, druga ma za zadanie włączyć sie dopiero wuwczas gdy ta 2kW nie daje sobie rady z podtrzymaniem temp.
    Nastawy to
    grzałka 2kW - 60 max- min 58stop
    grzałka 4 kW- 60 max- min 55 stop
    tak to powinno działać i działa w innych myjkach, lecz z tą i 3 innymi włąśnie jest problem wypalania styków.
    Przy granicznej temp 60 stopni, sterownik załącza styczniki i wyłącza, pracują jak stroboskop.
    Poza tym
    Zastanawiam sie dla czego program nieda sie załadować do Logo wersji 5, wygladaja tak samo , funkcje maja identyczne.

    Dodano po 43 [minuty]:

    A co do on i off grzałek to nie wiem dlaczego osoba tworzaca oprogramowanie zamieniła te funkcjie, ale wyglada to tak iz przy on sterownik ma wyłączyć podgrzewanie, a przy off złączyć. Podobno zamienienie tych temp czyli on załącz off wyłącz powoduje tekie same usterki ( niewłąściwa prace styczników .) Może akurat facet piszacy program skorzystał z takiego rozwiazania.

    Dodano po 2 [godziny] 5 [minuty]:

    Właśnie przyjżałem sie tej myjce, logo jest rozszeżone o modół, z racji pewnie mierzenia temperatury, czujnikpt 100 podpięty jest do modułu. Czy jest to prawdopodobne by moduł był przyczyną takiego zachowania sterownika logo.
  • Poziom 13  
    Spróbuj ustawić większą histerezę: grzałka 2kW ON 55st OFF 65st,
    4kW ON 50st OFF 65st i zobacz co się będzie działo.
    pozdrawiam
    Marek
  • Poziom 9  
    ok . w ten weekend niedam rady ale zaraz po postaram się podjechać i przstawić tą histerezę. Jak tylko to zrobe to dam znać.( czy pomogło)
    Pozdrawiam
  • Specjalista Automatyk
    Witam
    Najlepiej o ile jest taka możliwość , prześlij program - będzie prosto sprawdzić

    pozdrowienia
  • Poziom 12  
    Jasne, tak będzie najlepiej - wklej program.
    A ja mam kilka pytań: czy ta myjka zawsze tak wyglądała? Może oryginalnie nie było tam stycznika, ale moduł elektroniczny SSR do włączania grzałki? Stycznik nie wydoli mechanicznie z szybkim przełączaniem, a modułowi SSR jest to obojętne. I pytanie następne - czy, istotnie, wszystkie te myjki są jednakowe? Może jednak różnią się w jakichś szczegółach, o których wcześniej nie wiedziałeś?
    Porównaj programy z tych wszystkich myjek.
  • Poziom 9  
    Witam jak narazie nie mam dostępu do tej myjki, bo poleciała gdzieś na prezentację. A co do wyglądu samego układu, to wszystkie wygladają identycznie, różnią sie jedynie szczegułami (styczniki starszego typu), a poza tym wszystko jest takie same.
    Programu niestety nie moge wrzucić ( lojalka pracownicza)
    Ale zaciekawił mnie wasz pomysł odnośnie modułu SSR, mogli byście mi troche przybliżyc temat, ( co byś zaproponował)
    Z góry dziekuję i pozdrawiam!

    Dodano po 12 [minuty]:

    Znalazłem taki chyba był by ok. Co wy na to?


    http://www.allegro.pl/item798648907_przekaznik_elektroniczny_ssr_25_a_400v_radiator.html
  • Poziom 14  
    Moim zdaniem problemu należy szukać w programie, a konkretnie w histerezie grzałki, gdyż jak Kolega sam zauważył styczniki są włączane i wyłączane. Być może są 2 warunki, które sterują cewką stycznika przez co na wyjściu w jakimś przypadku pojawia się stan nieustalony - analiza wszystkich warunków sterowania cewką stycznika byłaby moim zdaniem dobrym pomysłem. Wymiana na SSR też wydaje się nie być zadowalająca, skoro ewidentnie przyczyna tkwi w oprogramowaniu sterownika (lub nastawach). Przekaźnik w sterowniku też ma przecież swoją żywotność (a w obecnych warunkach będzie się cały czas jego styk przełączał, co długodystansowo doprowadzi do konieczności częstej wymiany sterownika).
  • Poziom 9  
    Kolega ma racje, zapomniałem o przekażniku w Logo.
    Gdyby kturyś z kolegów był z Warszawy, chętnie skożystał bym z pomocy.
    Program dziś wrzuciłem na kość pamięci, ale nie mam kabelka, by go ściągnąć na kompa.
    Musze coś wymyśleć.
    pozdrawiam!
  • Specjalista Automatyk
    Mieszkam w Kobyłce k/W-wy, posiadam kabelek oraz oprogramowanie Logo! ComfortSoft. - służę pomocą.
    Proszę o kontakt na mojego e-maila.
    Mimo wszystko proponuję zastosowanie przekaźnika SSR - w przypadku sterownika Logo! wymagany jest zakup modułu wyjść analogowych, w celu sterowania PWM.
    Przykładowa strona przekaźników SSR jest tu: http://www.lemi.pl/sklep/index.php?cPath=23