Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Woltomierz na Atmega8. 1,8-10v

Manio95 03 Lis 2009 18:16 25813 73
  • #61 03 Lis 2009 18:16
    Manio95
    Poziom 21  

    atom1477 napisał:
    Po prostu połącz obydwa niebieskie pola nad którymi pisze "+12".

    Obydwa??Ja widzę tylko jedno niebieskie pole z napisem 12v.

    Dodano po 2 [minuty]:

    AA już widzę po prostu zobaczyłem różnice między tymi dwoma schematami bo w tym drugim niema lini łączącej kondensatora c1 z +mierzonego napięcia.
    To już rozumiem.

    Sorry za post pod postem ale pytanie czy zamiast 7805 może być 78l05 bo udało mi się zdobyć za free
    Ale one mają 0,1A a 7805 ma chyba 1A więc nie wiem czy nie za mało?
    Proszę o odpowiedz.

    I jeszcze jedno pytanie czy mogę to zrobić bez tego 7805 i tych 4 kondensatorów bo w zasilaczu mam już stabilizowane 5V i 12V więc moim zdaniem jest to zbędne
    Nie wiem tylko czy tak może być?

    Post był raportowany.
    Pisanie postu pod postem.
    Należy używać przycisku ZMIEŃ.
    Scaliłem TRZY posty. [hefid]

  • #62 06 Lis 2009 15:56
    atom1477
    Poziom 43  

    Pisałem już. Można ale będzie większe ryzyko awarii i o wiele mniejsza dokładność pomiarów.

  • #63 06 Lis 2009 16:22
    Manio95
    Poziom 21  

    A jak z 78l05 za mało te 100mA tak?

  • #64 06 Lis 2009 18:39
    atom1477
    Poziom 43  

    Jak nie użyjesz podświetlania LCD to będzie akurat. Jak użyjesz to niestety nie.

  • #65 06 Lis 2009 19:05
    Manio95
    Poziom 21  

    No właśnie podświetleni podłącze bezpośrednio pod 5V i już.
    Jutro jadę po atmege potem poskładam i napiszę czy działa :)

  • #66 06 Lis 2009 19:28
    atom1477
    Poziom 43  

    Wiesz jak możesz zrobić? uP i całą resztę zasil z 78L05, a samo podświetlanie LCD z napięcia 5V które zaje zasilacz ATX.

  • #67 06 Lis 2009 19:38
    Manio95
    Poziom 21  

    No właśnie o to mi chodziło w poprzednim poście :)

  • #68 06 Lis 2009 21:15
    atom1477
    Poziom 43  

    Tylko sprawdź czy na pewno GND i VCC podświetlania są rozdzielone z GND i VCC sterownika LCD. Na płytce LCD zwykle są zworki które to łączą. Trzeba je usunąć.

  • #69 07 Lis 2009 09:25
    Manio95
    Poziom 21  

    A jak ja to mogę sprawdzić??Zworki żadnej niema ale znalazłem o ni to: http://jangelectronic.republika.pl/images/inne/WC1602A.pdf tam jego opis :D
    Wiem tylko tyle że jak podłączałem go pod komputer to musiałem jeszcze podać napięcie oprócz na pin 1 i 2 i jeszcze do kontrastu przez potencjometr na 3pin to jeszcze 15 pin VB+ i minus na 16 pin VB- do podświetlenia a na tym schemacie nie widać nigdzie podłączonego podświetlenia ale wiem jak to podłączyć i jeszcze dodać potencjometr od jasności świecenia :)

  • #70 07 Lis 2009 10:08
    atom1477
    Poziom 43  

    Zobacz czy pin VB- łaczy się z GND a VB+ z VCC.

  • #71 07 Lis 2009 12:40
    Manio95
    Poziom 21  

    Nie,nie łączą się.
    Właśnie wróciłem ze sklepu z atmegą 8 zaraz biorę się za składanie układu a potem zaprogramuje moją atmegę:)
    Jestm bardzo ciekawy czy mi zadziała :D

    No nie działa :(
    Wygląda na spalony wyświetlacz :(
    Bez problemu zaprogramowałem atmegę ale teraz jak podłączam to zapala się tylko górny słupek i świeci a na dodatek jeden układ z tyłu zaczyna się grzać to ja od razu odłączam zasilanie :(
    Nie wiecie co jest nie tak?
    Cały układ dobrze poskładałem :D
    Powiem tyle że jak podłączałem do kompa to też się raz nagrzał ale potem działał.
    I jeszcze jedno mierząc miernikiem pin 1 i 2 jest tam przepustowość ale nie wiem czy
    powinna być?
    Może jak lutowałem wyświetlacz to coś źle polutowałem bo takie duże luty stawiałem więc nie wiem może coś z tego?


    OK już uratowałem wyświetlacz :) czego to ja nie naprawię :D
    Po prostu wyczyściłem wszystkie ścieżki dałem rezystor 10k między pin 15 a mase i przede wszystkim nie łącze pinu 5 na mase bo on bez tego powinien działać.
    Teraz pozostaje problem z tym że jak załączam "układ"To zaświeca się pierwsza linijka i nic poza tym ale słyszałem że z tym "programatorem" prosty występują takie problemy więc potem wgram na nią wsad jeszcze raz.Potem bo już mam tego dosyć :(


    A i jeszcze jedno mam program Adama Dybkowskiego ISP Programmer i gdzie mam wybrać żeby programowało chodzi mi czy programming Flash czy programming EEPROM czy programming User Sig czy mam zaprogramować do wszystkich ten sam wsad czy tylko do jednego z nich?
    Aha i tan programator raz łapie atmege a raz nie i trzeba długo próbować nie wiecie czy z programatorem na USB złożonym na atmega8 też są takie problemy?Bo tak myślę nad złożeniem :)

  • #72 12 Kwi 2010 18:31
    krzychu.84
    Poziom 16  

    Witam,
    czy udało się uruchomić ten multimetr?

    Mam jeszcze pytanie do autora tego projektu: czy multimetr może mierzyć prąd powyżej 10A?
    Wydaje mi się że tak, ale nie jestem pewien czy w programie czegoś nie trzeba zmienić?
    Chętnie wykonałbym sobie taki miernik. Szczegółowo wszystko wyjaśnione na podstawie schematu lecz nie do końca jestem przekonany z tym pomiarem prądu. Proszę o potwierdzenie.
    Pozdrawiam
    Krzysztof

  • #73 18 Kwi 2010 21:12
    Mateusz31
    Poziom 10  

    Witam
    Również mam zamiar zbudować taki mutimetr, lecz nie jestem pewny czy można w programie do atmega8 przyporządkować taką oto prostą funkcję: przy pomiarze napięcia 0,5 V aby był wyświetlany wynik -100 oraz przy pomiarze 2,5 V => 0,00 i przy 4,5 V => 100. Oczywiście w całym zakresie od 0,5 - 4,5 liniowo i proporcjonalnie. Może ktoś mógłby mi podpowiedzieć kilka linii składni? Z góry dziękuję ;)

  • #74 18 Kwi 2010 22:33
    atom1477
    Poziom 43  

    Code:
    Adc_data = Getadc(0) 
    
    S = Adc_data
    S = S - 512
    S = S * 0.244140625
    L = Round(s)