Elektroda.pl
Elektroda.pl
X
TermopastyTermopasty
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

serwomechanizm - zakłócenia.

12 Lis 2009 18:23 2926 7
  • Poziom 14  
    Jest sterownik serwomechanizmu. Impulsy 1 lub 2 mS. Pracuje prawidłowo. Jednak !!
    Po podłączeniu serwa przewodem elektrycznym (3x0.75) na odległość 10m - serwo nie jest stabilne -bardzo wyraźnie waha się w zakresie ok 5-10 stopni.
    Wina kabla. który chcę wymienić na 2+1w ekranie. Czy to uspokoi serwo ?
    Nie bardzo mogę wytłumaczyć sobie co dzieje się w przewodzie na tej odległości - może Ktoś mnie naprowadzić. (Indukcja magnetyczna ??)
    Pozdrawiam JZ
  • TermopastyTermopasty
  • Poziom 25  
    Z pewnością jest to problem przewodu. Przede wszystkim zakłócenia. 10 metrów kabla to niezła antena. Poza tym 10 metrów kabla to też rezystancja. Jeżeli serwo będzie bardzo mocno szarpać prądem, na zasilaniu napięcie będzie kucać, nawet o 1.2V, przy założeniu szarpnięć prądem do 3A (i rezystancji miedzi 0,017ohm*mm^2/m).
  • TermopastyTermopasty
  • Poziom 35  
    Podejrzewam tak jak kolega u góry głównie problem ze stratami w przewodzie. Zostaw samo sterowanie w tym przewodzie 10m a zasilanie podłącz do serwa przez krótki przewód i sprawdź jak to pracuje - powinny zniknąć problemy.

    Rozwiązania generalnie masz 3:
    1.Samo zasilanie umieścić blisko serwa
    2.Dodać duży kondensator przy serwie, który złagodzi skutki nagłych spadków napięcia
    3.Zwiększ przewód do 2.5+mm2

    Najlepiej byłoby albo zrobić oddzielne zasilanie blisko serwa, albo połączyć pkt.2 i 3. (czyli grubszy przewód + duży kondensator low-esr przy serwie)
  • Poziom 14  
    Dzięki za pomoc.
    Jest tak.
    W tej chwili na przewodzie sterującym znajduje się kondensator elektrolityczny najzwyklejszy chyba 10uF. Drgania o których pisałem na wstępie ustały.Jenak co jakiś czas serwo wzbudza się i delikatnie zadrży. W związku z czym stawiam na jakieś zakłócenia (szpilki ,odbicia) w przewodzie sterującym.
    Spróbuję 1. Wymienię przewód na 2+1w ekranie, jak nie zda egzaminu
    2.Wstawić jakiś filtr na przewód sterujący+C o którym pisze
    MirekCz w pkt2
    Przyznam że robię to trochę na ślepo bo takiego tematu jeszcze nie przerabiałem.
    Za jakiś czas podzielę się tym co mi wyszło.


    PS: serwo pracuje ciągle z impulsem 1ms, sporadycznie (przy braku napięcia w sieci230V) przełącza się na 2ms. (-Sterowanie przepustnicy-otwarta,zamknięta)
    Zajrzę tu jeszcze może Ktoś mnie jeszcze oświeci.
    JZ

    Uzupełniam : serwo TowerPro SG5010 - analogowe

    Przed wysłaniem każdego postu, proszę używać przycisku "Pisownia"!
    [Art]
  • Poziom 25  
    Jakiego typu jest to serwo? Analogowe? Cyfrowe? Może symbol?
    Elektrolit, nawet low-esr nie będzie tak chętnie "zjadał" zakłóceń jak kondensator ceramiczny. Już bez problemu można nabyć pojemności rzędu 1uF z w miarę dobrym dielektrykiem (X7R, aczkolwiek Y5V tez może być). Tak więc do 10uF dałbym jeszcze jeden lub kilka ceramików o wartościach pomiędzy 10nF a 1uF.
  • Poziom 35  
    Wiecie panowie, tylko ja miałem na myśli raczej 1000uf+ pomiędzy zasilanie, a nie w linię sterującą.
    Bez oscyloskopu trudno powiedzieć co tam się dzieje, ale podejrzewałbym, że ten kondensator 10uF pozwala trochę wyrównać napięcie linii sterowania wobec skaczącego napięcia masy i dlatego to lepiej działa. Tylko problemem jest ta skacząca masa, a nie linia sterująca, z tego co ja bym powiedział.
    Ceramik też nie jest zawsze najlepszą odpowiedzią, bo może wpadać w oscylacje - właśnie z powodu zbyt małego oporu.
  • Poziom 14  
    Jeszcze jedna próba podłączenia serwa. Niestety brak mi wiedzy.
    Serwo podłaczone przewodem od telewizji przemysłowej (2+1 w ekranie).
    Ze sterownika dwoma przewodami 12V (10m) podciagniete do 7805 dalej zasilanie serwomechanizmu. Trzeci przewód to sterowanie - bezposrednio na serwo. Ekran połaczony z masą przy sterowniku.
    I wygląda to tak: Na poczatku kabla 1ms co 20ms. na końcu, na poziomie 4V
    serwomechanizm - zakłócenia.

    Nie wiem jak do tego się zabrać. Czy Ktoś wskaże drogę ?

    JZ
  • Pomocny post
    Poziom 11  
    Witam 4V to za mało. Podnieś napięcie , a problem ustąpi