Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Kalibracja kitu avt 2322 (termometr zaokienny).

piotrek991 14 Nov 2009 21:45 3669 11
e-mierniki
  • #1
    piotrek991
    Level 9  
    Witam.
    Nie dawno zmontowałem ten kit i jakoś nie bardzo chce mu się działać. W projekcie tym przerobiłem układ wyświetlaczy tzn. temp. wyświetlana jest od lewej do prawej. Po zmontowaniu wszystkiego od razu to odpaliłem ale na wyświetlaczach pojawiały się niezrozumiałe znaki. Po dokładnych oględzinach odnalazłem 1 zimny lut i zwarcie pomiędzy 2 pinami (złącze szufladkowe x24). Usunąłem defekty i termometr zachowuje się tak jak na załączonym filmiku:
    http://piotrek991.wrzuta.pl/film/7hBTDNEb6vI/mov00002
    i tak po kolei:
    1. Z ustawionym napięciem 100mV pomiędzy REF Hi i REF LO uwaga! bez czujnika!
    2. Z ustawionym napięciem 100mV pomiędzy REF Hi i REF LO z czujnikiem
    3. Z ustawionym napięciem 1000mV pomiędzy REF Hi i REF LO bez czujnika
    4. Z ustawionym napięciem 1000mV pomiędzy REF Hi i REF LO z czujnikiem
    Ustawiałem różne napięcia, ponieważ w projekcie napisane jest żeby nastawić 1000mV a gdzieś na internecie czytałem, że 100mV aby termometr pokazywał właściwą temperaturę. Może te zwarcie co wyżej wymieniłem coś zepsuło, ale nie sądzę. Nie wiem dlaczego to nie działa, siedzę nad tym już gdzieś od tygodnia i zaczynam wątpić, że to jeszcze będzie działać, wiec proszę o waszą pomoc. Dziękuję.
    @Edit
    Zapomniałem dmdać jedną rzecz: koleś w sklepie nie dał mi jednego kondenstatora, czyli C1 o pojemności 100pF, więc wsadziłem na jego miejsce 50pF(taki znalazłem w domu) może to powoduje problem?
    @Edit
    Schemat:
    Kalibracja kitu avt 2322 (termometr zaokienny).
    A ten C wygląda tak:
    Kalibracja kitu avt 2322 (termometr zaokienny).
    Wlutowałem ten kondensator i w sumie nic nie uległo zmianie, tylko na ustawionym napięciu 1000mV pomiędzy REF HI i REF LO pokazuje 15,2. Doszedłem do wniosku, że mam popsuty czujnik LM35, bo jak go podłączam to się nic nie dzieje, ale jak podłącze baterie pod dwie z nóżek LM35 to reaguje przynajmniej, jutro kupie nowy i zobaczymy może zadziała.

    A i jeszcze link do kitu AVT tego:
    http://www.elportal.pl/pdf/k07/38_13b.pdf
  • e-mierniki
  • #2
    predom
    Level 26  
    Wstaw taki sam kondensator. Jesli nawet nie pomoze to tez nie zaszkodzi.
  • e-mierniki
  • #3
    piotrek991
    Level 9  
    Na kondensatorze 100pF będzie napisane 101 racja? Zaszedłem dziś do sklepu elektronicznego i powiedziałem:
    -kondensator 100pF poproszę
    Koleś szuka, szuka no i po chwili przynosi. Ja się pytam czy to na pewno 100pF a on mówi:
    -no przecież napisane na nim jest 100. (ciekawe jakbym powiedział np 10nF :D)
    Dopiero po fakcie poszperałem w necie i doszedłem do wniosku, ze to 101 powinno być napisane.
  • #4
    predom
    Level 26  
    No jasne ze koles dal ci zly kondensator! On sie widac tak zna na oznaczeniach elementow jak moja babcia na promie kosmicznym :D. Ten kondensator 100pf ma miec napis 101.
  • #5
    szod
    Level 32  
    Dobra, to zagadka - jaką pojemność według Was ma kondensator z napisem 100? :D Powiem tak, 101 nie jest jednym oznaczeniem 100p stosowanym w kondensatorach. Bywają też kondensatory które mają dosłownie napisane 100. Więc spokojnie wlutuj go na swoje miejsce. Nie wiem jaki jest schemat tego kitu, ale podejrzewam, że ten kondensator miał być zamontowany tuż przy układzie ICL7107 jako kondensator oscylatora? Jeśli tak to zamień na taki jak powinien być, bo 50p spowoduje większą częstotliwość pracy. Może to powodować niekiedy różne efekty. Kondensator 100p będzie powodował odświeżenie pomiarów ok. 3 razy na sekundę. Jeśli tak jest po zamianie to ok. Co do pytań dotyczących kitu to najlepiej wrzuć tu schemat.

    ------

    Według schematu to napięcie odniesienia powinno być ustawione na 1000mV. Wlutuj ten kondensator 100p o którym pisałeś i ustaw napięcie odniesienia. Powinno działać.
  • #6
    piotrek991
    Level 9  
    Zmieniłem ten czujnik i kondensator no ale dalej te badziewie pokazuje -11,.. dopiero jak pochucham na czujnik to temp zmienia sie na dodatnia, no co moglem zrobic zle...
  • #7
    szod
    Level 32  
    Według dokumentacji LM35 to w tym kicie rezystor polaryzujący wyjście napięciem ujemnym jest zbyt mały. Wzór na to: R = -Vs / 50µA. Zmień rezystor R4 z 1k na 100k.
  • #8
    piotrek991
    Level 9  
    Nie pomogło, nadal pokazuje minusową temp;] mam 16 stopni mrozu w pokoju :)
  • #9
    szod
    Level 32  
    Sprawdź czy na pewno napięcie odniesienia ma 1000mV. Zmierz jakie napięcie jest pomiędzy nóżkami 30 i 31 układu ICL7107. Jak jest to samo na mierniku co na termometrze spróbuj wylutować na próbę R4. Polaryzuje on wyjście LM35 napięciem ujemnym po to, żeby można było mierzyć ujemne temperatury. Bez niego układ też będzie działał, ale tylko w dodatnich.
  • #10
    piotrek991
    Level 9  
    Napięcie odniesienia jest ustawione na 1000mV a pomiędzy nóżkami 30 i 31 jest inne napięcie niż wyświetlane na wyświetlaczach. Szod spójrz na płytkę (jednowarstwową). Ten kto to projektował chyba myślał o niebieskich migdałach! Po 1: pomylone ścieżki na płytce dwuwarstwowej z wyświetlaczami a teraz jeszcze odkryłem, że przetwornica ICL7660 w ogóle nie miała zasilania! Dlatego caly czas pokazywal minusową temp. i jeszcze weź zerknij na C9:
    Kalibracja kitu avt 2322 (termometr zaokienny).
    Tylko, że teraz jeszcze pokazuje 16°, moze jeszcze cos pomieszane w sciezkach.
  • #11
    szod
    Level 32  
    W takim razie musisz dokładnie prześledzić płytkę według schematu. Ten rysunek mi niewiele mówi, bo nie ma na nim zaznaczone gdzie jest jaki element montowany. W ogóle pierwszą rzeczą jaką powinieneś zrobić po zmontowaniu urządzenia jest pomiar napięć zasilających.
  • #12
    piotrek991
    Level 9  
    Wiesz, doprowadziłem +5V do ICL7660, C9 poprawiłem tak jak ma być i w sumie powiedziałbym, że w końcu termometr działa, tylko, że pokazuje 26°C ale w pokoju wydaje mi się, że jest zimniej, cholera nie mam za bardzo z czym sprawdzić;/

    Dzieki wam, a szczególnie tobie Szod za zainteresowanie się moim problemem.
    Pozdro!