Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

exel wyszukiwanie wartości

dyrygent 19 Lis 2009 15:19 891 5
  • #1 19 Lis 2009 15:19
    dyrygent
    Poziom 8  

    Witam mam problem w exelu
    potrzebuje funkcje która w jednej kratce poda wyniki z całej kolumny
    teraz może rozpisze o co mi chodzi
    a2 ma wartość 3 , c2 wartość 7
    a3 ma wartość 5 , c3 wartość 4
    i potrzebuje teraz ustawić w jednej ktarce by po wpisaniu w a22 wartości 3 w b22 wyszło mi wartość z c2 czyli 7, ale po wpisaniu w a22 wartości 5 w b22 wyszła mi wartość z c3 czyli 4

    0 5
  • #2 19 Lis 2009 15:43
    szaleniec
    VIP Zasłużony dla elektroda

    Możesz skorzystać np. z fukcji jeżeli.

    0
  • #3 19 Lis 2009 16:03
    dyrygent
    Poziom 8  

    przy funkcji jeżeli ustawie tylko z a2 nac2 i nic poza tym

    0
  • #4 19 Lis 2009 18:07
    szaleniec
    VIP Zasłużony dla elektroda

    Kliknij prawym przyciskiem myszy na odpowiedni arkusz w excelu, następnie wybierz "wyświetl kod", w oknie, które się pojawi wpisz:

    Code:
    Private Sub Worksheet_Change(ByVal Target As Range)
    

    On Error GoTo BadChange
    Application.EnableEvents = False
    If Target.Address Like "$A$#*" Then

        If (Target And Range("a2").Value = 3) Then
        Range("c2").Value = 7
        Else: Range("c2").Value = ""
        End If

        If (Target And Range("a3").Value = 5) Then
        Range("c3").Value = 4
        Else: Range("C3").Value = ""
        End If
    End If

    BadChange:
    Application.EnableEvents = True
    End Sub


    W załączniku przykładowy plik z w/w funkcjonalnością.

    0
  • #5 19 Lis 2009 18:23
    adamas_nt
    Moderator Programowanie

    Ewentualnie w B22 wpisz

    Code:
    =WYSZUKAJ.PIONOWO(A22;A2:C3;3;0)

    0
  • #6 27 Lis 2009 21:57
    dyrygent
    Poziom 8  

    wielkie dzięki za pomoc

    0