Elektroda.pl
Elektroda.pl
X
Computer ControlsComputer Controls
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Flyback 12.5V 8A prośba o sprawdzenie schematu

19 Lis 2009 16:19 16176 47
  • Poziom 38  
    Witam
    Od dłuższego czasu zabieram się za zaprojektowanie płytki drukowanej i jakoś brak czasu mi na to nie pozwalał i że wreszcie go trochę znalazłem zabrałem się za pracę. Trafo jest autorstwa RoMana i częściowo mojego i głównie jego bym prosił o uwagi jaki innych użytkowników forum.
    Pozdrawiam
    Link tu: http://wyslijto.pl/plik/0ludfffxzs bo nie dało się wrzucić na elektrodę w tym dziale :/
    Jeszcze tu:
    Flyback 12.5V 8A prośba o sprawdzenie schematu
  • Computer ControlsComputer Controls
  • Pomocny post
    Poziom 42  
    Ale o czym tu dyskutować? Może jedynie o tym, że nie powinieneś symbolu uziemienia ochronnego (PE) stosować jako pseudomasy strony pierwotnej.
    Doskonale powinieneś pamiętać, że krytyczny jest projekt płytki.
  • Poziom 38  
    Racja. Protel lubi używać ten symbol jako masy a że mi było wygodnie tego nie zmieniać tak już zostało. Co do płytki wiem - z tym że jak ją zaprojektuje i się okaże że coś dodałem za dużo a co gorsza za mało to będzie problem. Już jedną zrobiłem i wiem ja zrobić już dobrze ta płytkę. Temat można by zamknąć a jak będę miał kłopoty to poproszę o aktywację i zmianę żeby 2 wątków nie robić.
    Pozdrawiam
  • Poziom 38  
    Witam ponownie.
    Przetwornicę udało mi się ładnie uruchomić i odziwo bez problemowo zadziałała za pierwszym razem. Problem mam natomiast z gasikiem. Zastosowane elementy R7 = 4,7 kohm/2W oraz C11 = 3,3 nF nie spełniają moich oczekiwań. Opornik R7 niestety się gotuje a chciałbym uzyskać maksymalnie małe straty na nim żeby nie było konieczne wstawianie opornika 4W. W związku z tym zamieszczam oscylogram napięcia na drenie:
    Flyback 12.5V 8A prośba o sprawdzenie schematu
    Niestety mój oscyl mógł łyknąć tylko 400V więc skorzystałem z płynnej regulacji wzmocnienia toru Y kanału A dzięki czemu przebieg się zmieścił na ekranie ale nie wiem ile dokładnie jest V/dz na pewno ponad 50 a w sumie nie więcej jak 500V.
    Dodatkowo zamieszczam przebieg napięcia na oporniku pomiarowym:
    Flyback 12.5V 8A prośba o sprawdzenie schematu
    Przetwornica obciążona żarówką około 20-25W
    Pozdrawiam i proszę o pomoc w dobraniu gasika.
    Ps. Do moderatorów - zastanawiam się nad zmianą nazwy tematu ponieważ teraz dotyczy problem a wcześniejszy wątek niewiele wnosił do sprawy.
  • Computer ControlsComputer Controls
  • Pomocny post
    Poziom 42  
    Czy do pomiaru użyto sondy 10:1? Bo coś mi tu za mocno oscyluje na narastającym zboczu - jakby z pojemnością przewodu oscyloskopu...

    Zwiększ rezystancję do 10 kom o obserwuj czy nie pojawiają się przerosty za duże. I tyle.
  • Poziom 38  
    Tak sondy 10:1 z tym, że to polska sonda i ma RC przy wtyczce BNC i to może powodować problemy. Poeksperymentowałem trochę i tak:
    - opornik 10k nic nie zmienia albo zmiana jest niezauważalna przy kondensatorze 3,3nF i co gorsza grzeje się niemal tak samo mocno.
    - teraz mam zastosowane 22nF i 33kohmy i jest już trochę lepiej opornik mniej się grzeje i pierwsza oscylacja jest wytłumiona co wyraźnie widać. Zrobię w nocy fotkę z 33k i 22nF.
    Myślę czy by nie użyć takie zestawu 33nF i 47kohm który w jakiejś przetwornicy na TDA4605 znalazłem w jakimś TV. Myślę też czy by nie dodać 220pF między D-S Q1?
    Spróbuję zmienić sondę 10:1 na taką co ma dzielnik w rączce pomiarowej.
    Pozdrawiam

    Dodano po 2 [godziny] 55 [minuty]:

    Dorzucam oscylogram przy 22nF i 33KkOhmy ale nadal ten opornik zbyt mocno się grzeje. Co jak co ale sondę muszę chyba zmienić :/
    Flyback 12.5V 8A prośba o sprawdzenie schematu
  • Poziom 42  
    Chwila - oscylogram wskazuje na przebijanie któregoś elementu - chyba za bardzo osłabiłeś snubber i teraz wali po MOSFETcie bez sensu.
  • Poziom 38  
    MOSFET jest na 800V. Ja już nie wiem czemu to nie działa. Jeszcze tą sondę (10:1) może uda mi się pożyczyć od kumpla. Z tym, że jak dam kondensator 3,3nF i 33kOhm to mam przebieg jak dwa posty wyżej (bez obcięcia pierwszej oscylacji). Jak dodam do niego 20nF to mam przebieg jak post wyżej (z obcięta oscylacją). Zmienię tą sondę bo bardzo możliwe, że tu jest problem co nie zmienia faktu, że tak czy inaczej opornik 2W chyba nie da rady :/. Podejrzewam, że bez gasika ten MOSFET wytrzyma ale docelowo chciałbym móc wstawiać MOSFETa na 600V jeśli się uda ponieważ jest łatwiej dostępny.
    Pozdrawiam
  • Poziom 39  
    Napisz w jaki sposób wykonałeś transformator...
    Przekładnia 90zw/8zw jest optymalna, ale nic nie wiemy o sposobie nawinięcia uzwojeń i wykonania szczeliny w rdzeniu - jeśli jest na wszystkich kolumnach to skutkuje to znacznym wzrostem indukcyjności rozproszenia i efektami jakie opisałeś i pokazałeś na oscylogramach powyżej.
    W prawidłowo działającym zasilaczu powinien wystarczyć tranzystor na 600V.
  • Poziom 38  
    Kolego lechoo popatrz na pierwszy post dokładnie :-) Do trafa niema się jak doczepić bo jest firmowe :-)
    Pozdrawiam

    Dodano po 12 [minuty]:

    Ale mogę dodać wzór PCB bo może to ono powoduje problemy?
    Flyback 12.5V 8A prośba o sprawdzenie schematu
  • Poziom 42  
    -> psooya

    Ale nie ma problemu - to Ty go znalazłeś. Masz przetwornicę flyback o mocy 100W a denerwujesz się stratami na snubberze 2W - to są zaledwie 2% mocy przetwornicy. Skoro spłaszczenie przebiegu wynikło z pojemności snubbera, to jest wszystko OK.

    -> lechoo

    Osobiście liczyłem ten transformator. Natomiast nie ja go nawijałem i obecnie będzie trudno dojść, czy szczelina została zrobiona tylko na kolumnie środkowej czy też na wszystkich kolumnach. W projekcie była tylko na kolumnie środkowej. 1 mm, AL ok. 209.
    Nie ma dużej indukcyjności rozproszenia, skoro przy mocy 100W, sporo nadmiarowym rdzeniu (ale to ze względu na szeroki zakres napięć wejściowych) rezystor 2W w snubberze się jeszcze nie pali.
  • Poziom 38  
    Witam
    To nie dokładnie tak jest. Ja nie dokładnie sprecyzowałem problem. Opornik 4,7kOhm i 3,3nF się dymił po 20 sekundach pracy. Po trochę dłuższym okresie to samo było z oporem 10k i pojemnością 3,3nF. Teraz przy 33k i 3,3nF temperatura opornika była do przyjęcia natomiast po zwiększeniu pojemności do 20nF już jest za wysoka. Dlaczego to takie ważne. Otóż całość będzie pracowała w temperaturze otoczenia dochodzącej do 60st.C i będzie narażona na drgania. Tak gorący opornik będzie powodował szybsze zużywanie się elementów w okół niego oraz same punkty lutownicze do których będzie przylutowany będą osłabione. Kolejną sprawą jest to że chyba wartość szpili zbliża się do 600V przy 305Vdc zasilania co będzie eliminować zastosowanie tranzystora 600V. Dokładnie skalibruje oscyloskop do nowej sondy żebym wiedział ile jest V/dz wtedy będę mógł się wypowiadać o zastosowaniu tranzystora na 600V. Gasik dobieram pierwszy raz więc nie wiem w którym momencie powinienem uznać, że przebiegi są "wzorcowe" :-) (brak punktu odniesienia)
    Pozdrawiam
    Ps. Co do szczeliny to jest wykonana na kolumnie środkowej bo inaczej bym widział ją na kolumnach bocznych w końcu to 0,5mm by było a połówki rdzenia ładnie do siebie przylegają.
  • Poziom 42  
    A spróbuj zamiast snubbera RC użyć transila P6KE200A albo jeszcze lepiej 1.5KE200A.

    Co do wydzielanego ciepła - bez przesady - snubber nie jest jedynym jego źródłem. Tutaj łącznie wydzieli się sporo więcej tego ciepełka.
  • Poziom 38  
    Łącznie wydzieli się sporo to wiem i niestety nic z tym nie zrobię. Równie dobrze mogę tam dać opornik 4W i po kłopocie pod warunkiem, że kupie jakiś metalizowany a nie drutowy. Urządzenie musi być maksymalnie niezawodne dlatego nie chcę aby smażył się jeden nie umocowany do niczego opornik i powodował usterki w postaci przebitego klucza po przegrzaniu opornika. Wszystkie pozostałe nagrzewające się elementy będą zamontowane do radiatora co poprawi ich wytrzymałość na wstrząsy. Z transilem wypróbuję może nawet jutro jak go gdzieś kupie ale pomysł wydaje się być dobry. Sondę inną już mam też.
  • Poziom 38  
    Witam
    Więc tak: Mam nową sondę ale pomiary nią chyba nie różnią się niczym od poprzedniej. Za to dioda transilowa wydaje się być dobrym rozwiązaniem. Połączyłem szeregowo diodę BA159 z 1.5KE200A i efekty są jak na załączonym oscylogramie.

    Flyback 12.5V 8A prośba o sprawdzenie schematu
    Flyback 12.5V 8A prośba o sprawdzenie schematu

    Wygląda na to, że przebiegi są ok ale jeszcze chciałbym prosić o popatrzenie okiem fachowca. W tym momencie przetwornica zasilana jest przez żarówkę 100W/230V i na kondensatorze głównym jest około 250Vdc. Oscyl ustawiłem tak by było około 62V / dz. Mam nadzieję, że pomiar nie jest zbyt oszukany. Podejrzewam jeszcze, że jak zasilę przetwornicę z 240Vac to opornik R5 (startowy) będzie się mocno grzał i nie wiem czy coś na to poradzę ale może nie będzie źle.
  • Pomocny post
    Poziom 42  
    Przebiegi są bardzo dobre i już nic więcej robić nie trzeba. Jak bardzo grzeje się transil? Bo trafić z napięciem się udało idealnie - 1.5KE160A strasznie by się grzał a tu mamy bardzo ładne stłumienie, wręcz wzorcowe.

    Zamiast opornika startowego możesz zastosować stabilizator LR8 - dostępny w Contrans TI. Po przejęciu zasilania przez uzwojenie bias stabilizator się wyłącza i z głowy.
    Możesz też spróbować zwiększyć wartość rezystora startowego ale wtedy możesz mieć utrudniony start przy niższym napięciu. No i zawsze pozostaje możliwość montażu pionowego dwóch rezystorów połączonych szeregowo - lepsze chłodzenie i na dobrą sprawę jest to tak naprawdę jedynie poprawne rozwiązanie, bo nie powinno się w tym miejscu stosować pojedynczego rezystora.
  • Poziom 38  
    Dzięki wielkie za pomoc. Transil jest letni czyli widać, że działa a nie gotuje się i jak na razie jestem bardzo zadowolony z tego rozwiązania. Będzie to jeszcze testowane dla pewności i wreszcie trafi do gotowego urządzenia. Zwiększenie R5 nie bardzo wchodzi w grę bo chciałem aby zasilacz poprawnie startował już od około 85Vac (co jeszcze sprawdzę na autotransformatorze). Jeśli będę faktycznie miał problem z R5 to na pewno zastosuję się do jednej z twoich porad.
    Jeszcze raz serdecznie dziękuję i pozdrawiam :-)

    Dodano po 9 [minuty]:

    Jeszcze wracając do LR8. Przeczytałem PDF i stabilizator ma się wyłączyć jeśli napięcie na BIAS będzie równe lub większe od napięcia wyjściowego LR8. Problem jest taki, że u mnie to napięcie po starcie powinno wynosić 12V (a sam start odbywać się będzie z 16V) i rosnąć pod wpływem dociążania strony wtórnej. Tak ustaliliśmy ze względy na nadmierny wzrost tego napięcia przy obciążaniu. Musze sprawdzić zakres zmian BIASa przy różnych obciążeniach. W ostateczności 2 oporniki i powinno być po kłopocie. Teraz w najgorszym przypadku (340V na oporniku) na R5 powinno być około 1,2W więc nie powinno być źle. Testy wykażą ale już się cieszę z naszych sukcesów.
  • Poziom 38  
    Witam jeszcze raz.
    Przetwornice trochę po testowałem z kolegą i co mogę powiedzieć:
    - R5 jest gorący ale jest to do przyjęcia przy zasilaniu z 230Vac
    - Transil przy obciążeniu strony wtórnej na 80W już dość mocno się grzał lekko parzył ale myślę że to jest jeszcze w normie i do przyjęcia.
    - Napięcie zasilania BIAS zmieniało się od 12V przy małym obciążeniu do 17V przy 80W czyli mój pomysł na BIAS 12V bardzo dobrze się sprawdza.
    Za to doszło do przykrej niespodzianki. Przetwornica wybuchła (ponoć sama z siebie po 10 minutach pracy - mnie przy tym wtedy nie było). Układ wyparował, klucz dostał zwarcia pomiędzy SDG co za tym idzie opornik bramkowy 22ohm wyparował, opornik od pomiaru prądu jak i od jego filtru wyparował. Nie wiem co było przyczyną i ponoć nie było to przypadkowe zwarcie. Wymieniłem wszystkie uszkodzone elementy i dodatkowo wymieniłem diodą BA159 pracującą w gasiku na HER207 ponieważ jakoś nie ufam tym BA159 i możliwe że dioda "przerwała" co spowodowało uszkodzenie klucza i reszty układu. Po wymianie działała z mocą 80W ponad 30 minut jak nie prawie godzinę bez żadnych problemów, potem podłączyliśmy ją do docelowego urządzenia które w tym momencie pobierało tylko 10W (nie było kompletne). Mam pytanie odnośnie zminimalizowania skutków takich wypadków - czy dodanie Zenerek do masy na pinach 3 (na 3,3V) i 6 (na 20V) UC3842 ma jakiś sens? Zenerki np 1,3W bo bezpiecznik niestety się nie uszkodził - wystarczyła energia zgromadzona w kondensatorze C9 220uF by rozsadzić pół strony pierwotnej :/
  • Poziom 42  
    Proszę o aktualny schemat i opis problemu tutaj a nie w raporcie.
  • Poziom 38  
    Witam
    Z góry dziękuję za pomoc i odblokowanie wątku.
    Schemat niczym się nie różni od poprzedniego poza snubberem w postaci transila i wymianą dławika filtru wyjściowego z 15uH na 6,8uH na typu DZS więc zamieszczam poprawiony:
    Flyback 12.5V 8A prośba o sprawdzenie schematu
    Problem jest taki iż zasilacz do około 150Vdc pracuje poprawnie. Poniżej tego napięcia z trafa słychać dość głośny trzeszczący pisk(jakby łuk elektryczny ale to tylko porównanie do dźwięku bo łuku żadnego niema). Podłączyłem oscyloskop i faktycznie zasilacz nie pracuje stabilnie. W tym celu zacząłem zwiększać C13 100nF aż do 1uF ale nie wpływało to kompletnie na nic (natomiast przy poprawnej pracy brak C13 czyli kompensacji powoduje niestabilna prace w całym zakresie więc sama kompensacja działa). Potem pomyślałem że ten pisk nosi w sobie coś z 50Hz/100Hz więc zwiększyłem C9 220uF/400V dodając drugi taki sam i również nic to nie zmieniło ani troszkę. Pomyślałem, że może to wina obwodu kontroli prądu więc najpierw wymieniłem 470pF C10 na 1nF co lekko wpływało na pisk ale nic sensownego nie uzyskałem a następnie pomyślałem że na chwile zmniejszę R12 0,47R na 0,22R co również nic nie dało i nie wpływało na pisk. Przed ostatnim krokiem było odłączenie R1 27k do zabezpieczenia nad napięciowego co również nic nie dało a ostatnim podciągnięcie kolektora transoptora przez 680R do Vref co również nic nie dało. Po tych operacjach pomysły mi się skończyły a przypomniałem sobie że z flybackiem na 5V też miałem ten sam kłopot ale nim się nie zajmuję i tylko skupiam się na 12,5V 8A. PCB nie uległo zmianie. Proszę o pomoc co może to powodować?

    Dodano po 7 [minuty]:

    Ps. Obciążam zasilacz dwoma drutowymi opornikami 3,3R 25W połączonymi równolegle.
  • Pomocny post
    Poziom 42  
    Ten układ nie ma praktycznie żadnej kompensacji. Dodaj choć slope-compensation, czyli tranzystor NPN małej mocy - kolektor do Vref, baza do R/C a emiter, przez połączone szeregowo rezystor 2k2 i potencjometr 4k7 do CS.

    Możesz wcześniej dodać kondensator 1 nF pomiędzy emiter a kolektor transoptora.

    Można również całkowicie pozbyć się wzmacniacza błędu (wbudowany w TL431) i zamiast TL431 wsadzić diodę Zenera na 11V i R14 zmniejszyć do 68R.
  • Poziom 38  
    Wypróbuje wszystkie możliwości i dam znać jutro co i jak się zachowuje. NPN dodam na samym końcu. Najpierw wypróbuję Zenerkę. Ale co dziwne mam zasilacze 30W 5V od 110V do 230Vac i są skonstruowane dokładnie jak mój. Ale fakt przy mniejszej mocy niema problemów z piskami choć w zasilaczach od monitorów też często była TLka i UC i bez tranzystora NPN jakoś miało działać w pełnym zakresie. W każdym razie dam znać jutro.
    Pzodrawiam
  • Poziom 38  
    Witam znów.
    Więc tak:
    Zrobiłem zamiast TLki Zenera + opornik i było gorzej niż na TLce, dodałem 1nF do kolektora transoptora ale nic to nie zmieniało (niewielkie zmiany i wcale nie dobre), zwiększałem ten kondensator aż do 10nF ale nie miało to sensu. Wróciłem do TLki ze schematu i zacząłem kombinować z CS. Zwiększyłem C14 470pF do 4,7nF i okazało się że teraz zasilacz pracuje już poprawnie od 119Vdc czyli zgodnie z założeniem, natomiast mam niesmak co do wielkości tej pojemności i chyba wypróbuję ten tranzystor NPN chyba, że można by tak zostawić to nie musiałbym komplikować układu. Układu z NPNem z braku czasu nie udało mi się zbudować ale co do niego mam pewną niejasność. Ta podkówka ma być szeregowo z 2,2k i bezpośrednio do CS suwak czy ma być jedna końcówka do macy do CS (suwak) a trzecia do 2,2k ? Wydaje mi się że to pierwsze bo inaczej nie widzę sensu dawać podkówkę do masy.
    Pozdrawiam i życzę miłego weekendu. Do napisania po weekendzie :-)
  • Poziom 42  
    Zwiększając pojemność na nóżce CS doprowadzasz to znieczulenia układu i zwiększasz prawdopodobieństwo awarii. Zrób slope-compensation na pająka. Potencjometr oczywiście szeregowo. Jakby miał gdzieś być podpięty do masy, to bym to wyraźnie napisał.
  • Poziom 38  
    Rozumiem. Tak tez myślałem że max C14 mógłby być 1nF (chyba dam tam 1nF i opornik 560R ponieważ można dostać 1nF w MKT a te są zdecydowanie stabilniejsze termicznie). Wykonam slope compensation ale już po weekendzie i wydaje się że pomoże.
    Pozdrawiam i odezwę się po niedzieli
  • Poziom 38  
    Witam
    Zrobiłem wg zaleceń z drobnymi zmianami typu 470p zastąpiłem 1n MKT i zamiast podkówki 4,7k dałem 10k a tranzystor to BC546 i muszę przyznać, że pomaga i przetwornicę da się uspokoić ale następuje ograniczenie mocy (spadek napięcia wyjściowego o prawie 2V) przy przy obniżaniu napięcia zasilania (płynnie ogranicza moc) co niestety nie jest wskazane zważywszy, że już wymagam lekko ponad 12V na wyjściu. Może jeszcze jakieś pomysły?
    Pozdrawiam

    Dodano po 1 [minuty]:

    Ps. Zmniejszyłem też 0,47R na 0,35R, uspokoiłem przetwornicę ale też nic to nie dało :/
  • Poziom 42  
    To zmniejsz jeszcze bardziej.
  • Poziom 38  
    Dałem teraz R12 0,22R i wymieniłem R9 z 1k na 560R żeby dalej stała czasowa filtru była taka sama przy zastosowaniu 1nF. Nadal efekty są niezadowalające :/ Nie udaje się uzyskać braku ograniczania mocy. Praktycznie w całym zakresie jest ograniczona. R12 chce dążyć do 0R a to raczej chyba nie jest wskazane. Do tego dość gwałtownie reaguje na zmiany podkówki więc docelowo trzeba będzie pewnie dać opornik 1% ale to już mniejszy problem. Coś mi się wydaje że trzeba będzie najprościej zaprojektować dwa trafa na 115Vac i na 230Vac i dostosować je tak by nie przekraczać 50% wypełnienia. Kurcze a myślałem że to takie proste....
    Pozdrawiam
  • Poziom 42  
    Skoro nie ma pełnej mocy, to oznacza, że przesadzasz znacznie ze slope-compensation i doprowadzasz do absurdu. POŁĄCZ dwie metody - np. dioda Zenera i slope-compensation. Załącz oscylogramy z nóżki CS. Na razie działasz chaotycznie.
    Projekt płytki też jest daleki o ideału. niestety...
  • Poziom 38  
    Zastosuje diodę Zenera ale na 12V. Bardzo możliwe że przesadzam i problem jest w PCB tylko że już nie wiem jak zrobić ja poprawnie. Widziałem setki tych rozwiązań i jedne miały punkt wspólny masy przy 5 nodze inne na głównym kondensatorze i żadna nie miała slope compensation i każda miała TL431 oraz czasami była i TL i Zenerka na 2 różnych transoptorach. Ja próbowałem obie i ta działa najlepiej. Może jakieś wskazówki to przeprojektuje PCB (może inny pinouttrafa - to najwyżej sobie tu przerobie to co mam a potem zmienię w w projekcie ) zresztą i tak chciałem zrobić je 2 warstwowe i zamówić w firmie więc wskazówki mile widziane. Dam znać wieczorem co uzyskałem po zmianach i wrzucę oscylogramy.
    Pozdrawiam