Elektroda.pl
Elektroda.pl
X
Computer Controls
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Problem z konfiguracją cisco 2600

01 Gru 2009 10:37 3611 21
  • Poziom 9  
    Witam
    Mam mały problem, trudno mi stwierdzić czy jest to wina konfiguracji routera, czy to może coś z adresacją u dostawcy.

    Wcześniej korzystałem z usług TPSA. I miałem przydzielone następujące adresy IP:
    - 80.50.164.174 – Adres Routera Cisco
    - 212.244.176.130 – Adres Firewalla Cisco
    - No i na koniec oczywiście nasza adresacja wewnętrzna.
    W tej konfiguracji adres który był rozgłaszany, był to adres Firewalla, na którym miałem skonfigurowany dostęp VPN do sieci wewnętrznej.

    W chwili obecnej wygląda to następująco:
    - 75.67.2.86 – Adres Routera Cisco
    - 75.67.2.90 – Adres Firewalla Cisco
    - No i na koniec oczywiście nasza adresacja wewnętrzna.
    W tej konfiguracji adres który jest rozgłaszany, to adres Routera, a co za tym idzie niestety jestem pozbawiony VPNa.

    Sprzęt to: Cisco 2600 i Cisco PIX 506E

    Dołączam starą (cisco 1600 na nim działało)
    Code:

    Current configuration:
    !
    version 11.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Cisco
    !
    ip subnet-zero
    ip nat inside source list 101 interface Serial0.99 overload
    clock timezone CET 1
    clock summer-time CEST recurring
    !
    !
    interface Ethernet0
     description DMZ
     ip address 212.244.176.129 255.255.255.248
     no ip route-cache
    !
    interface Serial0
     no ip address
     encapsulation frame-relay IETF
     no ip route-cache
     frame-relay lmi-type ansi
    !
    interface Serial0.99 point-to-point
     description Internet
     ip address 80.50.164.174 255.255.255.252
     ip nat outside
     no ip route-cache
     no arp frame-relay
     frame-relay interface-dlci 99
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0.99
    ip route 192.168.0.0 255.255.255.0 212.244.176.130
    access-list 101 permit ip 192.168.0.0 0.0.0.255 any
    access-list 101 permit ip host 212.244.176.130 any
    !
    end


    i nową konfigurację (cisco 2600)
    Code:

    Using 2225 out of 29688 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Cisco
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    !
    clock timezone CET 1
    clock summer-time CEST recurring
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    ip ips po max-events 100
    ip domain name yourdomain.com
    no ftp-server write-enable
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     description DMZ
     ip address 75.67.2.89 255.255.255.248
     ip nat inside
     no ip route-cache cef
     no ip route-cache
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     description Internet
     ip address 75.67.2.86 255.255.255.252
     ip nat outside
     no ip route-cache cef
     no ip route-cache
     duplex auto
     speed auto
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 75.67.2.85
    ip route 192.168.0.0 255.255.255.0 75.67.2.90
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source list 100 interface FastEthernet0/1 overload
    !
    !
    access-list 100 permit ip 192.168.0.0 0.0.0.255 any
    access-list 100 permit ip host 75.67.2.90 any
    !
    !
    control-plane
    !
    !
    banner login ^C
    -----------------------------------------------------------------------
    Cisco Router and Security Device Manager (SDM) is installed on this device. This
    feature requires the one time use, initial credentials, of username "cisco"
    with password "cisco".

    Please change these publicly known initial credentials through SDM or IOS CLI.
    Here's the Cisco IOS command:

    no username cisco

    NOTE: Please add a new username to be able to launch SDM for router management.

    For more information about SDM please follow the instructions in the QUICK
    START GUIDE for your router or at
    http://www.cisco.com/go/sdm
    -----------------------------------------------------------------------
    ^C
    !
    !
    end
  • Computer Controls
  • Poziom 32  
    Skoro tak to nie można podać tych samych IP jak w starej konfiguracji.
    A i czy tu ip address 75.67.2.86 255.255.255.252 i tu ip address 75.67.2.89 255.255.255.248 maska jest prawidłowa.
  • Computer Controls
  • Poziom 9  
    slvestr napisał:
    Skoro tak to nie można podać tych samych IP jak w starej konfiguracji.

    Nie są te same, są podmienione

    slvestr napisał:
    A i czy tu ip address 75.67.2.86 255.255.255.252 i tu ip address 75.67.2.89 255.255.255.248 maska jest prawidłowa.

    ten 86 to jest pojedynczy adres, a ten 89 to jest z puli 88-95. Dlatego inna maska.
  • Poziom 23  
    Kolego napisz jakie pule dostałeś od operatora, połączeniową /30 (na seriala)i twoją rozgłaszaną (adres i maske).
  • Poziom 32  
    A spróbuj tu ip route 0.0.0.0 0.0.0.0 75.67.2.85 zamiast IP wpisać nazwę interfejsu do którego jest wpięty internet czyli FastEthernet0/1
  • Poziom 9  
    Cytat:

    A spróbuj tu ip route 0.0.0.0 0.0.0.0 75.67.2.85 zamiast IP wpisać nazwę interfejsu do którego jest wpięty internet czyli FastEthernet0/1

    Z tego co pamiętam, to już to testowałem, ale jutro jeszcze sprawdzę dla pewności

    Cytat:

    kolego napisz jakie pule dostałeś od operatora, połączeniową /30 (na seriala)i twoją rozgłaszaną (adres i maske)

    ip: 75.67.2.86
    brama: 75.67.2.85
    maska: 255.255.255.252

    dodatkowe: 75.67.2.88-95
    brama: 75.67.2.89
    maska: 255.255.255.248
  • Poziom 23  
    Czy na pixie robisz nat ?, widzę że w 1600 nat nie działał gdyż nie było interfejsu inside, na 2800 masz nat włączony, może tu jest problem.
    Czy z konsoli routera możesz pingować adresy z puli prywatnej i odwrotnie czy z konsolii pixa możesz pingować adresy w internecie ?

    Jeśli zmiany z natem nie pomogą wklej conf pixa, jutro będę miał trochę więcej czasu spróbuje pomóc.
  • Poziom 9  
    abdenagof napisał:
    Czy na pixie robisz nat ?, widzę że w 1600 nat nie działał gdyż nie było interfejsu inside

    Nat na 1600 też działał: "ip nat inside source list 101 interface Serial0.99 overload"

    abdenagof napisał:
    Czy z konsoli routera możesz pingować adresy z puli prywatnej i odwrotnie czy z konsolii pixa możesz pingować adresy w internecie ?

    - z routera nie mam możliwości pingowania do adresów z puli prywatnej ani na odwrót
    - z pixa mogę pingować zarówno w świat jak i wewnątrz

    abdenagof napisał:
    Jeśli zmiany z natem nie pomogą wklej conf pixa, jutro będę miał trochę więcej czasu spróbuje pomóc.

    Code:
    PIX Version 6.3(3)
    
    interface ethernet0 auto
    interface ethernet1 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password xxx encrypted
    passwd xxx encrypted
    hostname cisco
    domain-name ciscopix.com
    clock timezone CEST 1
    clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 192.168.0.4 Lex
    name 192.168.0.20 obieg
    access-list inside_outbound_nat0_acl permit ip host obieg 192.168.0.240 255.255.255.248
    access-list inside_outbound_nat0_acl permit ip host Lex 192.168.0.240 255.255.255.248
    access-list inside_outbound_nat0_acl permit ip 192.168.0.0 255.255.255.0 192.168.0.252 255.255.255.252
    access-list outside_cryptomap_dyn_20 permit ip any 192.168.0.224 255.255.255.240
    access-list outside_cryptomap_dyn_40 permit ip any 192.168.0.240 255.255.255.248
    access-list outside_cryptomap_dyn_60 permit ip any 192.168.0.252 255.255.255.252

    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 75.67.2.90 255.255.255.248
    ip address inside 192.168.0.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool handel 192.168.0.225-192.168.0.238
    ip local pool zarzad 192.168.0.241-192.168.0.246
    ip local pool admin 192.168.0.253-192.168.0.254
    pdm location 219.96.38.0 255.255.255.128 outside
    pdm location obieg 255.255.255.255 inside
    pdm location LEX 255.255.255.255 inside
    pdm location 192.168.0.235 255.255.255.255 outside
    pdm location 192.168.0.192 255.255.255.192 outside
    pdm location 192.168.0.248 255.255.255.252 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface 2024 obieg 24 netmask 255.255.255.255 0 0

    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 75.67.2.89 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    aaa authorization command LOCAL
    http server enable
    http 219.96.38.0 255.255.255.128 outside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-128-SHA
    crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
    crypto dynamic-map outside_dyn_map 40 set transform-set ESP-AES-128-SHA
    crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60
    crypto dynamic-map outside_dyn_map 60 set transform-set ESP-AES-128-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map client configuration address initiate
    crypto map outside_map client authentication LOCAL
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption aes-256
    isakmp policy 20 hash sha
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 3600
    vpngroup handlowiec address-pool handel
    vpngroup handlowiec dns-server RDP_host
    vpngroup handlowiec idle-time 1800
    vpngroup handlowiec password ********
    vpngroup zarz address-pool zarzad
    vpngroup zarz dns-server RDP_host
    vpngroup zarz idle-time 1800
    vpngroup zarz password ********
    vpngroup admin address-pool admin
    vpngroup admin dns-server RDP_host
    vpngroup admin idle-time 1800
    vpngroup admin password ********
    telnet 192.168.0.1 255.255.255.255 inside
    telnet 192.168.0.0 255.255.255.0 inside
    telnet timeout 5
    ssh 219.96.38.0 255.255.255.128 outside
    ssh 192.168.0.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    dhcpd lease 3600
    dhcpd ping_timeout 750
    username mariusz password xxx encrypted privilege 15
    terminal width 80
    Cryptochecksum:xxx
    : end
  • Poziom 23  
    Próbowałeś wyłaczyć nat na 2600 i sprawdzić ? Do działania natu potrzebne jest wskazanie int inside, outside i wydanie magicznej formułki jak router ma robić nat. Na 1600 nie spełniłeś wszystkich warunków. Sprawdź to !
  • Poziom 9  
    hmm, może i na 1600 nie było spełnionych wszystkich warunków, ale działało.
    Jeśli mówiąc o wyłączeniu nata miałeś na myśli wydanie komendy "no ip nat inside", to przestał działać internet.
  • Poziom 23  
    Przepraszam nie doczytałem na poczatku twojego pierwszego posta, rozumiem że masz internet, jednak adres pixa nie jest dostępny z sieci ?, Twój dostawca internetu powinien rozgłaszać twoje 2 sieci, pix ma adres publiczny i ten adres powinien być dostępny z sieci.
  • Poziom 9  
    Tak, ze świata nie można dostać się na PIXa. I to jest właśnie mój problem;/
  • Poziom 23  
    Sądząc po zastosowanym routerze masz usługę dostępu do internetu bez BGP, powinieneś zadzwonić do operatora i przypomnieć o drugiej sieci.
  • Poziom 9  
    Powiedz mi tylko o co konkretnie mam się upomnieć. Bo zawsze jak do nich dzwonię, oni mówią, że wszystko jest OK.

    A co do routera, to mam takiego, bo potrzebowałem dwa wejścia ethernetowe i takiego akurat miałem na magazynie.
  • Poziom 23  
    Zapytaj się ich czy propagują informacje o twoich sieciach do internetu

    75.67.2.88/29
    i
    75.67.2.84/30

    czasem się zdarza że zapomną dodać u siebie sieci należącej do klienta i jej nie rozgłaszają

    Dodano po 1 [minuty]:

    Spróbuj zrobić taki test, odłacz router od internetu, podłącz do niego do interfejsu WAN komputer, wpisz w ustawienia IP komputera adres IP routera dostawcy i jako bramę domyślną adres IP twojego routera.
    Spróbuj zestawić VPN z pixem, jak się uda znaczy że u Ciebie wszystko jest ok
  • Poziom 9  
    abdenagof napisał:

    Spróbuj zrobić taki test, odłacz router od internetu, podłącz do niego do interfejsu WAN komputer, wpisz w ustawienia IP komputera adres IP routera dostawcy i jako bramę domyślną adres IP twojego routera.
    Spróbuj zestawić VPN z pixem, jak się uda znaczy że u Ciebie wszystko jest ok


    Niestety nie do końca rozumiem. Adres IP routera dostawcy??
    U mnie to wygląda tak:
    Światłowód do konwertera, skąd wychodzi RJ45 wchodzące do portu FastEthernet w 2600, z drugiego portu FastEthernet wychodzi do PIXA, a stamtąd do switcha.

    Wiem, że moja wiedza na temat sieci nie jest największa. Więc proszę o wyrozumiałość.
  • Poziom 23  
    Chodzi mi o to abyś w ramach TESTU swojej konfiguracji, odłączył przewód z portu FE0/1 routera 2600 i podłaczył tam zamiast konwertera komputer PC.

    Ustawienia komputera PC
    ip: 75.67.2.85
    maska 255.255.255.252
    brama: 75.67.2.86

    i z tego PC spróbował zestawić VPN do pixa, jeśli się uda to wina lezy po stronie operatora, jeśli nie to będziemy szukać dalej

    Dodano po 34 [sekundy]:

    oczywiście użyj kabla krosowego
  • Poziom 9  
    OK, zrobiłem jak kazałeś. Jeśli mówiąc zestawić miałeś na myśli np. przetestowanie pingów, to można było pingować na PIXa (75.67.2.90)
  • Poziom 23  
    Chodziło mi o zestawienie VPN czyli podłąaczenie się do sieci prywatnej za PIXEM,
  • Poziom 9  
    Próbowałem się połączyć tak jak zawsze Cisco VPN Clientem, ale nie udało się. Ale pingi na PIXa szły, a normalnie nie chcą.
  • Poziom 9  
    abdenagof napisał:
    Wklej log VPN Clienta


    Secure VPN Connection terminated locally by the Client
    Reason 412: The remote peer is no longer responding