Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Fibaro Fibaro
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Mikroprocesorowy tester elementów półprzewodnikowych

bobo 11 Gru 2009 08:11 232614 309
  • #121 11 Gru 2009 08:11
    mlassota
    Poziom 18  

    Co do testów...

    BT151F-600 jest wykrywany jako NPN hFE=0 - ciekawe dlaczego?
    Pozostałe tyrystory i triaki jakie sprawdziłem są juz ok.

    Modyfikacja polegająca na wywalenie kondensatora 100µF po stronie wtórnej stabilizatora dała bardzo dobry efekt - Tester załącza sie za każdym razem i zniknęły problemy z "pamiętaniem" ustawień - nawet w momencie wykonywania testów jednego po drugim

    Raz jeszcze gratulacje
    Pozdrawiam
    M

    PS Gratulacje Kolego eurotips

  • Fibaro
  • #122 11 Gru 2009 09:11
    Trabi
    Poziom 36  

    Potwierdzam. U mnie też wywalenie 100u po stronie wtórnej uspokoiło przyrządzik. Włącza się za każdym razem, zaczął mierzyć poprawnie i powtarzalnie :) . Dzięki za podpowiedzi. Gratulacje za walkę do końca dla kolegi eurotips. :)

  • #123 11 Gru 2009 10:17
    eurotips
    Poziom 33  

    Trabi napisał:
    Potwierdzam. U mnie też wywalenie 100u po stronie wtórnej uspokoiło przyrządzik. Włącza się za każdym razem, zaczął mierzyć poprawnie i powtarzalnie :) . Dzięki za podpowiedzi. Gratulacje za walkę do końca dla kolegi eurotips. :)


    To nie koniec ale dopiero początek.
    Widać na płytce że są tam "lewe" patenty,
    między innymi 4-nózkowy stabilizator i układ Resetu.
    Reset doskonale się sprawdza w testowaniu jeden po drugim,
    pewnie się załącza i wyniki są poprawne.
    Troszeczkę gorzej jest go właczyć jak LED zgaśnie,
    ale odkryłem, że zamiast pstrykania kilka razy można switch przytrzymać wciśnięty i wtedy wcześniej czy później, ale zaskoczy i pomiar jest poprawny.

    A oto kilka ciekawych elementów "widzianych" przez tester:

    tranzystor bipolarny IGBT z bramką FET typu MGP15N40CL TO-220
    NPN B=3;C=2;E=1 hFE=0 drugą stroną:NPN B=1;C=2;E=3 hFE=0

    tyrystor SCRs typu MCR25N
    pojemność: 1-2 0.19nF drugą stroną Pojemność: 2-1 0.19nF

    triak typu MAC15
    pojemność: 1-2 0.19nF drugą stroną Pojemność: 2-1 0.19nF

    N-MOSFET NTP60N06
    N-E-MOS C=4.49nF GDS=321 Vt=3227m i znaczek diody
    drugą stroną N-E-MOS C=4.34nF GDS=123 Vt=3227m i znaczek diody

  • Fibaro
  • #124 11 Gru 2009 11:51
    Trabi
    Poziom 36  

    Zrobiłem wersję z 1-wszego postu ze zmianami podanymi przez kolegów, ale bez innego stabilizatora. U mnie siedzi 7805 LDO. Przyrządzik startuje 100/100 z każdej pozycji, czy to reset, czy od początku. Błędów nie wywala. Musiałem jeszcze raz przeprogramowac procek, bo miałem ustawione 8MHz. Zmiana na 1MHz i wywalenie tego 100u dało efekt. I cały czas ciągnie z baterii 6F22 lekko już używanej.

  • #125 11 Gru 2009 11:58
    Paweł Es.
    Pomocny dla użytkowników

    Zważcie Panowie, że metodą pomiarów napięć na elemencie nie da się ze 100% poprawnością rozróżnić elementów, bo np. tranzystor z przerwą w obwodzie kolektora czy emitera (z drugim złączem sprawnym) będzie się zachowywał jak dioda półprzewodnikowa. Podobnie może być problem z elementami wielowarstwowymi typu tyrystory, triaki, które mogą się zachowywać lekko różnie od tego co by wynikało z ogólnie znanych układów zastępczych (tranzystorowych).

  • #126 11 Gru 2009 12:05
    eurotips
    Poziom 33  

    Zmieniłem wersję zasilania,
    zrobiłem tak jak pierwotnie planowałem,
    pięknie się załącza "na dotyk" z każej pozycji.
    Pobór prądu: 13 mA praca, 3 mA spoczynek,
    trochę dużo te 3 mA, ale 1 mA to prąd dzielnika do mierzenia napięcia,
    warto byłoby o rząd podnieść wartości oporów i zamiast 10/3.3 zastosować 100/33k bo przy oporności wejściowej ADC to te 10k tylko niepotrzebnie baterię obciążają. Pozostałe 2mA to sam stabilizator je pożera, nic z tym nie da się zrobić,
    pracuje za to w rewelacyjnym zakresie 5,5V -35V czyli nawet z Li-Ion rozładowanej jeszcze pójdzie oraz doskonale nadaje się na wersję stacjonarną.
    Zaznaczyłem czerwonymi kólkami istotne elementy,
    wywalenie elki za stabilizatorem nie uważam za dobry pomysł,
    po prostu 100u to za dużo, ja dałem 1u, ale uważam że książkowa wartość to 10u, bo procej jednak ciągnie swoje 10 mA.
    Druga sprawa to ten tranzystor inicjujący pomiar, jego baza nie może wisieć w powietrzu,
    te 100k do masy zdecydowanie potrzebne.
    No i zamiast kondensatora 100n przy pin1 układ Resetu.
    Kto ma ten da, musi być na 5V i dawać ujemny impuls przy włączaniu.
    a oto sprawdzony przezemnie schemat zmodyfikowanego zasilania:
    uSUWAM schemat aby nie mieszać w temacie,
    autor sam zmodyfikował schemat i proszę z niego korzystać.

    Paweł Es. napisał:
    Zważcie Panowie, że metodą pomiarów napięć na elemencie nie da się ze 100% poprawnością rozróżnić elementów, bo np. tranzystor z przerwą w obwodzie kolektora czy emitera (z drugim złączem sprawnym) będzie się zachowywał jak dioda półprzewodnikowa. Podobnie może być problem z elementami wielowarstwowymi typu tyrystory, triaki, które mogą się zachowywać lekko różnie od tego co by wynikało z ogólnie znanych układów zastępczych (tranzystorowych).


    No moje pomiary tyrystora i triaka ewidentnie są nieciekawe.
    A są to elementy nowe, nigdy nie używane i stosunkowo niedawno kupowane.
    Co ciekawe, pomiary są 100% powtarzalne, więc algorytm jest do przerobienia chyba.
    Bo już na BT136 mam NPN i hFE=0, tak samo NPN pokazuje BT151, stary poczciwy BTP128 od Jowisza widzi natomiast jako Rezystancję.

  • #127 11 Gru 2009 13:56
    bobo
    Poziom 28  

    Paweł Es. napisał:
    Zważcie Panowie, że metodą pomiarów napięć na elemencie nie da się ze 100% poprawnością rozróżnić elementów, bo np. tranzystor z przerwą w obwodzie kolektora czy emitera (z drugim złączem sprawnym) będzie się zachowywał jak dioda półprzewodnikowa. Podobnie może być problem z elementami wielowarstwowymi typu tyrystory, triaki, które mogą się zachowywać lekko różnie od tego co by wynikało z ogólnie znanych układów zastępczych (tranzystorowych).

    Świeta racja, niemniej jednak, nawet najlepszy przyrząd porafi zrobić na szaro mierzacego. Z reguły to ludzie sie myla ale bywaja testery które robia to lepiej od ludzi :D Wniosek, trzeba byc przytomnym, zdawać sobie sprawe z tego co robimy i czego możemy sie w wyniku spodziewać. Np. ten nieszczęsny tranzystor, skoro od razu pokazuje diodę to w głowie zaczyna mi świtać że coś tu nie gra. Chociaż, mogę przeciez mieć element który wyglada jak tranzystor a w rzeczywistości są to dwie diody ( np. S16C45 ).
    Pozdrówka

  • #128 11 Gru 2009 15:03
    Paweł Es.
    Pomocny dla użytkowników

    No akurat tę podwójną diodę można odróżnić od sprawnego tranzystora, przez sprawdzenie czy element wykazuje, w jednej z poprawnych polaryzacji, wzmocnienie powiedzmy większe od 20.

  • #129 11 Gru 2009 16:36
    eurotips
    Poziom 33  

    pRZETESTOWAŁEM 12SZT tyrystorów i triaków,
    5 z nich wykrył jako oporność R
    4 jako tranzystory NPN
    2 jako pojemność C
    1 jako tranzystor PNP
    Oto fotki przebadanych elementów:
    Mikroprocesorowy tester elementów półprzewodnikowych

  • Fibaro
  • #130 11 Gru 2009 17:48
    Paweł Es.
    Pomocny dla użytkowników

    BTA16 może być źle zinterpretowany, bo przy pomiarach, pomiędzy elektrodami A1 i G widac rezystancję ok. 78Ω w obie strony a pomiędzy pozostałymi elektrodami są przerwy (A1-A2 i A2-G). Więc jeżeli w procedurze pomiarowej nie ma próby włączenia triaka to będzie złe rozpoznanie. Czyli po podłączeniu miernik widzi:

    Mikroprocesorowy tester elementów półprzewodnikowych

    4 nowe BTA16 miały rozrzut rezystancji A1-G od 74 do 78Ω

    Dla BTA10 rezystancja pomiędzy A1 i G wynosi ok. 62Ω

    Przejście A1 G jest widziane jako rezystancja a nie np. jako złącze diodowe jakby to wynikało z prostego połączenia przeciwsobnego dwutranzystorowych układów zastępczych tyrystorów.

    Czyli jeżeli procedura pomiarowa nie spróbuje włączyć triaka (do tego potrzeba czasami sporych prądów) to zobaczy tylko rezystor

  • #132 11 Gru 2009 20:24
    skater156
    Poziom 14  

    Witam, mam pytanko.Czy tym urządzeniem można sprawdzić np:
    -czy dany połprzewodnik jest dobry?
    -czy tranzystor jest npn czy pnp?
    Przecież to można sprawdzić na mierniku.

  • #133 11 Gru 2009 20:41
    Freddy
    Poziom 43  

    skater156 napisał:
    Witam, mam pytanko.Czy tym urządzeniem można sprawdzić np:
    -czy dany połprzewodnik jest dobry?
    -czy tranzystor jest npn czy pnp?
    Przecież to można sprawdzić na mierniku.

    Nikt nie każe Ci robić tego testera.
    Przeczytaj pierwszy post, a nie tylko ostatni, to dowiesz sie wszystkiego.

  • #134 11 Gru 2009 22:21
    as1200
    Poziom 11  

    Prawdopodobnie zbiorę baty za poniższą prezentację mojego wykonania testera :)
    Najważniejsze jednak, że działa!

    Mikroprocesorowy tester elementów półprzewodnikowych Mikroprocesorowy tester elementów półprzewodnikowych Mikroprocesorowy tester elementów półprzewodnikowych

    Jeszcze dwa ujęcia testerka :)

    Mikroprocesorowy tester elementów półprzewodnikowych Mikroprocesorowy tester elementów półprzewodnikowych

    Pozdrawiam.

  • #135 11 Gru 2009 23:01
    bobo
    Poziom 28  

    as1200 napisał:
    Prawdopodobnie zbiorę baty za poniższą prezentację mojego wykonania testera :)

    Pochwały nie baty.

    Przez minione dni, nie dawały mi spokoju posty kolegów o "wieszaniu" testera i post o rezystorze wewnętrznym Atmegi. Postanowiłem przysiąść problem i po zerwaniu kilku godzin spłodziłem wersje która, jak do tej pory, działa 100/100. Zadałem sobie pytanie, może mylne, układ albo zadziała albo Atmega i cały tester idzie do krainy wiecznych snów, gdyby tak projektanci Atmega8 nie popełnili błędu a zrobili to celowo, to czy można skorzystać z tego faktu że wewnątrz jest rezystor? Można i to z bardzo dobrym skutkiem. W czym sztuczka? jeżeli przerwiemy ścieżkę pomiędzy nóżkami 7 i 20 ( Vcc i AVcc ) to połączenie robi tylko ten wewnętrzny rezystor, zasilanie dalej mamy. Jak się teraz sprytnie odseparować masami? równie prosto. Odciąć masę, nóżki 22 ( AGND ) i połączyć ją dławikiem ( 100uH ) z masą GND ( nóżka 8 ), odfiltrować, zasilanie nóżka 20, kondensatorem 0,1u i gotowe. Reszta elementów to już poprawa "samopoczucia" testera. Wszystkie próby wykonałem bazując na podstawowej wersji testera , łącznie z softem. W załączniku poprawiony schemat, trochę inne PCB.
    Pozdrówka

  • #136 11 Gru 2009 23:14
    eurotips
    Poziom 33  

    Jak nie zapuściłeś produkcji seryjnej to zrób jeszcze porządek z tym tranzystorem przy procku. Dodałeś już opornik 10k w kolektorze to dodaj jeszcze 100k łączący bazę do masy. Tranzystor nie lubi jak jego baza wisi w powietrzu, nawet zbliżając palec na odległość taki tranzystor może się wzbudzać. Na bank poprawi to stabilność.

    Właczenie LED również mi się nie podoba. Przytrzymanie switcha powoduje jego zgaszenie, pomimo że proc daje podtrzymanie, to myląca info. Ja propnuję podpiąć go do Vcc za stabilizatorem, doskonałe miejsce, na czerwony, będzie szybko rozładowywał te 10u do 1,4V po automatycznym wyłączeniu.

    Muszę przyznać że ten układ jest lepszy od stabilizatora 4pin bo po wyłączeniu nie pobiera prądu wcale, a mój patent pożera 2mA i potrzebny wyłącznik aby bateria nie zdechła.

    as1200 napisał:
    Prawdopodobnie zbiorę baty za poniższą prezentację mojego wykonania testera :)
    Najważniejsze jednak, że działa!


    Niepotrzebnie tyle dziurek pomiarowych dałeś,
    to dodatkowe pojemności.
    No a ten pojedynczy pasek poziomy z otworami to zmień sobie na rozładowywarkę kondensatorów, łącząc wszystkie piny do masy

  • #137 12 Gru 2009 00:01
    as1200
    Poziom 11  

    Cytat:
    No a ten pojedynczy pasek poziomy z otworami to zmień sobie na rozładowywarkę kondensatorów, łącząc wszystkie piny do masy

    Dziękuję za uwagi, co do powyższego okazało się, że tego poziomego paska pomiarowego używam najczęściej.
    Nie wiedziałem jaki rozkład będzie najbardziej optymalny więc zaryzykowałem w ten sposób.

    Pozdrawiam.

  • #138 12 Gru 2009 10:45
    Freddy
    Poziom 43  

    as1200 napisał:
    Prawdopodobnie zbiorę baty za poniższą prezentację mojego wykonania testera :)
    Najważniejsze jednak, że działa!

    Pozdrawiam.

    Nie zbierzesz żadnych batów, no chyba, że malutkie, za lutowanie kabelków do wyświetlacza :)
    Zachęcamy wszystkich którzy zrobią urządzenie do prezentacji wyników swojej pracy.

  • #139 12 Gru 2009 11:48
    as1200
    Poziom 11  

    Cytat:
    Nie zbierzesz żadnych batów, no chyba, że malutkie, za lutowanie kabelków do wyświetlacza :)

    Słabo widać na zamieszczonym wcześniej zdjęciu ale jest tam 'rozpinane' złącze :)
    Pozdrawiam.

  • #140 12 Gru 2009 13:02
    Freddy
    Poziom 43  

    Widać, widać napisałem przecież z :)
    Tak a propos, nie stosuj tej taśmy, fatalnie się zachowuje jako "lutowana", często sie ukrusza. W zagniatanych złączach tak, ale nie w lutowane.

  • #141 13 Gru 2009 01:13
    sq3dwe
    Poziom 15  

    Wykonałem płytkę zgodnie z tester_v2.pdf dzisiaj po obiadku zacznę go montować,będzie to trzeci egzemplarz testera.Podobno do trzech razy sztuka.Pierwszy to był z Elektora drugi na Atmega8 nie bardzo sie mnie udał w załączniku fotki.Po wykonaniu trzeciego zamieszczę fotki.Pozdrawiam Ryszard.

  • #142 13 Gru 2009 11:09
    eurotips
    Poziom 33  

    sq3dwe napisał:
    Wykonałem płytkę zgodnie z tester_v2.pdf dzisiaj po obiadku zacznę go montować,będzie to trzeci egzemplarz testera.Podobno do trzech razy sztuka.Pierwszy to był z Elektora drugi na Atmega8 nie bardzo sie mnie udał w załączniku fotki.Po wykonaniu trzeciego zamieszczę fotki.Pozdrawiam Ryszard.


    koniecznie zastosuj się do wskazówek które przekazałem koledze BoBo co do tej v2,
    jesteś radioamatorem więc rozumiesz że pozostawienie bazy tranzystora w powietrzu podczas pomiaru to błąd konstrukcyjny (chodzi o ten załączany switchem) zwłąszcza że dopuszczono możliwość wywałania następnego pomiaru przed upływem zadanego czasu. I nie wyrzucaj elki za stabilizatorem, BoBo już ją pozostawił, musi tam zostać minimum 10u ale przenieś za to LEDa, właśnie za stabilizator, będzie ci pięknie rozładowywał te 10u po zakończeniu pomiaru. No a ta masa przez dławik to chyba również błąd, w konstrukcji z "minusem na masie" on będzie "zbierał" zakłócenia a nie filtrował, prawda ?

    Cytat:
    Jak nie zapuściłeś produkcji seryjnej to zrób jeszcze porządek z tym tranzystorem przy procku. Dodałeś już opornik 10k w kolektorze to dodaj jeszcze 100k łączący bazę do masy. Tranzystor nie lubi jak jego baza wisi w powietrzu, nawet zbliżając palec na odległość taki tranzystor może się wzbudzać. Na bank poprawi to stabilność.
    Właczenie LED również mi się nie podoba. Przytrzymanie switcha powoduje jego zgaszenie, pomimo że proc daje podtrzymanie, to myląca info. Ja propnuję podpiąć go do Vcc za stabilizatorem, doskonałe miejsce, na czerwony, będzie szybko rozładowywał te 10u do 1,4V po automatycznym wyłączeniu.


    Ja chyba miałem więcej szczęścia i uruchomiłem ten tester z Elektora. Jest znakomity, bo na PICu zresztą. Kluczem w budowie to klucze analogowe 40HC52, udało mi się kupić sztuki co mają RdsON=130Ω i poszedł, jeśli będzie ponad 200Ω to będzie kicha.. Standardowy CD4052 Philipsa z toru AV sprzętu HiEnd ma około 1300Ω i tester na takim niestety nie chodzi.

    Tu w tym testerze popełniłem błąd projektując płytkę, ale jak się załączy to wskazania są powtarzalne. Ja dodałem scalak Reset i chodzi to miodzio, program jest dobry. Tylko jak na razie pomiar tyrystorów i triaków nie wychodzi, ale wszyscy wiemy że to nie takie proste. Teraz zbieram tranzystory cyfrowe czyli takie z jednym i dwoma rezystorami w środku, jak nazbieram tuzin to znowu wam przedstawię wyniki.:!:

  • #143 13 Gru 2009 11:58
    sq3dwe
    Poziom 15  

    Potwierdzam spostrzeżenia eutotips, mój z Elektora nie bardzo działał na układach CD4052 ale po zastosowaniu 74HC4052 działa super. Nie udało się mnie znaleźć w internecie wsadu full software 040409-41.zip. Z wersją free software 030451-11.zip działa bez problemowo nie muli elementów do pełni szczęścia brak tylko skanowania triaków, tyrystorów i darlingtonów.Jeszcze dzisiaj przed montowaniem trzeciego testera zastosuję podane usprawnienia. Może tym razem uda się zamieścić zdjęcia poprzedniego.

    Mikroprocesorowy tester elementów półprzewodnikowych Mikroprocesorowy tester elementów półprzewodnikowych Mikroprocesorowy tester elementów półprzewodnikowych Mikroprocesorowy tester elementów półprzewodnikowych Mikroprocesorowy tester elementów półprzewodnikowych

  • #144 13 Gru 2009 12:41
    eurotips
    Poziom 33  

    Jeśli swoim wpisem namieszałem w głowach a ktoś chciałby zrobić takie poprawki,
    pozwoliłem sobie na edycję schematu BoBo z naniesionymi przezemnie zmianami.
    Proszę o opinie nt moich zmian:
    1. dodanie do bazy T1 rezystora 100k do masy z jednoczesną zmianą wartości oporu w kolektorze z 10k na 100k
    2. zmiana miejscem opornika 27k
    edit: -nie można zmienić bo ma wpływ na wskazania, usunąłem tą zmianę ze schematu
    3. przeniesienie diody LED, jeśli ktoś nie chce przenosić również switcha, to w jej miejsce trzeba wlutować w kierunku przewodzenia zwykłą 1N4148. Przeniesienie switcha na plus wiąże się z dodaniem dodatkowych 2 oporników i jednej diody, wszystko pokazałem na schemacie.
    Co daje przeniesienie switcha na plus? pole popisu dla eksperymentatorów, można wtedy dać za nim przez opór 1-10k diodę LED która pokaże nam że switch podał sygnał, często bowiem katujemy tester niepotrzebnie, bo switche mają to do siebie że w czasie lutowania kiepszczą się, pomimo że pstryka to nie zawsze łączy, a potem powstają błędne opinie że to wina schematu załączania bądź zasilania.
    4. rezygnacja z dławika i jednocześnie przywrócenie zwory łaczącej Avcc z Vcc,
    tutaj można również spróbować zamiast zwory montować dławik, kto ma oscyloskop może się pobawić i poobserwować zakłócenia
    4. przywrócenie kondensatora C4 za stabilizatorem, trzeba się trochę pobawić, minimalna wartość to 1u, optymalna to 10u ale wtedy w linię Vcc musimy koniecznie dać czerwoną LED

    Usuwam schemat,
    proszę patrzxeć na ostateczną wersję zmodyfikowaną przez kolegę BoBo

  • #145 13 Gru 2009 13:08
    bobo
    Poziom 28  

    Dodanie rezystora 100k w bazie, jak najbardziej zasadne i łatwo mozna go dolutować od strony ścieżek, chociaż u mnie dokładnie nic nie zmienia ( nie mam zakóceń itp. ) tranzystor jest idealnie w stanie wyłączenia po puszczeniu przycisku, nie widze powodu aby go trzymać wciśnięty po wyswietleniu komunikatu na wyswietlaczu. Proszę zauważyć że, na PCB jest taka fikuśna ścieżka pod dławikiem, dokładnie to ona jest drutem i nic nie wnosi do układu więc mozna ją zostawić i dlawika nie stosować w przciwnym przypadku należy ją przeciąć. Dławik zastosowałem tylko z jednego powodu. Po dokonaniu przeróbek na nodze 20 pojawiała się dziwna, maleńka chmurka nałożona na stałe napiecie. Nie powodowało to żadnego fałszowania pracy testera ale mnie wkurzała. Ponieważ oscyloskop jakim dysponowałem nie pozwala dokładnie określić kształtu tej "maliny" więc szukałem sposobu na pozbycie sie jej. Radykalnie załatwiło sprawę wstawienie dławika. Czy zbiera zakłócenia, w moim przypadku nie, może dlatego że mam ekranowane pudełko? Kwestia diody, wszystko mozna zrobić aby świeciła, ja się tym mało przejmuje, mam podświetlany wyświetlacz. Pomiar tranzystorów z rezystorami wewnątrz. Robiłem pomiary tranzystorów DTC i DTA ( PNP i NPN ) w wyniku uzyskiwałem: prawidłowe podanie typu tranzystora ale reszta to już głupoty. Wnioskuję że wynika to z wtrącania rezystancji równoległych do układu i tym samym wpuszczania testera w maliny.
    Pozdrówka
    PS. tyrystorów i triaków nie mierzyłem.....poprostu nie mam ani jednego :cry:

  • #146 13 Gru 2009 16:23
    eurotips
    Poziom 33  

    bobo napisał:
    ... Mam natomiast wątpliwości co do przeniesienia opornika 27k. Równoległa oporność złącza BE i rezystora 100k daje w wyniku inną stałą czasową układu. Pomiar tranzystorów z rezystorami wewnątrz. Robiłem pomiary tranzystorów DTC i DTA ( PNP i NPN ) w wyniku uzyskiwałem: prawidłowe podanie typu tranzystora ale reszta to już głupoty. Wnioskuję że wynika to z wtrącania rezystancji równoległych do układu i tym samym wpuszczania testera w maliny. ...


    Tej zmiany nie byłem pewny, zastanawiało mnie tylko to pojemnościowe obciążenie portu bez żadnej rezystancji szeregowej. Takie walenie kijem po nerkach. No ale to coś zmienia w pomiarach więc nie należy tego robić.

    Teraz co do LED, dobrze zauważyłeś że masz podświetlany LCD więc i tak widzisz Vcc i nie ma u Ciebie sensu przenoszenia jej. Jak najbardziej zgadzam się z Tobą. Ale przy zasilaniu bateryjnym większość z tego podświetlenia rezygnuje i problematyczny staje sięReset po końcu pomiaru. Nawet u Ciebie, napięcie ci spadkie do około 2,4V (żółte led podświetlenia +złacze 1N4007). Gdybyś zastosował czerwony LED to napięcie spadałoby do 1,5V i reset byłby pewniejszy przy ponownym włączeniu. Teraz rzecz istotna, jeśli zabierzemy diodę LED niemożliwe będzie ponowienie pomiaru przed wyłaczeniem automatycznym, aby taką sposobność zachować switch poprzez rezystor 10k łaczymy bezpośrednio do plusa baterii. Schemat zrobi się prościutki, przejrzysty i co najważniejsze, w pełni funkcjonalny pod napisany soft.

    Jednak tester rozpoznał triaka, widzę na fotce :arrow: SQ3DWE
    Ciekawe jaki to typ, może mam taki, jestem bardzo ciekaw co pokaże na moim.

    A czy ktoś próbował połączenie szeregowo/równoległe 4 rezystorów aby zwiększyć ich stabilność czasowo-termiczną oraz tolerancję? szczególnie prosto to wykonać w wersji smd płytki.

  • #147 13 Gru 2009 18:59
    sq3dwe
    Poziom 15  

    Właśnie zakończyłem ostatnio podane modyfikacje na poprzednio wykonanej płytce płytce,nie przenosiłem tylko rezystora 27k.Triaki i tyrystory skanuje bez problemu,ale w tranzystorach Darlingtona ma problem z odczytem wzmocnienia w tranzystorach
    N-JFET myli końcówki.Oto wyniki pomiarów elementów fabrycznie nowych.
    BF245B N-JFET GDS 132 i odwrotnie GDS 321
    J310 N-JFET GDS 321 i odwrotnie GDS 132
    BT136 600E Triak G=1,A1=2,A2=3 i odwrotnie G=3,A1=2,A2=1 OK
    MAC97A6 Triak G=2,A1=3,A2=1 i odwrotnie G=2,A1=1,A2=3 OK
    MCR100-6 Tyrystor GAK 231 i odwrotnie GAK 213 OK
    BD901 NPN B=1,C=2,E=3 hFE=0 ^Uf=1261m
    BDX34B PNP B=1,C=2,E=3 hFE=0 ^Uf=1237m
    Sprawdziłem jak zachowuje się ten z Elektora i przy obróceniu N-JFET nie ma problemu z prawidłowym odczytem kolejności wyprowadzeń.

  • #148 14 Gru 2009 07:16
    Trabi
    Poziom 36  

    Witam po przerwie.
    Zastosowałem kilka zmian wskazanych przez kolegów (mimo że u mnie już działa b.dobrze). Co ciekawe, wstawienie 10µF na wyjściu z 7805 znów całkowicie go ogłupia: wyświetlanie 1-wszej linii, niemożność wejścia w "Testowanie..." itp. Zmniejszyłem do 1µF i działa. Co zauważyłem, elektrolity wskazuje dobrze dopiero za którymś z rzędu razem np. tantalowy 1µF pokazał za 5-tym czy 6-tym razem dobrze. A tak cały czas się zbliżał (997,5nF 998,2nF 999,1nF 999,8nF 1µF) i tak potem trzyma. No ale - jak to kolega pisał - to nie przyrząd typowo do badania pojemności :)

  • #149 14 Gru 2009 08:38
    sq3dwe
    Poziom 15  

    Cześć a jak radzi sobie z darlingtonami?

  • #150 14 Gru 2009 09:31
    Trabi
    Poziom 36  

    No problem w tym, że nie mam żadnego :( . Ale poszukam; może coś znajdę.

 
Black Friday do -15%
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
Ferguson