Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Udostępnianie plików pomiędzy 3 komputerami bez switcha/huba

QuendiX 07 Jan 2010 15:23 2298 4
  • #1
    QuendiX
    Level 10  
    Witam,

    Chcę mieć dostęp do udostępnianych plików na trzech komputerach:

    1. (PC stacjonarny) "SERWER" -
    posiada 2 karty sieciowe (RJ-45):
    a) podłączona skrętką do modemu Motoroli (internet upc)
    b) połączona skrętką z kartą sieciową 2 komputera (PC stacjonarny) "HEGEMON"

    2. (PC stacjonarny) "HEGEMON" -
    posiada 2 karty sieciowe (RJ-45):
    a) połączona skrętką z kartą sieciową 1 komputera (PC stacjonarny) "SERWER"
    b) połączona do Routera WiFi Huawei D100 :
    IP: 192.168.1.100 (przydzielane z DHCP Routera)
    Maska podsieci:255.255.255.0
    Brama domyślna: 192.168.1.1

    3. (Laptop) "LAPTOP" -
    Połączony przez WiFi z Router'em WiFi Huawei D100

    IP: 192.168.1.101 (przydzielane z DHCP Routera)
    Maska podsieci:255.255.255.0
    Brama domyślna: 192.168.1.1



    Router WiFi Huawei D100 ma tylko jedno złącze RJ-45. Router jest złączony z modem'em Huawei E220 i jest drugim łączem internetowym, które udostępnia internet w sieci, komputerom podłączonym pod Router.

    Wszystkie komputery pracują na Windows XP Home Edition SP3 i przypisane sa do grupy roboczej MsHome.

    Problem polega na tym, że pierwszy komputer "SERWER" nie widzi plików udostępnianych na komputerze "LAPTOP" i odwrotnie. Jedyny komputer, który widzi wszystkie na raz to "HEGEMON".

    Wiem, że rozwiązaniem byłby switch albo HUB. Jestem w posiadaniu Hub'a ale ma za mały przesył (technologia 10 BASE-T - 10Mbps) i ogranicza połączenie internetowe, czego nie chce.

    Czy jest możliwość takiego skonfigurowania połączeń sieciowych, aby każdy komputer widział pozostałe dwa w grupie roboczej bez konieczności dokupowania dodatkowego sprzętu ?

    Z góry dziękuje za rady :)

    Pozdrawiam
  • #2
    piterus99
    Level 43  
    karty na hegemonie masz ustawione w nat, bridge czy jakos inaczej?
    Zestaw na nich mostek sieciowy, sam fakt istnienia tych polaczen nie gwarantuje niestety przekazywania pakietow
  • #3
    QuendiX
    Level 10  
    Właśnie zastanawiałem się nad zmostkowaniem kart, ale nie wiem jak skonfigurować połączenie między komputaremi HEGEMON i SERWER. Komputery widzą się nawzajem tylko wtedy gdy na komputerze SERWER zrobię udostępnianie połączenia internetowego na HEGEMON.

    Nie korzystam z NAT'a, mostkowanie kart na HEGEMON też nic nie daje, a nawet skutkuje brakiem dostępu do kompa SERWER.

    Nie bardzo wiem co wpisać w ustawieniach (IP, Maska podsieci, Brama domyślna) kart łączących się nawzajem na komputerach SERWER i HEGEMON - to może być powodem dlaczego mostek nie pomaga.
  • Helpful post
    #4
    piterus99
    Level 43  
    Serwer(192.168.1.98/255.255.255.0/bez bramy/bez DNS) -- (192.168.1.99/255.255.255.0/bez bramy i dns) ->MOSTEK @HEGEMON<-(interfejs z DHCP zapięty do tego huawei) )( HUAWEI ))(( (DHCP) laptop

    Teraz powinno zaskoczyć, w otoczeniu możesz nie widzieć serwera, natomiast po wpisaniu //192.168.1.98 powinno zaskoczyć..

    Alternatywnie, osobna klasa adresowa, włączone udostępnianie połączenia na hegemonie i wywalenie bramek w niepotrzebnych miejscach, ale trzeba by dodać w laptopie regułkę do tablicy routingu, że pakiety do serwera mają lecieć przez hegemona. W WinXP wlaczony routing w teorii na jednym iface powoduje routowanie sie wszystkieog na wszystkie strony, o czym sam sie niestety któryś wakacji przekonałem...

    Pozdrawiam
  • #5
    QuendiX
    Level 10  
    Trochę nie zrozumiałem i za pierwszym razem od razu zmostkowałem obie karty na HEGEMONIE, a w ustawieniach TCP/IP wpisałem (192.168.1.99/255.255.255.0/bez bramy i dns). Na kompie SERWER w ustawienia TCP/IP wpisałem Serwer(192.168.1.98/255.255.255.0/bez bramy/bez DNS).

    Już się cieszyłem, bo wszystkie 3 kompy zaczęły się widzieć, ale.... HEGEMON stracił połączenie internetowe :P

    Pokombinowałem chwile dłużej i w końcu udało się.
    Poprzednio złączone mostkiem karty rozłączyłem (usunąłem mostek).

    Następnie na HEGEMONIE:
    a) W ustawieniach karty łączącej się z kompem SERWER wpisałem (192.168.1.99/255.255.255.0/bez bramy i dns).
    b) Na drugiej karcie łączącej się z Routerem DHCP przydzieliło samo adres IP,Maske i Brame (192.168.1.101/255.255.255.0/brama 192.168.1.1).

    I dopiero wtedy złączyłem obie karty mostkiem.

    Na kompie Serwer pozostał wcześniej wpisany adres. Po zmostkowaniu jednak karta na SERWER otrzymała z DHCP Routera przydział IP,Maski i bramę Routera (192.168.1.100/255.255.255.0/brama 192.168.1.1)

    Na kompie SERWER korzystam z netu UPC, a na LAPTOPIEi na HEGEMONIE internet z modemu podłączonego do Routera tak jak miało być.

    Każdy komputer widzi wszystkie trzy w grupie roboczej.

    Bardzo dziękuje za pomoc, punkcik odemnie, kłaniam się nisko :please: :piwo:

    Pozdrawiam.

    Zamykam temat.