Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Mega8][Bascom]Problem z falownikami

janusz182 17 Sty 2010 19:27 993 3
  • #1 17 Sty 2010 19:27
    janusz182
    Poziom 14  

    Witam, ostatnio wykonałem dwa konwertery 0-10V na 4 wyjścia cyfrowe i wpiąłem je w szafie do jednego wyjścia analogowego sterownika PLC. Układ sam w sobie działa i sprawuje się dobrze, ale do czasu uruchomienia dwóch falowników po 4 kW umieszczone w tej szafie. Wyjścia mojego urządzenia są typu przekażnikowego i zaczynają mrugać, po osiągnieciu pełnej mocy. Po prostu napiecie podawane na wejście ATMegi nie jest stałe i dlatego te załaczania przypadkowe. Oprócz tych dwóch falowników w szafie sa jeszcze dwa inne falowniko po 2kW i przy ich pracy wszystko jest ok.

    Proszę napiszcie jak pozbyć się tych przypadkowych załączeń jak odfiltrować te zakłócenia?

    0 3
  • #2 17 Sty 2010 20:36
    Kabuto15
    Poziom 18  

    Czy falowniki mają na wejściach filtr sieciowy ? Większość nowszych powinna już takie mieć i nie szarpać strasznie.
    Jeśli z kolei mają te filtry i dalej to zakłóca Twój układ możesz zastosować filtrację zasilania ATmegi. Większe kondensatory na wejściach i wyjściach stabilizatorów. Blisko nóżek zasilających kontroler obowiązkowo kondensatory 100nF. Dodatkowo możesz użyć kondensatorów Low ESR. Jeśli chodzi o pomiar samego napięcia 0-10V to musisz odpowiednio poprowadzić masę analogową (najlepiej jak najkrótsza i łącząca się w jednym punkcie z cyfrową).
    Ogólnie istnieje wśród społeczeństwa większe przekonanie (nie wiem czy poparte jakimiś większymi doświadczeniami), że AVR są słabe jeśli chodzi o zastosowania przemysłowe (dopasowanie elektromagnetyczne).

    0
  • #3 17 Sty 2010 21:34
    janbernat
    Poziom 38  

    Sprawdź czy przewody idące z falowników na silniki są ekranowane- pisza o tym w instrukcji montażu falowników.

    0
  • #4 18 Sty 2010 08:06
    janusz182
    Poziom 14  

    hmm, no rzeczywiście jeden nie jest ekranowany, (sam go skracałem i nie podłączyłem jeszcze ekranu tego przewodu, mam nadzieję że to pomoże, później zajmę się filtracją zasilania.

    Dziękuję bardzo

    0