Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Waga DIBAL C-102 nie taruje się.

21 Sty 2010 13:37 5880 12
  • Poziom 15  
    Dostałem wagę Dibal C-102. Była rozbierana i najwidoczniej usterka nie została zlokalizowana. Po podłączeniu zasilania załącza się ale po tarowaniu wyświetla się komunikat ERREUR ZERO.




    Zauważyłem że na płytce brakuje jednego elementu smd który z dużym prawdopodobieństwem nie został odlutowany a po prostu oderwał się.

    Waga DIBAL C-102 nie taruje się.


    Na płytce są również dwa niewykorzystane wejścia, do czego mogą służyć?


    Waga DIBAL C-102 nie taruje się.



    Waga DIBAL C-102 nie taruje się.


    Waga DIBAL C-102 nie taruje się.

    Bardzo proszę o pomoc w ustaleniu brakującego elementu oraz możliwych powodów tej usterki. Ideałem była by serwisówka, której nigdzie nie mogę znaleźć.
  • Moderator
    Witam.

    :arrow: CD4528BCM
    powyżej masz aplikację układu scalonego takiego jak u Ciebie porównaj z tymi danymi poszukaj ewentualnie tego układu na jakiś schematach i wyciągnij wnioski.
    Element to kondensator raczej taki jak masz na zdjęciu (pomarańczowy z lewej strony) oznaczenie na PCB – C36.
    Analiza aplikacji układu i Twego układu na PCB i po kłopocie...
    Pozdrawiam Brać lutującą. :D
  • Poziom 15  
    Łatwo powiedzieć jak się jest elektronikiem, niestety nie mam wystarczającej wiedzy żeby przeprowadzić taką analizę :(


    1,5h szukam sposobu na odszyfrowanie oznaczeń na kondensatorze, poza budową kondensatora tantalowego nic więcej się nie dowiedziałem. Mierzyłem napięcie w tym miejscu i wynosi około 12V czyli takie jak zasilanie. Możliwe że popełniłem błąd ale podłączałem w tym miejscu inne kondensatory (10uF, 4.7uF, i jakieś ceramiczne)z nadzieją że może zaskoczy.
  • Moderator
    Ja bym to interpretował tak: 2.2uF/35V, a Ty możesz to sprawdzić mierząc pojemność tego kondensatora...
    Poszukać możesz choćby na tym :arrow:
    Link
    slaff napisał:
    Na płytce są również dwa niewykorzystane wejścia, do czego mogą służyć?

    Wspomniane złącza mogą choć nie muszą być służyć do podłączania czujników na ten przykład lub być może są złączami serwisowymi w co raczej już wątpię. :D
  • Poziom 25  
    Witam. W załączniku szybka instrukcja kalibracji takiej wagi. Te wagi to tandeta. Występują w nich wszelkie uszkodzenia i nadają się do wyrzucenia. To moje i nie tylko moje zdanie. Najprawdopodobniej dostała uderzenie na szalkę lub rozprogramowała sie elektronika. Spróbuj zgodnie z opisem skalibrować ją. Sprawdź czy "chodzą" działki wewnętrzne - po wejściu w test obciąż wagę i sprawdź czy zmieniają wartość.
    Jeśli brak działek wewnętrznych to już większy problem: uszkodzenie elektroniki lub tensometru. Nie jesteś elektronikiem a bez dokładnych przyrządów pomiarowych nie sprawdzisz tego. Jeśli jednak działki zmieniają się pod wpływem obciążenia do kalibracji potrzebne są Ci wzorce masy. Więc polecam serwis wagarski, który powinien Ci pomóc. Sam możesz wykończyć wagę do reszty. Ale powodzenia.
  • Poziom 15  
    Mawi2 widzę że masz naprawdę sporą wiedzę na temat wag, i bardzo dziękuję za instrukcję. Poszedłem Twoimi krokami, troszkę różni się to co ja miałem na wyświetlaczu z instrukcją. Na czerwono zaznaczyłem komunikaty których nie miałem.

    Waga DIBAL C-102 nie taruje się.

    Ale udało mi się zmienić język, i wykonać kolejne kroki aż do "regul zero", na tym kroku waga się zatrzymała, nie reagowała na klawisz "*". W sumie to trochę różnią się u mnie klawisze od tych w instrukcji.

    Waga DIBAL C-102 nie taruje się.

    Jeśli chodzi o tensometr myślę, że jest w porządku. Mierzyłem napięcie wychodzące na niego i jest 4.99V, z tego co wywnioskowałem są dwa tensometry, pomiary wykazały 2.435V i drugie wyjście 2.566V. Podczas dość mocnego obciążania szalki wskazania rosną o około 0.003V to tyle ile potrafi zmierzyć mój miernik (Amprobe ACDC-3000) raczej dokładny.

    Jeśli waga przejdzie w fazę kalibracji to z dokładnymi odważnikami nie będzie problemu, tylko dlaczego to stanęło? Niestety problem stanowi jeszcze tasiemka, i nie zawsze klawiatura dobrze łączy.
  • Poziom 13  
    WITAM

    Waga ma zero poza zakresem. Jeżeli nie daje się wpisać podczas kalibracji nowej wartości "zera początkowego" to znaczy że jest to duży błąd zera.
    Na początku trzeba sprawdzić sygnał wyjściowy z tensometru.Opis Twojego pomiaru jest trochę dziwny.Przy belce tensometrycznej z czterema przewodami mamy
    dwa zas. + i - dwa wyj. + i -. w tym wypadku na zas. jest ok. 5V a na przewodach wyj. powinno być ok. kilku mV. Zwiększając obciążenie do obciążenia nominalnego na wyjściu powinniśmy uzyskać do kilkunastu mV. Napięcie wyj. nie może zmieniać polaryzacji.
    Jeżeli wyniki pomiarów odbiegają od opisanych to uszkodzona jest belka tensometryczna
  • Poziom 15  
    Otóż do czego doszedłem.
    Napięcia są mniej więcej takie ja na zdjęciu poniżej.
    W poście powyżej zrobiłem błąd pisząc że pod obciążeniem napięcie rośnie, miałem napisać maleje o te 3-4mV.

    Waga DIBAL C-102 nie taruje się.

    Udało mi się skalibrować wagę w trzech skalach, pomiar w całym zakresie jest wystarczająco dokładny..........

    Waga DIBAL C-102 nie taruje się. Waga DIBAL C-102 nie taruje się. Waga DIBAL C-102 nie taruje się.

    .....tyle, że jest jedno wielkie ale, żeby to osiągnąć waga musiała być obciążona 15kg odważnikiem. Te 15kg to było takie minimum żeby "zaskoczyło zero".
    Bardzo mnie to dziwi ponieważ gdyby waga została mocno obciążona i belka tensometryczna trwale odkształciła się to w tensometrze, który naklejony jest na górze odległości pomiędzy "ścieżkami" zwiększyły by się, przez co napięcie spadło sugerując układowi pomiarowemu obciążenie. A tu jest odwrotnie, czy mogło się zdarzyć, że ktoś w drugą stronę odkształcił belkę tensometryczną?
    Napięcie zmienia się w tak małym stopniu, że się zastanawiam czy to może być wina elektroniki.
    Co ciekawe brakujący kondensator nic nie wnosi, nie ma różnicy czy jest czy go nie ma, możliwe że układ z którym jest połączony przelicza wagę na cenę, u mnie nie ma prawdopodobnie wprowadzonych cen produktów.

    Dodano po 22 [minuty]:

    Przeliczanie jest w porządku, nie potrafię tylko zaprogramować klawiszy pod daną cenę.
  • Poziom 25  
    Witam. Czyli na 90 % uszkodzony tensometr. Tak może wystąpić takie uszkodzenie tensometru jakie opisujesz. Najczęściej taki efekt powstawał w tensometrach aluminiowych /a taki masz/ podczas nagłego uderzenia /czytaj coś spadło na szalkę może to być nawet 1 kg ale z wysokości 1 m to już sporo - wystarczy przemnożyć przez przyspieszeni/. I efektem takieg krótkotrwałego uderzenia które nie uszkodzi w sposób mechaniczny tensometru najczęściej były właśnie takie efekty. Jeśi masz dostęp do jakiegokolwiek innego przetwornika tensometrycznego możesz go podłączyć i sprawdzić działanie. Ważne jest tylko właściwe podłaczenie przewodów. Jeśli tensometr będzie od wagi np: 3 kg to zamiast 15 kg stawiasz na niego 3 kg. Co do programowania klawiszy funkcyjnych. Wieczorem poszukam Ci instrukcji użytkownika. Pozdrawiam.
  • Poziom 15  
    Podłączyłem belkę od wagi 6kg i jest wszystko w porządku.
    Obawiam się że waga pójdzie na złom bo ceny tensometrów przekraczają jej wartość :(
    Nie znalazłem konkretnie do tej wagi, nawet nie wiem gdzie tego szukać. Nie rozumiem dlaczego kawałek aluminium z otworem w środku i naklejonym tensometrem za 2euro kosztuje tyle kasy.
  • Poziom 12  
    Duży wybór tensometrów HBM ma M. Zajączkowski w Poznaniu. Nie są to tanie czujniki ale jakościowo bardzo dobre. Przedzwoń może Ci coś doradzi lub spróbuj jakiś tanich chińskich. Chińszczyznę chyba ma w ofercie firma EWP.
  • Poziom 25  
    A zrób tak: Weź potencjometr ok 47k. Jedną nogę podłacz do + zasilania a suwak do + lub - input sygnału. Potencjometr ustaw na max. Wejdź zgodnie z menu serwisowym w odczyt działek i tak jak ją obciążałeś aby coć zobaczyć - obciąż. Pojawią się działki, kręć potencjometrem tak aby zwiększyć ich wskazanie (musisz sprawdzić czy podłaczyć do + czy - input). Następnie odciążaj szalkę i dokręcaj potencjometrem aż do pustej szalki. Następnie dobierz rezystor o odpowiedniej wartości /stabilny temperaturowo/ i sprawdź czy wskazania są stabilne. Jeśłi tak - skalibruj wagę i sprawdź jej działanie w czasie. - Zaznaczam nie zawsze pomaga ale warto spróbować. Pozdrawiam.
  • Poziom 15  
    mawi2 napisał:
    A zrób tak: Weź potencjometr ok 47k. Jedną nogę podłacz do + zasilania a suwak do + lub - input sygnału. Potencjometr ustaw na max. Wejdź zgodnie z menu serwisowym w odczyt działek i tak jak ją obciążałeś aby coć zobaczyć - obciąż. Pojawią się działki, kręć potencjometrem tak aby zwiększyć ich wskazanie (musisz sprawdzić czy podłaczyć do + czy - input). Następnie odciążaj szalkę i dokręcaj potencjometrem aż do pustej szalki. Następnie dobierz rezystor o odpowiedniej wartości /stabilny temperaturowo/ i sprawdź czy wskazania są stabilne. Jeśli tak - skalibruj wagę i sprawdź jej działanie w czasie. - Zaznaczam nie zawsze pomaga ale warto spróbować. Pozdrawiam.


    Dzięki za pomoc ale poszedłem nieco po bandzie, wiedziałem że jeśli coś jest odkształcone to można to poprawić siłą. Najpierw naginałem ją ile sił aż wynik poprawił się o 7kg, niestety dalej nie szło, wziąłem młotek za pierwszym strzałem nieco się poprawiło za drugim jeden odczyt przestał działać :/ wyginając w drugą stronę pojawiły się cyfry ale nie 3000 działek ale w milionach, i dość mocno falował wynik.
    Tak już był na straty to ściąłem ostrożnie silikon z tensometru i widzę że jeden kabel oderwał się. Pewnie lekko dotykał i stąd te wyniki.

    Mogłem odrazu zadziałać z potencjometrem lub statycznie wyginać belkę a ja zaraz z młotkiem ;D