Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Jak uzależnić obroty FAN1 od temp grafiki?

a_d_a_m 30 Sty 2010 14:06 4529 25
  • #1 30 Sty 2010 14:06
    a_d_a_m
    Poziom 12  

    Witam.
    Mam taki problem:
    uszkodził się oryginalny wentylator od grafiki (nie miał pomiaru obrotów), wymieniłem go na lepszy z możliwością pomiaru obrotów. Podpiąłem do wyjścia FAN1 na płycie głównej. Jak uzależnić prędkość tego wentylatorka od temperatury karty??
    Mogę co najwyżej za każdym włączeniem kompa ustawić PWM dla FAN1 ale jak zrobić automatycznąregulacje od czujnika karty albo chociaż jak ustawić na stale obroty FAN1 na 70%. Bios nie ma takiej możliwości.
    Grafika GF8600GT
    Plyta ASUS P5B standard

    Dziękuję za podpowiedzi.
    Pozdrawiam.

    0 25
  • #3 30 Sty 2010 14:24
    a_d_a_m
    Poziom 12  

    używam tego programu wlaśnie po to aby ustawić na sztywno 70% dla FAN1. Tylko za każdym włączeniem kompa muszę to ustawiać a po drugie to nie można tam uzależnić PWM od temp karty.
    Jak uzależnić obroty FAN1 od temp grafiki?
    A propos co to jest to AUX ?? jest za wysokie 125C !!

    0
  • #4 31 Sty 2010 10:50
    leven
    Poziom 37  

    Fan 1 na plycie glownej nie bedzie dynamiczny dla grafiki bo bios plyty glownej nie ma odczytu czujnika gpu, wiec nie moze reagowac na zmiany temperatury.
    Jezeli bios karty ma dynamiczna regulacje obrotow wentylatorka, to wygodnym rozwiazaniem bedzie wykorzystac gniazdko fan na pcb karty.

    Dla sprawdzenia tej mozliwosci, edytuj bios karty nibitorem i w zakladce "temperatures" -> " fanspeed IC" sprawdz czy istnieje mozliwosc wpisania odpowiednich wartosci.

    Tu przyklad biosu z aktywna regulacja obrotow wentylatorka:

    Jak uzależnić obroty FAN1 od temp grafiki?

    http://www.programosy.pl/program,nvidia-bios-editor.html

    Jak chcesz edytowac bios karty, to musisz ten bios sciagnac z karty i wgrac go do pliku.
    To proste i mozna tego dokonac za pomoca programiku gpu-z.
    Sciagnij, uruchom gpu-z. Pod logo nvidi widnieje malenki znaczek. Kliknij go i zgraj bios do pliku.
    W nibitorze otworz bios i pokaz zakladke "fanspeed IC" na forum, to okresle czy jest aktywna opcja dynamicznej regulacji pwm.

    http://www.programosy.pl/program,gpu-z.html

    EDIT:

    Co do temparatur speed fana, to nie bierz tego do serca :D

    Sprawdz jeszcze odczyty w programiku hwmonitor i pokaz na forum.
    Osobiscie z niego korzystam i pokazuje wiarygodne odczyty.

    http://www.programosy.pl/program,hwmonitor.html

    Pokaz tabelke po obciazeniu komputera jakims testem czy grą.
    Bedzie widac minimalna temperature, terazniejsza i maxymalna.

    0
  • #5 31 Sty 2010 11:24
    a_d_a_m
    Poziom 12  

    Dziękuję za odpowiedź :)
    Zrobiłem wg instrukcji, poniżej zamieszczam wynik.

    P.S Na karcie grafiki mam wyprowadzenie do wentylatorka dwu przewodowe, więc jak się domyślam bez możliwości śledzenia obrotów.

    Jak uzależnić obroty FAN1 od temp grafiki?


    a to temperaturki:

    Jak uzależnić obroty FAN1 od temp grafiki?

    0
  • #6 31 Sty 2010 14:30
    leven
    Poziom 37  

    Otworz obudowe i sprawdz radiatorki w sekcji zasilania cpu oraz radiator mostka polnocnego. Uwazaj na palce, bo jak faktycznie czujnik mowi prawde, to jeden z tych radiatorow bedzie okropnie goracy.
    AUX, to na 90% mostek polnocny.

    Bios karty graficznej nie ma kontroli dynamicznej wentylatorka. Pozostaje evga precision (nie wiem czy bedzie regulowac ten bios) lub regulator obrotow.

    http://www.programosy.pl/program,evga-precision.html

    Link

    0
  • #7 31 Sty 2010 17:24
    a_d_a_m
    Poziom 12  

    Nie wiem dokładnie który to mostek, ale wszystko co ma radiator sprawdzałem i tylko w jednym przypadku jest dość ciepły ale nie parzy.

    Czy da się ustawić gdzieś obroty FAN1 płyty głównej na sztywno np.: 80% ??

    bo ten program nie da rady:
    Jak uzależnić obroty FAN1 od temp grafiki?

    0
  • #8 31 Sty 2010 17:44
    leven
    Poziom 37  

    Mostek polnocny, to chip z radiatorkiem najblizej procesora. On wedlog hwmonitora powinien topic skore na palcach :D
    Prawdopodobnie pasta wyschla i nie ma dobrego odprowadzania ciepla z rdzenia na radiator lub czujnik przeklamuje. Rozsadnie byloby sciagnac chlodzenie z NB i zmienic paste.
    Zalecam ostroznosc przy zdejmowaniu/zakladaniu chlodzonka. Mozna niechcaco ukruszyc rdzen chipu i bedzie po plycie.

    Temperatura 120 st c jest wlasciwie temperatura krytyczna i jesli jest ona prawdziwa, to nie wroze tej plycie dluzszego dzialania.

    Na fotce zaznaczylem radiatorek NB.

    Jak uzależnić obroty FAN1 od temp grafiki?

    Trzeba go sciagnac (zdjac zaczepy) i delikatnie odkleic radiatorek od rdzenia. Nie przechylaj radiatorka, bo wlasnie wtedy mozna ukruszyc chip. Jak zdejmowanie pojdzie opornie, to podgrzej radiatorek suszarka do bardzo goraca i wtedy delikatnie okrecaj go w obydwie strony az posci. Musisz sie kierowac wyczuciem. Nic na sile.
    Paste mozna zastosowac zwykla ceramiczna lub cos lepszego np. AS5 czy zalman stg-1 lub 2.

    Co do fan na plycie glownej, to musisz sam sprawdzic w biosie czy da sie przydzielic na sztywno ilosc obrotow coolerka.
    W asusie byly 3 warianty:
    1 silent
    2 medium
    3 performance.

    Tutaj tryb srodkowy bylby mile widziany.

    0
  • #9 31 Sty 2010 18:45
    a_d_a_m
    Poziom 12  

    Namierzyłem ten mostek i on jest najbardziej gorący, ale nie parzy, można trzymać palcami dowolnie długo ale im bliżej dna tym goręcej.
    Płyta jest na gwarancji, czy podlega to gwarancji - przegrzewanie się mostka?? w chwili włączenia kompa jest około 118C a później dochodzi do 125C. Biosem zajmę się pewnie później, główny cooler ma zdaje się możliwość sterowania ale te pozostałe to chyba nie, najwyżej zaktualizuje BIOS.

    Aha, jeszcze coś. Czasem mi się włącza "martwy piksel" ale to chyba nie wina monitora. Raz jest raz go nie ma, czy to wina karty grafiki czy można wiązać z tym mostkiem ??

    Dziękuję za odpowiedzi

    0
  • #10 31 Sty 2010 21:40
    leven
    Poziom 37  

    Wyskakujacy pixel, to wina matrycy. Mostek polnocny nie ma nic wspolnego z wyswietlaniem grafiki.
    Caly czas krazymy wokol problemu i widze, ze go nie rozwiazemy.
    Masz dwa rozsadne wyjscia.

    1 oddac plyte na gwarancje
    2 sciagnac chlodzenie z NB i przesmarowac chip swierza pasta

    Niestety mechaniczna ingerencja pozbawi plyte gwarancji.

    Mozesz oczywiscie zlekcjowazyc wysoka temperature NB i czekac az plyta wyciagnie nogi.
    Sprobowalbym jeszcze zamontowac coolerek 40 mm na radiator NB.
    Jak temperatura znacznie nie spadnie, to trzeba podjac kroki jak w punktach 1 i 2.

    0
  • #11 03 Lut 2010 20:57
    a_d_a_m
    Poziom 12  

    Aktualizacja BIOSu niczego co mógłbym zauważyć, nie poprawiła.
    Temp AUX ciągle na pozimie 125C.
    Czerwony piksel mi świeci lub mruga na ekranie.

    Monitor na gwarancji, czy martwy piksel pozwala na wymianę gwarancyjną matrycy?
    Płyta ASUS na gwarancji, gość w serwisie mówi, że jak się grzeje mostek to mam prawo reklamować całą płytę, a może by jej pomóc się wykończyć....?
    Może i monitorowi dopomóc....?

    Co radzicie? Jakie macie zdanie?

    0
  • #13 04 Lut 2010 18:53
    a_d_a_m
    Poziom 12  

    A jak znaleźć to miejsce AUX na płycie aby podłączyć termistor??

    0
  • #14 04 Lut 2010 20:32
    leven
    Poziom 37  

    U mnie aux, to jest NB (mostek polnocny).
    Jezeli ten czujnik jest faktycznie nie podlaczony, to zostaw to tak jak jest.

    Sciagnij i uruchom everest 5.30.1900 oraz uruchom hwmonitor.

    W everescie wejdz w zakladke komputer -> czujnik i porownaj temperature mostka polnocnego z odczytem 125 st C w hwmonitorze.

    U mnie tak to wyglada:

    Jak uzależnić obroty FAN1 od temp grafiki?

    0
  • #15 04 Lut 2010 21:22
    a_d_a_m
    Poziom 12  

    a u mnie nie ma tej temp w everescie 5.30.1900

    Jak uzależnić obroty FAN1 od temp grafiki?

    0
  • #16 04 Lut 2010 23:17
    leven
    Poziom 37  

    Everest nie pokazuje, bo jak pisal kolega wczesniej, czujnik moze "wisiec".
    Jak zaden radiatorek nie parzy, to zostawilbym to w spokoju.

    0
  • #17 06 Lut 2010 08:20
    a_d_a_m
    Poziom 12  

    no nie parzy ale pisaliście ze mogła wyschnąć pasta i nie ma styku termicznego z radiatorem a wtedy układ może mieć 127C a radiator tylko ciepły...

    A co do martwego pixla, to czy gwarancja go obejmuje??

    0
  • #18 06 Lut 2010 08:38
    leven
    Poziom 37  

    Zeby miec swiety spokoj, sciagnij chlodzenie z NB, SB i mosfetow. Zmien paste i zaloz chlodzenie z powrotem.
    Zareklamuj monitor.

    0
  • #19 06 Lut 2010 08:44
    a_d_a_m
    Poziom 12  

    w serwisie powiedzieli abym sam nie zdejmował radiatorów bo mogę uszkodzić układ, podobno te układy są delikatne i kruche...

    Chciałbym zlokalizować to latające wejście czujnika i zobaczyć czy faktycznie to jest to, jak to zrobić????????

    a to a propos monitorów:
    Jak uzależnić obroty FAN1 od temp grafiki?

    0
  • #20 06 Lut 2010 11:36
    leven
    Poziom 37  

    To oddaj plyte do serwisu i niech ustala co jest grane jak nie chcesz sie samodzielnie podjac sprawdzenia chlodzen.

    0
  • #21 06 Lut 2010 18:25
    a_d_a_m
    Poziom 12  

    z tym sobie pewnie jakoś poradzę, tzn oddam na gwarancji. Jednak problem obrotów pozostaje nierozwiązany.

    Mam taki pomysł:
    Istnieje możliwość pomiaru temp na karcie grafiki, istnieje możliwość sterowania PWM-em wyjścia FAN na płycie głównej.

    Trzeba napisać mały aplikację, która będzie ładowana przy uruchomieniu kompa, i w tle będzie mierzyła temp oraz proporcjonalnie sterowała obrotami FAN.
    Pomysł dziecinnie prosty, kto wie jak to zrobić w Builderze C++ lub innych środowiskach??

    0
  • #22 12 Lut 2010 14:07
    LED5W
    Poziom 32  

    a_d_a_m napisał:
    używam tego programu wlaśnie po to aby ustawić na sztywno 70% dla FAN1. Tylko za każdym włączeniem kompa muszę to ustawiać a po drugie to nie można tam uzależnić PWM od temp karty.

    Jeżeli SpeedFan wyświetla prawidłowo temperaturę i możesz nim sterować obrotami, to automatyczna regulacja będzie działać.
    Sądząc po screenie, nie ustawiłeś nawet docelowych temperatur.
    Wejdź w konfigurację, ustaw odpowiednie temperatury i zaznacz, który wentylator co chłodzi. Przejdź na zakładkę "Prędkości" i zaznacz "Automatycznie zmieniane" (wcześniej wybierając odpowiedni wentylator). Ewentualnie możesz jeszcze ustawić min. i maks. obroty. OK i zaznacz automat w gł. oknie.

    0
  • #23 13 Lut 2010 19:11
    a_d_a_m
    Poziom 12  

    SpeedFan nie chce regulować FANa, tzn zawsze mi zwiększa obroty na maxa mimo i tak ustawionego górnego progu temp dożo powyżej rzeczywistej. Tak jakby się obawiał że sobie nie poradzi później ("dmuchał na zimne), lub miał ogromną histerezę.

    Tak czy siak potrzebna aplikacja bardziej elastyczna ze szczegółowymi programowanymi parametrami.

    0
  • #24 13 Lut 2010 19:54
    LED5W
    Poziom 32  

    a_d_a_m napisał:
    SpeedFan nie chce regulować FANa, tzn zawsze mi zwiększa obroty na maxa mimo i tak ustawionego górnego progu temp dożo powyżej rzeczywistej.

    Pisząc "górny próg" masz na myśli pole "Przeznaczenie", czy "Ostrzeżenie"? Bo powinieneś zwiększyć to pierwsze.

    Możesz też zmienić wartość delty (zakładka "Opcje") na mniejszą.

    a_d_a_m napisał:
    Tak czy siak potrzebna aplikacja bardziej elastyczna ze szczegółowymi programowanymi parametrami.

    Raczej będzie ciężko. Poza tym i tak wiatrak obniży prędkość po uruchomieniu tego programu. Już chyba lepiej zrobić sprzętowy regulator...

    0
  • #25 15 Lut 2010 10:35
    a_d_a_m
    Poziom 12  

    Aby nie zostawić postu bez odpowiedzi - robię testy z różnymi nastawami, jak skończę to zamieszczę tutaj wyniki .

    0
  • #26 25 Mar 2010 09:32
    a_d_a_m
    Poziom 12  

    aby powoli kończyć temat napiszę jak "tym czasem" rozwiązałem problemy:
    -wgrałem najnowszy BIOS i ustawiłem w nim automatyczną regulację obrotów FAN1 w zależności od temp grafiki;
    -wgrałem oryginalne oprogramowanie ASUSProbe, które nie pokazuje temperatury AUX=127C, wcale nie pokazuje tego AUX;
    -martwy sub-piksel usunąłem poprzez "spoliczkowanie" matrycy;

    Niestety SPEEDFAN wariował, szczególnie po wyjsciu z uspienia więc nawet nie będę pisał o nim, osobiście odradzam tego typu programy do nadzorowania temp prockow, nie ma to jak BIOS

    0