Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Linux Knoppix, jak poprawnie zrobić konfiguracją postfixa?

antraxcdt 02 Lut 2010 20:13 738 0
  • #1
    antraxcdt
    Poziom 9  
    Witam mam problem z ustawieniem postfixa na linuxie dystrybucji Knoppix ( na maszynie wirtualnej ). Nie jestem pewien czy dobry dział ale mam nadzieję że tak.

    Opiszę krok po kroku co robię, i jakie ustawienia wpisuję i mógł by ktoś powiedzieć mi w którym miejscu robie błąd ?

    Mam za zadanie przesłać maila od Tomek1@hurtownia do Tomek2@hurtownia i z powrotem.

    No to zaczynamy:

    1. Włączam linuxa i okno konsoli. ( automatycznie loguje mnie jako root-a )
    2. apt-get update
    3. apt-get install postfix
    4. cd /etc/postfix
    5. cp main.cf main.cf.old ( jakbym coś spartolił )
    6. mc
    7. przechodzę do /etc/postfix/main.cf
    8. i teraz wprowadzam zmiany w pliku takie:
    ( to co było wcześniej zostawiam tylko zmieniam to )
    Cytat:

    mydomain = hurtownia
    myhostname = hurtownia.hurtownia
    myorgin = $mydomain
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    mydestination = $myhostname, localhost.$mydomain, localhost, hurtownia
    relay_domains = $mydestination, interia.pl, wp.pl
    relayhost =
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128, 192.168.1.0/28
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    mailbox_size_limit = 6400000
    message_size_limit = 6400000
    mail_spool_directory = /var/spool/mail (folder jest utworzony )


    9. wychodzę z powrotem do konsoli
    10. /etc/init.d/postfix reload
    11. adduser Tomek1
    12. adduser Tomek2
    13. newaliases
    14. no i piszę maila:
    Cytat:

    telnet finnix 25
    Mail from: Tomek1@hurtownia
    rcpt to: Tomek2@hurtownia
    data
    Subject: asdasdasdasd
    .[ENTER]
    QUIT


    15. su Tomek2
    16. mail

    no i teraz problem bo pisze że nie ma żadnego maila dla mnie ;/ może ktoś powiedzieć gdzie jest błąd ( napisałem tak łopatologicznie a nie tylko konfig bo może gdzieś indziej robię błąd ). Mam nadzieję że nie będzie odpowiedzi w stylu "sprawdź w google" albo "a co google boli"...

    Pozdrawiam i dziękuję z góry za pomoc.