Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

dziwne zachowanie wyłącznika zasilania Asus P5N-D

adamtko 13 Lut 2010 21:21 1893 8
  • #1 13 Lut 2010 21:21
    adamtko
    Poziom 10  

    Mam taką drobną uciązliwość związaną z przyciskiem zasilania na obudowie. Jak by to opisać... działa "odwrotnie". Gdy komputer jest WYŁĄCZONY, to muszę zasilanie przytrzymać kilka sekund, coby się odpalił. Natomiast gdy komputer CHODZI, to dotknięcie przycisku odcina prąd natychmiast. A powinno być na odwrót - włącznie natychmiast, a wyłączenie po kilku sekundach. Mi by to nawet nie przeszkadzało, gdyby nie to, ze mam małe dzieciaki, które są ciekawskie i wszędzie paluchy wtykają i taki guzik budzi zainteresowanie.

    Zajrzałem do BIOSu i wydaje mnie się, ze nie ma tam co więcej ustawiać.
    Zetknął się ktoś z takim zjawiskiem?
    Nie wiem, czy to awaria jakaś, czy jakieś nieumiejętne ustawienie/podłączenie czegoś

    Płyta główna to Asus P5N-D, pozostałe składniki chyba nieistotne, wszystko jest nowe. Wprawdzie pomiędzy płytą a wyłącznikiem zasilania jest wpięty panel VFD Zalmana, ale nie bardzo sobie wyobrażam, jaki sygnał mógłby wysyłać na pin PWR w płycie, żeby zasilanie padało jak ręką odjął.

    0 8
  • #2 13 Lut 2010 22:30
    sebas8503
    Poziom 13  

    Wejdź w BIOS: power\APM configuration\PWR Button < 4 secs
    i zmień [Instant-Off] chyba na [Suspend], nie pamiętam dokładnie.

    0
  • #3 14 Lut 2010 08:25
    adamtko
    Poziom 10  

    To zrobiłem zanim posta napisałem. Jest na [suspend] ustawione, a komputer dalej się zachowuje tak samo.

    0
  • #4 14 Lut 2010 08:56
    sebas8503
    Poziom 13  

    Gdzieś czytałem, że zdarza się taki problem z Phoenix Award BIOS. Może pomoże aktualizacja biosu.

    A jaka reakcja, gdy przycisk power podłączysz bezpośrednio z płytą (power sw)?

    0
  • #5 14 Lut 2010 09:15
    adamtko
    Poziom 10  

    BIOS aktualizowałem jakieś 2 tygodnie temu, jak zakupiłem sprzęt. Później sprawdzę, jaką mam wersję.

    Co do podłączenia guzika zasilania wprost do płyty - jest to dość skomplikowana operacja. Mam obudowę desktop, czy jak to się teraz mówi HDPC. W narożniku gdzie są konektory idzie masa kabli i jest ograniczony dostęp. Będę musiał wypiąć grafikę, chłodzenie, 2 dyski... Oczywiście, jak będę wiedział, że ma to sens, to to zrobię.

    Na razie mam taki pomysł, żeby spróbować sięgnąć tam ręką, odpiąć wtyczkę od przycisku, a w to miejsce wpiąć jakąś wtyczkę z kawałkiem kabelka i zwierać na krótko końcówki w celach testowych.

    0
  • #6 14 Lut 2010 09:53
    jaculat
    Poziom 13  

    opcja suspend (zawieszenie) nie wyłącza ci komputera tylko przechodzi w stan zawieszenia. jeżeli chodzi o testowanie to możesz wyciągnąć kabelek do pwr i zworkę zewrzeć śrubokrętem

    0
  • #7 14 Lut 2010 13:35
    adamtko
    Poziom 10  

    Nie wiem, czym by się różniło zawieszenie komputera od wyłączenia, bo wygląda to u mnie identycznie. No i przede wszystkim, istotne jest to, że reakcja następuje NATYCHMIAST przy wyłączaniu, a wg mnie powinna być chwila zwłoki, płyta powinna reagować na zwarcie przycisku po chwili jakiejś, tak jak się dzieje przy WŁĄCZANIU - to jest około 1-2 sekundy.

    Z ciekawości sprawdziłem działanie powera na laptopie i jest tak jak piszesz - wciśnięcie zasilania "zawiesza" system, a ponowne wciśnięcie po kilkudziesięciu sekundach - wznawia system. I jest to zgodne z ustawieniami w Windowsach w opcjach zasilania. No i ani w jedną ani w drugą stronę reakcja nie następujenatychmiast. Trzeba moment "potrzymać" guzik. Natomiast na omawianym sprzęcie, dotknięcie przycisku NATYCHMIAST wyłącza sprzęt całkowicie.

    Dodano po 43 [minuty]:

    No to teraz jestem kropce kompletnie. Odpiąłem kabelek przycisku zasilania i wpiąłem byle wtyczkę z kawałkiem kabla i... wszystko działa jak należy. Krótkie zwarcie włącza system, ale nie wyłącza. Żeby wyłączyć muszę zewrzeć na dłużej.

    Więc problem tkwi albo w przycisku zasilania, albo w panelu VFD który jest wpięty pomiędzy przycisk a złącze PWR. Chociaż dalej sobie nie mogę wyobrazić, jaki sygnał może wysyłać przycisk/panel do PWR, żeby wysadzać płytę natychmiast.

    Czeka mnie zatem prucie połowy sprzętu i bez większej nadziei na sukces, bo nie wiem czego szukać. Ale będę próbował eliminować jakoś sukcesywnie urządzenia

    Dodano po 2 [godziny] 25 [minuty]:

    No to kolejna aktualizacja. Wyprułem zatoki od dysków, od DVD i mając w miarę przyzwoity dostęp do kabelków zacząłem eksperymentować. Sama wtyczka z kawałkiem kabelka podpięta do pinów PWR na płycie pozwoliła stwierdzić, że płyta zachowanie płyty jest OK, jak już wcześniej pisałem.

    Następnie w oparciu o manuale obudowy i płyty eksperymentowałem z połączeniami. Schematy w obu manualach są dość... poglądowe. Kolory kabli z kosmosu, brak opisów poszczególnych pinów na połączeniach. Przy okazji "odwróciłem" wtyczkę LED_SW i dioda na obudowie zaczęła świecić. Ale zachowanie przycisku się nie zmieniło.

    W następnej kolejności wykręciłem wyłącznik. Ale nie ma w nim nic szczególnego. Ścieżki z 2 pinów idą prosto do takiego mikropstryczka, nie wiem jak się fachowo nazywa, z 2 kolejnych na LEDkę. Podłączyłem całość wprost do płyty z całkowitym pominięciem panela. Działa poprawnie. A podpięte pod panel - działa odwrotnie.

    Nie rozumiem tego. Jestem za głupi, za stary, albo obie rzeczy. Skoro działanie łączki PWR na płycie sprowadza się do wykrywania zwarcia (spadku napięcia?) i odpowiedniej reakcji, to jaki sygnał może przesyłać panel? Testowo obróciłem też wtyczkę PWR na płycie ale to też nic nie zmieniło. Więc jestem głupi kompletnie.

    Mam teraz następujące opcje:
    1) Ktoś mądrzejszy mi podpowie gdzie szukać rozwiązania (w razie potrzeby podeślę "schematy" połączeń i modele uwikłanych w zabawę urządzeń

    2) Zmontować całość, ale z pominięciem panelu. Nie wiem jeszcze, czy nie stracę jakiś istotnych funkcjonalności, bo poza wyświetlaniem panel jest też odbiornikiem sygnałów z pilota i pozwala na sterowanie komputerem, włącznie w wyłączeniem czy uśpieniem a nawet budzeniem. Te ostatnie funkcje zresztą działają prawidłowo nawet teraz. Byle nie było gorzej.

    3) Napisać do producenta w Korei czy gdzie tam ten Zalman się mieści bez większej nadziei na odpowiedź sensowną

    4) Nauczyć dzieci, że TEGO guzika nie wolno dotykać, co jest chyba na dziś beznadziejne.

    Pozdrawiam, dziękuję za podpowiedzi i czekam na jakieś ew. dalsze wskazówki, zwłaszcza w kwestii "co może wyłączyć płytę z marszu". Może jakieś za duże napięcie omyłkowo puszczone, może jakaś odwrotna polaryzacja... do licha nie wiem.

    0
  • #8 14 Lut 2010 21:15
    jaculat
    Poziom 13  

    ja to widzę tak : panel jest uszkodzony i zamiast zwarcia daje np jakieś napięcie co powoduje takie zachowanie

    po 1 czy wyłączanie z pilota działa dobrze?
    po 2 jak jest panel podłączony do płyty np. (usb) + sterowniki czy tylko do złącz sterujących jak zasilanie, dioda zasilania, dioda dysków,reset...
    po 3 spróbuj czy panel będzie działać z obejściem (bez połączenia przycisku pwr)

    0
  • #9 14 Lut 2010 22:05
    adamtko
    Poziom 10  

    jaculat napisał:
    ja to widzę tak : panel jest uszkodzony i zamiast zwarcia daje np jakieś napięcie co powoduje takie zachowanie

    po 1 czy wyłączanie z pilota działa dobrze?
    po 2 jak jest panel podłączony do płyty np. (usb) + sterowniki czy tylko do złącz sterujących jak zasilanie, dioda zasilania, dioda dysków,reset...
    po 3 spróbuj czy panel będzie działać z obejściem (bez połączenia przycisku pwr)


    Ad 2) Panel jest podłączony przez USB + sterowniki i dosyć rozbudowane oprogramowanie, dodatkowo pobiera zasilanie z moleksa (ale działa też bez tego zasilania), dodatkowo ma wzmiankowane połączenie z przyciskiem zasilania i płytą, oraz po dwa gniazdka na termistory i wentylatory.

    Ad 3) Nie bardzo jest jak sprawdzić - podłączyć pewnie by się dało, ale skąd wtedy sygnał do włączenia/wyłączenia systemu? Może z pilota?

    Ad 1) W tej chwili sprawa wydaje się załatwiona. Pominąłem panel w połączeniu płyty i wyłącznika po prostu. Przycisk zasilania działa w 100% prawidłowo - start systemu następuje natychmiast po dotknięciu przycisku, a wyłączenie po kilkusekundowym "przytrzymaniu". Poprawnie działa również detekcja dotknięcia przycisku zasilania w Windowsach - mogę przypisać jakąś akcję. Działają również wszystkie funkcje pilota, w tym wyłączanie/usypianie/restart systemu. Z tym, że odbywa się to... hmmm... programowo, czyli po uruchomieniu oprogramowania, a nie bezpośrednio przez PWR na płycie. I dobrze.

    I Twoja konkluzja z początku postu jest zbieżna z moją - panel jest uszkodzony i wysyła na piny PWR jakieś dziwne napięcie i to co następowało po tym to nie jest wyłączenie, tylko raczej gwałtowna padaka systemu. Ew. możliwe jest, że któreś kabelki są spięte "odwrotnie" i daje to taki efekt. W obecnej sytuacji dalsza analiza nie ma większego sensu chyba - funkcjonalność panelu/zasilania/pilota jest bez zarzutu, a diagnoza i ew. naprawa "dla sportu" nie jest warta świeczki.

    Najważniejsze, że działa, nic nie sfajczylem i udało mi się wszystkie bebechy wypruć i włożyć z powrotem. Dziękuję za pomoc. Jeśli nie pojawią się dodatkowe okoliczności to z mojej strony temat zamknięty.

    0