Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Układ oparty na fotorezystorze nie działa prawidłowo.

Domanoid 20 Feb 2010 00:54 1987 4
  • #1
    Domanoid
    Level 10  
    Chciałem zrobić układ przełączający stan przekaźnika na podstawie natężenia światła, układ wykonałem według schematu i opisu podanego przez _PREDATOR_ tutaj: https://www.elektroda.pl/rtvforum/topic311027.html

    Tak powinno być:
    Układ oparty na fotorezystorze nie działa prawidłowo.
    Jednak nie znalazłem tych tranzystorów a kupno przez internet dwóch tranzystorków mija się z celem (nie mam sklepu elektronicznego w promieniu 100km).
    Zamiast BC108 i BC178 zastosowałem BC557C i BC546C - czy takie rozwiązanie jest możliwe w przypadku tego układu? Przekaźnik ma na cewce napis 400Ohm.
    Tak wygląda mój układ teraz:
    Układ oparty na fotorezystorze nie działa prawidłowo.
    Jeśli trzeba zmienić rezystory proszę o pomoc, sam kombinowałem ale jestem w tym za cienki bolek.

    I ostatnie pytanie: czy to są fotorezystory zapakowane na płytkę?
    Układ oparty na fotorezystorze nie działa prawidłowo.
    Wyciągnąłem to ze starego radia samochodowego, sprawdzało czy płyta jest w środku, pod płytą znajdowały się dwie diody a nad właśnie to.
  • #2
    pierzchan
    Level 16  
    Wygląda na fotodiodę lub fototranzystor. Najlepiej podłącz omomierz i sprawdź jak się zachowuje przy różnym natężeniu światła.
  • #3
    Paweł Es.
    VIP Meritorious for electroda.pl
    Na schemacie pomyliłeś tranzystory miejscami:

    BC557 to tranzystor PNP (powinien być w obwodzie z przekaźnikiem)
    BC546 to tranzystor NPN (powinien być z lewej strony schematu)

    czy w układzie też pomyliłeś czy tylko na schemacie ?
  • #4
    Domanoid
    Level 10  
    To jest fototranzystor jednak, rozebrałem jeszcze kilka zepsutych radyjek samochodowych i we wszystkich są zastosowane fototranzystory.
    Paweł: Pomyliłem się tylko na schemacie. Nawet nie zauważyłem tej pomyłki. Dzięki za uwagę.

    W takim razie próbuję zrobić coś z części które posiadam. Czy taki układ ma rację bytu a do tego będzie dobrze działał?
    Układ oparty na fotorezystorze nie działa prawidłowo.
    W SV na pinie 1 jest +12V (instalacja samochodowa), a na 4 masa.

    Gdzieś musiałbym jeszcze dodać potencjometr aby mieć jakąś regulację. Wiem że w sytuacji progowej układ zachowuje się bardzo niestabilnie. Jednak nie potrafię tego wyeliminować. Proszę o jakieś porady.
  • Helpful post
    #5
    Paweł Es.
    VIP Meritorious for electroda.pl
    Przekaźnik się włącza w kolektorze, tranzystor musi pracować dwustanowo zatkany lub nasycony, bo się będzie grzał.

    Równolegle do cewki przekaźnika daj diodę np. 1N4001 tylko odwrotnie niż zasilanie, bo przy wyłączaniu zasilania przekaźnika występuje przepięcie i może zamordować tranzystor.

    Potencjometr daj w obwodzie fototranzystora (im większa rezystancja tym czulszy układ).

    Jak te fototranzystory są z koderów obrotowych w tych radiach, to one chyba głównie na podczerwień chodzą i przy świetle widzialnym mogą mieć mniejszą czułość (w podobnej obudowie są też diody LED na podczerwień).