Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Samsung HD161HJ - BIOS nie widzi, elektronika OK

21 Lut 2010 15:11 3995 18
  • Poziom 14  
    Dysk przestało wykrywać w BIOSie, komp wisi z pół minuty jeszcze przed momentem komunikatów z wykrywaniem dysków, później wykrywa tylko napęd , dysk nie. Tak się składa że mam drugi identyczny dysk , ten sam model, ta sama rev. i przełożyłem elektronikę , ale efekt ten sam, przywieszenie i dysku nie widzi. Elektronikę z tego uszkodzonego dysku przełożyłem do drugie sprawnego i dysk wykrywa poprawnie, czyli raczej elektronika jest ok. Gdzie można szukać przyczyny??
  • Poziom 14  
    OK, faktycznie nie poczytałem. Zbuduję ten układ - terminal, zrobię wtedy pełny opis i zamieszczę.
  • Poziom 14  
    podłaczyłem się przez terminal i lecą mi tylko krzaki

    Code:

    ţđ
      ńŕ"ŕţ@ŕYŔPü  )ô
                      &ˆôƒ2ö �úţůü�ţE YüČ„(ň‰HüT#ŮŇţ6 Q(‹ĐţńHţţŞú                                                             é@řđ‹řBŘ›š"ô‚™÷ÁÄ ć
                                                                                   Đ


    krzaki w różnej postaci, cały czas bez końca

    podłączałem inny dysk i odczyt jest jest ok, czyli układ mam sprawny....

    dorzucam odgłosy dysku: Link

    piknięcie na początku i na końcu nagrania to odgłosy układu włączającego i wyłączającego zasilanie
  • Poziom 14  
    podłączałem wg FAQ, seagate 2,5" SATA na ustawieniach 9600 8 N 1 i komunikacja była ok oraz tego Samsunga na ustawieniach 57600 8 N 1 (z dołu widoczny układ z dużą literą M czyli zakładam Marvell) oraz próbowałem również 38400 8 N 1...

    Dodano po 2 [godziny] 25 [minuty]:

    Udało się, problem był z masą..

    to odpowiedział dysk:
    Code:

    SPW 0000 NoLk
                                               5V: 05042
    SpnOk
    spd:  0000 0000 0000
     H: +00000
     ADC: 0007
     DAC: 6282
     SK C: 0001AEF5
    ENG>SRV>
      SvoTbl Loaded
      CL 015F CM 022E SL CCCE SM CC47
      BD

      FdtTbl Loaded

    *** Break at 0x005A [from Trap]
        005A: 001F
    DBG>DBG>:


    na tym drugim identycznym odczyt wygląda tak:

    Code:

     SPW 0000 NoLk

                   FlashCheckSum Ok!
                                    00017FFF 0000 B7055V: 05042
    SpnOk
    spd:  0000 0000 0000
     H: +00000
     ADC: 0004
     DAC: 8B8F
     SK C: 00018E03
    ENG>SRV>
      SvoTbl Loaded
      CL FFF3 CM 004C SL FFF1 SM FFE5
      BD

      FdtTbl Loaded
    Compare. 0001
                  hd0000: 009A  hd0001: 009A ENG>
  • Poziom 21  
    Sprawdź czy po podaniu komendy soft reset np w MHDD zostanie wykryty poprawnie.
  • Poziom 14  
    Próbowałem w MHDD i w Victoria, niestety bez rezultatu, dysku nie wykrywa, i bardzo długo wisi na etapie detekcji w biosie
  • Poziom 21  
    To ze nie wykrywa to ja wiem ale sama komendę soft resetu jest w stanie wysłać bezpośrednio na odpowiedni port...
  • Poziom 14  
    To się domyśliłem wybrałem port, dałem reset (f3 - w MHDD) bo rozumiem, że o ten reset chodziło i potem F2 by wykrył dysk, niestety bez rezultatu.
  • Poziom 21  
    Jest kolega pewny ze pracował z odpowiednim portem ?
    Jak zachowują się kontrolki?
  • Poziom 14  
    Po pierwsze zapobiegawczo wszystkie porty sprawdziłem, a po drugie podłączyłem drugi sprawny dysk w ten sam port, więc widziałem gdzie ten dysk się pojawia...
  • Poziom 14  
    Jeśli chodzi o kontrolkę HDD to świeci cały czas ciągłym światłem
  • VIP Zasłużony dla elektroda
    slavo_s2k napisał:
    Jeśli chodzi o kontrolkę HDD to świeci cały czas ciągłym światłem

    A kontrolki w MHDD? (na górze,np. ERR, DRDY, BUSY itd.)
  • Poziom 14  
    Tydzień wyrwany z życia, nie miałem czasu kontynuować tematu...

    patrze na kontrolki MHDD i BUSY jest na zielono, reszta szaro, reset nic nie zmienia.

    I co dalej??
  • Poziom 9  
    Trochę stary temat ale mam to samo, komp wisi z pół minuty zanim się włączy i nie widzi dysku. Chciał bym się dowiedzieć czy jakoś da się odzyskać dane.
  • Poziom 14  
    Mój dysk dalej leży w szufladzie biurka i czeka na czasy kiedy uda mi się znaleźć rozwiązanie :(
  • Poziom 18  
    Dzień dobry, mam taki sam problem, dysk startuje, słychać inicjalizację głowic i tak zostaje, w terminalu tak samo widać jak dysk wchodzi w tryb DBG>, wpisywanie w terminalu GO powoduje wyświetlenie BREAK z innym adresem, za czwartym czy piątym razem przechodzi w tryb ENG> lecz nie reaguje na żadne polecenie prócz klawisza ESC, czyli powrót do trybu DBG>. Wpisywanie polecenia SS, czyli tak jakby skok do następnej instrukcji także powoduje wyświetlenie kolejnej wartości Break (tym razem w nawiasie nia ma "from trap", ale coś w stylu "from SwSs")

    Code:

     SPW 0000 NoLk
                  5V: 04616
    SpnOk
    spd:  0000 0000 0000
     H: +00000
     ADC: FFFF
     DAC: 8F8E
     SK C: 0001AAAC
    ENG>SRV>
      SvoTbl Loaded
      CL FFE9 CM 01C2 SL 002C SM FFE1
      BD

      FdtTbl Loaded

    *** Break at 0x005A [from Trap]
        005A: 001F
    DBG>DBG>SS
    ENG>
    *** Break at 0x005B [from SwSs]
        005B: 001F
    DBG>SS
    ENG>
    *** Break at 0x005C [from SwSs]
        005C: 001F
    DBG>SS
    ENG>
    *** Break at 0x005D [from SwSs]
        005D: 001F
    DBG>SS
    ENG>
    *** Break at 0x005E [from SwSs]
        005E: 001F
    DBG>SS
    ENG>
    *** Break at 0x005F [from SwSs]
        005F: 001F
    DBG>SS
    ENG>
    *** Break at 0x0060 [from SwSs]
        0060: 001F
    DBG>SS
    ENG>
    *** Break at 0x0061 [from SwSs]
        0061: 001F
    DBG>SS
    ENG>
    *** Break at 0x0062 [from SwSs]
        0062: 001F
    DBG>SS
    ENG>
    *** Break at 0x0063 [from SwSs]
        0063: 001F
    DBG>SS
    ENG>
    *** Break at 0x0064 [from SwSs]
        0064: 001F
    DBG>SS
    ENG>
    *** Break at 0x0065 [from SwSs]
        0065: 001F
    DBG>SS
    ENG>
    *** Break at 0x0066 [from SwSs]
        0066: 001F
    DBG>SS
    ENG>
    *** Break at 0x0067 [from SwSs]
        0067: 001F
    DBG>SS
    ENG>
    *** Break at 0x0068 [from SwSs]
        0068: 001F
    DBG>SS
    ENG>
    *** Break at 0x0069 [from SwSs]
        0069: 0018
    DBG>SS
    ENG>
    *** Break at 0x006A [from SwSs]
        006A: 003E
    DBG>SS
    ENG>
    *** Break at 0xFFE9 [from Trap]
        FFE9: 0000
    DBG>SS
    E:0005 - Can't Set/Clr BP
    DBG>GO
    ENG>


    Temat widzę jest dość stary, ale czy ktokolwiek miał jeszcze do czynienia z tą usterką i udało mu się ją naprawić?W otchłaniach google można spotkać kilka takich samych przypadków bez rozwiązania.

    Dodatkowo, ciekawe jest, że nie ma nigdzie opisu poleceń terminala do dysków samsung, czy to jest jakaś tajemnica?