Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Prośba o spojrzenie w schemat timera z NE555

yogi009 06 Mar 2010 16:55 5509 11
  • #1 06 Mar 2010 16:55
    yogi009
    Poziom 42  

    Zrobiłem właśnie taki banalny układ odmierzający czas pracy (ma włączać 230V na ok. minutę), tu jest schemacik (ten pierwszy z dwóch przedstawionych) i opis:

    http://www.edw.com.pl/pdf/k07/18_11c.pdf

    Uruchomił się od pierwszego "kopnięcia", pracuje elegancko, ale mam jedną uwagę. Otóż przy załączeniu zasilania zachowuje się tak, jakby dostał impuls załączający ze switcha. Czyli włączam zasilanie tego timerka, a on od razu, niepytany, włącza przekaźnik i odlicza jeden pełny cykl włączenia. A chciałbym jednak, żeby po włączeniu zasilania timera, poczekał aż nacisnę jednak switch i świadomie włączył układ wykonawczy.

    Ponieważ nie jestem elektronikiem z zawodu, postanowiłem poprosić Szanownych Kolegów o podpowiedź, byłoby świetnie, gdyby zmiany były delikatne, mam już wszystko wlutowane w PCB. Oczywiście jeśli się nie da delikatnie, zrobię zmiany w projekcie PCB i wytrawię jeszcze raz.

    Drugie pytanko, przy okazji, być może następna wersja będzie wykonana w SMD, wtedy chyba byłoby miło zastąpić przekaźnik jakimś półprzewodnikiem typu triak, czy tyrystor (230V, max. 100W mocy obciążenia). Nie bardzo wiem, czy można sterować taki element z kolektora T1, a w sumie jest tam wysokie napięcie, więc wolę nie eksperymentować, tylko zapytać. Gdyby to był przy okazji jakiś przełącznik półprzewodnikowy z separacją galwaniczną od sieci 230V, to już byłbym naprawdę zadowolony :-)

    Pozdrawiam :-)

    0 11
  • Relpol
  • #2 06 Mar 2010 19:21
    jony
    Specjalista elektronik

    Też nie jest elektronikiem z zawodu.
    Ale zobacz sobie na schemat z triakiem
    Prośba o spojrzenie w schemat timera z NE555

    Co do pierwszej przypadłości to jest to dosyć dziwne.
    Bo w NE555 nie powinno być tego efektu, przynajmniej w moim egzemplarzu nie ma. No ale dodałem obwód resetu może zadziała.
    Ale może na początek zmniejsz R4 do 1K.

    0
  • Relpol
  • #3 06 Mar 2010 19:33
    Bonkot
    Poziom 39  

    Witam
    Miałem też taką "przypadłość" i po dodaniu układu opóźniającego, tak jak na rysunku kolegi jony pomogło. Układ działał prawidłowo.
    Pozdrawiam

    0
  • #4 06 Mar 2010 20:09
    yogi009
    Poziom 42  

    Wielkie dzięki za konkrety, wprowadzę te dwa elementy i napiszę, czy to pomogło (nie zakładam inaczej). Pozdrawiam serdecznie :-)

    =============

    No więc dodałem te dwa elementy na [4] 555 - nic to nie zmieniło. Wyrzuciłem je, zmniejszyłem R4 do 1k. W tej chwili nie mam autouruchamiania przekaźnika przy włączaniu zasilania, startuje na switch, ale po włączeniu już trzyma chyba do oporu. W każdym razie długo. Mogły się aż tak zmienić parametry RC ?

    0
  • #5 07 Mar 2010 13:43
    jony
    Specjalista elektronik

    yogi009 napisał:

    No więc dodałem te dwa elementy na [4] 555 - nic to nie zmieniło. Wyrzuciłem je, zmniejszyłem R4 do 1k. W tej chwili nie mam autouruchamiania przekaźnika przy włączaniu zasilania, startuje na switch, ale po włączeniu już trzyma chyba do oporu. W każdym razie długo. Mogły się aż tak zmienić parametry RC ?

    Możesz jaśniej? Bo nie rozumiem.

    0
  • #6 07 Mar 2010 16:46
    yogi009
    Poziom 42  

    Jaśniej ? :-) Po włożeniu oporniczna i kondensatorka do [4] wyjścia NE555 nic się nie zmieniło, czyli układ w dalszym ciągu przy załączaniu zasilania zachowywał się tak, jakby dostał impuls. Więc usunąłem te dwa elementy. Następnie zmniejszyłem wskazany przez Kolegę rezystorek z 10k do 1k. Efekt jest taki, że rzeczywiście nic się nie dzieje automatycznie, reaguje włączeniem przekaźnika na naciśnięcie switcha, ale potem już trzyma przekaźnik cały czas włączony (no, w każdym razie bardzo długo, nie udało mi się doczekać momentu wyłączenia). Stąd pytałem, czy zmiana R z 10k na 1k może tak dalece wpłynąć na czas włączenia. Wiem, że parametry tego ukłądu zależą od jedengo z elektrolitów (obecnie 100uF) i rezystora (obecnie około 490k). Natomiast wydaje mi się, że ten zmieniny rezystorek 10k (na 1k) nie powinien mieć wypływu na czas trwania impulsu załączającego.

    Jutro sobie przygotuję nowe płytki z Positivem (w niedzielę nie chcę psuć atmosfery domowej), zaprojektuję nową płytkę, już z przygotowanym miejscem na wszystkie elementy pokazane na tym schemacie z triakiem. Sprawdzę i powiem jak to się zachowuje. W sumie banalnie prosty układ i niby ruszył od razy, gdyby nie ten mały błąd w zachowaniu...

    0
  • #7 07 Mar 2010 17:56
    jony
    Specjalista elektronik

    Hmm, to dziwne. To może przywróć R4 do 10K.
    I wypróbuj działanie układu z innym egzemplarzem NE555

    0
  • #8 07 Mar 2010 18:17
    yogi009
    Poziom 42  

    Tak, tak :-))) Mam tu ich pół garści, nawet jestem przygotowany na SMD, jakby mi DIP-a zabrakło :-) Ale już tak poważnie, zrobię od nowa płyteczkę i obsadzę ją zupełnie innymi egzemplarzami, być może któryś był nie tego... Schemat w zasadzie odwzorowałem, jedynie zamiast BC148 dałem BC 147, no ale w tym przypadku to jest chyba bardzo dobry zamiennik. Poza tym układ w zasadzie pracował. Nawet dobrze, że muszę się zabrać za nową płytkę, od razu wsadzę na jedną mostek, stabilizator i może przełącznik-switch-10 do wyboru czasu włączenia. Tak sobie wymyśliłem bardzo prosty timer do naświetlarki, z reguły naświetlam 1 minutę, ale jak będę mógł sobie na microswitch'u wybrać inny czas (czyli w układzie skalibrowany opornik zamiast peereki 1MOhm), to już będzie nadmiar szczęścia. A przy okazji uczę się obsługi Eagla. No same pozytywy :-) Pozdrawiam.

    0
  • #9 07 Mar 2010 20:41
    Paweł Es.
    Pomocny dla użytkowników

    Układ się samowyzwala z powodu różnicy progów zadziałania wejść TRIG i RESET.
    W momencie włączenia zasilania, ładują się kondensatory filtrujące zasilanie C3 i C4. Wejście RESET wykonuje swoją pracę do momentu gdy napięcie na nim nie przekroczy ok. 0.5V do 1V, potem przestaje zerować układ. Wejście TRIG wyzwala układ gdy napięcie na nim jest mniejsze od 1/3 napięcia zasilania co dla 12V wynosi 4V. Gdy napięcie zasilania narasta to najpierw znika sygnał RESET a dopiero potem sygnał TRIG. W karcie katalogowej jest podane, że układ 555 działa od napięcia zasilania wynoszącego 4.5V (do 16V) ale to jest wartość gwarantowana przez producenta, jednak niektóre egzemplarze układu 555 mogą działać przy niższym napięciu i w nich dochodzi do samowyzwolenia w momencie włączenia zasilania.

    Ten układ Jonego powinien działać ale ja bym dał tam kondensator 100uF, by impuls zerujący był dłuższy i napięcie na wejściu TRIG wzrosło powyżej progu nim zniknie sygnał RESET.

    Dodatkowo dałbym równolegle do rezystora 100k diodę 1N4001 (katodą do plusa) dzięki czemu po wyłączeniu zasilania kondensator szybciej się rozładuje.

    Prośba o spojrzenie w schemat timera z NE555

    0
  • #10 07 Mar 2010 22:27
    yogi009
    Poziom 42  

    R5 (numeracja z ostatniego schematu z tymi niebieskimi dodatkami) już próbowałem za radą Kolegów, natomiast C5 miał wartość 100nF, diodę widzę pierwszy raz :-) Dobrze, że tak szybko, zdążę do jutra jeszcze zmodyfikować projekt płytki. Uruchomię i dam znać.

    Mam rozumieć, że dla tego ukłądu pewniejsze byłoby zasilanie niższym napięciem ? Np. 5V ? Musiałbym wtedy przede wszystkim wymienić przekaźnik, reszta to detale.

    -----------

    To poproszę o sprawdzenie schematu, żebym nie narobił się na darmo. W Eaglu dopiero stawiam pierwsze kroki :-)

    Prośba o spojrzenie w schemat timera z NE555

    Stabilizator na wejściu dałem, bo mam na oddzielnej gotowej płytce trafo, mostek i kondensatorki, ale brak miejsca na 7812 :-)

    0
  • #11 08 Mar 2010 09:32
    Paweł Es.
    Pomocny dla użytkowników

    Ale chyba tym przekaźnikiem JSM1, to nie chcesz włączać tych 230V, bo on przełącza napięcia zdaje się do 16V ?

    Z jakiego napięcia będziesz zasilać ten układ ?

    Co do przekaźników elektronicznych, to najlepiej (jeżeli nie masz doświadczeń z konstrukcją układów na napięcia sieciowe) zastosować gotowy przekaźnik elektroniczny, np. coś z tych:

    http://www.cyfronika.com.pl/p_poprzewodnikowe.htm

    0
  • #12 08 Mar 2010 09:42
    yogi009
    Poziom 42  

    Paweł, stosuję przekaźnik Matsushita JB1-12, oglądałem notę i wydaje mi się, że ma zakres do 10A i 250V, ale jeśli możesz to ew. sprawdzić, to będę zobowiązany. Co do półprzewodników, wolałbym jednak kiedyś popełnić samodzielną konstrukcję z triakiem lub tyrystorem. Z tymi elementami się w praktyce nie bawiłem, ale z innymi tak, nawet sporo. Piszę natomiast, dla jasności, że nie jestem zawodowym elektronikiem, czyli nie mam wykształcenia w tym kierunku i stąd luki w teorii :-) Odbiornik będzie potrzebował ok. 60W przy 230V.

    0