Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Brak dostępu do internetu w IBM ThinkPad A20M

12 Mar 2010 20:54 6285 46
  • Poziom 22  
    Witam
    Tydzień temu dostałem laptopa trochę starego, ale to nic i chciałem podpiąć neta w celu sprawdzenia, więc wyciągnąłem wtykę ze stacjonarnego kompa i włożyłem do laptopa i nie bardzo chce działać wyskakuje komunikat,, możesz nie mieć dostępu do internetu lub do niektórych zasobów sieciowych, ponieważ sieć nie przypisała adresu sieciowego do tego komputera''. Wyłączałem nawet router, ale nic z tego. Może ręcznie trzeba wpisać adres?
  • Poziom 22  
    Wejdź w zakładkę połączenia sieciowe i sprawdź czy na laptopie ustawione jest we właściwościach - Protokół TCP/IP 4 - automatyczne uzyskiwanie adresu IP oraz DNS. Jeśli problem nadal istnieje - spróbuj wpisać tam na sztywno ustawienia takie same jakie otrzymuje komputer PC.
  • Poziom 19  
    Ewentualnie może włączona jest filtracja MAC adresów na routerze. Warto byłoby to sprawdzic. :)
  • Poziom 22  
    Poczekaj. Witux od razu wystrzelił z filtracją MAC. Wina może być również sprzętowa...

    A ja zapytam - co to w ogóle za router, czy sam go kupowałeś?
    Tutaj był podobny problem: https://www.elektroda.pl/rtvforum/topic943296.html

    Hmm... oraz czy masz może kabel krosowany - aby spróbować połączenia PC - notebook.

    P.S. Czy w momencie włączania laptopa do sieci - PC również jest podłączony do routera? (jeśli kopiujesz ustawienia z PC, w momencie podłączania do sieci laptopa PC powinieneś go odłączyć od sieci ETH, ponieważ następować będzie konflikt adresów)
  • Poziom 22  
    Krzyq napisał:
    Poczekaj. Witux od razu wystrzelił z filtracją MAC. Wina może być również sprzętowa...

    A ja zapytam - co to w ogóle za router, czy sam go kupowałeś?
    Tutaj był podobny problem: https://www.elektroda.pl/rtvforum/topic943296.html

    Hmm... oraz czy masz może kabel krosowany - aby spróbować połączenia PC - notebook.

    P.S. Czy w momencie włączania laptopa do sieci - PC również jest podłączony do routera? (jeśli kopiujesz ustawienia z PC, w momencie podłączania do sieci laptopa PC powinieneś go odłączyć od sieci ETH, ponieważ następować będzie konflikt adresów)

    Router sam kupowałem, jest to Pentagram Cerberus. Chodzą na nim 2 PC. Mój i siory i niedawno dostałem starego laptopa, wiec postanowiłem podłączyć neta w celu sprawdzenia. Odłączyłem kabel od swojego kompa i podłączyłem, wyskoczył komunikat ,,To połączenie ma ograniczoną łączność lub brak łączności. Możesz nie mieć dostępu do internetu lub niektórych zasobów sieciowych,, Pierwsze co mi przyszło do głowy to wyłączenie z zasilania routera i tak zrobiłem, ale nadal to samo
    Kabel skrosowany mam podłączam PC i laptopa i co dalej?
    Trzeba utworzyć nowe połączenie?

    Dodano po 1 [godziny] 7 [minuty]:

    wina chyba stoi po stronie sprzętu, czyli w laptopie jest coś uszkodzone.
    Podłączyłem PC z Laptopem skonfigurowałem i na PC komunikat kabel odłączony, a na Laptopie normalnie
    bartek_korzeniak napisał:
    A zeby kolega zrozumiał to dorzucę uż jedna para przewodów służy do wysyłania a druga do odbioru danych (zielone pomaranczowe w standardzie), w normalnej sytutuacji gdy wykożystujemy jakis przełącznik sieciowy (switch na pewno nie wiem jak hub...) on sam radzi sobie z przewodem i czy podlaczysz taki czy taki bedzie hulać (nie na kazdym starsze swiche ponoc mialy z tym jeszcze problemy). Kwestia crossowania przewodu to poprostu ręczne narzucenie/zmiana toru sygnałów.

    Jeśli masz możliwość przeciśnięcia przewodu którego używasz do internetu zrób z niego crossa (najlepiej popros znajomego ktory ma zaciskarke, nie rob tego srubokretem :P ja pierwsze wtyczki tak zaciskalem :D)

    Jeśli nie odwiedź sklep komputerowy i zakup tzw beczkę RJ45 i zamów aby sprzedawca zacisnął Ci 10cm przewodu crossowanego


    Po tym wszystkim pozostaje Ci tylko ustwić adresację na obu komputerach.
    Wchodzisz we właściwosci połączenia przewodowego, własciwosci protokolu TCP/IP i zmieniasz na statyczne adresy np:

    KOMP1
    adres IP: 192.168.1.1
    maska : 255.255.255.0

    KOMP2
    adres IP: 192.168.1.2
    maska : 255.255.255.0

    pozniej pozostaje tylko wejsc we wlasciwosci folderu który chcesz aby był współdzielony i w zakładce udostepnianie klnikasz taki dlugi podkreslony napis "po prostu włącz udostepnianie plików" (czy cos takiego nie pamietam dokladnie)

    Na drugim komputerze odpalasz start -> uruchom -> \\[adresIPkomputeraZktórymChceszSięPołączyć] [enter]

    i to tyle, poczytaj sobie jeszcze o mapowaniu dysków to ulatwisz sobie proces dzielenia zasobów


    EDIT: Pamiętaj ze jesli chcesz kozystac z internetu musisz przywrócic poprzednią adresacje czyli pewnie automatyczne pobieranie adresu IP przez DHCP
  • Poziom 22  
    witux napisał:
    By wyeliminować to, musi spróbować tego sposobu. Świat się nie zawali.


    Zawalić nie zawali, ale bieganie nie w temacie też utrudnia życie. Zacznijmy może po prostu od początku. Co do DNS 194.204.152.34 - to jest DHCP typowe dla Neostrady. Utrudnienia mogą się pojawić jeśli nasz kolega jest z innej sieci.

    demsy napisał:

    Router sam kupowałem, jest to Pentagram Cerberus. /../ Odłączyłem kabel od swojego kompa i podłączyłem, wyskoczył komunikat ,,To połączenie ma ograniczoną łączność lub brak łączności. Możesz nie mieć dostępu do internetu lub niektórych zasobów sieciowych,,


    Podłączenie 2 kompów robisz dokładnie tak jak napisał bartek korzeniak... po tym podłączeniu klikasz polecenie Start/Uruchom i tam "cmd" a następnie w otwartym oknie wpisz ping 192.168.xxx.xxx (numer ip drugiego komputera) jeśli się pingują to ciężko będzie.

    Skoro sam kupowałeś router - to powinieneś wiedzieć czy są na nim blokady MAC (ale raczej powinny być włączone - chyba że sam je założyłeś - to na czas prób możesz to wyłączyć, albo spróbować dopisać tego MACa do przepuszczanych w routerze).

    Przed połączeniem kabla - spróbuj przeczyścić styki wejścia karty sieciowej w notebooku. Nie ma na nich żadnego ciemnego nalotu, nie są ułamane (powinny być co najmniej 4 albo najlepiej 8)?

    Wydaje mi się że są jakieś problemy z obsługa DNS przez Twoją kartę w notebooku. Stąd też pytanie - czy ustawienia IP u siostry i u siebie masz na sztywno (stałe IP) czy pobierane automatycznie - zarówno IP jak i DNS?

    Jak mam rozumieć - adres routera to 192.168.1.100?
  • Poziom 22  
    Krzyq napisał:
    witux napisał:
    By wyeliminować to, musi spróbować tego sposobu. Świat się nie zawali.


    Zawalić nie zawali, ale bieganie nie w temacie też utrudnia życie. Zacznijmy może po prostu od początku. Co do DNS 194.204.152.34 - to jest DHCP typowe dla Neostrady. Utrudnienia mogą się pojawić jeśli nasz kolega jest z innej sieci.

    demsy napisał:

    Router sam kupowałem, jest to Pentagram Cerberus. /../ Odłączyłem kabel od swojego kompa i podłączyłem, wyskoczył komunikat ,,To połączenie ma ograniczoną łączność lub brak łączności. Możesz nie mieć dostępu do internetu lub niektórych zasobów sieciowych,,


    Podłączenie 2 kompów robisz dokładnie tak jak napisał bartek korzeniak... po tym podłączeniu klikasz polecenie Start/Uruchom i tam "cmd" a następnie w otwartym oknie wpisz ping 192.168.xxx.xxx (numer ip drugiego komputera) jeśli się pingują to ciężko będzie.

    Skoro sam kupowałeś router - to powinieneś wiedzieć czy są na nim blokady MAC (ale raczej powinny być włączone - chyba że sam je założyłeś - to na czas prób możesz to wyłączyć, albo spróbować dopisać tego MACa do przepuszczanych w routerze).

    Przed połączeniem kabla - spróbuj przeczyścić styki wejścia karty sieciowej w notebooku. Nie ma na nich żadnego ciemnego nalotu, nie są ułamane (powinny być co najmniej 4 albo najlepiej 8)?

    Wydaje mi się że są jakieś problemy z obsługa DNS przez Twoją kartę w notebooku. Stąd też pytanie - czy ustawienia IP u siostry i u siebie masz na sztywno (stałe IP) czy pobierane automatycznie - zarówno IP jak i DNS?

    Jak mam rozumieć - adres routera to 192.168.1.100?


    Internet mam z multimedi
    Co do blokady MAC to nie jestem pewnyBrak dostępu do internetu w IBM ThinkPad A20M

    Roter sam przypisuje IP do danego komputera
    ja mam np.192.168.1.101, siostra ma 192.168.1.102 itd... i tak do 192.168.1.104, bo ma tyle wyjśc i IP jest stałe
    adres routera to 192.168.1.100
  • Poziom 22  
    Hmm... chociaż nie wiem co to za router - ale to nie jest przypadkiem zakładka WAN zamiast LAN? - na zamieszczonym wyżej zdjęciu? Mi chodzi o zakładki po stronie LAN - ewentualnie Firewall lub Filter.

    A możesz wyłączyć filtr (albu przestawić na filtr aplikacji albo URL), albo wejść w ustawienia FireWalla/Filtra i tam powinna być MAC list albo coś takiego i dodać oryginalny adres MAC karty sieciowej laptopa? Nie wiem co to za router - więc strzelam w ciemno - że takie coś na bank gdzieś tam powinno być. Tyle że nie powiem Ci konkretnie gdzie.

    Bo wiesz... łączenie laptop <> PC będzie miało sens jeśli przywrócisz stary MAC na notebooku. Bo jak mniemam próbowałeś się łączyć z dwiema kartami o tym samym MACu (po użyciu oprogramowania zaleconego przez wituxa - a ten sposób jest dobry tylko przy braku dostępu do ustawień routera).

    Na wszelki wypadek - jakbyś bał się utracić ustawienia routera - w zakładce system setup albo pokrewnej powinna być możliwość zapisania pliku backupu obecnych ustawień. (Wtenczas jak coś pozmieniasz na tyle że nie będziesz mógł wbić na router - strzelisz zwykły reset do fabrycznych ustawień, automatyczne pobieranie IP na PC i wgrasz na nowo zapisane na dysku ustawienia - taka przydatna rada przy majstrowaniu w routerze).
  • Poziom 22  
    Z tego co masz wynika - że nie ma żadnego ograniczania względem MAC - lista jest pusta, a pola Active jest NO. (Hehe Mam router Planete na tym samym sofcie co Twój Pentagram).

    Backup ustawień zapiszesz sobie na dysku przez Romfile Backup SAVE w Maintenance / Firmware.

    Upewnij się że w zakładce: Interface Setup / LAN router ma ustawione Dynamic Route na RIPv1. Natomiast w Access Management ACL w tabeli wyglądało tak: 1 Yes 0.0.0.0-0.0.0.0 ALL LAN

    Powiedz jeszcze czy ping ma odpowiedź - przy połączeniu Laptopa z routerem (kablem prostym) - na laptopie wejdź w Start / Uruchom wpisz cmd i w nowym oknie wpisz ping 192.168.1.100. Najpierw sprawdź ping przy automatycznym pobieraniu IP (zresetuj programowo połączenie internetowe - Wyłącz i potem Włącz). Jeśli będzie inne niż 192.168.1.x oznacza że Windows przydzielił jakiegoś śmiecia. Wtenczas wpisz z palca ustawienia jakie dawałeś wcześniej - te skopiowane z PC. Następnie znowu zresetuj programowo połączenie - wyłącz i włącz, lub automatycznie "napraw" - po tym zabiegu ponownie sprawdź ping do 192.168.1.100.

    Jeśli to nie zadziała spróbuj jeszcze ewentualnie przeinstalować sterowniki do karty sieciowej w laptopie i koniecznie sprawdź te styki. (Obawiam się, że to może być problem natury sprzętowej ;( niż softu i ustawień, ale pokombinować jeszcze trzeba - bo informacja o połączeniu daje jeszcze złudzenie, że może się uda)

    P.S. Czy informacja "To połączenie ma ograniczoną łączność lub brak łączności. Możesz nie mieć dostępu do internetu lub niektórych zasobów sieciowych" pojawia się nawet jeśli kabel wypięty jest z drugiej strony?

    P.S. 2 > DNSy Multimedii to: 217.172.224.92 oraz 81.15.136.251 - przy ręcznym podawaniu IP możesz spróbować je wpisać w miejscu DNS.
  • Poziom 22  
    Upewnij się że w zakładce: Interface Setup / LAN router ma ustawione Dynamic Route na RIPv1. Natomiast w Access Management ACL w tabeli wyglądało tak: 1 Yes 0.0.0.0-0.0.0.0 ALL LAN

    Wygląda to tak
    Brak dostępu do internetu w IBM ThinkPad A20M
    teraz ustawiłem tak
    Brak dostępu do internetu w IBM ThinkPad A20M


    A może nie mam czegoś zainstalowanego?
    To jest moja karta
    Brak dostępu do internetu w IBM ThinkPad A20M

    ,,P.S. Czy informacja "To połączenie ma ograniczoną łączność lub brak łączności. Możesz nie mieć dostępu do internetu lub niektórych zasobów sieciowych" pojawia się nawet jeśli kabel wypięty jest z drugiej strony?,,
    Jeśli mam ustawione automatycznie to się pojawia zawsze, nawet jesli kabel jest odpięty z drugiej strony, ale jak ustawie wszystko ręcznie to jest coś takiego
    Brak dostępu do internetu w IBM ThinkPad A20M
    i nawet jeśli kabel odepnę to nic się nie zmienia, a powinien wyskoczyć komunikat ,,kabel odłączony,,,

    Coraz bardziej wydaje mi się że wina stoi po stronie uszkodzonego gniazda, bo po wpięciu przewodu nie zaświeci się nawet na moment dioda
  • Poziom 22  
    Dobra, te ustawienia ACL są ok (to są ustawienia tak samo jakby nie było ACL).

    Sprawa zaczyna się rozjaśniać. Problem nie leży po stronie ani konfiguracji routera, ani po stronie budowy sieci. To wszystko wykluczyliśmy.

    Problem leży wyłącznie po stronie laptopa.
    Trzeba zająć się więc kartą w notebooku. Mówisz że jest leciwy - więc nie możemy wykluczyć po prostu uszkodzenia elementów elektronicznych, lub uszkodzeń mechanicznych. Ale spójrz jeszcze na te sterowniki...

    Wyszukaj na internecie i przeinstaluj sterowniki na nowe (możesz tego dokonać również w menadżerze urządzeń). A jeśli nie jesteś pewien - czy karta została dobrze wykryta możesz użyć programu EVEREST, który określi Ci w miarę dokładniej niż XPek rodzaje elementów w komputerze.

    W tym temacie: https://www.elektroda.pl/rtvforum/topic945441.html poruszana była tematyka tej karty, natomiast tu: http://support.microsoft.com/kb/839013/pl opis instalacji od Microsoftu.