Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

XP nie czyta żadnego pendriva, karty, dysku (USB), floppa

13 Mar 2010 18:15 4506 7
  • Poziom 2  
    Po kilku dniach od formatu niemal nowego HDD, założeniu 2 partycji i instalacji XP PRO nagle każdy pendrive, drugi HDD (pod USB), dyskietka we floppie, jak i aparat cyfrowy SONY (z kartą Memory Stick, przez firmowy kabelek i przy zainstalowanym programie firmowym) podłączone do kompa nie są uruchamiane autorun'em jak wcześniej, a próby otwarcia z 'Mojego komputera' dają niezmiennie komunikat: 'Dysk w stacji dysków X jest niesformatowany, czy chcesz sformatować go teraz?' Nie dawałem OK. To samo zrobiło się nawet z partycją D (415GB, 'Easeus' pokazuje że niesformatowana, a przy starcie XP-eka, że jest pod FAT32 (tworzyłem pod NTFS)). Nie mogę odczytać żadnego nośnika oprócz partycji C i płyt CD/DVD z nagrywarki.

    Przeczytałem masę porad z hasłem 'Dysk w stacji X jest niesformatowany...' ale wszystkie dotyczą jednego nośnika i porady głównie tego jak odzyskać z nich dane. Na karcie Memory Stick mam zdjęcia, które w aparacie wyświetlają się normalnie. Wygląda że karta jest OK i dane na niej tak samo. Niemożliwym wydaje się żeby wszystkie nośniki nagle padły tego samego dnia. Pomyślałem że może jest problem z kontrolerem USB, ale to nie tłumaczy faktu, że to samo jest z floppem. Natrafiłem też na taką informację: "Polecenia dla systemu są zawarte w pliku Autorun.inf - i właśnie taki plik jest wgrywany na Twojego pendrive po włożeniu go do zainfekowanego komputera. Kiedy wkładasz go do swojego komputera - wirus automatycznie się instaluje." Zabezpieczyłem wyjątkowo system przy tej instalacji, jak nigdy, i od razu wirus? Ale na to trochę wygląda, bo i parę innych dziwnych rzeczy się dzieje. Przeskanowałem dokładnie zaktualizowaną Avirą Antivir i Malwarebytes - zero infekcji. Co to może być?
  • Pomocny post
    Poziom 43  
    Wirus typu Autorun plus może coś jeszcze. Avast sobie z tym nie radzi.
    Poczytaj podwieszone wątki w Pogotowie Antywirusowe i przenieś tam wątek.
  • Poziom 2  
    Jestem pierwszy raz na tym forum. Jak się przenosi wątek do innego działu?
  • Poziom 43  
    Poproś Moderatora lub skasuj i załóż jeszcze raz.
  • VIP Zasłużony dla elektroda
    artaa, szkodniki wpisujące pliki autorun nie generują komunikatu o niesformatowanym dysku. Jeżeli dotyczy to różnych zewnętrznych nośników to jest możliwy jakiś problem z portami USB.
    Pytanie do autora: czy te nośniki są poprawnie odczytywane na innym komputerze?
  • Poziom 2  
    Nie mam w tej chwili możliwości sprawdzić tych nośników na innym komputerze. Obawiałbym się też komuś zainfekować nimi kompa, gdyby to okazało się przyczyną. Ale tak na zdrowy rozum biorąc, wygląda na rzecz niemożliwą, żeby jednego dnia uszkodziło się tyle różnych nośników, które jeszcze w przeddzień działały bez zarzutu. Myślę, że tę opcję można spokojnie wykluczyć. Faktycznie, raczej wyglądałoby to na kontroler USB, ale w takim razie dlaczego to samo jest z dyskietkami z floppa? (Menadżer Urządzeń: 'To urządzenie działa poprawnie'). Na jakąś infekcję wskazywałyby też dziwne zjawiska, typu że nagle w czacie skypowym zamiast otwierać strony WWW z przesłanych mi linków, otwiera albo puste albo inne (nie te spod linków), tak samo okno Opery nie otwiera normalnie, tylko zawsze przesunięte w prawo lub lewo. Nigdy wcześniej mi się takie rzeczy nie działy, a przypominam, że tydzień temu reinstalowałem XP i w pierwszych dniach wszystko było OK. Natomiast teraz podłączałem nośniki pod różne (przedni i tylne) porty USB i ten sam komunikat... W 'Menadżerze urządzeń' niby wszystko z kontrolerami USB jest OK (załącznik). Na mój gust to wygląda raczej na dzieło wirusa... Jakieś sugestie?
  • Poziom 31  
    1. Dobry skaner online niech przeskanuje ci kompa (włącz widok plików ukrytych i systemowych oraz koniecznie wyłącz przywracanie systemu).
    2. Program AV i skanowanie po wykonaniu czynności z nawiasu.
  • Poziom 2  
    Skanowałem już zaktualizowaną Avirą i Malwarebytes'em i nic nie znalazły. Jak padła sugestia normalne antywirusy mogą nie wykrywać infekcji przenoszonych przez autorun.... Chętnie przeskanuję jeszcze Kasperskim on-line lub innym, typu Panda, tylko że myślałem o tym żeby właśnie skorzystać z przywracania systemu do daty sprzed problemu i teraz nie wiem czy gdy wyłączę przywracanie, to będę mógł po ponownym włączeniu skutecznie takie przywrócenie jeszcze zrobić?
    Czekam na potwierdzenie i jeśli tak, zabieram się za skanowanie.

    [Dodam jeszcze jedną opinię: "Jeśli winny byłby wirus lub inny śmieć rozprzestrzeniany przez Autorun.inf
    to na partycji C miałbyś zapewne kopię tego pliku.
    Raczej błędna instalacja(sterowniki coś mieszają) lub antiwirus coś blokuje.
    Jedyny sposób sprawdzić nośniki na innym kompie lub z płytki z systemem Live"
    ]

    Zrobiłem przywracanie systemu do punktu z dnia następnego po instalacji XP, gdy wszystko było jeszcze OK, ale jednak partycja D (415GB) na tym samym dysku co systemowa, która stała się ostatnio nagle także 'niesformatowana', wciąż pozostaje taka. Wyłączyłem funkcję Autoodtwarzania w Konfiguracjach.