Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

samsung omnia i900 - Pod co podłączyć gniazdo ładowania ?

Janosik_pat 20 Mar 2010 03:20 10367 19
  • #1
    Janosik_pat
    Level 15  
    Witam

    Mam problem, gniazdo w mojej omni zostało wyrwane bezpowrotnie i oto pytanie.
    Pod jaki układ mogę się "podłączyć" aby telefon mógł być ładowany ?
    Jeżeli jest to możliwe to ze zdjęciem i wskazanymi punktami.
    Był bym bardzo wdzięczny ponieważ zostałem zmuszony do ładowania same baterii innym telefonem, a zależy mi aby naładować go np podczas podróży samochodem.

    Pozdrawiam
  • #2
    any56
    Level 39  
    Możesz podłączyć przez USB ale to wymaga adaptacji ładowarki.
  • #3
    Janosik_pat
    Level 15  
    z tym że w samsungu gniazdo usb jest jest niejako połączone z ładowarką i zestawem słuchawkowym.
  • #5
    Janosik_pat
    Level 15  
    Dziękuje ze schematu wynika że dojście nie jest trudne, muszę rozkręcić jeszcze raz samsunga. Będę działał po weekendzie.
    Dziękuje za pomoc na pewno jeszcze się odezwę ;)
  • #6
    _Glowart_
    Level 24  
    Czasem to miejsce gdzie najwygodniej się wlutować jest zalane klejem także nie zdziw się jak będziesz musiał go trochę zeskrobać.
  • #7
    Janosik_pat
    Level 15  
    Witam

    Proszę o pomoc, pod co dokładnie mogę podłączyć kabel + z ładowarki ?
    Mogę skorzystać z układu U304 v_dc?



    ------------------------------------------------------------------------


    Już rozwiązałem problem podłączyłem się pod D302 pod pierwszy pin, ten co nad nim jest rezystor R316. Gniazdo zamontowałem od nokii ( musiałem je trochę spiłować ale jest ok), lekko wchodzi wtyczka więc nie muszę się martwić że zostanie wyrwane.


    Niebawem postaram się podłączyć gniazdo mini usb


    Pozdrawiam
  • #8
    ScApi
    Level 11  
    Przekopałem całą instrukcję serwisową i to co wypluło Google i nie udało mi się zlokalizować jakiegoś miejsca w które można było by się wpiąć z sygnałami USB, mógłby ktoś podpowiedzieć, zasilanie rozwiązałem jak wyżej, pozostało tylko USB reszta połączeń raczej zbędna.

    Byłbym wdzięczny

    Dodatkowe pytanie, bo chyba ktoś kto wcześniej naprawiał w/w omnię coś pokręcił albo ja już się zakręciłem, jak powinno wyglądać złącze przylutowane do płyty, tą szerszą częścią czy tą węższą, bo na allegro są 2 różne wersje, i nijak mi wg. schematów nie pasuje pinologia.
  • #9
    Janosik_pat
    Level 15  
    Witam, ja sobie odpuściłem już usb, złącza samsunga są dwa rodzaje. Pierwszy to starszy a drugi nowszy i pasuje ten nowszy nie pamiętam jakie modele mają starsze i nowsze ale na aukcjach masz napisane.
    Co do tego jak zamontować to musiał byś pokazać zdjęcie pustego pola bo mi się nie chce rozkręcać telefonu. Ważne jest to czy stare nie było wyrwane bo jak tak to może być problem o w sumie trzyma się chyba na dwóch blaszkach które wchodzą w płytę na wylot a środkowa część jest z lutowana, jeszcze są dwie łapki które też powinny być zlutowane. Wszystko powinno się trzymać b. mocno ponieważ nóżki od gniazda dociskają do płyty więc w pewnym sensie odpychają się od gniazda a samo gniazdo musi wytrzymać wkładanie i wyjmowanie wtyczki. Dodam tylko że jeżeli laminat się oderwie od płytki to czeka trochę więcej pracy.

    ---up


    Po tym jak gniazdo z nokii już nie dawało rady ( czyt uszkodziło się ) wlutowałem miniUSB panel trochę odstaje, miałem już zabierać się do podłączenia danych do gniazda ale w sumie pomyślałem i dochodzę do wniosku że używam Bluetooth i wifi do przesyłu danych.

    Pozdrawiam
  • #10
    dragon
    Level 12  
    Witam

    W załączniku przygotowałem rozpiskę sygnałów gdzie się podpiąć aby mieć w omni ładowanie i komunikację przez USB. Zaznaczam że tym sposobem naprawiłem niejedną omnię. Powiem więcej, nawet przy całkowicie wyrwanych wszystkich polach lutowniczych gdzie zostają tylko przelotki wgłąb płyty pcb odpowiednią techniką lutowania i dużą dozą cierpliwości można przywrócić złącze do pełnej sprawności... osobiście używam takiej od ponad pół roku :D

    Pozdrawiam
    Attachments:
  • #11
    ano33
    Level 11  
    A w którym miejscu podpiąć te piny? ktos wie ? Bo chcialbym podpiąć słuchawy!
    5- AUDIO OUT_R -
    6- GND AUDIO
    7- AUDIO OUT_L
    8- BEND_END
    9- nJACK_INT

    Edit!
    Wiec doszedlem do tego ze sygnal wychodzi z ucd402 - tylko gdzie podpiac pin odpowiedzialny za wylaczenie glosnikow w momencie podpiecia sluchawek?
  • #12
    dragon
    Level 12  
    Osobiście robię to tak że bardzo cienkie druciki w emali 0,1mm lutuję na płasko do przelotek ktore pozostają po wyrwanych polach lutowniczych, część drucików podlutowuję do ZD400 i tak jak jest w solucji podanej wyżej. Tak zabezpieczone druciki pokrywam bardzo cienką warstwą poxipolu co uniemozliwia ich wyrwanie a następnie kładę złącze i wszystkie 19 (ładowanie to dwa piny w złączu) drucików lutuję do złącza które dzięki podskrobaniu emali na PCB przylutowane jest bokami do masy. Po przylutowaniu, sprawdzam złącze podpinając ładowarkę, kabel AV, zestaw HF i kabel USB, jeśli wszystko dobrze działa to zalewam złącze i luty poxipolem. Wymaga to czasu i precyzji ale jest możliwe do zrealizowania. Tym sposobem naprawiłem już kilka omni. Acha, lutuje to wszystko zwykłą transformatorówką ze specjalnie przygotowanym grotem 0,5mm :). Zycze powodzenia przy naprawach...
  • #13
    Janosik_pat
    Level 15  
    Jestem pod wrażeniem ;), ja dałem sobie spokój z odkopywaniem wyrwanych ścieżek, zależało mi głównie na ładowaniu. Wykorzystałem mini usb ponieważ mogę ją teraz ładować z komputera. Jedno mnie dziwi, podłączenie + ładowania pod pin19/20.
    Jak mnie najdzie to podepnę d+ i d- ale puki co nie chce mi się znowu tego ruszać. Po za tym uszkodziłem plastiki przyciskające taśmę od przycisków i LCD, pół godziny ją zakładałem ale dałem radę, mam pecha do tych tasiemek.

    Myślałem kiedyś trochę też nad oryginalnym gniazdem jak pisze dragon może poxipol wytrzyma ale puki jest dobrze to nie ruszam :)
  • #14
    dragon
    Level 12  
    Janosik_pat czemu się dziwisz z tym podpięciem +ładowania do pinu 19 i 20 ? Zwróć uwagę na serwisówkę do i900 i tam wyraźnie jest zaznaczone że te piny to właśnie +ładowanie. Za - ładowania odpowiadają piny 1 i 2. Pin 1 tak naprawdę jest anteną dla radia ale dzięki temu że na płycie jest zwarty cewka do masy dla ładowarki jest po prostu masą. Jeśli zdecydujesz się na podpięcie D- i D+ to nie zapomnij o sygnale USB_INT. Dzięki niemu telefon wie że podpiąłeś kabel USB.
  • #15
    Janosik_pat
    Level 15  
    Masę mam podłączoną jako minus ale plus mam podłączony pod co innego. A USB_INT do ? Mam gniazdo mini USB to może wykorzystać właśnie do tego ? czy pod 5+ ?
  • #16
    dragon
    Level 12  
    Jestem ciekawy pod co masz podpięty +ładowanie ? . W załączniku jest rzut z serwisówki dla rozwiania wątpliwości na jakich pinach jest - i + ładowanie. Sprawdziłem właśnie oryginalny kabel USB do omni i jest tak że wykorzystuje się 4 sygnały, są to: masa, +D, -D, USB_INT. Sygnał USB_INT w kablu podłączony jest do +5V po stronie wtyczki do komputera. Jeśli w omni użyłeś gniazdo mini USB to nie widze możliwości pogodzenia ładowania i komuniacji. No chyba że na stałe na płycie PCB omni podłączysz sygnał USB_INT do +ładowanie, ale nie ręcze że to bedzie dobrze działać.
  • #17
    Janosik_pat
    Level 15  
    W załączniku dałem strzałkę na miejsce gdzie się podłączyłem ale gdybym wcześniej wiedział że jest lepsze dojście to bym tak nie kombinował. W sumie to jeżeli INT ma mieć 5+ to najlepiej jest połączyć je z 5+, napięcie jest podczas ładowania czyli gdy podłączam kabel USB. Wadą było by ciągła próba komunikacji podczas samego ładowania. Zastanawiam się jak to jest zrobione np w nawigacjach gdzie wykorzystane jest gniazdo miniUSB ale chyba wtedy wykorzystany jest piąty pin gniazda ID minUSB tyle tylko że ten pin to raczej masa albo któryś z D,. sam już nie wiem poczytam bo już zgupiałem.
    e: pozwoliłem sobie wykorzystać kawałek twojego zdjęcia ;)
  • #18
    Luk_GSM
    Level 11  
    Witam wlutowałem złącze ładowania (dodam że wcześniej było oberwane) udało się jednak podlutować "+" pod 19,20 "-" pod 1,2 a samsung nadal nie ładuje. zapala się tylko czerwona dioda od góry natomaist gdy tel jest właczony nie pokazuje się ikona ładowania. zgodnie z zaznaczonym schematem pojawia mi sie +5 na rezytorku zgodnie z solucją "drago".

    Proszę o podpowiedź co może być przyczyną takiego zachowania samsunga.

    Dodano po 2 [minuty]:

    Czy "+5" podać na nóżke 18 - USB_INT??
  • #19
    Janosik_pat
    Level 15  
    Quote:

    D302 pod pierwszy pin, ten co nad nim jest rezystor R316


    Zobacz pod nim może pomoże, chociaż jak świeci się czerwona dioda to znaczy że prąd dochodzi. USB_INT jest tylko po to aby telefon wiedział kiedy jest podłączony kabel USB.