Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Stacja lutownicza na Atmega8

JaroFon 26 May 2013 22:29 276447 632
Altium Designer Computer Controls
  • #421
    electricianul
    Level 12  
    Ja posiadam Kolbe Pensola z termopara 24v/48w. Kupil TME-Timisoara.
    Wazne zeby termopara byla typu K. Schemat elektroniczny zaczerpniety zostal z artykulu w EP. Stacja lutownicza posiada rowniez detektor wykrywajacy przejscie fazy przez zero(MOC-3041 zero crrosing).
    Gdy grzalka pracuje na panelu przednim swieci sie dioda czerwona LED
  • Altium Designer Computer Controls
  • #422
    ryba884
    Level 19  
    Witam.

    Czy ktoś zamiast zasilacza na transformatorze próbował zastosować przetwornicę np. na TL494?
  • #423
    tomciu1
    Level 10  
    Witam,
    mam pytanie odnośnie zasilacza lutownicy.
    Udało mi się zdobyć używany transformator bo ten TST100 jednak trochę kosztuje.
    Mój problem polega na ty, że ten transformator jest już dość wiekowy i pracując przy 220V dawał na wyjściu 24V, przy 230V daje natomiast coś ok 26V. I tu moje pytanie, czy stosując takie trafo w płytce zasilacza nie trzeba zmienić wartości np. oporników przy LM311 czy też MOC3020?
    domyślam się, że kolbie 2V róznicy nie zrobi?
  • #424
    Popak
    Moderator on vacation ...
    Nic nie zmieniaj. A jak bardzo byś był na to uczulony zawsze można ten jeden zwój od tranfa odwinąć :)
  • Altium Designer Computer Controls
  • #426
    PF
    Level 19  
    Czy ma ktoś dostęp do takiej rozlutownicy, a właściwie do opisu pinów we wtyczce i zastosowanej tam termopary :
    Stacja lutownicza na Atmega8

    http://www.tme.eu/pl/details/pensol-sl916-d2/stacje-rozlutownicze/sorny-roong-industrial/#

    Teoretycznie kolba PENSOL-IRON-N pochodzi od stacji :

    PENSOL-SL10-N
    PENSOL-SL20-N
    PENSOL-SL30-N

    a rozlutownica od stacji PENSOL-SL20, PENSOL-SL30.
    Niestety nie wiem co oznacza to -N przy oznaczeniach stacji od kolby.

    Może dokładając drugie gniazdo do naszej stacji, można by uzyskać całkiem niezły zestaw.
  • #427
    tomciu1
    Level 10  
    Witam, chcialem wykonać tę stacje wg. projektu z EP no i trafiłem na problem z płytką zasilacza. Otóż w EP było napisane, że przy zwarciu wyjscia Lm311 z wejściem optotriaka to na zaciskach grzałki powinna wystąpić połowa napięcia zasilania. U mnie niestety występuje całe. Ponieważ wyjście lm'a podciągnięte jest do zasilania a triak otwarty na ful uznałem, że układ jest uszkodzony, wymiana jednak nic nie pomogla :/. i tumoje pytanie, czy winne moga być diody przy scalaku? Nie mogłem kupić LL4148 więc dałem 1N4148. Czy to może być to czy drugi komparator z rzędu zepsułem przy lutowaniu?
  • #428
    dzikuss98
    Level 11  
    Mialbym pytanie techniczne - czy moge ta stacje polutowac lutowica transformatorowa. Jestem poczatkujacy i tylko taki sprzet posiadam na stanie
  • #429
    krzysiek1959
    User under supervision
    Tak ,możesz polutować lutownicą transformatorową a nawet inną .
  • #430
    miszczo997
    Level 28  
    tomciu1 wrote:
    Witam, chcialem wykonać tę stacje wg. projektu z EP no i trafiłem na problem z płytką zasilacza. Otóż w EP było napisane, że przy zwarciu wyjscia Lm311 z wejściem optotriaka to na zaciskach grzałki powinna wystąpić połowa napięcia zasilania. U mnie niestety występuje całe. Ponieważ wyjście lm'a podciągnięte jest do zasilania a triak otwarty na ful uznałem, że układ jest uszkodzony, wymiana jednak nic nie pomogla :/. i tumoje pytanie, czy winne moga być diody przy scalaku? Nie mogłem kupić LL4148 więc dałem 1N4148. Czy to może być to czy drugi komparator z rzędu zepsułem przy lutowaniu?


    Którą wersję płytki zrobiłeś? Na jednej był błąd właśnie przy op07, porównaj dobrze schematy. Diody nie mają znaczenia.
  • #431
    tomciu1
    Level 10  
    Problem nie jest z OP07 bo pomiar temp. działa. Za to LM311 jest chyba walnięty bo tak jak pisałem jeśli sygnał z jego wyjścia potraktować jako sterowanie triaka to napięcie nie jest odpowiednie. Dziwi mnie tylko różnica schematów Pana Szkutnika i tego z Ep. Różnice są właśnie przy LM311. W plikach, które załączyłem i, z których korzystałem przy budowie na schemacie wyjście Lm'a(ZCD) jest podciągnięte przez rezystor do vcc. Na stroni Pana Szkutnika http://www.myelectronics.republika.pl/stacja_lutownicza/ideowy11.PNG to nóżka nr 6 jest podciągnięta do vcc. Co jest więc poprawne?
  • #432
    krzych
    Level 13  
    tomciu1 na lm311 6 noga ma być pusta, a wyjście noga 7 (ZCD) podciągnięte poprzez opór do VCC.
  • #433
    bearq
    Level 38  
    Witam,

    jako iż przydała by mi się stacja postanowiłem wykonać ten projekt. Pobrałem paczkę Stacja lutownicza_JaroFon2_ver3.1 i w tym tygodniu na pewno płytka zostanie wytrawiona a sama płytka polutowana. Stacja będzie zasilana trafem 2x12 170W.
    Na początku wystartuję z gotowego softu ale później mam zamiar go przerobić. Chciałem się dowiedzieć jak stacja reaguję na zmianę temperatur bo po jednym filmiku zauważyłem że stacja przeważnie przebija temperature zadaną nawet o 80 stopni a zapewne dośc męczące jest czekanie co chwilę na ustabilizowanie temperatury. Czy problem leży tylko w sofcie?

    Pozdrawiam
  • #434
    miszczo997
    Level 28  
    Kwestia histerezy leży wyłącznie po stronie programowej. Przy wgraniu orginalnego wsadu z elektroniki praktycznej, gdzie zastosowano aproksymację wielomianową i regulację typu PID histereza wynosi około 4 stopni(+- 2 od temperatury zadanej), gdy grzałka jest w spoczynku. Polecam zajrzeć na ten schemat, gdzie poprawiłem kilka błędów https://www.elektroda.pl/rtvforum/viewtopic.php?p=10414860#10414860 i zwrócić uwagę na podłączenie op07, i porównać ze schematem z EP, bo z tego co pamiętam, gdzieś był błąd i nie wiem, czy został poprawiony.
    Pozdrawiam
    Paweł
  • #435
    tomciu1
    Level 10  
    Ja już nie wiem co jest. Drugi raz wymieniłem komparator i nic nie pomogło. Tym razem scalak umieścilem w potstawce żeby mieć pewność, że go nie przegrzeje jak było. Czy ktoś wypowie się czy tak jak pisze w pdfie 3500 dodanym przeze mnie, po zwarciu GRZ z ZCD napięcie na zaciskach grzałki powinno wynosić połowę zasilającego? Tak rzeczywiście ma być, bo u mnie jest całe.? Wykonywał ktoś tą stacje zgodnie z EP? Płytke sprawdziłem pod kątem zwarć, zimnych lutó i przerwanych scierzek i nic :/
  • #436
    zdenek_zdenek
    Level 20  
    Kolego wytraw sobie moją płytkę z 6 str. u mnie działa do dzisiaj.
  • #438
    miszczo997
    Level 28  
    zdenek_zdenek wrote:
    Kolego wytraw sobie moją płytkę z 6 str. u mnie działa do dzisiaj.

    Podobnie, kilka stron wcześniej masz płytkę(do której już nie raz linkowałem) poprawioną przeze mnie, którą uruchomiły już 3 osoby i wszystko działa.
    Pozdrawiam
    Paweł
  • #439
    tomciu1
    Level 10  
    Sęk w tym, że płytke wykonywałem podług projektu z EP i mam wykonaną także płytkę sterownika a nie działa tylko zasilacz. Obszukałem płytkę i nic nie znalazłem, będę próbował więc wykonać ją od nowa. Teraz mam za to inny dziwny problem. Kożystam z wsadu z EP a mój problem polega na tym, że wciśnięcie + i - jednocześnie powinno przełączać do menu a nie powoduje nic. Kilka razy przez przypadek zadziałało ale nie wiem jakim cudem. Problem jest otyle dziwny, że używając zestawu uruchomieniowego działa identycznie, tak więc awarię sterownika wykluczam. Ktoś używał tego wsadu? Mieliscie podobnie?
  • #440
    yogi009
    Level 43  
    Szczerze mówiąc, zaoszczędzisz czas wykonując płytkę, którą Ci wskazali Koledzy, szukanie błędów na obecnej płytce to droga pod górkę. Chyba, że masz na tak zwanym podorędziu jakiegoś elektronika, który na miejscu spróbuje się z tym posiłować.
  • #441
    bearq
    Level 38  
    Panowie tak jak ktoś już się tutaj pytał czy jest szansa zastąpić czymś te elementy bo u siebie nie mogę ich dostać a kupowanie i płacenie za przesyłkę jakoś średnio się opłaca.
    Dokładnie chodzi o OP07CN, MOC3020M oraz LM311N
    Do tego dochodzi jeszcze kwarc który w formie 1Mhz jest cholernie drogi (20zł!) gdzie o innych częstotliwościach można kupić w granicach 1zł (najblizszy 1Mhz u mnie w sklepie to 3,579MHz).
    Z góry dziękuję
  • #442
    zdenek_zdenek
    Level 20  
    O ile pamiętam to kwarc nie jest potrebny wraz z kondensatorami przy nim. Mega chyba działa na wewnętrznym.
    Coś mi się nie chce wierzyć, że w łodzi nie ma tych elementów.
  • #444
    bearq
    Level 38  
    Odwiedziłem 3 sklepy w Łodzi i nigdzie tego nie ma a chciałem w weekend ją już złożyć. Korzystam dokładnie ze schematu od użytkownika marco47 gdzie wprowadziłem tylko małe udoskonalenie czyli wyjście pod wiatrak.
    Według schematu kwarc jest włączony pomiędzy 9 a 10 pin Atmegi oraz dwa kondensatory.
    Schemat wysyłaj poniżej. Dodam że kupiłem Atmege8A-PU Stacja lutownicza na Atmega8
  • #446
    bearq
    Level 38  
    Przejechałem pół miasta ale udało mi się kupić zamiast MOC3020M kupić MOC3021M oraz zamiast OP07CN kupić OP07CP. Z tego co widzę to prawie to samo.
    Co do oscylatora to jego koszt mnie przeraża, ale postaram się coś taniej upolować.
  • #448
    bearq
    Level 38  
    Z tego co wiem to w projekcie Stacja lutownicza JaroFon_ver3 potrzebny jest kwarc 1Mhz który kosztuje w graniacach 15-20zł. Chyba że mozna tam użyć innego
  • #449
    yogi009
    Level 43  
    http://sklep.avt.pl/generator-kwarcowy-1mhz.html

    Tu masz dużo taniej o wiele bardziej precyzyjny generator kwarcowy, choć projekt stacji lutowniczej akurat tego nie wymaga. Poszukaj w internecie. Poza tym można śmiało uruchomić ATmegę-8 z wewnętrznym taktowaniem 1MHz.
  • #450
    Gonza
    Level 27  
    bearq wrote:
    Z tego co wiem to w projekcie Stacja lutownicza JaroFon_ver3 potrzebny jest kwarc 1Mhz który kosztuje w graniacach 15-20zł. Chyba że mozna tam użyć innego

    Uparłeś się na ten kwarc :) Jeśli soft jest na 1MHz, to zostaw Atmegę na fabrycznie ustawionym wewnętrznym oscylatorze 1MHz i po kłopocie.