Elektroda.pl
Elektroda.pl
X
TermoPasty.pl
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[FT232RL] Grzanie się układu - pomysły

zdebel 26 Kwi 2010 17:16 3438 21
  • #1 26 Kwi 2010 17:16
    zdebel
    Poziom 14  

    Wykonałem sobie płytkę pod ten scalak, ładnie zaprogramowałem sobie ledy itp. i nazwy, układ działa poprawnie. Zauważyłem tylko po chwili używania, że układ się masakrycznie grzeje, parzy w palec. Czy miałby ktoś jakiś pomysł co może być nie tak, jak coś to wrzuce też schemat. Diody są dwie, czerwona przez 300 Ohm do CBUS3 a zielona przez 1 kOhm (300 mi sie skończyło) do CBUS4, obie zapalane minusem. Z góry dziękuję za pomoc.

    Dodano po 1 [godziny] 13 [minuty]:

    Od momentu napisania posta mam caly czas podlaczony uklad i na petli nadaje dane, temp. tak na oko to około 60 stopni, jak sie przytrzyma palcem to parzy, tymniemniej uklad dziala stabilnie. W datasheecie wyczytałem, że układ ten rozprasza 500mW mocy.

    0 21
  • TermoPasty.pl
  • Pomocny post
    #2 26 Kwi 2010 17:35
    mirekk36
    Poziom 42  

    Masakra jakaś, i to jeszcze nawet nie pokażesz swojego dokładnego schematu czy nawet płytki, żeby zobaczyć coś tam nababolił ;)

    A zbaboliłeś coś na maxa i na 100% - bo to że on może rozpraszać 500mW nie oznacza, że ma się tak grzać!!!!

    Zrobiłem już setki układów z wykorzystaniem FT232RL i jeszcze ANI JEDEN nie był nawet lekko ciepły - zwykła temperatura otoczenia. W ogóle żadnego nawet minimalnego grzania!

    Szok ;) grzeje ci się, 60st C !!!! a ty jeszcze tłumaczysz sobie, że to działa stabilnie. Do czasu aż pójdzie z dymem nie tylko scalak ale i USB albo coś jeszcze - zależy co namieszałeś

    0
  • TermoPasty.pl
  • #4 26 Kwi 2010 17:47
    polprzewodnikowy
    Poziom 26  

    Czemu nie połączyłeś VCC i VCCIO razem?

    0
  • #5 26 Kwi 2010 17:48
    zdebel
    Poziom 14  

    Ponieważ wybieram logikę albo 5V albo 3V3.

    0
  • #6 26 Kwi 2010 17:55
    mirekk36
    Poziom 42  

    Schemat masz ok ;) to teraz pokaż płytkę - bo tam musi być pies pogrzebany ;)

    0
  • #8 26 Kwi 2010 18:27
    mirekk36
    Poziom 42  

    Chcesz powiedzieć, że przy taaaaaaaak małych odstępach pomiędzy ścieżkami, przelotkami a nawet pinami scalaka - nie porobiłeś zwarć przy lutowaniu?????

    [FT232RL] Grzanie się układu - pomysły

    - chyba że płytka była robiona przez jakąś firmę na zamówienie to uwierzyłbym, że nie ma zwarć albo przerw

    - chyba, że montowałeś elementy na fali - to wtedy bym uwierzył że nie masz zwarć szczególnie na nogach scalaka

    ale może jak pokażesz fotkę tej płytki - to może się zdziwię ? albo ty się sam zdziwisz jak odkryjesz zwarcie(-a)

    0
  • #9 26 Kwi 2010 18:33
    zdebel
    Poziom 14  

    No ok, wstępnie jak sam badałem przed napisaniem posta to przejrzałem, zresztą jakby zasilanie było zwarte to by nie chodziło co nie? Przed chwilą podpiąłem płytke pod zasilacz i prąd był początkowo ~90mA a następnie spadł do ok. 50mA. Jak przejrzę wyżej wymienione miejsca to napisze znów :)

    0
  • #10 26 Kwi 2010 18:47
    mirekk36
    Poziom 42  

    Ja tylko przykładowe miejsca pokazałem bo dla manualnego wykonywania płytek jest ich sporo więcej ;)

    Nie chodzi mi o zwarcie zasilania VCC z GND. Czy tylko takie mogą być zwarcia?

    Dodano po 48 [sekundy]:

    aha - ale rozumiem, że niczym poza tym nie obciążasz tego układu ???

    0
  • #11 26 Kwi 2010 18:58
    zdebel
    Poziom 14  

    Niczym, tylko pętle RX-TX zrobiłem. Płytkę metodą foto robiłem i z tego co miernikiem badałem to zwarć nie znalazłem, przeleciałem całego scalaka. Wydaje mi się, że najłatwiej problem zlokalizujemy, jak określimy co może powodować takie grzanie się układu. Chyba tylko w tak prostym pod względem połączeń układzie problemem, mogłoby być zwarcie 3v3 do masy. Jeśli chodzi o fotkę, to mam niestety za słaby aparat żeby oddać szczegóły.

    0
  • #12 26 Kwi 2010 19:13
    mirekk36
    Poziom 42  

    zdebel napisał:
    Jeśli chodzi o fotkę, to mam niestety za słaby aparat żeby oddać szczegóły.


    Jak dasz dobre oświetlenie to w miarę dobrą fotkę można i słabym aparatem zrobić z bliska. Nie chodzi o silne punktowe oświetlenie żarówą ale o rozproszone światło - najlepjej na białej kartce papieru i wokoło też dać białe kartki żeby odbijały i zmniejszały cienie ;)

    A jak chcesz dojść do tego co może powodować bez sprawdzenia części sprzętowej - to troszkę jak wróżenie z fusów. Taaaakie grzanie może wynikać tylko niestety z jakiegoś złego montażu bo schemat jest zbyt prosty, żeby w nim coś źle zrobić choć i tacy się zdarzają ;)

    [FT232RL] Grzanie się układu - pomysły

    Dodano po 1 [minuty]:

    Poza tym nie chodzi o same zwarcia ścieżek ale zwarcia w trakcie lutowania, cyna mogła ci się rozlać nawet pod układem

    0
  • #13 26 Kwi 2010 19:58
    zdebel
    Poziom 14  

    Ok, wylutowałem układ i mam pytanie czy wewnątrz układu, może być jakieś przejście od zasilania do masy? Sprawdziłem i mam na samym układzie (czyste nóżki) przejścia z nogi 20 (vcc) do wszystkich mas oraz lini test. Bo jeżeli tak nie powinno być to mam odpowiedź, ciekawe tylko czemu układ działa poprawnie, ładnie się programuje itp. :D Bo jeśli chodzi o samo lutowanie, pod układem pięknie czysto :)

    0
  • #14 26 Kwi 2010 20:08
    mirekk36
    Poziom 42  

    żeby jeszcze było wiadomo co oznaczają twoje "przejścia"

    0
  • #15 26 Kwi 2010 20:09
    zdebel
    Poziom 14  

    Mój miernik ma test przejścia i sobie pika :)
    Po pomiarze, około 63 ohmy.
    -update-
    Podlutowałem 2 cieniutkie druciki pod VCC i GND, dałem pod zasilacz laboratoryjny i dziabie tyle samo prądu, czyli chyba uwalony układ dostałem. Pozostaje pytanie czemu on dobrze działa.

    Jeszcze tylko dla pewności się spytam, ponieważ na stanie nie miałem 4.7uF dałem 100nF. Zakładam, że pełni on rolę czysto filtrującą, bo znalazłem ciekawego kwiatka tutaj: http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=76989
    Dokładnie chodzi o "ensure that you have added a 4.7uF (besides the 100nf) capacitor between usb_vcc and gnd else the ft232rl will act erratic and heat up." Czy jest to możliwe?

    0
  • Pomocny post
    #16 26 Kwi 2010 20:57
    utak3r
    Poziom 25  

    "Przejście" między Vdd i Vss jest w miarę normalne - o ile mówimy o rezystancji rzędu megaomów ;) ale 63 omy?? Toć to zwarcie... układu nie znam, ale to bardzo interesujące.

    A co do kondensatora, to różnica jest o rząd wielkości...

    0
  • #17 26 Kwi 2010 21:21
    zdebel
    Poziom 14  

    Nic, czeka mnie wypad do sklepu i tyle, dziękuję wszystkim za pomoc :)

    0
  • #18 26 Kwi 2010 21:22
    mirekk36
    Poziom 42  

    zdebel napisał:

    Jeszcze tylko dla pewności się spytam, ponieważ na stanie nie miałem 4.7uF dałem 100nF. Zakładam, że pełni on rolę czysto filtrującą, bo znalazłem ciekawego kwiatka tutaj: http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=76989
    Dokładnie chodzi o "ensure that you have added a 4.7uF (besides the 100nf) capacitor between usb_vcc and gnd else the ft232rl will act erratic and heat up." Czy jest to możliwe?


    Nie możliwe, to jest jakieś "ble-blanie". Ja zawsze jak polutuję scalaka to często zanim jeszcze dolutuję kondki podłączam już USB i sprawdzam czy jest widoczny i działa. Jeszcze nigdy się nie zdarzyło żeby nie działał jeśli był dobrze polutowany, NIGDY. (Ale oczywiście później zawsze te kondki lutuję - to podstawa)

    A ty sam go niestety uwaliłeś a nie dostałeś takiego ze sklepu. Jak tak będziesz podchodził to jeszcze wiele twoich scalaków odejdzie do "krainy wiecznych łowów" a ty będziesz sobie wciąż tłumaczył że to tak fabryka ci dała .

    Wystarczy że pod scalakiem przy tak małych odstępach ścieżek zasilania od padów SMD scalaka (TAK SIĘ NIE ROBI panie kolego) zwarło się jakieś wyjście w stanie wysokim z GND albo odwrotnie i już masz smażalnię ryb. Wprawdzie działa ale się smaży aż zdechnie na amen - nie dziwota.

    Te scalaki są niezawodne i na prawdę bez przesady mówię, że sam osobiście użyłem ich już chyba ze 200szt - zawsze było OK.

    0
  • #19 26 Kwi 2010 21:30
    zdebel
    Poziom 14  

    Nie jest to pierwsza płytka SMD jaką już robię, a taki psikus mi się pierwszy raz przytrafił. Może faktycznie było jak mówisz, w takim razie jak będę nowy montował to 10x sprawdzę zanim zasilę i tyle :) no i muszę uważać z tymi ścieżkami

    0
  • #20 26 Kwi 2010 21:39
    mirekk36
    Poziom 42  

    Czy to to przypadkiem nie "koci" autoruter za ciebie te ścieżki pociągnął ? ;) bo tak jakoś mi te ścieżki eaglowski autoruterem pachną.

    Na drugi raz to sam zrób ścieżki w tak prostej płyteczce a zacznij właśnie od zasilania. Nie wspominając już, że to bardzo dobry pomysł żeby 10x albo i więcej razy sprawdzić przed zasileniem. Ja zawsze tak robię - bo rutyna może zgubić

    0
  • #21 27 Kwi 2010 20:19
    zdebel
    Poziom 14  

    Wlutowałem właśnie nowy układ i od razu działa poprawnie :) nic się nie grzeje, diody migają -> mam pod ręką przydatne narzędzie :)

    0
  • #22 27 Kwi 2010 20:25
    mirekk36
    Poziom 42  

    No to już będziesz wiedział jak sprawdzać przed uruchomieniem, żeby nie palić kolejnych układów ;)

    powodzenia ;) .... mówiłem, że to są bardzo przyjazne człowiekowi scalaczki

    0