Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

AES/EBU Po taniości z SoundBlastera Live! USB do Behringer

28 Kwi 2010 23:28 2751 17
  • Poziom 12  
    Drodzy mam taki problem i pytanie.

    Otóż potrzebuję wyprowadzić możliwie najtańszą techniką (na razie testuję opcje) sygnał cyfrowy z PC'ta do zwrotnicy Behringer DCX2496. Postanowiłem posłużyć się do tego moim Sound Blasterem Live! USB który posiada coaxial digital out. Stworzyłem stosowny kabelek (około 40 cm - więc krótki). Pin 2 sygnał, 3 masa w XLR i odpaliłem całą konfigurację testowo. Wyniki są takie:

    1. Coax z CD Playera Yamaha (domowy model) do DCX'a - wszystko chodzi idealnie

    2. PC na Windows XP i najnowsze dostępne sterowniki oraz SB Live! - dzwięk jak z extremalnie podrapanego kompaktu, muzyka leci, daje się rozpoznać, ale tak ze 20% ramek dochodzi uszkodzonych, całość bardzo kostropata, momentami przerywa

    3. PC na Vista x64 i najnowsze sterowniki + SB Live! - kompletny haos (niezależnie od 16 bit vs 24 bit i przy dowolnej częśtotliwości próbkowania). Nie jest to normalny szum cyfrowy, ale coś jakby extremalny przester. Muzyki rozpoznać się nie daje, natomiast mixer głośności w kompie skutecznie ten zgiełk pogłaśnia i scisza (przez co sądzę że problem leży w formatowaniu danych na wyjściu, nie zaś samym wyjściu z SB)

    -------------
    Teraz pytania: co zrobić żeby SB zaczął działać poprawnie. Po przykładzie nr. 1 widać że Behringer radzi sobie z spdif, jeśli dane są w poprawnym formacie. Być może nawet spdif i AES EBU to to samo <z poprawką na moc sygnału>

    Jeśli nie ma opcji na właściwe ustawienia SB - jaka jest inna najtańsza droga uzyskania dobrego sygnału AES EBU dla Behringera <ogólnie zniechęcam do porad z gatunku kup kartę za 1500 PLN - bo to wiem i będzie to ostateczność jak nic tańszego nie zda egzaminu>

    dzięki!

    Dodano po 59 [minuty]:

    Zrobiłem jeszcze 2 testy i zamiast DCX'a podłączyłem PC + SB do kina domowego DENON (innym kablem). Efekt był ten sam - hałas. Dochodzę do przekonania że to wina driverów creativa i tu bym szukał rozwiązania. Więc jeśli ktoś kiedyś zwalczył taki problem - dajcie znać jak.
  • Serwisant
    Minimum to Audigy2. Na Livie miałem problemy z transmisją cyfrową(ale nie na każdej). Ponad to polecam łączyć transmisje cyfrowe kabelkiem optycznym.
  • Poziom 12  
    Dzięki, zasadniczo masz rację, tylko że DCX nie ma wejścia optycznego. To jest urządzenie powiedzmy sceniczne klasy "pro" więc działa na XLR AES/EBU.

    Widziałem na allegro takie konwerterki z formatu optycznego do coax (za 50 PLN). Czy ktokolwiek z Was próbował to podpiąć do jakiegoś urządzenia pro? Działa? Generalnie wyjście optyczne na kinie domowym zadziałało poprawie (z SB Live!) kłopot dotyczy tylko coaxa, zatem być może poprawne skonwerowanie opticala do coaxa rozwiąże problem?
  • Poziom 15  
    Cześć. Spróbuj tak. Wywal te sterowniki i zainstaluj kx'y. Znajdziesz je tutaj. Te stery wymagają konfiguracji i pomęczenia się, ale są bezkonkurencyjne. Z drugiej strony w twoim wypadku cała konfiguracja to wyczyszczenie DSP i przełączenie sygnału z źródła do odpowiedniego wyjścia karty. W razie problemów służę pomocą w konfiguracji.

    Masz Vistę, więc musisz doczytać, czy KX'y będą chodzić. Mi na XP te sterowniki obsługują 2 karty (SB 5.1 i Audigy 2) jednocześnie. Miałem też podobną konfigurację do twojej i nie traciłem żadnych próbek, jednak mam dosyć mocny sprzęt (2x2GHz AMD, 1Gb RAM)
  • Poziom 12  
    Hej! Wielkie dzięki za rzeczową poradę, jeszcze przed założeniem wątku próbowałem pójść tą drogą, no i porażka ponieważ KX'y nie obsługują kart na USB. Tylko i wyłącznie PCI'owe wersje (o czym piszą w helpie, ja nie uwierzyłem próbowałem założyć no to wyskoczyło w połowie instalacji stosowne okienko i dowidzenia).

    Próbowałem pójść jeszcze inną trasą i zastosować drivery ASIO4All, Plugin w winampie do obsługi sterów ASIO no i poprawna konfiguracja. Cała sztuczka się udała, ale efekt był analogiczny. Na XP śmieci w dziwęku, na Viście haos. Stąd zresztą dość ciekawy wniosek że ASIO4All być może jest jakimś oszustwem bo ostatecznie odwołuje się do warstwy WDM driverów systemowych (a idea zdaje się miała być taka, że steruje hardware'm bezpośrednio na poziomie kernelowym - co daje latency +/- 2ms)

    Jeszcze jakieś opcje? Może ktoś przymusił KX'y do pracy z USB? To mogłoby pomóc...
  • Poziom 15  
    Widzisz, nie doczytałem, że chodziło o USB. Tak masz rację, że KX'y nie obsługują kart na USB. Ja mam obie karty na PCI więc problemu nie miałem. Nie ma możliwości zmuszenia kx'ów do działania z kartami USB. Te karty są po prostu nie wspierane, sam się przekonałeś. Wpadł mi do głowy jeden pomysł, by wydłubać jakoś sterowniki z instalatora i przy pomocy menadżera urządzeń na siłę wcisnąć sterowniki do systemu, ale nie wiem czy się da i na moje oko to jest to bez sensu, bo ideą KX'ów jest dostęp do wszystkich funkcji procesora Emu poprzez panel DSP, a w tym wypadku tego panelu nie będziesz mieć zainstalowanego.

    Skoro masz kartę na USB to pewnie podłączasz ją do laptopa. Opcją jest jeszcze Audigy2 na PCIMCIA, ale nie próbowałem i nie wiem czy jest wspierana przez KX'y. Nie wiem czy ma wyjście cyfrowe i nie wiem czy w ogóle ruszy na twojej konfiguracji :P
  • Serwisant
    Nie wiem czy czegoś nie pokręcę, ale spdif elektryczny pracuje z poziomem 5V, a AES/EBU z poziomem 15V (kiepska pamięć) ponad to karty creativa jako transmisja cyfrowa działają tylko z próbkowaniem 48kHz

    Trochę pomieszałem choć miałem rację z poziomami, a szczegóły są TU
  • Poziom 20  
    Mam audigy2 na PCIMCIA, wiec jak chcecie to moge to posprawdzac(o ile nie potrzeba nic wiecej oprocz karty i komputera :P ).
  • Poziom 12  
    Red - jakbyś dał radę zobaczyć czy ci to ruszy to by była ciekawa informacja. Na jakim systemie działasz?

    ------------------
    A teraz update z mojej strony: Na dużym kompie, (tym z Vistą) zrbiłem wyjście spdif bezpośrednio z płyty głównej (było na niej w postaci pinów) zamocowałem gniazdo XLR z tyłu obudowy, wszystko ładnie i mega profesjonalnie. Podłaczam pod Bera a tu z głośników dobiega.... znajoma sieczka, dokładnie taka sama co i z SB Live! Sprawdziłem dla pewności driver. Oczywiście jest inny (Realtek)... ale efekt ten sam. Zgłupiałem i już nic nie rozumiem. Ktoś mi to objaśni proszę???

    Dodano po 4 [minuty]:

    Może pomału czas zmienić, albo rozszerzyć pytanie: Czy ktokolwiek z Was podłączył DCX'a pod peceta skutecznie (mówię o dostarczaniu muzyki z kompa nie sterowaniu samym krosem, bo z tym idzie mi bezproblemowo). Jeśli tak to w jaki sposób? <podajcie system, kartę, rodzaj kabla>
  • Poziom 34  
    Zastosuj SRC2496. Ma wejście TOSLINK czy SPDIF i wyjście AES/EBU. Jeśli karta dźwiękowa nie ma wyjścia AES/EBU nie podłączysz jej do takiego wejścia. SPDIF -a nie podepniesz w ten sposób - nie te poziomy napięć. Standard to standard.
  • Poziom 20  
    Ja mam na XP, jeszcze wytlumacz mi jak to sprawdzic :P
  • Poziom 12  
    Red, robisz tak.
    1. kabelek który wyprowadzi twój spdif na XLR. zakładam że na karcie masz chincha, co daje taki layout bolec chinch na pin 2 XLR, masa chinch na pin 3 XLR
    2. podłączasz beringera tymże kabelkiem (input A)
    3. na beringerze w setapie zakładka pierwsza zmieniasz format wejścia na AES/EBU
    4. W ustawieniach systemu zakłazka audio wybierasz wyjście spdif jako domyślne
    5. odpalasz w dowolnym playerze jakiś dziwęk (mp3 może być)
    6. zprawdzasz na pasku koło zegarka /ikonka głośniczek/ czy na pewno urządzeniem aktywnym jest spdif
    7. piszesz czy z Beringerka sączy się dzwięk, sieczka, czy też nic się nie sączy

    i tu rozgałęzienie. jeśli nic się nie sączy to podłącz chincha na moment do dowolnego DVD lub CD pod wyjście cyfrowe (Audio CD w środku) i jeśli pojawi się dzwięk, to bez wyłączania bera jeszcze raz podłącz go pod kompa. Dajesz znać co słychać.

    finito procedury. dzięki ;)

    Dodano po 3 [minuty]:

    do świra - w zasadzie masz rację gdyby nie wspomniany przeze mnie fakt poprawnego śmigania Bera po podłączeniu pod coax najzyklejszeko kompakt disku Yamahy. Mam dowód rzeczowy że DCX łyka spdif, tylko dla jakiejś przyczyny nie lubi tego z kart dzwiękowych, szczególnie pod Vistą <na XP działa na 50%>
  • Poziom 20  
    Tylko w tym problem, ze najpierw trzeba miec tego behringera :P Napisalem wyzej, ze moge sprawdzic jezeli nie potrzeba niczego wiecej oprocz karty i komputera :P Jesli da sie to sprawdzic bez DCX'a to napisz w jaki sposob, a jesli nie to masz do mnie tylko 50km :P
    Ps. W tej karcie spdif jest optyczne wyprowadzone takim wtykiem: http://images.marketplaceadvisor.channeladvis...m/hi/68/68411/do9903.1.75cm_optical_cable.jpg
  • Poziom 12  
    red, przeoczyłem, sorry, poza tym z opticalem też dużo nie zdziałamy. dzięki za chęci. na razie zainwestuje w konwerter optical to coax i zabacze czy ta opcja zadziała. pozdro.
  • Poziom 34  
    com4tee napisał:
    do świra - w zasadzie masz rację gdyby nie wspomniany przeze mnie fakt poprawnego śmigania Bera po podłączeniu pod coax najzyklejszeko kompakt disku Yamahy. Mam dowód rzeczowy że DCX łyka spdif, tylko dla jakiejś przyczyny nie lubi tego z kart dzwiękowych, szczególnie pod Vistą <na XP działa na 50%>


    Zgadza się - temat kiedyś przerabiałem. Wydaje mi się że tutaj jest problem z transmisją danych. Nie pamiętam już który standard (czy AES/EBU czy SPDIF) wysyła dodatkowe ramki danych i stąd te zgrzyty. Być może że yamaha ma sprzętowo robionego SPDIF-a a SB robi to programowo (odpowiada za to sterownik) i właśnie ta programowa obróbka SPDIF-a robi kaszankę. Pozatym - myślę że mają tutaj jeszcze do gadania poziomy napięć tych standardów.
  • Poziom 10  
    Miałem podobny problem. Tymczasowo pomogło podłączenie masy SPDIF-a do obudowy komputera. Później Live'a zastąpił Digigram, żeby wszystko było zgodnie ze sztuką.
  • VIP Zasłużony dla elektroda
    A pin 3 wejścia AES masz wiszący czy spięty z pinem 1? Yamasza gra bo ma wyjście spdif po trafie.
  • Poziom 12  
    Chaka no więc jedynka była "luźna", ale to nieważne! Ponieważ problem uległ rozwiązaniu. Trochę "na małpę" bo nie wiem finalnie co nie działało ale solucja jest taka:

    Podłączamy do sound blastera przejściówką coax-optical f-my M-Audio (model CO2) zamieniając opticala z SB na Coax, wrzucamy to w Bera i wszystko gra pięknie jak malina. Koszt rozwiązania niestety wysoki bo przejścióweczka w USA bez transportu kosztuje 70 baksów, ale DZIAŁA.

    Sądzę (po wszystkich experymentach) że w Sound Blastach 24 kbit usb uszkodzone lub niekompatybilne jest wyjście COAX (albo w moim eglemplarzu, albo ogólnie) Zatem przestrzegam wszystkich chętnych przed wyciąganiem sygnału cyfrowego z kompa tą kartą. Analog chodzi poprawnie, ale już analog 5.1 to kolejna męka (ze względu na drivery z których tylko część i to te najstarsze z 2005 dobrze działały w surroundzie). Ogólnie przestrzegam przed tym wyrobem - jest bardzo tani, ale za razem bardzi zły. Co mi z tego że kosztował 140 PLN czy jakoś tak jak na przejścióweczkę wydałem dodatkowe 300 (żeby zaczęło działać to co powinno od początku)

    Amen