Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel Wypisanie danych po wybraniu z listy

29 Kwi 2010 12:51 4580 2
  • Poziom 9  
    Witam,
    mam pytanie w jaki sposób wypisać dane jeżeli komórka to prawda?
    Mam sobie arkusz1 w którym zrobiłem sobie w komórce A1 rozwijalną listę (odbiorców z arkusz2 "Nazwa") - odbiorcy są w arkuszu2; kolumny-> A-Nazwa; B-Ulica; C-Kod; D-Miasto
    I chcę żeby gdy wybiorę z listy odbiorce w pozostałych komórkach same wypisywały się dane z tego wiersza.
    Próbowałem to zrobić za pomocą: =WYSZUKAJ(A1;Arkusz2!A:A;Arkusz2!B:B)
    czyli wyszukaj nazwę z A1 w Arkuszu2 i wypisz Arkusz2B z tego wiersza przynajmniej ja to tak rozumiem, no ale niestety wysypuje się to i nie wiem dlaczego

    Może macie lepszy pomysł?Tylko chciałbym uniknąć VBA :)

    pzdr
    mk
  • Pomocny post
    Poziom 40  
    Lepiej zastosować wyszukaj.pionowo.

    Przykład (nazwa jest wpisywana w A1)
    Code:

    w B2 wpisz =WYSZUKAJ.PIONOWO(A1;Arkusz2!A:D;2;0)
    w C2 wpisz=WYSZUKAJ.PIONOWO(A1;Arkusz2!A:D;3;0)
    w D2 wpisz=WYSZUKAJ.PIONOWO(A1;Arkusz2!A:D;4;0)


    Chociaż twoje rozwiązanie tez by przeszło tylko popełniłeś błąd wskazując (całą) tabelę z danymi jako A:A a chciałeś zwrot wartości z B:B.
    Jakbyś swoją formułę wpisał tak jak poniżej to by ci wyszło.

    Code:
    =WYSZUKAJ(A1;Arkusz2!A:D;Arkusz2!B:B)


    Tylko że aby funkcja "Wyszukaj" działała prawidłowo wartości w kolumnie nazwa muszą być posortowane rosnąco (zobacz w pomocy do tej funkcji - w Uwaga) inaczej może nie znaleźć danej nazwy.

    Przy wyszukaj.pionowo (i wyszukaj.poziomo) nie ma takiego wymogu z tym że na końcu funkcji musi być 0 (fałsz) bo jak będzie 1(prawda) to funkcja może znajdować podobny wyraz do podanego przez ciebie i będzie zwracała jego dane.



    Ewentualnie można też zastosować formułę indeks
  • Poziom 9  
    Wszystko Działa tak jak opisałeś! Dziękuję