Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Potencjometr cyfrowy DS1802 zbiera 50Hz z otoczenia

27 May 2010 05:42 4051 6
  • Level 12  
    Mam problem z którym nie potrafię sobie poradzić. Najpierw trochę o układzie: Dwa potencjometry cyfrowe na DS1802 podpięte pod wspólny stabilizator. Wejście jednego kanału wchodzi na oba DS-y, masy każdego kanału nie stykają się ze sobą ani z masą zasilania.

    Schemat (nie rysowałem drugiego DS-a ani przycisków volume):

    Potencjometr cyfrowy DS1802 zbiera 50Hz z otoczenia

    Wiem, D1 i R2 powinny być przed R1, ale tak było mi wygodniej zrobić płytkę a to przecież nie powinno mieć wpływu.

    Płytka:

    Potencjometr cyfrowy DS1802 zbiera 50Hz z otoczenia

    Płytka jest jednostronna, czerwona ścieżka na top layer to zwora.

    W czym jest problem: Na minimalnym i maksymalnym volume wszystko działa jak powinno, ale na mniejszym od maksymalnego (nawet o jedno "oczko") wyjście modulowane jest przez 50Hz, które skądś się tam bierze. Oczywiście paskudnie słychać to po podpięciu wzmacniacza. Zasilanie z akumulatora (jako jedyny układ), wejście z komputera, wyjście niepodłączone (oprócz oscyloskopu). Jeden kanał oscyloskopu do wejścia, drugi do wyjścia.

    Zrzuty z oscyloskopu - pomarańczowy to wejście, niebieski wyjście:

    Potencjometr cyfrowy DS1802 zbiera 50Hz z otoczenia

    Widmo wejścia i wyjścia pokazuje na wejściu minimalne 50Hz, które na wyjściu jest o wiele większe, oprócz tego na wyjściu są inne śmieci:

    Potencjometr cyfrowy DS1802 zbiera 50Hz z otoczenia

    Potencjometr cyfrowy DS1802 zbiera 50Hz z otoczenia

    I jeszcze sygnał różnicowy (zielony):

    Potencjometr cyfrowy DS1802 zbiera 50Hz z otoczenia

    Macie jakiś pomysł jak to ugryźć?
    Czy Twoje urządzenia IoT są bezpieczne? [Webinar 22.06.2021, g.9.00]. Zarejestruj się za darmo
  • Helpful post
    Editor
    AVE...

    Ja bym stawiał na zbyt małą filtrację zasilania. Dodaj drugi elektrolit za regulatorem...
    Jeśli pobór prądu nie jest zbyt duży, to zamień stabilizator na diodę Zenera...
  • Level 12  
    Urgon wrote:
    Ja bym stawiał na zbyt małą filtrację zasilania. Dodaj drugi elektrolit za regulatorem...

    Nawet jeżeli układ jest zasilany z akumulatora?
  • Helpful post
    Level 33  
    A ja myślę, że to problem właśnie mas/masy...
  • Helpful post
    Level 21  
    A ja bym wywalil R1 i zwiekszyl kondensatory przy stabilizatorze. Kiedys tez mi sie takie cuda dzialy a biora sie one ze zbyt duzego poboru pradu ze zrodla, ktore nie ma odpowiedniej wydajnosci pradowej - stad oscylacje stabilizatora. Ten kond 22u dalbym co najmniej 220uF albo wiecej. Drugi kond np 10-47uF. Moze miec to wplyw na roznice w obu kanalach potencjometra. Zaczalbym od podpiecia odpowiedniego zasilania zewnetrznie i pomierzenia co sie wtedy stanie. Potem przeanalizowal jeszcze raz note katalogowa i jakies dzialajce aplikacje;)
    Pozdrawiam
  • Helpful post
    Level 24  
    Połącz masy audio z masą zasilania.
  • Level 12  
    Wiem że mam refleks, ale dopiero teraz miałem czas, żeby wrócić do tego układu.

    Dodałem kondensator 22u za stabilizatorem, połączyłem masy w jednym miejscu i brum zniknął - dzięki.

    Pozostał jeszcze jeden niezauważony wcześniej problem (widać go na zielonym wykresie różnicowym), a mianowicie duża nieliniowość na dole sygnału przy volume mniejszym od max. Dla potomnych napiszę tylko że mnie olśniło, że przecież ten cud techniki nie radzi sobie z napięciami poniżej masy, a po wycięciu DC przez kondensatory wejściowe właśnie takie napięcia się tam pojawiają. Spolaryzowałem wejścia dzielnikami 2x390k na połowę napięcia zasilania i problem zniknął, wygląda na to że wszystko działa.

    Dzięki za wszystkie odpowiedzi.
pcbway logo