Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przekierowanie portów Livebox + LinkSys wrt54gl ?

berko 10 Cze 2010 16:11 3134 7
  • #1 10 Cze 2010 16:11
    berko
    Poziom 10  

    Witam,
    Mam taką konfigurację:
    internet (neostrada)-->(ip zewnętrzny) [LiveBox] (ip:192.168.1.1)--> (WAN ip: 192.168.1.10 )[LinkSys](LAN ip:192.168.0.1)--->(LAN ip: 192.168.0.2 )[Komputer].

    Chcę przekierować port RDP 3389 na komputer w sieci lan w celu dostania się na zdalny pulpit z zewnątrz.
    Dodam, że Linksys wrt54gl pracuje na firmwarze DD-WRT.
    Zrobiłem już jedną konfigurację ale nie działa, wygląda ona tak:
    Na live Box ustawiłem przekierowanie TCP portu 3389 na Linksys czyli na adres ip WAN-a 192.168.1.10, po czym na linksysie port 3389 przekierowalem na adres komputera czyli 192.168.0.2 Niestety przekierowanie nie działa.
    Czy robię coś nie tak, jak to rozwiązać ?.

    Dzięki.

    0 7
  • #2 10 Cze 2010 17:14
    bogiebog
    Specjalista Sieci, Internet

    > Niestety przekierowanie nie działa.
    jak to sprawdzasz ?

    0
  • #3 10 Cze 2010 18:36
    berko
    Poziom 10  

    bogiebog napisał:
    > Niestety przekierowanie nie działa.
    jak to sprawdzasz ?

    na drugim kompie w tej samej podsieci do ktorego robilem przekierowanie 192.168.0.x w mstsc rdp podalem ip zewnatrzny neostrady, probowalem rownierz z ip livebox-a 192.168.1.1.

    0
  • #4 10 Cze 2010 19:02
    bogiebog
    Specjalista Sieci, Internet

    > podalem ip zewnatrzny neostrady,

    tak raczej tego nie sprawdzisz, tzn z wnętrza nie wejdziesz na ten port po zewnętrzym IP adresie

    ale możesz spróbować następująco
    - zainstaluj apache, w httpd.conf upewnij się ze ma linię "Listen 0.0.0.0:80"
    - sprawdż ze http://192.x.x.x/ działa z twojego komputera
    - teraz przekieruj port 3389 na 80 na drugim routerze
    - wejdz na stronę apache przez http proxy np http://www.upr0xy.info/
    podając http://zew-ip:3389/
    jak dostaniesz strone swoją apacha tzn że przekierowanie działa poprawnie, zmien tylko 3389=>80 na 3389=>3389 i winno być ok

    PS: dlaczego robisz podwójny NAT ? jeden na LB drugi na linksysie ? tzn masz w ten sposób dwa firewall-e. Ten firewall na LB nie wystarcza ?

    0
  • #5 10 Cze 2010 20:11
    berko
    Poziom 10  

    bogiebog napisał:
    > podalem ip zewnatrzny neostrady,

    tak raczej tego nie sprawdzisz, tzn z wnętrza nie wejdziesz na ten port po zewnętrzym IP adresie

    ale możesz spróbować następująco
    - zainstaluj apache, w httpd.conf upewnij się ze ma linię "Listen 0.0.0.0:80"
    - sprawdż ze http://192.x.x.x/ działa z twojego komputera
    - teraz przekieruj port 3389 na 80 na drugim routerze
    - wejdz na stronę apache przez http proxy np http://www.upr0xy.info/
    podając http://zew-ip:3389/
    jak dostaniesz strone swoją apacha tzn że przekierowanie działa poprawnie, zmien tylko 3389=>80 na 3389=>3389 i winno być ok

    PS: dlaczego robisz podwójny NAT ? jeden na LB drugi na linksysie ? tzn masz w ten sposób dwa firewall-e. Ten firewall na LB nie wystarcza ?


    Sprawdzilem to po prostu laczac sie z zewnatrz przed 3G, nie działa.
    Nie rozumiem co masz na mysli mowiac, ze mam podojny NAT ?.

    Dodano po 1 [minuty]:

    berko napisał:
    bogiebog napisał:
    > podalem ip zewnatrzny neostrady,

    tak raczej tego nie sprawdzisz, tzn z wnętrza nie wejdziesz na ten port po zewnętrzym IP adresie

    ale możesz spróbować następująco
    - zainstaluj apache, w httpd.conf upewnij się ze ma linię "Listen 0.0.0.0:80"
    - sprawdż ze http://192.x.x.x/ działa z twojego komputera
    - teraz przekieruj port 3389 na 80 na drugim routerze
    - wejdz na stronę apache przez http proxy np http://www.upr0xy.info/
    podając http://zew-ip:3389/
    jak dostaniesz strone swoją apacha tzn że przekierowanie działa poprawnie, zmien tylko 3389=>80 na 3389=>3389 i winno być ok

    PS: dlaczego robisz podwójny NAT ? jeden na LB drugi na linksysie ? tzn masz w ten sposób dwa firewall-e. Ten firewall na LB nie wystarcza ?


    Sprawdzilem to po prostu laczac sie z zewnatrz przed 3G, nie działa.
    Nie rozumiem co masz na mysli mowiac, ze mam podojny NAT ?. Chce zeby wyjscie na swiat byl przez router WRT54gl, ktory ma wiecej mozliwosci jesli chodzi o kontrole.

    0
  • #6 10 Cze 2010 20:21
    bogiebog
    Specjalista Sieci, Internet

    > Nie rozumiem co masz na mysli mowiac, ze mam podojny NAT ?.
    tzn że NAT-owanie robi LB (dzieli publiczny IP na adresy w sieci 192.168.1.x), i linsksy (dzieli 192.168.1.10 na adresy w sieci 192.168.0.x)

    > 192.168.0.2
    to jest komputer docelowy, czy ma przypisaną domyślna bramę ? (uruchom CMD.exe, wpisz "ipconfig")


    1) sprawdż czy przekierowanie na LB działa,
    wepnij kompa w port LAN Liveboxa i przekieruj na jakiś aktywny port na kompuerze,

    2) sprawdż czy przekierowanie na linksysie działa
    z komputera w sieci 192.168.1.x na komputer w sieci 192.168.0.x (czyli kompuery po obu stronach linksysa)

    jak 1 i 2 działa to 1+2 musi działać.

    0
  • #7 11 Cze 2010 19:31
    berko
    Poziom 10  

    Wszystko już działa. Widocznie na połączeniu 3G miałem jakiegoś zonka.

    Dzięki za pomoc !.

    0
  • #8 16 Cze 2010 12:46
    berko
    Poziom 10  

    Odnawiam temat.
    Niestety Modem Siemens Speedstream 4100 co 2 dni się wiesza. Objawy to:
    - brak odpowiedzi na ping z zewnątrz i wewnątrz.
    - brak dostępu do modemu po Http-ie
    - brak dostępu do internetu z poziomu sieci lan/routera.
    - (dziwne) Diody na modemie się świecą/mrugają. Dioda DSL( synchronizacja z centralka TP jest nawiązana), sioda Ethernet również się świeci.

    Dziwne jest również to, że modem nawet jeśli ma prawidłowe zestawienie z internetem i działa to dioda "internet" w ogóle nie działa.

    Problem zwieszenia się modemu rozwiązuje jedynie wyłączenie i włączenie modemu.
    Modem jest bardziej nagrzany niż mój router linksys wrt54gl, ale wydaje mi się, że nie jest to jakaś temp, która jest alarmująca.
    Modemu nie resetowałem do ustawień fabrycznych. Myślałem, żeby wgrać jakiś najnowszy firmware, niestety na stronie siemensa nie mogę nić znaleźć.

    Dzięki za pomoc.

    0