Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

PNP nie działa, jak poprawić?

Demmo 22 Cze 2010 13:10 3646 13
  • #1 22 Cze 2010 13:10
    Demmo
    Poziom 16  

    Witam,
    po analizie już wykonanego układu i sprawdzeniu jakże wspaniale nie działa pewna jego część, zwracam się z prośbą o pomoc :)

    Sprawa dotyczy tranzystora pnp i jego sterowania. Błąd jest głupi, bo tranzystor sterowany jest 0 lub 5V, a na wyjściu ma 24V... w związku z tym nie jest w stanie się zamknąć i cały czas przewodzi :cry: Gdyby na wyjściu było 5V nie było by oczywiście problemu.. ale jest 24V i tyle być niestety musi.

    Problemu by też zapewne nie było, gdyby całość była sterowana w ukł. open collector.. ale nie jest, bo podpiąłem to bezpośrednio do /Q układu CD4013 zasilanego z 5V.

    Czy istnieje jakaś "sztuczka", żeby to jeszcze uratować? Płytka była trochę droga, a co jeszcze gorsze wykonanie trwa, trwa i trwa, i jeżeli da się to jakoś wykonać bez ponownego zamawiania PCB, to chyba skakałbym z radości.
    Miejsca na rzeźbę jest niewiele, bo tranzystor jest w SOT23, a rezystory 0603 ;)

    PNP nie działa, jak poprawić?

    0 13
  • Relpol
  • #2 22 Cze 2010 13:23
    Cersunited
    Poziom 16  

    najpiewrw kolega napisze do czego to potrzebuje po drugie może najpierw poczyta o tranzystorach ,trybach pracy polaryzacji bazy itp!!! Co tam z tą bazą jest? bo nie widać dalej? jak jest spolaryzowana? Jak nie ma być to na tranzystorze a koniecznie OC to proponuje układy przetwornic np 7406 jest o ile pamiętam na 30v a jak nie to poszukać 74xx. Mają OC tylko trzeba dać rezystor podciągający sterowanie logika jak w TTL
    Pozdrawiam

    Dodano po 2 [minuty]:

    Tak w ogóle to ten schamt taki nie bardzo... lepiej byłoby npn w układzie tez WE wyjście na kolektorze rezystor z emitera wywalić tylko dobrać prądy tak by nie uszkodzić go.No i inaczej polaryzować bazę.

    0
  • #3 22 Cze 2010 13:37
    Demmo
    Poziom 16  

    Chodzi ogólnie o to, żeby wystawiać logiczną jedynkę (24V) na wyjściu (STAT_A) w momencie, gdy poprzedzający powyższy schemat CD4013 (wyjście /Q) w układzie przełącznika bistabilnego jest załączony (czyli na /Q jest wtedy 0V). Do STAT_A dołączone mogą być różne rzeczy, np. przekaźnik, lampka sygnalizacyjna itp.
    Ogólnie, niezależnie od tego co jest na schemacie wcześniej, pojawia się tam napięcie 0V (logiczne 0) lub 5V (logiczna 1).

    Chodzi mi głównie o to, czy da się powyższe "bezboleśnie" naprawić, bo wstawienie jeszcze pośredniego NPNa załatwiło by sprawę, tylko nie mam go gdzie dać.. tak jak pisałem płytka jest już wykonana.
    A widziałem różne cuda wianki typu jakoś tam wpięta dioda zenera czy inne takie i może tutaj też dało by się jakoś zakombinować, żeby to uratować...

    0
  • #4 22 Cze 2010 13:47
    Cersunited
    Poziom 16  

    no bez przesady układ to 5 elementów z płytka więc nie ma co naprawiać tylko robić nowe. A jak napisałem

    0
  • Relpol
  • #5 22 Cze 2010 13:57
    piotr5000
    Poziom 21  

    Jeśli masa 5V i 24V są wspólne to punkt wspólny R3 i R5 ma potencjał -19V ... -24 względem emitera . Tranzystor będzie w stanie przewodzenia .
    Jeżeli zamienisz 24V i GND tranzystora i zamienisz go na NPN to zadziała .
    W przyszłości zastosuj transoptor i po problemie . Oddzielisz galwanicznie napięcia .

    0
  • #6 22 Cze 2010 13:58
    Demmo
    Poziom 16  

    Cersunited napisał:
    no bez przesady układ to 5 elementów z płytka więc nie ma co naprawiać tylko robić nowe. A jak napisałem

    To jest bardzo mały fragment całości :) I ogólnie jak na razie wszystko inne działa (płytka jest stopniowo uruchamiana i jestem powiedzmy w połowie), tylko właśnie to, jako potwierdzenie załączenia, nie działa.
    Po przeanalizowaniu już nawet wiem czemu nie działa i napisałem o tym w pierwszym poście, niestety przed wysłaniem płytki do wykonania przesymulowałem praktycznie wszystko poza tym... no i się zemściło :(

    piotr5000 napisał:
    Jeśli masa 5V i 24V są wspólne to punkt wspólny R3 i R5 ma potencjał -19V ... -24 względem emitera . Tranzystor będzie w stanie przewodzenia .
    Jeżeli zamienisz 24V i GND tranzystora i zamienisz go na NPN to zadziała .
    W przyszłości zastosuj transoptor i po problemie . Oddzielisz galwanicznie napięcia .

    Dokładnie tak, czy 0, czy 5V, na bazie i tak jest wystarczająco, żeby przewodził.


    Póki co też nie mam pomysłu, jak uratować to w wersji PNP i chyba pozostanie mi ta zamiana na NPN...

    0
  • #7 22 Cze 2010 14:45
    Cersunited
    Poziom 16  

    no jak nie chcesz zmienic na 74xx to zrob npn nie rozumiem w czym problem? nawet nie musisz scieżek przecinać tylko odwrócisz tranzystor by emiter szedł do masy. wtedy bez rezystora(by nie bylo dodatkowych spadków napięcia) bezpośrednio do masy a z plusa rez podciagający. gdyby było tak że nadal nie działa do końca zrób dodatkowyt stopień lub bez niego podciągnij wyjscie licznika do Vcc np 3k3


    Moderowany przez Mirek Z.:

    Ostrzeżenie - p.15 regulaminu. Proszę nie śmiecić na forum!

    0
  • #8 22 Cze 2010 15:21
    Demmo
    Poziom 16  

    Hmm.. nie do końca jeszcze widzę, jak to zrobić bez cięcia ścieżek :) Wstawiłem NPNa na schemacie i tak wygląda numeracja jego wyprowadzeń.
    PNP nie działa, jak poprawić?
    Wygląda więc na to, że faktycznie cała reszta była by ok po wstawieniu NPN, pod warunkiem, że miejscami zamieni się 24V i GND.. czyli jednak z cięciem ścieżek. Ale się da...

    Cersunited napisał:
    no jak nie chcesz zmienic na 74xx to zrob npn nie rozumiem w czym problem?

    Na 74xx nie mam niestety na tej płytce miejsca, bo mam już rząd tranzystorów w obudowie SOT23 i ewentualna zamiana byłaby bardzo inwazyjna. Ale tak na poczet przyszłych układów, to widzę, że 7406 ma wyjścia OC do 30V i faktycznie dzięki niemu można dość upakować wyjścia - więc dzięki za namiary.
    W NPN "problem" u mnie przeważnie jest w tym, że chciałbym sterować plusem, a nie masą.. ale ogólnie to wsio ryba, bo wystarczy resztę układu podłączyć do plusa zamiast do masy i takie tam. Ogólnie w wybranych zastosowaniach preferuję sterowanie plusem, ale mając do wyboru brak tej opcji lub zmianę na NPN, to chyba jednak się skuszę. :)

    0
  • #9 22 Cze 2010 15:31
    Cersunited
    Poziom 16  

    Bierzesz npn i wkładasz odwrotnie tak by emiter by do masy czyli n3 tam gdzie teraz n2 baza czy npn czy pnp jest i tak na środku a kolektor tam gdzie teraz emiter czyli n2 zamiast 3. To w ogóle jak koledze ma działać z tym pnp skoro polaryzujesz dodatnio baze? pnp musi mieć baze spolaryzowana odwrotnie. na npn dajesz dodatnie napięcie dla przewodzenia. Co do scieżek to jedynie wyjście czyli Twój STAT A musi być na kolektorze wtedy jak nzwa Open Collector wskazuje.

    0
  • #10 22 Cze 2010 16:55
    Demmo
    Poziom 16  

    Baza na środku jest np w TO92. Ja natomiast mam SOT23, o czym wcześniej już pisałem.

    PNP nie działa, jak poprawić?

    Więc cała akcja z obracaniem jest nieco bardziej skomplikowana.

    Co do polaryzacji.. hmm.. ja to rozumiem tak, że jak mam podciągniętą bazę przez R3, czyli nie wymuszam nic, to mam Ube=0V, a jak wymuszam masę, to mam Ube=-24V i wtedy tranzystor przewodzi.
    Problem w tym, że pierwsza sytuacja nie występuje, bo nie mam "nic" tylko +5V, czyli Ube=-19V...
    Układ z tego co wiem działałby, gdybym jeszcze pośrednio wsadził tam NPNa lub transoptor, bo wtedy mam właśnie GND, albo "nic" ze strony sterowania.

    0
  • #11 22 Cze 2010 19:29
    vonar
    Poziom 28  

    Jeżeli nie gra roli szybkość, to może by pozostać przy PNP i spróbować upchnąć pomiędzy R3/R5 a CD4013 diodę Zenera na, powiedzmy, 20-22V? Na symulatorze działa :P

    0
  • #12 22 Cze 2010 21:28
    janbernat
    Poziom 38  

    20V dioda stabilizacyjna lepiej będzie niż 22V.
    Tak to jest jak się nie zrobi dzałającego prototypu.

    0
  • #13 23 Cze 2010 08:23
    Demmo
    Poziom 16  

    vonar napisał:
    Jeżeli nie gra roli szybkość, to może by pozostać przy PNP i spróbować upchnąć pomiędzy R3/R5 a CD4013 diodę Zenera na, powiedzmy, 20-22V? Na symulatorze działa :P

    W tym zastosowaniu szybkość jest raczej drugorzędną sprawą. W symulatorze niestety nie wiem, gdzie zmienia się napięcie zenerki (nie widzę takiego parametru), więc prosiłbym jeszcze o info, jak powinna być zorientowana względem CD4013.

    janbernat napisał:
    Tak to jest jak się nie zrobi dzałającego prototypu.

    Dokładnie tak. Bo prototyp-pająk był, tylko dotyczył innych kwestii najważniejszych funkcjonalnie. To potwierdzenie wydało mi się tak oczywiste (standardowy błąd ;) ), że zarówno w symulacji jak i w pająku je pominąłem - niestety. I teraz mam...

    0
  • #14 23 Cze 2010 12:46
    vonar
    Poziom 28  

    Demmo napisał:
    prosiłbym jeszcze o info, jak powinna być zorientowana względem CD4013.


    Anoda połączona z portem układu, katoda do rezystorów.

    0