Elektroda.pl
Elektroda.pl
X
Elektroda.pl
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

WA-2204C WR-2204 WRTR-141 naprawa firmware

29 Cze 2010 19:30 2836 3
  • Poziom 9  
    Witam!
    Posiadam AP WA-2204C (z jednym gniazdem RJ-45) - który jest ponoć bliźniaczy do Sparklan WRTR-141.
    Będę się posiłkował tym tematem który jest zablokowany.
    Już dłuższy czas - ze 3 lata używałem tego AP, czasem były z nim problemy (zawieszał się) ale potrzebowałem internetu wiec się nim nie zajmowałem. Od ok roku mam internet ASDL - nie potrzebowałem AP-ka, więc postanowiłem uaktualnić mu oprogramowanie. Robiłem to jakieś pół roku temu wiec nie mam już linków do plików- w każdym bądź razie po wgraniu drugiego z 3 plików AP przestał odpowiadać i poszedł w odstawkę. Ostatnio zaopatrzyłem się w interfejs RS232 i po znalezieniu tematu dotyczącego sparklan'a spróbowałem ożywić mojego AP. Najpierw wgrałem (za pomocą Pumpkin'a) ten plik: WRTR-141-8M-HEX8000.bin a później WRTR-141-8MRAM.BIN w obu przypadkach AP nie odpowiadał.

    To log z hyperterminalu (PuTTY):
    Code:

    UART1 output test ok
    Uart init
    mfid=00000001 devid=00002249
    Found 1 x 2M flash memory

    ---RealTek(RTL8186)at 2006.05.29-10:27+0800 version 1.4.B.AP.1 [16bit](180MHz)
    no sys signature at 00010000!
    Jump to image start=0x80350000...
    decompressing kernel:
    Uncompressing Linux... done, booting the kernel.
    done decompressing kernel.
    early printk enabled
    Determined physical RAM map:
     memory: 00800000 @ 00000000 (usable)
    Initial ramdisk at: 0x8016b000 (1740800 bytes)
    On node 0 totalpages: 2048
    zone(0): 2048 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: root=/dev/ram console=0 ramdisk_start=0 single
    Calibrating delay loop... 178.99 BogoMIPS
    Memory: 4760k/8192k available (1272k kernel code, 3432k reserved, 1816k data, 44k init, 0k highmem)
    Dentry-cache hash table entries: 1024 (order: 1, 8192 bytes)
    Inode-cache hash table entries: 512 (order: 0, 4096 bytes)
    Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 2048 (order: 1, 8192 bytes)
    check_wait... unavailable.
    POSIX conformance testing by UNIFIX
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    Serial driver version 6.02 (2003-03-12) with no serial options enabled
    ttyS00 at 0x00c3 (irq = 3) is a rtl_uart1
    state->flags=00000000
    Realtek GPIO Driver for Flash Reload Default
    block: 64 slots per queue, batch=16
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    RealTek E-Flash System Driver. (C) 2002 RealTek Corp.
    Found 1 x 2M Byte AMD AM29LV160DB at 0xbe000000
    RTL8185 driver version 1.9 (2006-03-27)
    8186NIC Ethernet driver v0.0.5 (Mar 3, 2006)
    eth0: RTL8186-NIC at 0xbd200000, 00:01:02:03:04:05, IRQ 4
    eth1: RTL8186-NIC at 0xbd300000, 04:05:06:07:08:09, IRQ 5
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 512 bind 1024)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    NET4: Ethernet Bridge 008 for NET4.0
    RAMDISK: ext2 filesystem found at block 0
    RAMDISK: Loading 1700 blocks [1 disk] into ram disk... done.
    Freeing initrd memory: 1700k freed
    VFS: Mounted root (ext2 filesystem).
    Freeing unused kernel memory: 44k freed
    mount /proc file system ok!
    serial console detected.  Disabling virtual terminals.
    init started:  BusyBox v1.00-pre8 (2005.09.16-02:17+0000) multi-call binary


    BusyBox v1.00-pre8 (2005.09.16-02:17+0000) Built-in shell (msh)
    Enter 'help' for a list of built-in commands.

    Initialize: not found
    Initialize: not found
    Initialize: not found
    BusyBox v1.00-pre8 (2005.09.16-02:17+0000) multi-call binary

    Usage: ifconfig [-a] <interface> [<address>]

    Initialize: not found
    Initialize: not found
    Initialize wlan0 interface
    Initialize AP MIB failed!
    Using wlan script...
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    BusyBox v1.00-pre8 (2005.09.16-02:17+0000) multi-call binary

    Usage: ifconfig [-a] <interface> [<address>]

    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    [: -le: argument expected
    Initialize: not found
    Initialize: not found
    [: 2: unknown operand
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    Initialize: not found
    BusyBox v1.00-pre8 (2005.09.16-02:17+0000) multi-call binary

    Usage: ifconfig [-a] <interface> [<address>]

    Initialize: not found
    Initialize: not found
    killall: syslogd: no process killed
    killall: klogd: no process killed
    SIOCGIFFLAGS: No such device
    bridge br0 doesn't exist; can't delete it
    Setup bridge...
    Initialize: not found
    device eth0 entered promiscuous mode
    eth0:phy is 8305
    SIOCDELRT: No such process
    Initialize: not found
    Initialize: not found
    br0: port 1(eth0) entering listening state
    SIOCDELRT: No such process
    Initialize: not found
    Initialize: not found
    [: 0: unknown operand
    Initialize: not found
    Initialize: not found
    Auto-Discovery (ver 1.01)
    492
    493
    # Initialize AP MIB failed!

    br0: port 1(eth0) entering learning state
    read WLAN_DISABLED value failed!
    br0: port 1(eth0) entering forwarding state
    br0: topology change detected, propagating


    Czy można jeszcze naprawić tego AP?
    Czy dobrze (skutecznie) wgrałem firmware od Sparklan'a?
    Czy mimo tego AP nie działa?
    Co robię źle?

    Z góry dzięki za pomoc :D
  • PCBway
  • Poziom 9  
    Jest ktoś wstanie mi pomóc?
  • PCBway
  • Poziom 10  
    WA-2204C jest bliźniaczy do WAPR-141. Ja właśnie wgrałem na mój WAPR-141 firmware od WRTR-141 i uwaliłem go
  • Poziom 17  
    Witam
    Posiadam router taki jak w temacie, czyli Wa-2204C. Przez przypadek jak aktualizowałem wa-2204a nagrałem plik konfiguracyjny do wa-2204c - kabel lan był, podłączony do złego urządzenia. Router przestał odpowiadać - nie można nawiązać połączenia z bramą. Jednak udało mi się przed chwilą przesłać na ap programem pumpkin prawidłowy firmware ze strony - http://ftp.dipol.com.pl/WLAN/N2647_WA2204C/ jednak router po tej operacji dalej nie reaguje. Ktoś ma jakiś pomysł na rozwiązanie problemu?

    P.S próbowałem przed chwilą nagrać soft wapr-141 - dwa pliki po wprowadzeniu ap w tryb recovery przesłałem pumpkinem jeden po drugim - jednak router dalej nie odpowiada po wpisaniu bramy tj. 192.168.1.254
    Zauważyłem również, że po wgraniu tych dwóch plików ap się nie restartuje.