Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[EXCEL] Automatyczne dodawanie apostrofu do komórek

Marcin_Sk 14 Lip 2010 00:38 9722 4
  • #1 14 Lip 2010 00:38
    Marcin_Sk
    Poziom 10  

    Witam !

    Mam problem, z uwagi na to, że excel widzi komórkę jako tekst poprzez poprzedzenie tego tekstu apostrofem, potrzebuję rozwiązania jak dodać apostrof automatycznie do wszystkich komórek naraz. Mam oko 2500 wierszy i nie bardzo mi się chce do każdego wpisywać to ręcznie. Dzięki z góry

    0 4
  • #2 14 Lip 2010 08:37
    marcinj12
    Poziom 40  

    A funkcja konwersji na tekst =TEKST(A1; "0") nie wystarczy?

    0
  • #3 14 Lip 2010 09:34
    Marcin_Sk
    Poziom 10  

    Nie próbowałem... Sprawdzę i dam znać. Dzięki za pomoc

    0
  • #4 15 Lip 2010 23:06
    wrych
    Poziom 20  

    Proponuję odpalić w VBA taką funkcję:

    Code:
    Function apostrof()
    
    For i = 1 To 30
    For j = 1 To 5
    Cells(i, j).Value = Chr(39) + CStr(Cells(i, j).Value)
    Next j
    Next i
    End Function

    Oczywiście zakres dla i, j ustalasz stosownie do potrzeb.

    0
  • #5 05 Sie 2010 14:36
    walek33
    Poziom 28  

    :arrow: wrych
    A próbowałeś kolego odpalić tą funkcję?

    Dodane:

    Dla ułatwienia dodam, że to powinien być Sub a nie Function. :D Jeśli się mylę popraw mnie.

    1
  Szukaj w 5mln produktów