Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[EXCEL] Automatyczne dodawanie apostrofu do komórek

Marcin_Sk 14 Jul 2010 00:38 15095 4
  • #1
    Marcin_Sk
    Level 10  
    Witam !

    Mam problem, z uwagi na to, że excel widzi komórkę jako tekst poprzez poprzedzenie tego tekstu apostrofem, potrzebuję rozwiązania jak dodać apostrof automatycznie do wszystkich komórek naraz. Mam oko 2500 wierszy i nie bardzo mi się chce do każdego wpisywać to ręcznie. Dzięki z góry
  • #2
    marcinj12
    Level 40  
    A funkcja konwersji na tekst =TEKST(A1; "0") nie wystarczy?
  • #3
    Marcin_Sk
    Level 10  
    Nie próbowałem... Sprawdzę i dam znać. Dzięki za pomoc
  • #4
    wrych
    Level 20  
    Proponuję odpalić w VBA taką funkcję:
    Code:
    Function apostrof()
    
    For i = 1 To 30
    For j = 1 To 5
    Cells(i, j).Value = Chr(39) + CStr(Cells(i, j).Value)
    Next j
    Next i
    End Function

    Oczywiście zakres dla i, j ustalasz stosownie do potrzeb.
  • #5
    walek33
    Level 29  
    :arrow: wrych
    A próbowałeś kolego odpalić tą funkcję?

    Dodane:

    Dla ułatwienia dodam, że to powinien być Sub a nie Function. :D Jeśli się mylę popraw mnie.