Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel kopiowanie według zadanych kryteriów

promien27 26 Lip 2010 16:16 1875 2
  • #1 26 Lip 2010 16:16
    promien27
    Poziom 1  

    Excel
    mam dwie kolumny A i B potrzebuję skopiować do kolumny C wartość z B lecz według kryteriów z A przykład:
    A B
    2 10,1
    3 2,8
    5 8,2
    6 6,5
    8 1,4

    w tablicy A4
    kopiuj do C 6,5

    [/quote]

    0 2
  • #2 26 Lip 2010 18:39
    jonnya
    Poziom 10  

    Trochę niejasne ale wynika z Twojego opisu, że chcesz skopiować wartość, która mieści się w przedziale +- 0.5 względem kolumny A?? Jeśli tak to w pierwszej komórce kolumny C (C1) umieść formułę:

    Code:

    =JEŻELI(B1<=A1+0,5;JEŻELI(B1>=A1-0,5;B1;0);0)

    następnie kliknij na tą komórkę, CTRL+C, zaznacz kolumnę C do ostatniej komórki tabeli i CTRL+V

    :).

    0
  • #3 26 Lip 2010 20:36
    marek003
    Poziom 40  

    promien27 napisał:


    w tablicy A4
    kopiuj do C 6,5



    Możesz trochę jaśniej?

    W tej "tablicy" kryteriów masz "A4" czy "6"

    Docelowo jak kolega wyżej zasugerował trzeba skorzystać z funkcji Jeżeli jednak na tak "jasno" opisany problem bardzo ciężko dać czytelny przykład.

    0