Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Dwa programatory, dwa programy,a żaden nie programuje

piotreks-89 25 Sie 2010 15:28 1220 8
  • #1 25 Sie 2010 15:28
    piotreks-89
    Poziom 12  

    Kupiłem kit AVT 2550p. Próbowałem nim zaprogramować AVR ATmega 8 ale BASCOM w ogóle nie wykrywa programatora, ani uc, oto komunikat:
    Dwa programatory, dwa programy,a żaden nie programuje
    , a jak chce zaprogramować to BASCOM stoi w miejscu. Wczoraj kupiłem na allegro ten programator do PonyProg-a 2000 SI Prog API. Podłączyłem wszystkie piny tego programatora do mojej AtTiny 2313, ale otrzymuje taki błąd w PonyProg-u 2000:
    Dwa programatory, dwa programy,a żaden nie programuje
    Czy to może być wina tego, że kupiłem przedłużacz portu COM, który był nie crossowany (tak powiedzieli mi w sklepie, powiedzieli też, że to ten będzie dobry). Co mam robić???

    0 8
  • #2 25 Sie 2010 16:55
    janbernat
    Poziom 38  

    Czy procesor ma zasilanie, czy kit jest dobrze polutowany, czy przewód od LPT jest krótki, czy w Bascomie jest ustawiony programator STK200/300, czy jest zainstalowana jakakolwiek drukarka, czy nie odwróciłeś wtyczki od przewodów programator- płytka, czy są sprawdzone przejścia omomierzem, czy nic nie jest podłączone do MOSI/MISO/CLK, czy dobrze jest ustawiony numer LPT.
    Jak odpowiesz sobie na te pytania i nie będzie działać-to zadaj następne.

    0
  • #3 25 Sie 2010 18:01
    piotreks-89
    Poziom 12  

    1. czy nic nie jest podłączone do MOSI/MISO/CLK
    2. czy jest zainstalowana jakakolwiek drukarka
    Nie rozumiem tych dwóch pytań.
    1. O co chodzi do mosi/miso/clk (czy to jest reset?) podłączone są wyjścia programatora
    2. Co ma to wspólnego. Drukarkę mam zainstalowaną ale na USB

    0
  • Pomocny post
    #4 25 Sie 2010 18:49
    janbernat
    Poziom 38  

    Czy żadne zewnętrzne urządzenie nie obciąża nadmiernie MOSI/MISO/CLK.
    Jak w układzie jest coś wlutowane to może tak czasem być.
    Co do drukarki na USB- nie wiem.
    Chodzi o odowiednią konfigurację portu LPT.
    Zwykle program do drukarki na LPT sam to robi- ale chyba można zrobić to w BIOS-ie.

    0
  • Pomocny post
    #5 25 Sie 2010 18:56
    landy13
    Poziom 29  

    piotreks-89 napisał:
    ...clk (czy to jest reset?)...

    To nie reset, to zegar. Ale skoro nie wiesz co to jest, to może go wcale nie podłączyłeś?

    0
  • #6 26 Sie 2010 10:16
    piotreks-89
    Poziom 12  

    Podłączyłem do XTAL 1 i XTAL 2 rezonator 7.37 Mhz i potem dwa kondensatory 22pF i do masy. Jeśli moglibyście to narysujcie mi schemat prawidłowego połączenia. Chce powiedzieć jeszcze, że zbudowałem Sample Electronics programmer, ale on też mi nie działa :(

    0
  • #7 26 Sie 2010 12:07
    janbernat
    Poziom 38  

    Do nowej ATmegi nie jest potrzebny żaden kwarc.

    0
  • Pomocny post
    #8 26 Sie 2010 13:46
    Samuraj
    Poziom 35  

    A napięcie podłączyłeś :?:
    Większość nowych zaczynających przygodę z mikrokontrolerami myśli że układ weźmie napięcie z powietrza lub z portu LPT/COM.

    0
  • #9 26 Sie 2010 15:33
    piotreks-89
    Poziom 12  

    Rzeczywiśie nie podłączyłem zewnętrznego napięcia ;). Dzięki wam wszystkim. Ale działa mi tylko ten programator z Allegro.pl

    0
  Szukaj w 5mln produktów