Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel, formatowanie warunkowe i data

turbin2 29 Sie 2010 19:51 3064 4
  • #1 29 Sie 2010 19:51
    turbin2
    Poziom 2  

    Witam,

    mam następujące daty:

    2010-08-23 - 2010-08-29

    2010-08-30 - 2010-09-05

    2010-09-06 - 2010-09-12


    Ustawiam formatowanie warunkowe, z komórkami zawierającymi, z datami występującymi - w tym tygodniu. I co? Zostają wyróżnione dwie daty: 2010-08-29 i 2010-08-30. Z tego wynika że w excelu pierwszym dniem tygodnia jest niedziela. Można to jakoś zmienić, żeby pierwszym dniem tygodnia był poniedziałek? Wtedy powinny się wyróżnić daty - 2010-08-23 - 2010-08-29.

    Mam nadzieje że wytłumaczyłem mój problem, proszę o pomoc.

    Pozdrawiam,
    turbin

    0 4
  • #2 29 Sie 2010 20:27
    marcinj12
    Poziom 40  

    Jeżeli używasz funkcji DZIEŃ.TYG() to jest tak jak mówisz - domyślnie "1" oznacza niedzielę. Wystarczy użyć opcjonalnego parametru równego 2: =DZIEŃ.TYG(A2;2)

    0
  • #3 29 Sie 2010 21:03
    turbin2
    Poziom 2  

    Niestety nie używam, po prostu mam wpisaną datę. Wytłumaczy mi ktoś jak to zrobić? Ponieważ wcześniej pogogolowałem trochę i wpadłem na tą opcję ale niestety nie wiedziałem jak jej użyć.

    0
  • #4 29 Sie 2010 21:41
    marcinj12
    Poziom 40  

    W Narzędzia->Dodatki masz bibliotekę Analisysys Toolpack. Załącz ją, i do testowania czy data jest w obrębie bieżącego tygodnia użyj funkcji: WEEKNUM(), coś w stylu:

    Code:

    =JEŻELI(ORAZ(WEEKNUM(A4;2)=WEEKNUM(DZIŚ();2);A4<=DZIŚ());PRAWDA;FAŁSZ)

    0
  • #5 29 Sie 2010 22:17
    turbin2
    Poziom 2  

    A nie dałoby się tego zrobić w jakiś łatwiejszy sposób?

    0