Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Dwa routery Linksys BEFVP41 połączenie LAN-WAN brak dostępu

16 Wrz 2010 11:45 3709 8
  • Poziom 9  
    Witam.
    Bardzo proszę szanownych forumowiczów o poradę.
    Mam router 1 (główny) BEFVP41 podłączony do modemu DSL TP, obsługuje około 10 komputerów biurowych (dostęp WWW, udostępnianie plików i drukarek itp.).
    Podsieć nr 1: 192.168.1.x

    Potrzebuję wydzielić drugą podsieć obsługującą trzy komputery.
    Te trzy komputery spiąłem do routera nr 2 tej samej firmy Linksys.
    Podsieć nr 2: 192.168.2.x

    Ostatnio pojawiła się potrzeba zmapowania dysku twardego komputera z podsieci 2 -> do wybranego komputera podsieci 1. I tu mam problem. Standardowo między routerami z adresami publicznymi robiłem to za pomocą VPN. Tutaj mam połączenie portów LAN-WAN dwóch routerów i najwyraźniej VPN nie chodzi - przynajmniej mi nie udało się tego uruchomić (nie wiem czy Linksysy obsługuja VPN'y na portach LAN).

    Proszę o podpowiedź jak tego dokonać? Próbowałem już:
    a) włączać DMZ dla komputera z udostępnionym dyskiem - nie robi
    b) wyłączać DHCP (mam sztywne IP-ki)
    c) wpisywać w tabeli routingu adresy dwóch komputerów które mają widzieć swoje zasoby,

    Generalnie komputery z podsieci 2 mają dostęp do internetu, chodzą pingi do routera 1. Z podsieci 1 nie chodzą pingi ani do routera 2 ani do żadnego z komputerów podsieci 2.

    Poddaję się i proszę o poradę :idea: - prześledziłem sporo wątków ale nie znalazłem odpowiedzi a sądzę będzie banalnie prosta:)

    Pozdrawiam Jarek
  • Poziom 15  
    Sprecyzuj założenia komunikacji sieci 1 z siecią 2.

    Jak ustawisz routing miedzy siecią 1 a 2 to wszystkie komputery z sieci 1 beda mogły dostawać się do komputerów z sieci 2.

    Jeśli to ma być komunikacja z dowolnego komputera z sieci 1 do tego jednego z sieci dwa to można przekierować port TCP445 na IP stacji która ma udostepniać pliki (ale wtedy mapowanie po IP a nie NETbios).
    Jeśli ma to być tylko z jednego kompa w sieci 1 do tego w sieci 2 to trzeba by w routerze 2 skonfigurować dodatkowo Firewalla tak żeby przepuszczał ruch na tym porcie tylko z IP tego jednego kompa.
  • Poziom 9  
    Potrzebuję podłączyć dysk sieciowy w (tylko) jednym komputerze podsieci (1) IP 192.168.1.125 z (tylko) jednym komputerem podsieci (2) o IP 192.168.2.100 . Firewall routera podsieci (2) mam trwale wyłączonego. Próbowałem już forwordować w routerze (2) porty odpowiedzialne za mapowanie dysków (zdaje się UDP 338 i 339 i ten 445 TCP też) już wcześniej ale 'nie robi'.
    Router (2) obsługuje dość duży ruch między dwoma stanowiskami roboczymi a serwerem plików na adresie 192.168.2.100, w dodatku te dane mają być 'utajnione' dlatego ta podsieć tak została wydzielona. Teraz jest potrzeba 'odtajnienia' tylko udostępnionego na serwerze 192.168.2.100 katalogu z danymi dla stanowiska dla księgowości w drugim budynku.

    Pozdrawiam Jarek
  • Poziom 15  
    Cytat:
    Ostatnio pojawiła się potrzeba zmapowania dysku twardego komputera z podsieci 2 -> do wybranego komputera podsieci 1


    Cytat:
    Potrzebuję podłączyć dysk sieciowy w (tylko) jednym komputerze podsieci (1) IP 192.168.1.125 z (tylko) jednym komputerem podsieci (2) o IP 192.168.2.100


    Sprecyzuj to jakoś bo z jednego postu wynika że masz mapować zasoby z kompa w sieci 2 na komp w sieci 1 a zdrugiego że masz zamiar zrobić coś całkiem odwrotnego.

    Chodzi o to że komputer z sieci 2 ma udostepniać pliki komputerowi z sieci 1 ?

    Czy na routerze 2 jest włączony NAT?
  • Poziom 9  
    Komputer z podsieci (1) ma się dostać do zasobów dyskowych tego z podsieci (2).

    Mapowanie dysku sieciowego ma być skonfigurowane na komputerze z podsieci (1) - na razie nie widać komputera->udostępnionego dysku z podsieci (2).

    Udostępnianie dysku jest włączone na komputerze z podsieci (2). Dysk jest udostępniony prawidłowo bo widać go i można go zmapować z obu pozostałych komputerów podsieci nr (2).

    NAT z tego co pamiętam jest włączony. Urządzenie będę miał znowu dopiero jutro w rękach - muszę podjechać do firmy. Dziś szukam wszelkich podpowiedzi gdzie szukać rozwiązania:?:.
    Sądzę powinienem tego NAT'a wyłączyć. Próbowałem przekierowywać na przykład cały zakres portów 1-65535 TCP i UDP na komputer serwer plików 192.168.2.100. Z tego co czytam to samo robi uaktywnienie DMZ dla adresu 192.168.2.100 i też tego próbowałem ale 'nie robiło'. Ale miałem raczej tego NAT'a włączonego bo nie przypominam żebym to odhaczał na 'disable' a defaultowo po 'hard reboot' z guzika na obudowie jest przecież ustawiony na 'enable'. Nie będzie neta ze stacji roboczych ale tam go wcale nie potrzeba.

    Pozdrawiam Jarek
  • Poziom 15  
    NAT zostaw włączony.

    1. Zrób przekierowanie na routerze 2
    z WAN (port TCP 445) na 192.168.2.100 (port TCP 445)

    2. Uruchom "Wiersz poleceń" i wpisz telnet 192.168.2.100 445 i Enter. Jeśli połączenie dojdzie do skutku (czarny ekran bez żadnych komunikatów) to znaczy że jest OK.

    Jeśli zadziała spróbuj zamapować dysk używając IP a nie nazwy komputera \\192.168.2.100\nazwaudziału (oczywiście najpierw zamknij okno z teletem)

    Jeśli nie zadziała spróbuj rozdać adres serwera plików z DHCP routera 2 (static) i sprawdź wtedy... może to brzmi dziwnie ale spróbuj (miałem podobne przejścia i to z linksysem właśnie).
  • Poziom 9  
    Proszę o wyjaśnienie tego ostatniego akapitu.
    Wprawdzie DHCP mam na 'enable' ale zakres adresacji automatu jest od 150 do 200, natomiast te static IP mam na sztywno ustawione w PC: 100 dla serwera plików oraz 101 i 102 dla stacji. Automat na przykład dla serwisu z notebooka.
    Czy masz na myśli żeby DHCP dać na 'disable'?
    Dzięki za porady bo po trzech godzinach prób i pół dnia szukania rozwiazania w necie leciutko wymiękłem.
    Tak się jeszcze zastanawiam czy aby ten router podsieci (1) nie jest leciutko 'trzaśnięty' - przeglądarka łączy się po restarcie przez jakieś 2-3 minuty a później już nie. I to niezależnie od czyszczenia pamięci przeglądarki czy jej zmiany z IE na Operę czy inną. Po odpięciu od switchy dostęp jest 'no limits'. Być może ciut za cieniutki dla 10 kompów ten routerek, wprawdzie chodzą 2 skonfigurowane VPN z szyfrowaniem 1024 bitów ale z prawie zerowym ruchem (zdalne dostępy serwisowe).
    Biorę jutro trzeci router (prywatny) i spróbuję połączenia prywatnego z nowszym routerem sieci (2).
    W każdym bądź razie upewniasz mnie że trzeba szukać drogi innej niż tunel VPN a to już znacznie zawęzi krąg podejrzanych.

    Pozdrawiam Jarek
  • Poziom 15  
    Cytat:
    Proszę o wyjaśnienie tego ostatniego akapitu.
    Wprawdzie DHCP mam na 'enable' ale zakres adresacji automatu jest od 150 do 200, natomiast te static IP mam na sztywno ustawione w PC: 100 dla serwera plików oraz 101 i 102 dla stacji. Automat na przykład dla serwisu z notebooka.
    Czy masz na myśli żeby DHCP dać na 'disable'?


    Żadnego wyłączania DHCP wszystko jest "jak Pan Bóg przykazał" i niech tak zostanie (pisałem właśnie żebyś taki model zastosował).

    Cytat:
    przeglądarka łączy się po restarcie przez jakieś 2-3 minuty a później już nie


    Skąd dokąd się łączy? Mówisz o połączeniu z zewnątrz do strony zarządzania routera czy o połączeniach od strony LAN na zewnątrz?
  • Poziom 9  
    Hej.
    W piątek po południu próbowałem przez kolejne 2-3 godziny ustawiać jak napisałeś. Niestety zero postępów. Ostatecznie wrzuciłem tymczasowo inny routerek jako ten (2) aby chodziła w ogóle podsieć (2) a linksysa w kieszeń i do domu na warsztat z nim. Dziś od rana meczę go podłączonego analogicznie do mojego routera Linksys który działa podobnie jak router (1) z jedyną różnicą że obsługuje neostradę domową zamiast DSL w firmie. Dalej zero rezultatów...
    Przekierowanie portów (forwarding) w routerze (2) działa pod warunkiem że wyłączy się DHCP (informacja w Help'ie Linksysa). Próbowałem ustawienia linksys (2) zarówno jako 'Gateway' jak i 'Router' (z help'a wynika ze raczej powinien być tryb Router a ten (1) powienien być Gateway) Podglądam log'i routera (1) i routera (2). Przy próbie mapowania dysku (lub tego telneta na porcie 445 o którym pisałeś) w logach routera (1) pojawia się informacja o wychodzeniu pakietów z komputera o adresie np: 192.168.1.102:1234 na komputer 192.168.2.100:445. Natomiast problem jest raczej w routerze (2) - w 'incoming logs' nie ma ani śladu informacji o przychodzących pakietach.
    Ten kłopot z dostępem po dwóch - trzech minutach dotyczy dostępu przez przeglądarkę na adres strony konfiguracji routera (czyli 192.168.1.1) czyli po LAN'ie. Po restarcie działa ten dostęp przez 2-3 minuty a później już nie. Bez komputerów podsieci (1) działa to dłużej ale też wyłącznie po restarcie zasilania routera. Nie pomaga zmiana przeglądarki i kasowanie pamięci przeglądarki.
    Może jakieś sugestie bo ręce lecą? Zastanawiam się powoli nad switchem z VLAN'em i jednym routerem. A ten zostałby jako rezerwa na wypadek usterki sprzętowej.
    Pozdrawiam Jarek

    Dodano po 4 [godziny] 13 [minuty]:

    Witam.
    Temat rozwiązany:D.
    Najpierw stwierdziłem że może kabelki czy wtyczki coś nie tak bo nie szły pingi z routera (1) do routera (2) prawidłowo. Więc jak do ręki wziąłem pudełko to w czasie wysyłania pingów nagle kilka przeszło a później znów nic. I się okazuje lekko prawdopodobnie gniazdka są sprzętowo naruszone bo się dziewczyny przyznały że jak im nie chodziło badziawie to sobie resetowały i pudełko z szafki wyciagały z kabelkami - to się miało prawo coś obruszać. Jak się dobrze powtykało i zostawiło - pingi do routera (2) zaczęły działać.
    Router (2) MUSI pracować w trybie 'gateway' (w trybie 'router' nie chodzi).
    W router (2) ustawiamy forwordowanie portów: 137 i 138 UDP oraz 139 TCP na komputer serwer plików (192.160.2.100).
    W komputerze z podsieci (1) włączamy mapowanie dysku sieciowego, wpisujemy ścieżkę: \\adres_routera_2_w_podsieci_1\katalog_udostępniony.
    Klikamy i się łączy. Jak próbowałem adres: \\192.168.2.100\katalog_udostępniony niestety nie chciał się łączyć. Ale nie widzę tu problemu bo potrzebuję dostępu tylko do jednego komputera.
    Uff. Może się komuś przyda.
    Dzięki za wszelką pomoc i pozdrawiam Jarek