Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Programowanie po isp-problem z kablem BeeProg+

picia22 16 Wrz 2010 13:40 906 2
  • #1 16 Wrz 2010 13:40
    picia22
    Poziom 27  

    Witam , zrobiłem sobie kabelek do isp, ale mam problem jakie wartości rp1 i rp2 ustawić.Dałem według zaleceń producenta ale niestety albo mam same 00 albo FF,czy może wlutować potencjometr i się pobawić.Do testów ziołem sprawne radio z pamięcią st24c32, rezystorki 1kohm do Vcc.Odczyt kości w adapterze przebiega prawidłowo po isp kicha.

    Programowanie po isp-problem z kablem BeeProg+

    0 2
  • #2 16 Wrz 2010 19:06
    fabi
    Spec od car audio

    RP1 i RP2 są to rezystory podciągające szynę w docelowym układzie. W programie masz uwagę, że jeżeli te rezystory są mniejsze od 500 om, to nie będzie możliwa komunikacja z pamięcią. Natomiast jeżeli są większe od 1k to nie trzeba odcinać linii od układu.


    (*1): If you have RP1 and RP2 resistors too low (RP1, RP2 < 500 Ohm), the programmer is not able to provide the sufficient level L at SDA/SCL pins, you have to isolate SDA and SCL signals of programmed chip (by jumpers, for example). In this case, the programmer provides pull-up resitors for SDA/SCL pins. If you have RP1 and RP2 resistors > 1kOhm, is not necessarily to isolate SDA and SCL signals of programmed chip.


    Ważną sprawą jest ustawienie adresu A0, A1 i A2, są to nóżki układu 1,2 i 3. W zależności od podłączenia tych nóżek (do masy bądź do plusa) ustawia się odpowiedni adres układu na szynie.

    0
  • #3 16 Wrz 2010 23:26
    picia22
    Poziom 27  

    akurat w tym radiu AoA1A2 sa do masy wiec adres 000 ale jak zobaczysz na wrzut ekranu końcowe adresy są prawidłowe ale bufor ma same 00,i pojawia sie to tylko przy zasilaniu pamięci z programatora i bez rezystorów,na zasilaniu zewnętrznym i na rezystorach mam same FF

    0
  Szukaj w 5mln produktów